Forum: PC Hard- und Software Linux Mint Mate: VLC Player mit Artefakten


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von herbert (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Linux Gemeinde!

Vor zwei Tagen Habe ich eine DVD bekommen (Celine Dione )von einem 
Konzert 2013 in Quebec. Rein ins Laufwer und VLC Player mit der 
Wiedergabe beauftragt. Danach wurde meine Miene immer düsterer. Was habe 
ich da für eine Sch***DVD gekauft fragte ich mich zuerst,lauter 
Artefakte, oder ist die DVD gut und was anderes nicht in Ordnung.Mein 
Bastel-Mint läuft auf einer externen USB-Festplatte an USB 2.0. Ist das 
ein Problem ,umgesteckt auf USB 3.0. Problem immer noch vorhanden.
Windows XP gebootet ,alles nochmal und siehe da ,die DVD läuft ohne 
diese Artefakte.
Ich habe natürlich immer darauf geachtet, dass alle Filter die man 
aktivieren kann (ganz besonders den Scharfzeichner) auszuschalten denn 
die belasten die CPU enorm weil das in Echtzeit gerechnet wird.
Frage .Wer hat zu Linux Mint Mate noch Windows laufen und hat da schon 
ähnliches bemerkt.

So und dann hätte ich noch eine Frage: Dieses Konzert "UNE SEULE FOIS" 
ist vor zwei oder 3 Jahren mal im 3Sat übertragen worden. Mein Full HD 
Mitschnitt auf eine Festplatte weist leider Ton und Bildfehler auf. Hat 
wer die Sendung mitgeschnitten und besitzt davon eine etwa 3,7GB große 
fehlerfreie Datei?
Die Bildqualität ist da natürlich noch eine Ecke besser als auf der DVD.

von herbert (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Ok, wer zu Linux kein Windows mehr hat , wird den qualitativen 
Unterschied nicht sehen können. Entweder liegt das an den Codecs oder an 
der nicht ganz gelungenen Einbindung von VLC in Linux.

Gerade hatte ich noch ein anderes Problem, das Computermäßig "neu" für 
mich ist.
Ich schalte mein Kabelmodem ja immer aus wenn ich den Rechner nicht 
laufen habe .Das Teil verbraucht Standby 11 Watt,mein Rechner 45Watt im 
Office-Betrieb.
Wenn ich Linux hochfahre und dann das Modem erst einschalte ,dann komme 
ich ohne Neustart nicht in Internet. Manchmal vergesse ich das halt was 
unter Windows kein Problem ist. Was kann ich unter Linux tun ,außer neu 
starten?
Die Windows Systemzeit ist jedesmal um 2 Stunden verstellt wenn ich 
vorher Linux mate laufen hatte. Hatte erst die Battery in verdacht aber 
die hatte noch über 3 Volt nach dem ich die Spannung gemessen hatte.
danke schon mal...

von Alexander K. (pucki)


Bewertung
0 lesenswert
nicht lesenswert
Viele Ursachen.

1.) Schau mal nach ob die DVD kopiergeschützt ist. Könnte sein das Linux 
da Probleme hat.

2.) Kopiere die VOB-Dateien (die 1. 1 GB große reicht zum Testen) auf 
die Platte und spiele sie von da direkt an. Das ist eine MPG2-Datei. 
Notfalls umbenennen in MPG. Das schließt Timing-Fehler mit den Laufwerk 
aus.

2a.) Erhöhe in VLC die Puffergröße. Das hilft auch oft bei so Problemen.

3.) Prüfe ob VLC die neuste Version hat o. ob bekannt ist das es mit der 
aktueller Version Probleme gibt.

Gruß

   Pucki

von Bugger (Gast)


Bewertung
0 lesenswert
nicht lesenswert
herbert schrieb:
> Die Windows Systemzeit ist jedesmal um 2 Stunden verstellt wenn ich
> vorher Linux mate laufen hatte. Hatte erst die Battery in verdacht aber
> die hatte noch über 3 Volt nach dem ich die Spannung gemessen hatte.
> danke schon mal...

Das ist ein Windows Bug.
Windows kann nicht mit einer CMOS-Clock umgehen die auf GMT steht.

Linux hat aber einen Workaround für die Bugs von Windows: 
http://manpages.ubuntu.com/manpages/xenial/man1/timedatectl.1.html

von Sven D. (sven_la)


Bewertung
0 lesenswert
nicht lesenswert
herbert schrieb:
> Was kann ich unter Linux tun ,außer neu
> starten?

Abmelden und wioeder anmelden versuchen.

herbert schrieb:
> ie Windows Systemzeit ist jedesmal um 2 Stunden verstellt wenn ich
> vorher Linux mate laufen hatte.

Das ist normal, Linux geht standardmässig davon aus, das Deine Systemuhr 
nach UTC geht, also MEZ -1 Stunde und MESZ -2 Stunden.

https://techlr.de/dual-boot-windows-10-und-linux-falsche-uhrzeit/

von Rolf M. (rmagnus)


Bewertung
0 lesenswert
nicht lesenswert
herbert schrieb:
> Wenn ich Linux hochfahre und dann das Modem erst einschalte ,dann komme
> ich ohne Neustart nicht in Internet. Manchmal vergesse ich das halt was
> unter Windows kein Problem ist. Was kann ich unter Linux tun ,außer neu
> starten?

Du kannst mal versuchen, nur das Netzwerk neu zu starten.
In einer Konsole:
sudo service networking restart

Eigentlich sollte aber auch unter Linux der Network-Manager das selber 
hinbekommen.

von DPA (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Versuch eventuell mal hw accelerated video decoding ein oder aus zu 
schalten. https://wiki.debian.org/HardwareVideoAcceleration und checke, 
ob die auch vorhanden ist: 
https://wiki.archlinux.org/index.php/Hardware_video_acceleration#Verification 
Und ist gstreamer1.0-vaapi installiert? In den einstellungen kann man 
irgendwo zum rendering noch andere dinge verstellen. Einfach mal ein 
parr durchprobieren.

Versuch eventuell auch mal einen anderen video Player. z.B. "mplayer 
dvdnav:// -dvd-device /dev/sr0"

von DPA (Gast)


Bewertung
0 lesenswert
nicht lesenswert
herbert schrieb:
> Wenn ich Linux hochfahre und dann das Modem erst einschalte ,dann komme
> ich ohne Neustart nicht in Internet.

Ist das über /etc/network/interfaces, was auch immer systemd heutzutage 
macht, oder über networkmanager konfiguriert? Poste mal die 
/etc/network/interfaces, und die ifconfig ausgabe bei funktionierendem 
Internet.

Es gibt mehrere arten, wie sowas konfiguriert sein kann, und zu wissen, 
welche genutzt wird, ist essenziell, um herauszufinden, wo etwas schief 
geht.

von zitter_ned_aso (Gast)


Bewertung
0 lesenswert
nicht lesenswert
herbert schrieb:
> Mein
> Bastel-Mint läuft auf einer externen USB-Festplatte an USB 2.0. Ist das
> ein Problem ,umgesteckt auf USB 3.0. Problem immer noch vorhanden.
> Windows XP gebootet ,alles nochmal und siehe da ,die DVD läuft ohne
> diese Artefakte.

Über USB? Ist das System dann etwa gleich schnell wie bei einer LIVE-CD? 
;-)

von Alexander K. (pucki)


Bewertung
0 lesenswert
nicht lesenswert
Umstecken bringt GARNIX, wenn der Stecker nicht innen BLAU ist.

Sollte der Hersteller nicht pfuschen, besagt die Farbe nämlich das es 
USB-3.0 Speed kann.

Grau an USB-3.0 ist schön aber Verschwendung, wenn man des Extra-Strom 
nicht braucht.

Gruß

   Pucki

: Bearbeitet durch User
von Nano (Gast)


Bewertung
0 lesenswert
nicht lesenswert
herbert schrieb:
> Wenn ich Linux hochfahre und dann das Modem erst einschalte ,dann komme
> ich ohne Neustart nicht in Internet. Manchmal vergesse ich das halt was
> unter Windows kein Problem ist. Was kann ich unter Linux tun ,außer neu
> starten?

Linux sollte die Verbindung zum Router automatisch erkennen, sobald der 
Router verfügbar ist.

von Nano (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Bugger schrieb:
> Das ist ein Windows Bug.
> Windows kann nicht mit einer CMOS-Clock umgehen die auf GMT steht.

Kann Windows 10 immer noch nicht mit einer CMOS-Clock umgehen, die auf 
UTC Zeit eingestellt ist?

von herbert (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Alexander K. schrieb:
> 2.) Kopiere die VOB-Dateien (die 1. 1 GB große reicht zum Testen) auf
> die Platte und spiele sie von da direkt an. Das ist eine MPG2-Datei.
> Notfalls umbenennen in MPG. Das schließt Timing-Fehler mit den Laufwerk
> aus.

Habe ich schon getestet ,bringt aber keine Bildverbesserung.

Alexander K. schrieb:
> Erhöhe in VLC die Puffergröße. Das hilft auch oft bei so Problemen.

Habe ich auch schon vollzogen (Grundeinstellung 300,jetzt 1800)Ich nehme 
mal an , dass es sich bei dieser Änderung um die besagte Vergrößerung 
des Pufffers handelt.

Sven D. schrieb:
> as ist normal, Linux geht standardmässig davon aus, das Deine Systemuhr
> nach UTC geht, also MEZ -1 Stunde und MESZ -2 Stunden.

Ich werde die vorgeschlagene Änderung in der Registry mal machen.

Rolf M. schrieb:
> Eigentlich sollte aber auch unter Linux der Network-Manager das selber
> hinbekommen.

Der Meinung bin ich auch. Muss mal spezifisch googeln

zitter_ned_aso schrieb:
>> Mein
>> Bastel-Mint läuft auf einer externen USB-Festplatte an USB 2.0. Ist das
>> ein Problem ,umgesteckt auf USB 3.0. Problem immer noch vorhanden.
>> Windows XP gebootet ,alles nochmal und siehe da ,die DVD läuft ohne
>> diese Artefakte.
>
> Über USB? Ist das System dann etwa gleich schnell wie bei einer LIVE-CD?
> ;-)

Das ist eine 3.0er Festplatte die ich an 2.0 angesteckt habe weil meine 
Bord-Steckplätze nur ganz hinten sind und die 2.0 er leichter zu 
erreichen waren.Aber das ist Geschichte den seit Gestern habe ich eine 
Verlängerung von einem halben Meter.
Aha , eine 3.0 er Festplatte an 2.0 ist nicht schneller als mein DVD 
Laufwerk?
Wo hast denn das her?  :-)

Alexander K. schrieb:
> Umstecken bringt GARNIX, wenn der Stecker nicht innen BLAU ist.

Das ist mir schon klar seit es 3.0 gibt...

Nano schrieb:
> Linux sollte die Verbindung zum Router automatisch erkennen, sobald der
> Router verfügbar ist.

Wie bei Windows halt auch, weil ein Neustart jedesmal halt echt ätzend 
ist...

Nano schrieb:
> Kann Windows 10 immer noch nicht mit einer CMOS-Clock umgehen, die auf
> UTC Zeit eingestellt ist?

W10 habe ich noch nicht getestet ich habe hier wie du weist XP. Da 
wollte ich heute schon umstellen weil MS ja spezielle Zeitserver hat. 
Aber da bekam ich heute eine Fehlermeldung, hatte aber keine Zeit mich 
damit länger zu beschäftigen. Ich hole das nach.

von herbert (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Gemeinde!

Ich hasse Threads allüberall wo es um Probleme geht und das Thema ins 
nichts verläuft oder mit der Meldung "Danke ,jetzt läuft es" beendet 
wird und die Frage offen bleibt :Warum läuft es jetzt.

Ich habe unter win xp und mate getestet.Win VLC Version 2.2.4/Mate 
V3.0.8-0

Ich bin die Einstellungen durchgegangen und bin bei Setup "Deinterlace" 
fündig geworden. Meine Windows Version läuft in der Einstellung 
"automatisch und im Modus "angleichen"mit sauberen Bild. Sobald ich 
diesen Modus ändere gibt es das Problem. Ersatzweise hilft es dann auch 
"Deinterlace" auszuschalten.

Mate: Hier hilt es nur "Deinterlace" auszuschalten. Eine "spielerei" mit 
Veränderungen in der Abteilung "Modus" bringt nichts.

Dieses Problem für mich erledigt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.