Forum: Mikrocontroller und Digitale Elektronik Defekter Antriebsverstärker


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Robert H. (einurelf)


Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Moin

wie sehen die Chancen einer Reparatur für zwei Low-Cost Servo 
Antriebsverstärker mit folgendem Symptomen aus?

Leistungselektronik noch ok. Regler hält den Motor auf Position.
Parametrierung über das Onboard-Display/Tasten geht noch.

Keine USB Kommunikation möglich (Windows zeigt nichts im Gerätemanager 
an)
Ausßnahme: Ein Regler bringt Windows beim USB Verbindungsversuch zu 
einer Fehlermeldung, die auf ein fehlerhaftes USB Gerät verweißt.

An beiden Reglern Ethernet/Ethercat Kommunikation total tot. Keine Led 
leuchtet bei gestecktem Netzwerkkabel.

In der Nähe der USB Buchse befindet sich ein Silabs CP2109 (U11).
Die Ethercat Geschichte wird über J4 mittels 10 Pol. Pfostenstecker auf 
das
"Mainboard" geführt.

Habe einen funktionierenden Regler selben Typs als Referenz da.

Die beiden defekten Regler kann ich erst öffnen(Versiegelt), wenn ein 
schmaler Taler bezahlt wurde.

Was sagen Eure Glaskugeln?
Über hilfreiche Antworten in dieser Sache bedanke ich mich schon mal im 
voraus.

Gruß
Robert

von was (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Robert H. schrieb:
> Was sagen Eure Glaskugeln?

Dass ich unter diesen Umständen nicht mehr als den Wert der Komponenten 
(für mich) dafür zahlen würde.

Für den jetzigen Besitzer sind die Regler so wohl weniger Wert als 
nichts, sie kostenlos abzunehmen wäre also schon ein Gefallen.

von Robert H. (einurelf)


Bewertung
-1 lesenswert
nicht lesenswert
Leider weiß ich auch nicht, was der Besitzer mit den Reglern 
veranstaltet hat.
Seiner Aussage nach waren diese auf einem Teststand und funktionierten 
dort wohl noch.

Normalerweise ist der Verbindungsaufbau "Pflegeleicht". Anstecken, 
Verbindungsart in der Software einstellen und gut ist.

Selbst unbestromt angesteckt(USB) erkennt Windows schon eine UART Bridge 
bei meinem funktionierenden Regler.

von A-Freak (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Spekulatius:
Im Testaufbau wurde Potentialausgleich und EMV nicht ganz ernst genommen 
und die Schnittstellen zum PC durch eine Spannungsspitze zwischen 
verschiedenen "Masse"-Potentialen zerstört.

von Robert H. (einurelf)


Bewertung
-1 lesenswert
nicht lesenswert
... also könnte der CP2109 das Zeitliche gesegnet habe?

von was (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Da "könnte" dann alles mögliche das Zeitliche gesegnet haben.

Es macht ja schon einen großen Unterschied, ob beim Einstecken des 
USB-Steckers GND oder +5V zuerst Kontakt hatten und das ist nunmal 
völlige Glückssache.

Daher, selbst wenn A-Freak recht hat, immernoch unmöglich zu sagen was 
hin ist, ohne das Ding zu öffnen.

von c-hater (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Robert H. schrieb:

> ... also könnte der CP2109 das Zeitliche gesegnet habe?

Das wäre absolut denkbar, würde aber allein nicht erklären, warum auch 
Ethernet tot ist. Sprich: da muss wohl noch mehr kaputt gegangen sein.

von Robert H. (einurelf)


Bewertung
-1 lesenswert
nicht lesenswert
c-hater schrieb:
> Das wäre absolut denkbar, würde aber allein nicht erklären, warum auch
> Ethernet tot ist. Sprich: da muss wohl noch mehr kaputt gegangen sein.

Die Überlegung hatte ich auch schon. Leider sieht man nicht wo J4 Auf 
dem Mainboard hingeführt wird. Vermute mal richtung U1 
(TMS320F28335ZJZA). Unter der Lackschicht sind im Licht Verbindungen zu 
erahnen.

von Wolfgang (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Robert H. schrieb:
> Was sagen Eure Glaskugeln?
ESD-Schaden

von c-hater (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Robert H. schrieb:

> Die Überlegung hatte ich auch schon. Leider sieht man nicht wo J4 Auf
> dem Mainboard hingeführt wird. Vermute mal richtung U1
> (TMS320F28335ZJZA). Unter der Lackschicht sind im Licht Verbindungen zu
> erahnen.

Naja, die eigentlichen Ethernet-Signalanschlüsse sind vermutlich nicht 
betroffen, die sind ja durch den Übertrager vergleichweise gut 
geschützt.

Ich würde eher auf eine Rückwirkung über eine Versorgungsspannung 
tippen, die irgendwie gemeinsam genutzt wird. Entweder ist halt auch 
diese Versorgung als Folgeschaden abgeraucht oder sie lebt noch und wird 
nur durch eine Schutzschaltung daran gehindert, weiter Strom zu liefern. 
Wenn letzteres der Fall wäre, dann geht Ethernet wieder, sobald der 
CP2109 ausgelötet ist.

von Robert H. (einurelf)


Bewertung
-1 lesenswert
nicht lesenswert
c-hater schrieb:
> Wenn letzteres der Fall wäre, dann geht Ethernet wieder, sobald der
> CP2109 ausgelötet ist.
Das wäre sehr erfreulich. Der Versuch wäre eine Überlegung wert, den 
schmalen Taler zu bezahlen. Leider habe ich noch keinen der art kleinen 
SMD Baustein verlötet.

von Alexander K. (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Robert H. schrieb:
> Ausßnahme: Ein Regler bringt Windows beim USB Verbindungsversuch zu
> einer Fehlermeldung, die auf ein fehlerhaftes USB Gerät verweißt.

Lässt auf sehr kurzfristigen richtigen Kontakt schließen.

Und Windows reagiert auf wackelige Stecker -/- Unsaubere Daten -/- Werte 
SEHR zickig.

Ich würde das Poti mal mit Kontaktspray oder ähnlichen beglücken. Diese 
Teile neigen bei mir dazu zu verdrecken -/- korrodieren. Dann kann der 
Widerstand gigantisch sein, und das Gerät "spinnt".

Und den USB-Kabel tauschen, und Stecker überprüfen nicht vergessen.

Ich habe die Erfahrung gemacht, das 95% aller Fehler auf mechanischen 
Verschleiß zurück zu führen sind.

Aber wie schon hier geschrieben. Es kann alles sein.

Gruß

  Pucki

von Robert H. (einurelf)


Bewertung
-1 lesenswert
nicht lesenswert
Danke für den Hinweis. Ich hatte bereits verschiedene Kabel mit drei 
verschiedenen PCs und unterschiedlicher Software ausprobiert und es 
zeigten sich immer dieselben Symptome. Ethernet komplett tot und an 
einem Regler mit USB gemecker von Windows.
Es wäre auch absoluter Zufall, wenn zwei Regler mit insgesamt vier 
Anschlüssen korrodierte oder wacklige Anschlüsse hätten.
Bis jetzt hatte noch keiner meiner weiteren Servoregler selben 
Herstellers sollche Probleme gemacht.

von c-hater (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Robert H. schrieb:

> Das wäre sehr erfreulich. Der Versuch wäre eine Überlegung wert, den
> schmalen Taler zu bezahlen. Leider habe ich noch keinen der art kleinen
> SMD Baustein verlötet.

Du brauchst ihn ja auch erstmal nicht einlöten, sondern nur auslöten. 
Das ist viel einfacher, insbesondere deshalb, weil er ja nicht gerade 
groß ist.

Da braucht man doch bloß einen etwas größeren Lötprügel wählen, einmal 
links kurz draufhalten, einmal rechts kurz draufhalten, dann fällt das 
Teil freiwillig ab, bzw. läßt sich per Pinzette abheben, als wäre das so 
vorgesehen. Dann maximal noch ein wenig Nacharbeit mit Entlötlitze und 
der Drops ist gelutscht.

Wenn du solch einfache Techniken nicht beherrschst, was soll dann dieser 
Thread? Du kannst dann doch eh' nix ausrichten, ganz egal, was 
tatsächlich kaputt ist.

von Robert H. (einurelf)


Bewertung
-1 lesenswert
nicht lesenswert
c-hater schrieb:
> Da braucht man doch bloß einen etwas größeren Lötprügel wählen, einmal
> links kurz draufhalten, einmal rechts kurz draufhalten, dann fällt das
> Teil freiwillig ab.
Sieht so aus als wäre der min. auf drei Seiten verlötet.

c-hater schrieb:
> Wenn du solch einfache Techniken nicht beherrschst, was soll dann dieser
> Thread?
Um einzuschätzen ob sich eine Reparatur lohnt wird.
Zur Not frage ich halt jemanden, der mit solche filigranen Lötarbeiten 
etwas routinierter ist.

Du vielleicht?
Wohnst du zufällig im Raum Kiel?

Mal was anderes,
kurz hinter der USB Buchse ist eine 503B (D3). Dient die nicht dem ESD 
Schutz?
Wenn die durch ist, wie äußert sich das auf dem Messgerät?

von Robert H. (einurelf)


Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
So, ich habe jetzt einen defekten Regler aufgemacht.

Auf der Rückseite Nähe USB sind zwei unschöne Widerstände.
R151 ist tot und C105 (Bestückungsdruck ist für eine andere Ausführung)
hat 0,05 Ohm.

Vorderseite Nähe USB hat D3 folgende Messungen ergeben:
503B (D3) Kaputt?
1 -> 4 = 4,08V
1 -> 3 = 2,9V
1 -> 2 = 5V

In dem funktionierendem Regel und einem Regler anderer Ausführung 
folgendes:
503B (D3) Baugleich IO
1 -> 4 = 3,2V
1 -> 3 = -75mV
1 -> 2 = 5V

503B (D3) 100W Ausführung
1 -> 4 = 3,2V
1 -> 3 = -80mV
1 -> 2 = 5V

Wenn es nur diese beiden Bauteile sind, wäre dies erfreulich.

In den defekten Reglern ist eine andere Hardwarerevision verbaut und ich 
konnte diesmal die Ethercatplatine ausbauen.
Auf der Rückseite der RJ45 Anschlüsse sieht es irgendwie nach 
Wasserschaden aus.

von Thomas Z. (usbman)


Bewertung
0 lesenswert
nicht lesenswert
Robert H. schrieb:
> R151 ist tot

Da ist kräftig Strom vom Gehäuse der USB Steckverbindung nach GND 
geflossen. Nur mit ESD kann man den abgebrannten 0Ohm Widerstand nicht 
erklären.

Vielleicht wurde da mal ohne Trenntrafo mit einem Oszi rumgewerkelt. Der 
USB Chip dürfte das nicht überlebt haben. Funktionell braucht's den 0Ohm 
Widerstand aber nicht

von Robert H. (einurelf)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke für deine Einschätzung. Bei einem Regler habe ich noch etwas mehr 
Hoffnung, das der CP2109 noch lebt, da Windows noch meckert, wenn ein 
USB Kabel gesteckt wird.

Den zweiten Regler habe ich eben aufgemacht.
Rückseite ist ein Widerstand wieder tot und der CP2109 hat wohl einen 
Bauchschuss erlitten.

Auf der Vorderseite ist D3 (503B) auch durch:
2-2 503B (D3) Kaputt?
1 -> 4 = 110 mV
1 -> 3 = -25 mV
1 -> 2 = 5V

von Thomas Z. (usbman)


Bewertung
0 lesenswert
nicht lesenswert
Dann sind beide Regler auf die gleiche Weise gestorben und haben 
vermutlich auch den gleichen Schaden.
Der kaputte Widerstand ist erst Mal unerheblich die verbinden ja nur den 
Schirm mit Gnd.

Als erstes würde ich die Schutzdioden runternehmen die sind für den 
Betrieb auch nicht notwendig. Und mach alle Tests mit einem ordentliche 
selfpowered Hub. Wer weiß schon was an den Usbpins so rauskommt.

von Robert H. (einurelf)


Bewertung
0 lesenswert
nicht lesenswert
Thomas Z. schrieb:
> Und mach alle Tests mit einem ordentliche
> selfpowered Hub. Wer weiß schon was an den Usbpins so rauskommt.
... jetzt wo du es sagst. Danke dafür. Hab ich gar nicht dran gedacht, 
das ich mir sonst noch den USB Port vom PC zerschiss.

Wie verhält sich das mit dem CP2109?
Hab gelesen das hier die VID un PID programmiert werden kann.

von Thomas Z. (usbman)


Bewertung
0 lesenswert
nicht lesenswert
Den CP2109 kenn ich nicht näher aber soweit mir bekannt ist wird er ccd 
erkannt da wird dann eine VID PID keine große Rolle spielen. Zumindest 
bei W10 wird er automatisch richtig erkannt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.