Forum: Analoge Elektronik und Schaltungstechnik Oszilloskop zeigt Phasenverschiebung in Rad mit nur 1 Pi an?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Peta (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin Leute,

ich habe ein OWON Smart DS7102V.
Ich hab eine Schaltung wo ich gerne die Phasenverschiebung messen 
möchte. Es gibt dazu die Funktion Phase. Allerdings stimmt der Wert der 
dort angezeigt wird nicht wirklich. Das Oszilloskop kann diesen Wert nur 
in Radiant anzeigen.
Im Bild sieht man unten Links bei den Measurements den Punkt RD: 0,511

Nach meiner Berechnung:
Winkel = (360/(2*pi)) x 0,511 = 28,65°

Wie man aber im Bild erkennen kann, kommt dieser Winkel unmöglich hin.

Wenn ich allerdings anstatt mit 1 Pi rechne kommt ein Ergebnis raus was 
richtig ist (überprüft mit der Zeit usw.)

Winkel = (360/(1*pi)) x 0,511 = 57,3°

Meine Frage wäre, ist sowas normal? Oder ein Fehler? In der 
Bedienungsanleitung steht dort leider hierzu gar nichts.

Wäre schön wenn jemand hiermit Erfahrung hätte und mir erklären könnte 
warum das so ist....

Vielen Dank schonmal!

Gruß
Peta

von Nur mal so grob geschaetzt (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das kommt doch wohl so hin


Eine Halbwelle gleich Pi 3,14

Scheitelpunkt Pi halbe 1,57

Zähle mal die Kaestchen... Und kalkuliere mal neu...

von Peta (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also ich weiß nicht ob ich aufn Schlauch stehe, aber ich hab das mal 
eingezeichnet.

In Grün wäre eine Phasenverschiebung von 90°, was in Rad 1,57 entspricht 
(pi halbe).
An der markierten blauen Stelle ist die angezeigte Phasenverschiebung. 
Was das Oszilloskop als 0,511 rad berechnet. Was in Deg 28,65° 
entspricht.

Meine Daumenwert sagt aber das es ca. 2/3 von 90° entsprechen sollte, 
sprich so ca. 60°.

von Kurvi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ev. ein Programmierfehler in der Firmware?
Was ist denn die Phasenverschiebung, wenn Du direkt das Eingangssignal 
auf Kanal zwei legst und es investierst?

von Peta (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ok nun bin ich wirklich verwirrt.

Ich hab das Foto schnell mit meinem Handy gemacht und hier ist die 
Phasenverschiebung korrekt.

Ich habe aber noch mehrere Messungen gemacht, wo es mit dem "2 * Pi" 
nicht hingekommen ist.

von Nur mal so grob geschätzt (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Du solltest darauf achten einen gemeinsamen Bezugspungt zu wählen. Zum 
Beispiel die Null - Linie. Oder...

von Nur mal so grob geschätzt (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Du solltest darauf achten einen gemeinsamen Bezugspunkt zu wählen. Zum 
Beispiel die Null - Linie. Oder...


Das hast Du aber nicht gemacht! Stichpunkt Vertikale Verschiebung...

von Peta (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vertikal habe ich nicht verschoben, das sieht man doch neben den Kanal 
Einstellung:
Kanal 1: 20mV~ 0.00 div
Kanal 2: 200mV~ 0.00 div

Die 0.00 div bedeuten doch das ich vertikal nichts verschoben habe oder?

Habe nur horizontal was geändert, da steht oben rechts bei -36nS.

Oder habe ich dich Falsch verstanden?

von C. A. Rotwang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Nicht außer Acht lassen, es könnte auch sein, das die Angabe des 
Phase-shifts stimmt, aber nicht der gezeichnete Graph. Solche Effekte 
hat man schon öfters bei Interpolation gesehen wenn die Abtastrate das 
Nyquist Kriterium verletzt.
(Foto und screenshoot sind mit unterschiedlichen samplerates aufgenommen 
(100k und 250k) und als Frequwnz wird mal 1M und mal 400Hz angezeigt.)

Ich hab das schon öfters beim Durchdrehen der Zeitablenkung an 
samplescopes gesehen, das da andere Sinusperioden als vorhanden 
dargestellt werden:

Aliaseffekt: 
https://de.wikipedia.org/wiki/Alias-Effekt#/media/Datei:Aliasing_mrtz.svg

von Kurvi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Bleibt das Problem bestehen, wenn Du die Eingangssignale AC einkoppelst?

von C. A. Rotwang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
C. A. Rotwang schrieb:
> (100k und 250k) und als Frequenz wird mal 1M und mal 400Hz angezeigt.)

Korrektur:
oberes Post: 250M/s -> 1.014 MHz
unteres Post:100k/s ->   434 Hz

Um welches Eingangsignal handelt es sich ? Welcher Messbereich muss also 
eingestellt werden um die genausten Ergebnisse zu ereichen?

Tipp:
Phasenverschiebung kann man auch im xy-mode (Lissajous-Figur) ermitteln
https://de.wikipedia.org/wiki/Lissajous-Figur

von Michi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Setz doch mal die Triggerschwelle auf die Nullinie. Evtl. nimmte er die 
Triggerimpulse.
Der Winkel im ersten Bild ist 360^°*(0,8/4,9)=59°

von Quatsch (Gast)


Bewertung
-3 lesenswert
nicht lesenswert
Peta schrieb:
> Vertikal habe ich nicht verschoben, das sieht man doch neben den
> Kanal
> Einstellung:
> Kanal 1: 20mV~ 0.00 div
> Kanal 2: 200mV~ 0.00 div
>
> Die 0.00 div bedeuten doch das ich vertikal nichts verschoben habe oder?
>
> Habe nur horizontal was geändert, da steht oben rechts bei -36nS.
>
> Oder habe ich dich Falsch verstanden?

Deine Rote Kurve ist eindeutig nicht symmetrisch zu der 0 Linie!!!

Eindeutig und einfach zu erkennen!!!

Du solltest die Pfoten von solchen Geraeten lassen!!!

von Kaffeetasse (Gast)


Bewertung
0 lesenswert
nicht lesenswert

von Reinhard R. (reirawb)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Peta,

ich habe das gleiche Gerät und auf Grund deines Postes auch mal damit 
gespielt. Als erstes der Test mit gleichphasiger Einspeisung beider 
Kanäle, mit und ohne Invertierung von Kanal 2. Ich bekomme in beiden 
Fällen schwankende Anzeigen, einmal 0.00rad (0xPi) und einmal ~3,14 
(1xPi). Wenn ich dann die Phase vom Kanal 2 schiebe (4kHz, RC-Tiefpass 
1kOhm/100nF) bekomme ich auch den falschen Wert, der ungefähr der Hälft 
des errechneten Wertes entspricht. Im letzten Bild habe ich die Frequenz 
noch auf 40kHz erhöht, wodurch ein Phasenwinkel von fast 90 Grad 
enrsteht. 90 Grad = 0,5xPi = 1,57rad. Angezeigt werden 0,725rad, also 
der halbe Wert.
Übrigens, der Wert ändert sich nicht, wenn ich einen Kanal invertiere 
(Bilder OWON_7a/OWON_8a).
Alles sehr mystisch :-(

Reinhard

: Bearbeitet durch User
von Rainer V. (a_zip)


Bewertung
-2 lesenswert
nicht lesenswert
Wer mißt, mißt Mist :-) alte Bauernweisheit...
Gruß Rainer

von samm (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Es sieht so aus. als ob die Formel zur Berechnung der Phasenverschiebung 
nicht nur im Handbuch, sondern auch in der Firmware fehlerhaft ist.

http://files.owon.com.cx/probook/SDS_Series_USER_MANUAL.pdf
Wg. Spam-Filter ist das .cx durch .cn zu ersetzen

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
samm schrieb:
> Es sieht so aus. als ob die Formel zur Berechnung der Phasenverschiebung
> nicht nur im Handbuch, sondern auch in der Firmware fehlerhaft ist.

Das wäre wenigstens konsequent.
Die korrekte Umrechnung müsste so etwa im Lehrplan der Jahrgangsstufe 9 
dran gewesen sein :-(

von Reinhard R. (reirawb)


Bewertung
0 lesenswert
nicht lesenswert
Danke an samm für die Aufklärung, ins Handbuch habe ich natürlich nicht 
rein geguckt...
...wer guckt schon ins Handbuch...

Reinhard

von Ich (Gast)


Bewertung
-7 lesenswert
nicht lesenswert
Messgeräte sind mittlerweile so billig das der Poebel sie kaufen kann...

Die sollten wieder richtig teuer werden damit nur fachkundige Sie kaufen 
können!

Im Ernst.

von Und dann? (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich schrieb:
> Messgeräte sind mittlerweile so billig das der Poebel sie kaufen kann...

Meinst du kaufen oder Firmware schreiben ?

von Rainer V. (a_zip)


Bewertung
0 lesenswert
nicht lesenswert
Ich wiederhole mich natürlich ungern, aber schon die Frage des TO hat 
doch gezeigt, dass er nicht weiß, was er macht...wenn ich beliebig 
zwischen zwei Punkten auf der Schwingung die Phase messe, dann ist sie 
natürlich auch unterschiedlich. Sehe kein Problem :-)
Gruß Rainer

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.