Forum: Analoge Elektronik und Schaltungstechnik BS2101F Gate Treiber macht Probleme


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Luca E. (derlucae98)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich designe aktuell einen Halbbrücken-Durchflusswandler und bevor ich 
den Prototypen teste, habe ich den PWM Controller getestet, um 
expoldierenden Halbleitern vorzubeugen.
Die Mosfets werden mit einem High-/Low-Side Treiber (BS2101F) 
angesteuert.

Eigentlich hatte ich den L6395 dafür angedacht, allerdings hat mich beim 
Bestellen der BWL-Blitz getroffen, sodass ich in der parametrischen 
Suche bei Mouser einen Treiber gefunden habe, der ein paar Cent 
günstiger ist, aber das selbe Pin out hat...

Der L6395 ist laut Figure 5 im Datenblatt für diesen Anwendungsfall 
geeignet. Was der L6395 kann, kann der BS2101F auch, dachte ich.
Bevor ich nun das Lehrgeld zahle und einen L6395 bestelle, möchte ich 
klären ob der BS2101F wirklich nicht für diese Anwendung geeigent ist, 
oder ob das Problem - wie so häufig - vor dem Lötkolben sitzt.

Anbei die Testschaltung. R103 ist später die Primärwicklung des 
Übertragers.
Der untere Mosfet schaltet, wie zu erwarten, wunderbar. Der obere Mosfet 
schaltet jedoch immer nur für ein paar Zyklen und macht dann erstmal 
Pause. Die Schaltflanken sehen auch nicht so toll aus.
Verändern des Bootstrapkondensators C104 (Werte zwischen 100n und 10u 
ausprobiert) verlängert nur die "Pausenzeit".

Kanal 1 (Gelb): HDRV
Kanal 2 (Blau): PRI1
Kanal 3 (Lila): LDRV

Liegt es also nur an dem Treiber oder liegt der Fehler wo anders?

: Bearbeitet durch User
von Mike (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Scherzkeks... ;o)

von Ingo Less (Gast)


Bewertung
0 lesenswert
nicht lesenswert
R103 muss gegen Masse vom Abgriff der Halbbrücke...

von Ingo Less (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Und du musst du Eingänge gegenphasig takten!

von Luca E. (derlucae98)


Bewertung
0 lesenswert
nicht lesenswert
Ingo Less schrieb:
> R103 muss gegen Masse vom Abgriff der Halbbrücke...
> Und du musst du Eingänge gegenphasig takten!

Es wird ein Flusswandler, kein Gegentaktwandler.
https://www.embedded.com/wp-content/uploads/media-1045711-nscpowerfig1.jpg

von Sven S. (schrecklicher_sven)


Bewertung
0 lesenswert
nicht lesenswert
Du mußt den R103 schon angemessen niederohmig machen, damit sich der 
Bootstrapkondensator auch aufladen kann.

von Luca E. (derlucae98)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> Du mußt den R103 schon angemessen niederohmig machen, damit sich der
> Bootstrapkondensator auch aufladen kann.

Das macht natürlich sinn. Ich habe mal strombegrenzte 300V an den 
Wandler angelegt. -> Selbes Problem.

Im Datenblatt des UCC27714 habe ich eine Schaltung gefunden, die dem 
Problem entgegenwirkt und den Bootstrapkondensator immer in der lowphase 
auflädt. In der Simulation funktioniert das schon mal gut. Ich mache 
eine neue Platine und teste das mal.

von Sven S. (schrecklicher_sven)


Bewertung
0 lesenswert
nicht lesenswert
Luca E. schrieb:
> Ich habe mal strombegrenzte 300V an den
> Wandler angelegt. -> Selbes Problem.

Und R103 mit 4,7K belassen? Dann ändert sich natürlich nichts.

von Luca E. (derlucae98)


Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> Und R103 mit 4,7K belassen? Dann ändert sich natürlich nichts.

Nein, natürlich mit der Primärwicklung des Übertragers.

von Sven S. (schrecklicher_sven)


Bewertung
0 lesenswert
nicht lesenswert
Besonders bei niedriger Leistung oder im Leerlauf, also kurzer 
Einschaltdauer der Transistoren, ist es kaum möglich, Cboot auf Spannung 
zu halten. Deshalb wird oft ein Impulstrafo verwendet, um die 
Transistoren anzusteuern. Die von Dir gezeigte Schaltung vermeidet 
dieses Problem aber auch.

von Luca E. (derlucae98)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Neue Schaltung, neues Glück. Mit obiger Schaltung funktioniert der 
Wandler nun einwandfrei. Sogar mit nicht allzu schlechtem Wirkungsgrad 
von 89%.

Luca E. schrieb:
> das Problem - wie so häufig - vor dem Lötkolben sitzt

Womit das dann auch wieder einmal bewiesen wäre. ;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.