Forum: Analoge Elektronik und Schaltungstechnik LED´s Parallel und in Reihe Geschaltet, ungleichmäßige Helligkeit


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Leander (Gast)


Bewertung
-5 lesenswert
nicht lesenswert
Moin,
ich habe mir einen LED Würfel gebaut, wo die Verschiedenen Ebenen durch 
den - Pol Verbunden sind, mithilfe eines Transistors, Senkrecht sind die 
"Säulen" durch den +Pol verbunden, mit jeweils einem Vorwiderstand. Das 
alles wird durch mehrere Schieberegister gesteuert. Hat jemand eine Idee 
wie man das fixen könnte ?

MFG Leander

: Verschoben durch Moderator
von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
2 lesenswert
nicht lesenswert
Leander schrieb:
> mit jeweils einem Vorwiderstand.
Also 1 Vorwiderstand für mehrere parallelgeschaltete LEDs?
Ein Schaltplan mit Bauteilwerten wäre nicht schlecht. Oder wenigstens so 
viel Skizze, dass der TXT2SCHEMATIC-Konverter im Kopf nicht abstürzt...

: Bearbeitet durch Moderator
von s.c.n.r. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Leander schrieb:
> Hat jemand eine Idee wie man das fixen könnte ?
Lötkolben anschmeißen und notfalls mit Hilfe einer Lötzinnabsaugepumpe 
das Lötzinn wieder entfernen.

von Leander (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Okay, einen Schalplan kann ich nachher mal machen, den Lötkolben wieder 
anschmeißen bringt ja nicht, verlötet ist ja alles richtig

von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert
Vermutlich waren es billige LEDs, die von Natur aus ungleichmäßig hell 
sind bei gleicher Stromstärke.


MfG

von Leander (Gast)


Angehängte Dateien:

Bewertung
-6 lesenswert
nicht lesenswert
So, das ist jetzt mal der Schalplan, aber nur mit 4 Leds anstatt 64, 
einfachheitshalber.

von LED (Gast)


Bewertung
2 lesenswert
nicht lesenswert
:-)))

von Jörg R. (solar77)


Bewertung
2 lesenswert
nicht lesenswert
Leander schrieb:
> So, das ist jetzt mal der Schalplan, aber nur mit 4 Leds anstatt
> 64, einfachheitshalber.

Na, den überprüfe aber noch mal;-)

: Bearbeitet durch User
von Mike (Gast)


Bewertung
3 lesenswert
nicht lesenswert
Mich wundert, dass überhaupt eine LED leuchtet. Liegt die Anode auf GND, 
müsste die Kathode einige Volt negativer sein, damit ein Strom durch die 
LEDs fließt. Eine negative Versorgungsspannung gibt es aber im 
Schaltplan nicht.

von Leander (Gast)


Angehängte Dateien:

Bewertung
-3 lesenswert
nicht lesenswert
Uuuups, die LEDs sollten natürlich andersherum sein :D
Und R1 und R2 sind jeweils 220Ohm und R3 und R4 jeweils 1k Ohm

von HF Spätsialist (Gast)


Bewertung
3 lesenswert
nicht lesenswert
Wenn die Emitters der Transistoren so in der Luft hängen wird's
wohl schwierig werden ....

von Jörg R. (solar77)


Bewertung
1 lesenswert
nicht lesenswert
Leander schrieb:
> Uuuups, die LEDs sollten natürlich andersherum sein :D
> Und R1 und R2 sind jeweils 220Ohm und R3 und R4 jeweils 1k Ohm

Die Leds liegen mit den Kathoden auf GND, Q1 und Q2 haben welche 
Funktion?

Die Emitter sind verbunden, hängen sonst aber in der Luft...?

Beitrag #6304669 wurde von einem Moderator gelöscht.
von Leander (Gast)


Bewertung
-4 lesenswert
nicht lesenswert
Q1 und Q2 etc geben entweder ein HIGH oder LOW  Output, die Transistoren 
sind natürlich bei 1 mit dem -Pol verbunden :D

von LED (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Und erkennst du jetzt das Problem selber? Was passiert mit R1, wenn
a) keine LED leuchtet
b) D1 oder D2
c) D1 und D2

von Leander (Gast)


Bewertung
-4 lesenswert
nicht lesenswert
Ja, er wird unterschiedlich "beansprucht" die Frage war nur ob man 
dagegen etwas machen kann :D

von Jörg R. (solar77)


Bewertung
1 lesenswert
nicht lesenswert
Leander schrieb:
> Q1 und Q2 etc geben entweder ein HIGH oder LOW  Output, die
> Transistoren
> sind natürlich bei 1 mit dem -Pol verbunden :D

Natürlich ist nix, wir möchten nicht raten wo und wie etwas verschaltet 
ist.

Zeige mal einen korrekten Plan.

Aktuell haben die Transistoren keine Funktion, auch wegen GND an den
Kathoden der Leds.

: Bearbeitet durch User
Beitrag #6304691 wurde vom Autor gelöscht.
von HF Spätsialist (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Leander schrieb:
> die Transistoren
> sind natürlich bei 1 mit dem -Pol verbunden :D

Nö, sind sie nicht. Du hast gar kein Signal -Pol.

von Christian S. (roehrenvorheizer)


Bewertung
1 lesenswert
nicht lesenswert
Also laut Plan sind die LEDs immer an und die Transistoren ohne jede 
Funktion, also nur Dekoration.

MfG

von wer (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Leander schrieb:
> Ja, er wird unterschiedlich "beansprucht" die Frage war nur ob man
> dagegen etwas machen kann :D

Jeder LED einen eigenen Widerstand verpassen, ganz einfach.

von Christian S. (roehrenvorheizer)


Bewertung
1 lesenswert
nicht lesenswert
Warum arbeitet U1 gegen +5V? Das kann doch so nicht gewollt sein, 
sondern dies sind die positiven Versorgungen für die LEDs und die 
Transistoren sollen die Kathoden gegen GND schalten, die bereits mit 
zwei LEDs nachgeben und deswegen ist die Frage ganz oben erst 
entstanden. Da gehören auch Transistoren hin, bestenfalls als FETs.


MfG

von Teo D. (teoderix)


Bewertung
-2 lesenswert
nicht lesenswert

von Maxe (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Und dass da nicht noch ein spaetes Erwachen kommt: Du kannst die LEDs 
nur Zeilenweise pulsen.

von wer (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Teo D. schrieb:
> Blödsinn!

Von Multiplexing war bisher keine Rede, oder?

TO hat was von Schieberegistern gesagt, der Schaltplan ist fürn Eimer, 
also gehe ich davon aus, dass die LEDs einzeln angesteuert werden.

von Maxe (Gast)


Bewertung
3 lesenswert
nicht lesenswert
wer schrieb:
> Von Multiplexing war bisher keine Rede, oder?.
Das ist ja ne Matrix, die funktioniert nur ueber Multiplexing. Ausser 
man schraenkt sich darauf ein, dass die LEDs nur in bestimmten 
Kombinationen leuchten koennen.

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Leander schrieb:
> Q1 und Q2 etc geben entweder ein HIGH oder LOW  Output, die Transistoren
> sind natürlich bei 1 mit dem -Pol verbunden :D

Nicht nur das. In einer funktionsfähigen Schaltung sollte U1 deutlich 
anders beschaltet sein. Was haben die +5V an U1.1 oder U1.15 zu suchen?

Und wo sind die Abblockkondensatoren?

Falls der µC auf dem Arduino Nano mit 3.3V läuft, sollte die 
Schieberegister aus der 74HCT-Serie sein.

von Leander (Gast)


Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Also dann hier der richtige Plan, allerdings mit nur 4 LED´s und es sind 
nicht alle Anschlüsse von der Schieberegistern angeschlossen der 
einfachheitshalber. Das einzeige Problem ist, dass die LEDs 
unterschiedlich hell leuchten, je nachdem welche an sind.

von Teo D. (teoderix)


Bewertung
1 lesenswert
nicht lesenswert
wer schrieb:
> Teo D. schrieb:
>> Blödsinn!
>
> Von Multiplexing war bisher keine Rede, oder?

OK, egal wie, es war verwirrend... :)

von Jens G. (jensig)


Bewertung
1 lesenswert
nicht lesenswert
>einfachheitshalber. Das einzeige Problem ist, dass die LEDs
>unterschiedlich hell leuchten, je nachdem welche an sind.

Tja, entweder sind die LEDs Kacke (unterschiedlicher Wirkungsgrad), oder 
aber das Timing ist unterschiedlich. Oszilloskop würde helfen, dies 
(nicht) zu bestätigen ...
Ach ja - sind LEDs in der vollen Ausbaustufe direkt parallel oder 
seriell geschaltet? Oder alles einzeln wie dargestellt?

: Bearbeitet durch User
von Abdul K. (ehydra) Benutzerseite


Bewertung
-2 lesenswert
nicht lesenswert
Einfache Lösung: LEDs EINER Bin kaufen. Also wohl eher nicht aus China, 
sonderm vom Distri.
"WE"-Lösung: Alle LEDs optisch beurteilen und im Controller eine PWM für 
jede LED realisieren, die die Helligkeitsschwankungen ausgleicht.

von Leander (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
mhhh, also ja, ich kann jede LED einzeln ansteuern.
>"Teuere" LED´s werden dann etwas teuer, wenn man 1000 Verbaut :D
>"WE"-Lösung: Alle LEDs optisch beurteilen und im Controller eine PWM für
>jede LED realisieren, die die Helligkeitsschwankungen ausgleicht.

Man kann soweit ich weis keinen PWM wert durch ein Schieberegister 
realisieren.

>Und wo sind die Abblockkondensatoren?

Würden solche helfen ? Wenn ja wo müsste ich die einbauen ?

von M. P. (phpmysqlfreak)


Bewertung
0 lesenswert
nicht lesenswert
Leander schrieb:
> mhhh, also ja, ich kann jede LED einzeln ansteuern.
>>"Teuere" LED´s werden dann etwas teuer, wenn man 1000 Verbaut :D
>>"WE"-Lösung: Alle LEDs optisch beurteilen und im Controller eine PWM für
>>jede LED realisieren, die die Helligkeitsschwankungen ausgleicht.
>
> Man kann soweit ich weis keinen PWM wert durch ein Schieberegister
> realisieren.
>

Möglich ist es schon. Software-Lastig und weitaus langsamer. Die 
Register müssen schnell genug befüllt werden, den rest kann man mit OE 
am 595er machen.

>>Und wo sind die Abblockkondensatoren?
>
> Würden solche helfen ? Wenn ja wo müsste ich die einbauen ?

Nah an die Versorgungsspannungskontakte der ICs - idealerweise so, dass 
die Kondensatoren NICHT über Stichleitungen angeschlossen sind.

von Leander (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>Möglich ist es schon. Software-Lastig und weitaus langsamer. Die
>Register müssen schnell genug befüllt werden, den rest kann man mit OE
>am 595er machen.

Ja, allerdings wechseln die LEDs die ganze Zeit zwischen ON/OFF merhmals 
in der Sekunde, also wird das nichts :D

>Nah an die Versorgungsspannungskontakte der ICs - idealerweise so, dass
>die Kondensatoren NICHT über Stichleitungen angeschlossen sind.

Also Praktisch parallel vor die Schieberegister oder was meinste mit 
ICs, kenne mich da nicht wirklich/ kaum aus.

von Jens G. (jensig)


Bewertung
1 lesenswert
nicht lesenswert
>Würden solche helfen ?

Diese Frage ist egal, denn Abblock-Cs werden immer pro IC vorgesehen, 
und zwar möglichst nah am IC, um den ICs eine möglichst saubere Spannung 
zu spendieren (es sei denn, das Datenblatt oder die globale Erfahrung 
sagt was anderes).
Denn CMOS enthalten (wie viele andere ICs auch) Gegentaktstufen, die 
gerne im Umschaltmoment vergleichsweise viel Strom ziehen, und damit 
hochfrequente Ströme verursachen, die die Logik der ICs stören könnte. 
Deswegen immer Abblock-Cs.
Ob fehlende Cs ursächlich für das Problem verantwortlich sind, ist da 
eher egal. Aber man schließt damit eine mögliche Ursache aus.

>Wenn ja wo müsste ich die einbauen ?
Einen 33nF-100nF Keramik oder gleichwertiges pro IC möglichst nah dran 
(nicht Luftlinie, sondern kurze Leitungswege).

von Maxe (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Ist dir die Matrix-Problematik denn klar?

Wenn du in deinem Beipiel D1 und D4 leuchten lassen willst, geht das 
nicht gleichzeitig. Du müsstest nämlich für D1 die Spalte1 und Zeile1 
schalten, für D4 aber Spalte2 und Zeile2. Im Endeffekt würden dann alle 
vier LEDs leuchten. Es darf also zu jedem Zeitpunkt immer nur einer der 
Transistoren durchgeschalten sein. Die Transistoren werden dann 
durchgetaktet und jeweils das passende Zeilenmuster auf U1 ausgegeben.
Deswegen werden auch die Transistoren verwendet, da mehrere Spalten 
gleichzeitig auf die eine aktive Zeile geschalten werden können.

Deshalb die Frage nach deiner Ansteuerung.

von Leander (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
>Ist dir die Matrix-Problematik denn klar?

Ja klar, das habe ich ja auch so gemacht, dass immer nur 1 Ebene 
Leuchtet, dann ausgeht und dann die 2te Leuchtet, und das dann halt ein 
paar 100x pro Sekunde gemacht wird.

>Einen 33nF-100nF Keramik oder gleichwertiges pro IC möglichst nah dran
Oder quasi zwischen die LED´s und dem Transistor/Schiebe Register ?

von Abdul K. (ehydra) Benutzerseite


Bewertung
-2 lesenswert
nicht lesenswert
Oder die Widerstände weg und die Transen zu Stromquellen machen. Dann 
ist die Regelung steifer, das optische Bild müßte gleichmäßiger werden. 
Aber viel ist damit nicht zu machen.

von Jens G. (jensig)


Bewertung
2 lesenswert
nicht lesenswert
Leander (Gast)

>>Nah an die Versorgungsspannungskontakte der ICs - idealerweise so, dass
>>die Kondensatoren NICHT über Stichleitungen angeschlossen sind.

>Also Praktisch parallel vor die Schieberegister oder was meinste mit
>ICs, kenne mich da nicht wirklich/ kaum aus.

Was verstehst Du unter dem Begriff IC?
Für mich ist das ganz ein fach ein Stück Plastik , aus dem viele Beine 
aus Metall herausschauen. Wenn das z.B. ein CMOS im 14-DIL-Gehäuse ist, 
dann war meistens Pin 7 und 14 der Betriebsspannungsanschluß, und dann 
machte man eben einen 100nF-Keramik-C möglichst kurz ran.
Möglichst kurz heist ganz wenige cm zw. Pin 7 und 14 bei Standard-CMOS 
(bei HC(T) möglichst weniger als wenig).

von Jens G. (jensig)


Bewertung
3 lesenswert
nicht lesenswert
>>Einen 33nF-100nF Keramik oder gleichwertiges pro IC möglichst nah dran
>Oder quasi zwischen die LED´s und dem Transistor/Schiebe Register ?

Wie meinen?
Natürlich sollte man dort, wo die LEDs und deren Schalter (Transistoren) 
die Energie (LED-Ströme) abgreifen, auch abblocken, damit dort die 
Betriebsspannung einigermaßen konstant und störungsarm bleibt.

von Leander (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Ein Abblockkondensator wäre ja einfacher einzubauen als ein IC, reicht 
dann davon 1 aus oder wären beide besser ?

von Leander (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Also irgendwie war ich gerade sehr verwirrt.
Mit dem IC meinst du also das Schieberegister, habe das immer mit SR 
abgekürzt ?

Also würdet ihr einfach einen 33nF-100nF Keramik nach dem IC und dem 
Transistor empfehlen ?

von Mani W. (e-doc)


Bewertung
2 lesenswert
nicht lesenswert
Ohne Abblockkondensatoren und auch Stützkondensatoren auf der
Betriebsspannung wird das sowieso nix...

von Leander (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Ja, deswegen ja die Frage. Ich bin mir halt unsicher ob es was bringt, 
wenn ja wie viel, und welche wo ich welche Kondensatoren einbauen 
muss...

von Mani W. (e-doc)


Bewertung
2 lesenswert
nicht lesenswert
100 nF Kerko direkt auf VDD und Gnd der ICs, jeder IC erhält einen
Kondensator, möglichst auf direktem Weg, also auf der Lötseite fliegend
dran, Betriebsspannungen mit Elkos stützen 10-47 µ, mehrere verteilt...

Und zusätzlich mal schlau machen, wozu das ganze dient!

von Leander (Gast)


Angehängte Dateien:

Bewertung
-4 lesenswert
nicht lesenswert
Also dann so ?

von Jörg R. (solar77)


Angehängte Dateien:

Bewertung
2 lesenswert
nicht lesenswert
Leander schrieb:
> Also dann so ?

Nein, Abblock-Cs kommen parallel an die Spannungsversorgung-Pins der 
ICs. Und zwar so nahe wie möglich. Es gibt sogar IC-Sockel (DIL) mit 
integrierten Cs. Ein C je Chip reicht.

In deiner Variante bekommt der Chip kurz Spannung, bis die Cs aufgeladen 
sind.

: Bearbeitet durch User
von Mani W. (e-doc)


Bewertung
2 lesenswert
nicht lesenswert
Leander schrieb:
> Also dann so ?

Es ist schon eigenartig, dass zwar ICs zusammengeschaltet werden,
aber grundlegende Dinge nicht vorkommen und dann noch so eine
Schaltung präsentiert wird...

Na ja...

von Jörg R. (solar77)


Bewertung
2 lesenswert
nicht lesenswert
Mani W. schrieb:
> Leander schrieb:
>> Also dann so ?
>
> Es ist schon eigenartig, dass zwar ICs zusammengeschaltet werden,
> aber grundlegende Dinge nicht vorkommen und dann noch so eine
> Schaltung präsentiert wird...

Viel präsentiert wurde ja nicht?


Mike schrieb:
> Mich wundert, dass überhaupt eine LED leuchtet.

Mich auch.

: Bearbeitet durch User
von Dietrich L. (dietrichl)


Bewertung
1 lesenswert
nicht lesenswert
Leander schrieb:
> Ja klar, das habe ich ja auch so gemacht, dass immer nur 1 Ebene
> Leuchtet, dann ausgeht und dann die 2te Leuchtet, und das dann halt ein
> paar 100x pro Sekunde gemacht wird.

Und wie sicher bist du, dass die Software das auch so macht? Bei der 
Ansteuerung einer Matrix kann man auch leicht Fehler machen...

Um das heraus zu finden kannst du ja mal nur die Hardware testen:
Schieberegister entfernen und immer nur eine Zeile und eine Spalte "zu 
Fuß" (mit Drähten) einschalten. Dann sollten alle LEDs gleich hell sein.

Noch eine andere Möglichkeit für Helligkeitsunterschiede:
Die Widerstände sind nach deiner Aussage 220Ω. Je nach LED-Typ 
(Flussspannung) fließen da schon einige mA. Und das lässt die 
Ausgangsspannung der 74HC595 schon merklich einbrechen, was exemplar- 
und herstellerabhängig unterschiedlich sein kann.

von Leander (Gast)


Bewertung
-5 lesenswert
nicht lesenswert
Also wie schon 5x erwähnt, der Würfel funktioniert. Das einzigste 
Problem ist nur dass sie Unterschiedlich hell sind.
>Und wie sicher bist du, dass die Software das auch so macht?

Weil ich die selber geschrieben hab und es funktioniert ?

von Jens G. (jensig)


Bewertung
2 lesenswert
nicht lesenswert
>Weil ich die selber geschrieben hab und es funktioniert ?

Daß Du die selber geschrieben hast, ist ja kein Garant für 
Fehlerfreiheit.
Und daß die funktioniert, hast Du noch nicht bewiesen, denn dafür sollte 
man schon mal ein Oszilloskop bemühen, um zu sehen, ob die Impulse 
wirklich die richtige Länge haben. Denn das könnte die unterschiedliche 
Helligkeit bewirken.
Ansonsten bin ich auch schon reichlich verwundert, wie man angeblich ICs 
zusammenklöppeln kann, und dann noch nix von Abblockung gehört hat, und 
dann sowas wie in Unbenannt1.PNG presentiert.

: Bearbeitet durch User
von Leander (Gast)


Bewertung
-5 lesenswert
nicht lesenswert
Naja, dann gebs ich hier auf, mehr als

das wundert mich aber
sicher dass das auch funktioniert
und dann noch
>dann sowas wie in Unbenannt1.PNG presentiert.

sowas präsentiert mit ä

bekommt...

euch allen dann einen schönen Tag noch...

von Jörg R. (solar77)


Bewertung
1 lesenswert
nicht lesenswert
Leander schrieb:
> Naja, dann gebs ich hier auf, mehr als
>
> das wundert mich aber
> sicher dass das auch funktioniert
> und dann noch
>>dann sowas wie in Unbenannt1.PNG presentiert.
>
> sowas präsentiert mit ä
>
> bekommt...
>
> euch allen dann einen schönen Tag noch...

Du hast keinen Grund die beleidigte Leberwurst zu spielen.
Du hast Lösungsansätze bekommen. Ob deine SW in Ordnung ist wissen wir 
nicht. Wenn sie so in Ordnung ist wie deine Schaltpläne darf man daran 
zweifeln.

Die Leds müssen bei Dir unterschiedlich hell leuchten. Scheinbar bis zu 
8 Leds hängen an einem Vorwiderstand. Wie sollen sie dann konstant hell 
leuchten wenn 1 bis 8 Leds an sind. Selbes Thema am Transistor. Je nach 
Anzahl der Leds ändert sich der Strom. Dadurch ändert sich auch Uce.

Es sind auch keine Widerstandswerte angegeben um mal eine grobe 
Berechnung für die Transistoren durchführen zu können.
Besser geeignet wären Mosfets, wurde glaube ich auch schon angeregt.
Die Schiebegister sind auch nicht die idealen Treiberstufen.

Wir wissen auch nicht ob du vernünftig verkabelt hast, auch hier können 
sich Fallstricke ergeben. Vielleicht bricht auch deine Stromversorgung 
ein..usw....usw.

Wie schon mehrfach gesagt, die Fragmente aus deinem Schaltplan helfen 
nur bedingt weiter.

: Bearbeitet durch User
von Joachim B. (jar)


Bewertung
-2 lesenswert
nicht lesenswert
Leander schrieb:
> Also dann so ?

echt jetzt einen Kondensator in die Zuleitungen?
Was macht ein Kondensator?
Er trennt Gleichströme und wie soll das IC dann arbeiten wenn kein 
"Gleichstrom" zum IC kommt?

Wie kommt das Basteln vor dem Verständnis?

Beispielschaltungen von Stütz- oder Abblockkondensatoren an IC findet 
man zu Hauf im Netz:
https://www.mikrocontroller.net/attachment/123557/Power_Capacitor.png
https://cdn-reichelt.de/bilder/web/xxl_ws/C130/GS-KD_16P.png
http://www.lothar-miller.de/s9y/uploads/Bilder/Entkopplung_OK1.jpg
https://www.langer-emv.de/de/product/stoerfestigkeit/81/emv-design-in-der-ic-umgebung-fuer-esd-und-burst/998

von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert
Mani W. schrieb:
> Leander schrieb:
>> Also dann so ?
>
> Es ist schon eigenartig, dass zwar ICs zusammengeschaltet werden,
> aber grundlegende Dinge nicht vorkommen und dann noch so eine
> Schaltung präsentiert wird...
>
> Na ja...

Früher in echten Büchern bekam man die Thematik vollständig erklärt und 
hatte so ein recht umfangreiches Wissen beim Start mit 
Digitalschltungen.


mfG

von Sebastian S. (amateur)


Bewertung
-1 lesenswert
nicht lesenswert
Leuchtdioden parallel schalten ist keine gute Idee.
Wenn Du Dir mal die Durchlasskennlinie einer Diode anschaust, wirst Du 
feststellen, dass schon geringe Spannungsänderungen große Stromdifferenz 
zur Folge haben.
Hinter einem Widerstand bedeutet dass, dass sich die eine Diode den 
ganzen Strom krallt und die andere zusehen muss wo sie bleibt. Somit 
lässt sich die Helligkeitsdifferenz leicht erklären.
Schon die "normalen" Fertigungstoleranzen reichen hierfür aus.
Leichte Unterschiede (bei nicht sortierten Dioden) kann man durch 
"eigene" Widerstände ausgleichen. Also vor jede Diode einen Widerstand. 
Oder auch nicht.

von Peter D. (peda)


Bewertung
0 lesenswert
nicht lesenswert
Leander schrieb:
> Weil ich die selber geschrieben hab

Gerade dann kann es gut sein, daß die Helligkeitsunterschiede am 
Programm liegen.
Etwas anderes wäre es, wenn das Programm schonmal ohne 
Helligkeitsprobleme gelaufen wäre.
Sag doch wenigstens mal, ob die Unterschiede mit einem Transistor oder 
mit einem IC korrelieren.

von MaWin (Gast)


Bewertung
3 lesenswert
nicht lesenswert
Leander schrieb:
> Also dann hier der richtige Plan

Besser, aber mit welcher Salamischréibe erfahren wir die 
Widerstandswerte ?

Leander schrieb:
> Das einzeige Problem ist, dass die LEDs
> unterschiedlich hell leuchten, je nachdem welche an sind.

Im Prinzip funktioniert deine Schaltung, immerhin sind die 
Vorwiderstände in den richtigen Leitungen.

ABER:

Sie funktioniert nur für wenig Strom, also geringe Helligkeit, denn 
deine 74HC595 konnen nur 20mA liefern, aus allen 8 Ausgängen gar nur 
80mA zusammen, also 10mA pro LED, und die 2N2222 können nur 800mA 
schalten, und das auch nur wenn sie 80mA Basisstrom bekommen würden, 
aber mehr als 20mA, liefern deine 595 nicht was nur für eschaltete 200mA 
reicht, falls sie nicht durch zu hochohmige Widerstände vollständig 
ausgebremst sind.

Ein 4 x 4 x 4 Würfel hat ein Multiplex-Verhältnis von 4, eine LED die 
mit 20mA betrieben werden soll wird also 1/4 der Zeit von 80mA 
durchflossen, und für 16 davon müssen 1.28A geschaltet werden.

Das bringt deine Schaltung nicht mal ansatzweise, es wird alos was 
überlastet und wohl daher sinkt die Helligkeit.

Nimmt man die 10mA die ien 595 sicher schafft als Spitzenstrom leuchten 
die LEDs nur so hell wie mit 2.5mA Dauerstrom, und muss der 2N2222 bis 
160mA schalten was e rmit 16mA Basisstrom, also einem 270 Ohm 
Basiswiderstand auch schafft, die LEDs brauchen auch 270 Ohm bei 
rot/gelb/grün oder 100 Ohm bei blau/weiss.

Keine Ahnung, warum man bastelt ohne zuvor Grudlagen zu lesen:
http://www.dse-faq.elektronik-kompendium.de/dse-faq.htm#F.8.1

Keine Ahnung auch, warum man 2N2222 heute noch verwendet, im hübschen 
Metallgehäuse, und warum man sich die Mühe mit 595 macht, statt CAT4016 
oder ähnlich sinnvolle Konstantstromtreiber.

von Abdul K. (ehydra) Benutzerseite


Bewertung
-3 lesenswert
nicht lesenswert
Ja, MaWin hat mal wieder recht.

Waren es nicht 64 LEDs, da gibt's doch die MAXxy Treiber, die alle auf 
einmal versorgen. Wenn man wenig weiß, nimmt man bewährte fertige Ideen.

Ein Würfel mit 64 Lampen, wie sind die verteilt? Die Gleichung geht ja 
gar nicht auf.

Die Abblock-Kondis, die hat er schon richtig eingezeichnet, es ist aber 
ungewohnt für Profis wenn die Versorgungsleitungen in den Plan komplett 
reingezeichnet werden, und so als Signalpfade erscheinen. Zumindest für 
Masse ist das doch sehr ungewöhnlich.

von Jörg R. (solar77)


Bewertung
1 lesenswert
nicht lesenswert
Abdul K. schrieb:
> Waren es nicht 64 LEDs, da gibt's doch die MAXxy Treiber, die alle auf
> einmal versorgen. Wenn man wenig weiß, nimmt man bewährt

MAX7219
HT16K33...128 Leds

von Wolfgang (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Abdul K. schrieb:
> Die Abblock-Kondis, die hat er schon richtig eingezeichnet, ...

Hier bestimmt nicht.

Leander schrieb:
> Unbenannt1.PNG

Der Minuspol eines Elkos hat am VCC-Pin des ICs genauso wenig zu suchen, 
wie der Pluspol am Gnd-Pin - egal wie man es dreht.

von Abdul K. (ehydra) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Wolfgang schrieb:
> Abdul K. schrieb:
>> Die Abblock-Kondis, die hat er schon richtig eingezeichnet, ...
>
> Hier bestimmt nicht.
>

Da fehlt nur nocb ne Leitung, vermutlich hat er es richtig, nur der Plan 
ist falsch. Sonst würden die ICs gar nicht laufen!!

von Joachim B. (jar)


Bewertung
1 lesenswert
nicht lesenswert
Abdul K. schrieb:
> vermutlich hat er es richtig,

und nach was soll beurteilt werden nach "vermutlich" oder nach dem was 
man gezeigt bekommt?

von Abdul K. (ehydra) Benutzerseite


Bewertung
-2 lesenswert
nicht lesenswert
Der Würfel leuchtet doch!

von Joachim B. (jar)


Bewertung
-3 lesenswert
nicht lesenswert
Abdul K. schrieb:
> Der Würfel leuchtet doch

Nachbars neue Sensortouch Nachtischlampen leuchteten auch ohne das er 
was geschaltet hatte, so geht moderne Elektronik.

von MaWin (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Jörg R. schrieb:
> MAX7219

Der bringt im Schnitt nur 5mA pro LED

> HT16K33...128 Leds

Der bringt nur 100uA ohne, und 10mA mit externen Zeilentransistoren.

Steht alles in der dse Faq.

von Abdul K. (ehydra) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
5mA reichen für gute LEDs völlig aus.

von Roland F. (rhf)


Bewertung
-1 lesenswert
nicht lesenswert
Hallo,
MaWin schrieb:
> ...und warum man sich die Mühe mit 595 macht, statt CAT4016
> oder ähnlich sinnvolle Konstantstromtreiber.

Zu Anfang war von 64 LEDs die Rede, dafür würde ich einen MAX7219 oder 
MAX7221 verwenden.

rhf

von Mani W. (e-doc)


Bewertung
0 lesenswert
nicht lesenswert
Abdul K. schrieb:
> Die Abblock-Kondis, die hat er schon richtig eingezeichnet

Sicher?

Joachim B. schrieb:
> Abdul K. schrieb:
>> vermutlich hat er es richtig,
>
> und nach was soll beurteilt werden nach "vermutlich" oder nach dem was
> man gezeigt bekommt?

Dass der TO keine Ahnung hatte, was so Kondensatoren eigentlich sollen
ist ein Kaffee, dass meine Beleuchtung und der Fernseher noch 
funktionieren
ist vermutlich auf das Vorhandensein von Spannung und Strom aus der
Steckdose zurückzuführen...

Das zum Thema "vermutlich"...

;-))

von Abdul K. (ehydra) Benutzerseite


Bewertung
-2 lesenswert
nicht lesenswert
Er hat ein Design gelötet und den Schaltplan im Kopf. Und dann für euch 
versucht zu zeichnen. Dabei hat er sich verwurschtelt. Das ist alles.

Klar ist er Anfänger.

von Mani W. (e-doc)


Bewertung
1 lesenswert
nicht lesenswert
Abdul K. schrieb:
> Dabei hat er sich verwurschtelt.

Und Elkos in Vdd und Gnd in Serie gezeichnet nennst Du verwurschtelt?

von Abdul K. (ehydra) Benutzerseite


Bewertung
-1 lesenswert
nicht lesenswert
Es nervt! Er zahlt später eure Rente!

von Mani W. (e-doc)


Bewertung
-2 lesenswert
nicht lesenswert
Leander schrieb:
> Naja, dann gebs ich hier auf, mehr als
>
> das wundert mich aber
> sicher dass das auch funktioniert
> und dann noch
>>dann sowas wie in Unbenannt1.PNG presentiert.
>
> sowas präsentiert mit ä
>
> bekommt...
>
> euch allen dann einen schönen Tag noch...

Hast Du keine Nerven oder warum schmeißt Du jetzt das Handtuch?

Dir wurde geholfen, wenn Du jetzt Dein angeknackstes Ego nicht
unter Kontrolle bekommst, dann ist das Deine Sache, aber schassel die
Leute hier nicht einfach ab!

https://www.ostarrichi.org/wort/3284/abschasseln

: Bearbeitet durch User
von Mani W. (e-doc)


Bewertung
-1 lesenswert
nicht lesenswert
Und noch etwas, was ich weder auf Mir noch auf den vielen anderen
Schreibern sitzen lasse:

Sehr viele hier haben schon vor gut 50 Jahren Elektronik erlernt,
Detektorempfänger, Lichtorgeln, Verstärker usw. gebaut und haben
bis heute viel gelernt mit weiterentwickelten, besseren Bauteilen...

Andere haben mit µC weiter gearbeitet seit den 80ern...

Und auch Mechanik in all seinen Formen...


Dieses Forum beinhaltet sehr viele unterschiedliche Menschen, die
keineswegs dumm sind, aber bereit, anderen Menschen Hilfe zu bieten...

Ich denke, jeder war froh, wenn er Input von erfahrenen Leuten erhielt,
und so lernten sehr viele von uns immer mehr...

Dass jetzt immer wieder Einige aus der Versenkung auftauchen, die
meist keinerlei Grundlagenwissen haben, aber irgend welche Schaltungen
zusammen frickeln und dann die Helfer diskreditieren, halte ich für
sehr impertinent!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.