Forum: Platinen AD20 Kann Traces nicht löschen


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Designer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Miteinander

AD20 plagt mich mal wieder mit komischem Verhalten:

Hat jemand eine Idee woher das stammen könnte?

Ich kann seit gestern keine Traces oder Rooms mehr löschen.

Ich kann die Traces markieren, somit ist kein Selection Filter aktiv.

Will ich die Trace mit Backspace oder Delete löschen, so passiert 
nichts.


Der Altium Support ist bereits bemüht, jedoch habe ich ziemlich Druck 
und muss dieses Board ASAP fertigstellen. Bisher nichts brauchbares als 
Rückmeldung erhalten.


Das einzige was geht ist, die Trace markieren, dann CTRL+X und dann 
nochmals auf die Trace klicken. Ist aber sehr mühsam..


Mit AD19 im selben Projekt, habe ich das Problem nicht, auch wenn ich 
die kompletten Preferecens aus AD20 importiere..


Bin dankbar um jeden Tipp.

von Taz G. (taz1971)


Bewertung
0 lesenswert
nicht lesenswert
Bei Ärger mit Shortcuts kenne ich zwei Wege.
Der sanfte Weg, rechts click in Toolbar -> customize, auf Reiter 
Toolbars und "PCB Shortcuts" Restore (wenn die Bar nicht "active" ist 
hast Du schon dein Problem, dann brauchst Du kein Restore).

Der harte Weg, ich mal faul und kopieren den Text vom Altium forum:
There is a file which is used by AD to declare shorctuts and scripts. 
This file has an RCS extension and should be located under:

C:\Users\your-pc-user-name-here\AppData\Roaming\Altium\Altium Designer 
{some hex numbers here}

Removing the DXP.RCS file should be enough to fix your issue.
If this doesn't work, try DXF.RAF and UserTools.TLT

Do this when AD is not running.



Ich würde die Dateien zur Sicherheit nur umbenennen und nicht löschen, 
Altium legt diese Dateien beim Start neu an und das Problem sollte weg 
sein.

von Wühlhase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Geht löschen denn nur mit Shortcuts/Tastaturbefehlen nicht, und 
funktioniert es mit dem Rechtsklickmenü?

Diese Marotte kannte ich von Altium noch nicht. :(

von Wühlhase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Es ist zwar ein lästiger Würgaround, aber ich hatte zuletzt immer noch 
Altium 17 parallel installiert. Wenn mir was in AD19 nicht gepasst hat, 
mußte AD 17 ran (und meistens hab ich damit dann eine ganze Weile 
weitergearbeitet).

von Thorsten S. (thosch)


Bewertung
0 lesenswert
nicht lesenswert
So ein Problem hatte ich noch nicht mit Altium.
Aber bei mir hat das Interactive Routing mal die Leitungen bei jedem 
Mausklick gleich permanent verlegt.
Und im Meßmodus (Ctrl-M) führte jeder einzelne Mausklick zu Start- und 
Endpunkt auf einmal. Messen ging also nicht.
Ähnliches beim Bearbeiten von Polygonen...

Nach endloser Suche und Austausch der Maus gegen ein anderes Fabrikat 
kam ich auf den Grund: Ich hatte im Maustreiber die 
Doppelklick-Geschwindigkeit auf etwa 3/4 des Maximums raufgesetzt.
(die alte Maus war unschuldig, aber der Treiber der neuen setzte beim 
Installieren die Werte auf Defaults)

AD kann damit nicht umgehen, wenn die Doppelklickgeschwindigkeit im 
Maustreiber mehr als ein paar wenige Ticks erhöht wird!


Das war in AD15 und wurde gemeldet, aber in AD20 ist der Bug immer noch 
drin.

: Bearbeitet durch User
von Designer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe den Bug auch gemeldet...

Einzige Lösung ist: AD20 neu installieren..
Das Problem tritt erst auf wenn wir unsere System Settings laden.. 
Irgendwas dadrin scheint den Bug auszulösen..

Habe die Settings neu erstellt und kann Sie jetzt auxh wieder laden..

Support ist unbrauchbar..

von Wühlhase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Designer schrieb:
> Support ist unbrauchbar..

Ich hab zwar keine Ahnung wie das mit dem Telesupport ist, aber das 
Forum fand ich damals, als ich mit Altium angefangen habe, ziemlich gut.

Stelle Supportanfragen lieber dort.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.