Forum: Mikrocontroller und Digitale Elektronik CC1101: 868MHz Module aus Fernost


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Sven Scholz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Gemeinde,

im Dezember hatte ich CC1101 868MHz Module via eBay bestellt.
4 Stück. Die kamen im Februar bei mir an und ich konnte ALLE erfolgreich 
in Betrieb nehmen. Kleine Kupferantenne mit jeweils 9 Windungen lag auch 
mit im Päckchen.

Da das so super geklappt hat, habe ich im Juni nochmals 5 von diesen 
Modulen bei eBay bestellt. Auch wieder die 868MHz Variante.
Diese kamen auch wieder 1 Monat später bei mir an. Zu meiner 
Überraschung,
die Antenne sieht anders aus. Der Draht ist dünner. Die Antennenlänge 
gleich, allerdings die Windungszahl sehr viel höher. Zirka doppelt so 
viele.

Eins von den neuen Modulen wollte ich gestern in Betrieb nehmen bzw. in 
das bestehende "Netzwerk" einbringen.
Modul wurde erkannt und korrekt initialisiert. Allerdings werden keine 
Daten empfangen.

Na toll.

Die Module selbst weisen zu den bisherigen kaum Unterschiede auf. Der 
Schriftzug ist auch identisch. Einzig 2 Widerstände nahe der 
Kontaktleiste verlaufen bei den neuen Modulen von links nach rechts 
(waagerecht) und bei meinen bsiherigen von oben nach unten (senkrecht).

Ich werde evtl. noch Fotos einstellen...

Die Antenne habe ich mittlerweile auch mal getauscht und gegen einen 
einfachen Kupferdraht mit der Länge 8,6cm getauscht - NICHTS.

Wie würdet ihr jetzt weiter vorgehen?
Ich denke generell, dass das Modul schon funktioniert.
Die Frage ist nur auf welcher Frequenz?
Sieht für mich aus, als ob die neuen Dinger eher 433, oder 915MHz 
Modulen sind...

Danke und viele Grüße

von Sven Scholz (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe noch 2 Fotos gefunden...

Variante 1 zeigt die Module, die ich bisher verwendet habe.
Variante 2 zeigt die neuen Module, die keine Daten empfangen können von 
den Modulen Variante 1.

Ob die Module der Variante 2 untereinander Daten empfangen/senden können 
muss ich noch ausprobieren...

von funker (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sven Scholz schrieb:
> Modul wurde erkannt und korrekt initialisiert. Allerdings werden keine
> Daten empfangen.

Sind die Quarzfrequenzen unterschiedlich?

von Sven Scholz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
funker schrieb:
> Sind die Quarzfrequenzen unterschiedlich?

Puhh, das habe ich noch nicht überprüft. Werde ich am Abend nachholen 
und mich wieder melden...

Mal angenommen die wären unterschiedlich, ist das durch 
Register-Settings "behebbar"?

Danke und viele Grüße!

von Beo Bachta (Gast)


Bewertung
-3 lesenswert
nicht lesenswert
Sven Scholz schrieb:
> Puhh, das habe ich noch nicht überprüft. Werde ich am Abend nachholen
> und mich wieder melden...

Wenn man Widerstände nicht von Kondensatoren unterscheiden kann
dann wird's allgemein schon schwierig.

Sven Scholz schrieb:
> Einzig 2 Widerstände nahe der
> Kontaktleiste verlaufen bei den neuen Modulen von links nach rechts
> (waagerecht) und bei meinen bsiherigen von oben nach unten (senkrecht).

von Johannes S. (jojos)


Bewertung
0 lesenswert
nicht lesenswert
mit den CC1101 habe ich noch nichts gemacht, aber ein Blick ins 
Datenblatt sagt schonmal Quarz 26-27 MHz, der macht den Unterschied 
nicht.
Für 433 und 868 MHz ist die Beschaltung vor der Antenne anders, 
zumindest im Referenzdesign. Da sieht aber auch alles gleich aus.
Und die beiden Kondensatoren sind sicher Abblock C, in Variante 1 sieht 
das Layout etwas besser aus weil die näher am Chip sind. Aber das V2 
deshalb gleich nicht mehr funktioniert glaube ich nicht. Vielleicht ist 
durch die falsche Antenne und Fehlanpassung schon der 
Endstufentransistor hops gegangen?

Mit RFM69 habe ich schon Nodes gebaut, da würde mich auch interessieren 
ob es einfache Messgeräte für Arme gibt mit denen man die Frequenz und 
Leistung messen kann? Mal abgesehen von RSSI Anzeige von 
Empängermodulen?

: Bearbeitet durch User
von Old P. (old-papa)


Bewertung
-1 lesenswert
nicht lesenswert
Also mal ehrlich, mit Antennen baben diese beiden Drahtkringel nichts 
gemeinsam. Dass sind bestenfalls Hilfsantennen und irgendwie auf die 
Frequenz gezimmert. Die 2. ist dabei völlig gaga... Andererseits wird es 
wohl kaum daran liegen, wenn der Abstand bei den Empfangsversuchen keine 
Dutzende Meter betrug.

Old-Papa

von Kosmos (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das ist wirklich merkwürdig.
Normalerweise ist der chinesische Markt ja der Inbegriff von 
gleichbleibender Qualität und Reproduzierbarkeit. Das ist den vielen 
Normen und Standards zu verdanken, die dort in der Produktion...

äh - moment. Sagte ich China?
Achso... da kauft man ja, weil's billig ist.

von Beo Bachta (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kosmos schrieb:
> äh - moment. Sagte ich China?

Es wird Zeit dass man sich mehr und mehr den dortigen
Gepflogenheiten anpasst - dann ist das Überraschungsmoment
nicht so gross.

Also zuerst mal: Erwartungshaltung: NULL.

von Thorsten S. (thosch)


Bewertung
0 lesenswert
nicht lesenswert
Ob die ominösen Module von ebay tatsächlich einen echten CC1101 von Ti 
enthalten?
Wenn man mal die Modul-Preise mit denen des nackten ICs CC1102 bei 
seriösen Distris vergleicht, können einem da Zweifel kommen...

Was den Quarz angeht: 26MHz vs. 27MHz würden locker reichen, daß die 
Module bei gleicher Config nicht miteinander "reden".
Sende- und Empfangsfrequenz der unterschiedlich bestückten Module liegen 
dann im 868 MHz Band über 30MHz auseinander.

von Mörtel (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Thorsten S. schrieb:

> Sende- und Empfangsfrequenz der unterschiedlich bestückten Module liegen
> dann im 868 MHz Band über 30MHz auseinander.

Ein SDR-Stick für ein paar Euro ist da ein hilfreiches Messutensil.

von HM Funker (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sven Scholz schrieb:
> Variante 1 zeigt die Module, die ich bisher verwendet habe.
> Variante 2 zeigt die neuen Module, die keine Daten empfangen können von
> den Modulen Variante 1.

Machst Du was mit Homematic? Dort gibt es einen Thread zu de Thema 
(verschiedene China Module) und auch Testsoftware für die 
Frequenzeinstellung.

Vielleicht findest Du dort brauchbare Tipps?
 https://homematic-forum.de/forum/viewtopic.php?f=76&t=59315

HTH!

von Thorsten S. (thosch)


Bewertung
0 lesenswert
nicht lesenswert
Mörtel schrieb:
> Ein SDR-Stick für ein paar Euro ist da ein hilfreiches Messutensil.

Jo. Zuerst aber mal 'ne simple Lupe, um die Quarzbeschriftung zu 
checken.
Danach kann man dann anfangen, zu messen.

von Mister A. (mratix)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe das angehängte Bild gerade ausgegraben.

Es gibt einen ausführlichen Test- und Vergleichsbericht. Dient zunächst 
mal die Originale von den Fakes zu unterscheiden. Finde gerade die Seite 
nicht...

Der Filteraufbau im letzten Abschnitt (Antennenbereich) bestimmt dann 
das Frequenzband, nicht allein die Antenne. Da es auch Fakes zu 433/868 
MHz Modulen gab, eben nur mit der "falschen" Antenne.
Die rot eingekreisten Komponenten helfen ganz einfach anhand der 
Anordnung (Layout) die Fakes zu identifizieren.

Mir wurde damals auch ein linker Hund untergeschoben. Der Ersatz kam 
dann richtig und war funktionsfähig.

Nachtrag, hier https://wiki.fhem.de/wiki/Selbstbau_CUL
aber es gibt noch eine weitere Seite.

: Bearbeitet durch User
von Sven Scholz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mörtel schrieb:
> Ein SDR-Stick für ein paar Euro ist da ein hilfreiches Messutensil.

Wie funktioniert das dann?
Du meinst ich solle mit einem der neuen CC1101 Module und der aktuellen 
Konfiguration Datenpakete senden und das dann mit einem SDR 
"aufzeichnen"?

Also so ein SDR stellt mir dann da auf welcher Frequenz mein CC1101 
sendet?
Bzw. ob das Modul überhaupt etwas sendet...

Das wäre natürlich sehr hilfreich...

von Heinz R. (heijz)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe in letzter Zeit einige dieser Module gekauft - fast keines 
funkt auf der richtigen Frequenz
(mit SDR.Stick angeschaut, als Referenz Original-Homematic-Sender)

Angeblich liegt es großteils an falschen Kondensatoren beim Quarz


Schau mal hier:
https://asksinpp.de/Grundlagen/FAQ/Fehlerhafte_CC1101.html#frequenzanpassung-per-sketch

odder hier der 2. Beitrag:

https://forum.fhem.de/index.php/topic,91740.msg872505.html#msg872505

von Sven Scholz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Gemeinde,

ich habe mir mittlerweile mal einen SDR-Stick besorgt und diesen unter 
Linux zum Laufen gebracht. Ich verwende die Software Gqrx SDR.

Die Frequenz hatte ich einfach mal auf 868MHz gestellt.
Und tatsächlich, die 3 bisherigen Module die ich momentan im Betrieb 
habe ließen sich alle wiederfinden.
Alle Sende dabei um 868,35 MHz herum.
Auf dem unteren "Wasserfall-Bildschirm" sehe ich im Raster von 30sek 
immer kleine gelbe Rechtecke. Super!

Jetzt das ganze mit den neuen Modulen...
Eins mal probehalber in Betrieb genommen.
Im Wasserfall tut sich da plötzlich um einiges mehr...
Auch hier sehe ich den größten Peak bei etwa 868,3Mhz, allerdings 
schlägt sich die gelbe Farbe horizontal quer durch.
Mit immer weiter abgeschwächten "Peaks" nach links und nach rechts.
Was zum Geier ist das???
Sieht für mich als Laie eher wie eine Störung/Jammer aus.
Wieso bekomme ich hier keinen klar definierten gelben Rechteck?

Ich werde später mal einen Screenshot anhängen, aber vielleicht hat 
jetzt ja schon jemand eine Vermutung.

Danke!

von Häh? (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wenn die Sendepower zu hoch ist oder Sender und Empfänger zu nahe 
beieinander sind, hat man diesen Übersteuerungseffekt.

von Sven Scholz (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Anbei wie versprochen der Screenshot...
Wie gesagt, die guten Module senden ein definiertes Paket (gelbe 
Rechtecke) auf der richtigen Frequenz.
Bei den "bösen" Modulen sehe ich den Peak auch etwa in der Nähe 
(<868,4MHz), allerdings viele viele Harmonische Frequenzen, die sich 
horizontal erstrecken/ausbreiten.

Eine Erklärung für dieses Verhalten wäre super...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.