Forum: Analoge Elektronik und Schaltungstechnik IGBT Halbbrücke Induktive Spannungsspitzen


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Alexander S. (shivero)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Forenmitglieder

Ich habe folgendes Problem:
Ich habe einen DC Bus möglichst Induktivarm mit 2 IGBTs (IXXN110N65B4H1) 
gebaut. Das Gatesignal ist sauber.
Schalten möchte ich damit einen Dicken Ferritkern als HV quelle.
Allerdings hab ich das Problem, dass im Ausschaltmoment eine Riesige 
Induktive Spannungsspitze daherkommt, und ich außerdem HF Rippel in der 
Off time habe. Betroffen davon ist der Lowside IGBT
Durch wesentlich mehr Windungen ist der Transient nicht mehr so schlimm 
allerdings zieht die Topologie dann auch keinen Strom mehr bei 
Kurzgeschlossener Sekundärspule. Ich hab ja so das Gefühl dass die 
Interne Freilaufdiode einfach zu langsam ist um.diesen Transienten 
abzufangen.
Hat irgendwer eine Idee wie man dem Herr werden kann?

: Verschoben durch Admin
von blubb (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Zeige uns doch mal einen Schaltplan und welchen Snubber Du bis her 
verwendest?

Und was sind riesige Überspannungen für Dich? Wäre hilfreich zu wissen, 
ob es 100 oder 1000V sind..

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Alexander S. schrieb:
> Betroffen davon ist der Lowside IGBT

Schliesse daraus, das du eine Halbbrücke benutzt. Die Spitze sollte also 
nicht höher sein als die pos. Versorgung, denn der Highside IGBT hat ja 
eine Bodydiode. Wenn sie doch höher ist, dann solltest du die DC Rail 
besser abblocken, damit die Spitze vom Kondensator geschluckt wird und 
dich davon vergewissern, das die Bodydiode schnell genug ist. Ist sie 
das nicht, schalte eine parallel zur Highside.

von Alexander S. (shivero)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Spannungsspitzen sind nochmal die Eingangsspannung als Spitze oben drauf 
also bei 100VBus ist Peak 200V CE

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
1 lesenswert
nicht lesenswert
Aber das ist doch völlig normal. Wenn die IGBT dafür zu klein 
dimensioniert sind, baust du welche mit höherer Spannungsfestigkeit ein. 
Das ist nun mal die Natur der Gegen-EMK. Jegliches Wegsnubbern der 
Spitze auf der Brückenseite kann man zwar machen, kostet aber Energie in 
den Snubber und stresst diesen nicht unerheblich.

: Bearbeitet durch User
von di/dt (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Selbstverständlich ist das nicht normal, zumindest nicht bei sauberem 
Design der Brücke. Ohne Bilder von Layout/Aufbau wird man aber nichts 
vernünftiges sagen können. Welche Schaltfrequenz? Wo steht/wie 
angebunden ist der DC-link Kondensator?
Wieso hast du eigentlich so eine grosse Totzeit? Deine Totzeit macht 
fast die halbe Schaltperiode aus.

von Alexander S. (shivero)


Bewertung
0 lesenswert
nicht lesenswert
Geschalten wird mit 30kHz Totzeit ist keine drin da die Dinger über GDT 
laufen und wenn ich ne Totzeit einbaue schwingt mit der Miller Effekt in 
die Totzeit. Das läuft über den GDT langsam genug um einen Shoot Through 
zu vermeiden Bild vom Aufbau kann ich heute Abend machen

von Sven S. (schrecklicher_sven)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Alexander S. schrieb:
> außerdem HF Rippel

Und welche Frequenz verbirgt sich da?
Es gibt zwei Möglichkeiten:
Du hast irgendetwas total vermurkst, oder Du jagst ein Phantom.

von Alexander S. (shivero)


Bewertung
0 lesenswert
nicht lesenswert
Den Knick in der On/Off time könnten sich unsere Mosfetkiller auf 
Discord auch nicht wirklich erklären.
Die HF ist so Hoch da kann ich mit mein 10Mhz Scipe nicht hinzoomen. Der 
Transient aber ist da weil die 400V TVS ausgelöst haben und die 
Feinsicherung gekommen ist

von Sven S. (schrecklicher_sven)


Bewertung
-1 lesenswert
nicht lesenswert
Alexander S. schrieb:
> Die HF ist so Hoch da kann ich mit mein 10Mhz Scipe nicht hinzoomen.

Könnte es sich auch um 100Hz Netzbrumm handeln?

von Alexander S. (shivero)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier die Bilder vom Bus

von Alexander S. (shivero)


Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> Alexander S. schrieb:
>> Die HF ist so Hoch da kann ich mit mein 10Mhz Scipe nicht hinzoomen.
>
> Könnte es sich auch um 100Hz Netzbrumm handeln?

Das würde man dann ja aber sehen können das sieht viel Hochfrequenter 
aus

von di/dt (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Alexander S. schrieb:
> Ich habe einen DC Bus möglichst Induktivarm mit 2 IGBTs (IXXN110N65B4H1)
> gebaut. Das Gatesignal ist sauber.

Joa...leider ist das von "induktivitätsarm" weit entfernt. Mit der 
Verkabelung fängst du dir im Kommutierungsloop ordentlich parasitäre 
Induktivität ein. Dein Gateloop ist ebenfalls eher schlecht. Wie hoch 
sind deine Gatewiderstände?

von Mani W. (e-doc)


Bewertung
-1 lesenswert
nicht lesenswert
di/dt schrieb:
> Wieso hast du eigentlich so eine grosse Totzeit? Deine Totzeit macht
> fast die halbe Schaltperiode aus.

Wo siehst Du eine Totzeit?

von Alexander S. (shivero)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die einzigen Kabel sind sie vom Rail zum Trafo und vom GDT aufs Gate. 
Die Gatewiderstände sind 27 Ohm Und das Gatesignal schaut eigentlich 
Recht gut aus

von Sven S. (schrecklicher_sven)


Bewertung
-1 lesenswert
nicht lesenswert
Alexander S. schrieb:
>> Könnte es sich auch um 100Hz Netzbrumm handeln?
>
> Das würde man dann ja aber sehen können das sieht viel Hochfrequenter
> aus

Dann hast Du ein 10MHz Oszi, das in Wirklichkeit eine so hohe Bandbreite 
besitzt, daß die auf dem Bildschirm nicht mehr aufgelöst werden kann.
Daran glaube ich nicht.

von di/dt (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Alexander S. schrieb:
> Die einzigen Kabel sind sie vom Rail zum Trafo und vom GDT aufs Gate.
> Die Gatewiderstände sind 27 Ohm Und das Gatesignal schaut eigentlich
> Recht gut aus

Ob Kabel oder nicht spielt nicht die Hauptrolle, es geht um die 
Leiterschleife die du mit dem Kommutierungsloop aufspannst. Deren 
eingeschlossene Fläche musst du minimieren (deine "Alu-Balken" die du 
verwendet hast). Und die eingeschlossene Fläche ist in deinem Fall 
riesig. Überleg mal wie sehr du diese Fläche minimieren könntest, wenn 
du ein PCB verwenden würdest bei dem du zwei Coplanare Flächen als 
Leiter verwendest (such dir mal bei Google entsprechende Literatur 
zusammen).

Das Gatesignal sieht ganz ok aus, allerdings hast du eben nur ein 10 MHz 
Scope ;) Wenn das auf 200 MHz schwingt wirst du nicht allzuviel 
erkennen. Die 27 Ohm sind nicht ganz wenig und helfen sicher das ganze 
zu dämpfen.

Mani W. schrieb:
> Wo siehst Du eine Totzeit?

Die "Stufe" im Bilder während der On- bzw. Off-Periode sieht genau wie 
ein Interlock-Delay aus wo die Bodydiode leitet (grösserer 
Spannungsabfall der Diode im Vergleich zum eingeschalteten Schalter).

von Alexander S. (shivero)


Bewertung
0 lesenswert
nicht lesenswert
Sehr interessanter Einwand. Die Idee mit den PCB und großen Flächen ist 
mir auch schon gekommen, hätte den Aufbau auch eben auf so PCB Basis 
bevor ich die Alurails angefertigt hatte, da sah das Schaltverhalten 
exakt genau so aus, hatte aber auch keine Masse im Mittellayer sondern 
Vorder und Rückseite auf dem gleichen Potential. Vielleicht würde es ja 
was bringen Vorderseite und Rückseite mit den verschiedenen CE Strecken 
zu belegen, sodass sich die entstehenden Induktivitäten gegenseitig 
aufheben.

von Sven S. (schrecklicher_sven)


Angehängte Dateien:
  • preview image for C.jpg
    C.jpg
    106 KB, 101 Downloads

Bewertung
-1 lesenswert
nicht lesenswert
Ich würde diesen Dingern nicht über den Weg trauen. (Bild)
Du schreibst von 100V Betriebsspannung. Es hat überhaupt keinen Sinn, 
spannungsmäßig so extrem überdimensionierte Kondensatoren zu verwenden. 
Die müssen in der Lage sein, den Induktionsstrom beim Schalten 
aufzunehmen.

di/dt schrieb:
> Das Gatesignal sieht ganz ok aus,

Nein, überhaupt nicht. Es ist kein bißchen eckig, außerdem fehlt die 
Plateauspannung. Kann aber auch davon abhängen, wo gemessen wurde.

von di/dt (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Sven S. schrieb:
> Ich würde diesen Dingern nicht über den Weg trauen. (Bild)
> Du schreibst von 100V Betriebsspannung. Es hat überhaupt keinen Sinn,
> spannungsmäßig so extrem überdimensionierte Kondensatoren zu verwenden.
> Die müssen in der Lage sein, den Induktionsstrom beim Schalten
> aufzunehmen.

Dem würde ich zustimmen, die parasitäre Induktivität besonders von den 
Folienkondensatoren ist nicht zu unterschätzen.

Sven S. schrieb:
> di/dt schrieb:
>> Das Gatesignal sieht ganz ok aus,
>
> Nein, überhaupt nicht. Es ist kein bißchen eckig, außerdem fehlt die
> Plateauspannung. Kann aber auch davon abhängen, wo gemessen wurde.

Stimmt natürlich, allerdings meinte ich eher "nicht unbedingt gefährlich 
für den Schalter". Ausserdem denke ich sollte man bei dem Gateloop nicht 
unbedingt mit diesen Details anfangen - zumal das Messergebnis stark 
davon abhängen wird wo gemessen wurde.

von Alexander S. (shivero)


Bewertung
0 lesenswert
nicht lesenswert
di/dt schrieb:
>> Ich würde diesen Dingern nicht über den Weg trauen. (Bild)
>> Du schreibst von 100V Betriebsspannung. Es hat überhaupt keinen Sinn,
>> spannungsmäßig so extrem überdimensionierte Kondensatoren zu verwenden.
>> Die müssen in der Lage sein, den Induktionsstrom beim Schalten
>> aufzunehmen.

Das soll ja nicht bei 100V bleiben, aber wenn ich mit dem Transienten 
mit 325V draufgeht zerhauts mir die IGBTs. Das ist nicht Sinn der Sache.

di/dt schrieb:
> Nein, überhaupt nicht. Es ist kein bißchen eckig, außerdem fehlt die
> Plateauspannung. Kann aber auch davon abhängen, wo gemessen wurde.

Hjau die Plateauspannung ist da vorm Widerstand, wird aber vom 
Gatewiderstand weggedämpft.

Ich habe auch festgestellt der Transient existiert nur im Absoluten 
Kurzschluss Fall, wenn der Lichtbogen schon vorher zündet bevor Metall 
auf Metall ist, kommt es garnicht zu dieser Überspannung. Ich hab auch 
schon mit der Idee gespielt einfach einen Widerstand, Diode in Serie zu 
einer bidirektionalen 55V TVS wieder zurück zum Elko zu legen, sodass 
die Spitze ab 55V über Uin einfach wieder zurück in die Elkos geladen 
wird also Collector Low -W-->|-->|<-- Collector High

: Bearbeitet durch User
von Sven S. (schrecklicher_sven)


Bewertung
-1 lesenswert
nicht lesenswert
Alexander S. schrieb:
> Hjau die Plateauspannung ist da vorm Widerstand, wird aber vom
> Gatewiderstand weggedämpft.

Am Treiberausgang würde ich aber ein Rechteck wie mit dem Lineal 
gezeichnet erwarten.

Es soll also ein Schweißgerät werden.
Ich rate mal: Du verwendest einen Ferritkern Trafo mit getrennten 
Wicklungen für Primär und Sekundär. Speziell bei sekundärseitigem 
Kurzschlussfall fließt da primärseitig ein hoher Blindstrom. Die 
Stromabfallzeit des abschaltenden IGBT ist gleichzeitig die 
Stromanstiegszeit für den gegenüberliegenden Kondensator (Die 
"Einschaltzeit" einer Diode spielt hier keine Rolle!).

Tipp:
Mit Deinen "Ebay-Schnäppchen" kommst Du da nicht weiter.
Mit Bauteilen vom Schrottplatz verschwendest Du Deine wertvolle 
Bastelzeit.

von Alexander S. (shivero)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> Am Treiberausgang würde ich aber ein Rechteck wie mit dem Lineal
> gezeichnet erwarten.

Am Treiberausgang ist es wie mit dem Lineal gezeichnet

Sven S. schrieb:
> Es soll also ein Schweißgerät werden.
> Ich rate mal: Du verwendest einen Ferritkern Trafo mit getrennten
> Wicklungen für Primär und Sekundär.

Nein Soll eine HV Quelle werden, natürlich getrennt Prim und Sek

Sven S. schrieb:
> Tipp:
> Mit Deinen "Ebay-Schnäppchen" kommst Du da nicht weiter.

Worauf genau willst du da Hinaus?

von Sven S. (schrecklicher_sven)


Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Alexander S. schrieb:
> Worauf genau willst du da Hinaus?

Siehe Bild:
Wenn Q2 ein ist, fließt Strom durch den Trafo, klar.
Wenn Q2 abschaltet, will die Streuinduktivität des Trafos den Strom 
aufrechterhalten. Der Trafo entmagnetisiert sich durch Q1. Weiter kein 
Problem. Aber die Kondensatoren müssen da schon mitmachen können. Groß 
ist nicht gleich gut.

von Sven S. (schrecklicher_sven)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Da habe ich doch glatt das falsche Bild angehängt.
Hier das richtige.

von Sven S. (schrecklicher_sven)


Bewertung
0 lesenswert
nicht lesenswert
Aber das Oszi-Bild ist auch nicht schlecht. Es stellt Strom- und 
Spannungsverlauf gegenüber.
Das können sich Deine Mosfetkiller mal durch den Kopf gehen lassen.

von Alexander S. (shivero)


Bewertung
0 lesenswert
nicht lesenswert
Wie der Stromverlauf durch die Freilaufdiode läuft ist einleuchtend, und 
auch Elkos habe ich verschiedene probiert, alles das selbe ich denke 
langsam wirklich es könnte am Kommutierungsloop liegen der ja eine 
Schleife bildet zwischen beiden Schaltern. Ich werde da Mal etwas 
anderes versuchen und gucken was passiert. Vielleicht Mal die Idee mit 
der TVS und den Loop parallel mit PCB dazwischen laufen zu lassen, ich 
werde euch auf dem Laufenden halten. Ich denke nicht dass die Elkos das 
Problem sind denn die Snubber dürften kein Problem damit haben als 
extrem Impulsfest solche Spitzen zu snubbern

von Alexander S. (shivero)


Bewertung
0 lesenswert
nicht lesenswert
Ich werde den Aufbau komplett redesignen müssen, die IGBTS liegen viel 
zu weit auseinander, die Kommutatorpfade sind viel zu lang und bilden 
eine Schleife, das ganze schwingt so Hochfrequent auf, dass der 
Ferritkern sich durch den HF-Rippel aufheizt auf gut Deutsch, das ganze 
haut nicht hin weil mein Layout so beschissen ist, dass ich selbst mit 
300qmm2 Kupferschienen noch immer einen Schwingkreis hätte. Also werde 
ich die Brücke so designen müssen, dass die Kommutatorpfade parralel 
zueinander mit wenig Abstand entgegengesetzt laufen, damit sich die 
Induktivitäten zum Teil aufheben können. Die IGBTS müssen direkt 
nebeneinander liegen und nicht meterweit voneinander entfernt.

Aber trotzdem danke ich allen für die Anteilnahme und die Gedanken. Ich 
halte euch auf dem Laufenden wenn ich das Ding komplett neu gebaut habe.

von Alexander S. (shivero)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Problem gelöst
1. Der Dicke Balken unter Last war 100Hz Ripple aufgrund unzureichender 
Glättung
2. Die IGBTs sind jetzt ganz nah nebeneinander und die Strecken kurz 
gehalten. Jetzt ist das Bild unter Last befriedigend

von Sven S. (schrecklicher_sven)


Bewertung
-1 lesenswert
nicht lesenswert
Alexander S. schrieb:
> 1. Der Dicke Balken unter Last war 100Hz Ripple aufgrund unzureichender
> Glättung

Alexander S. schrieb:
> Die HF ist so Hoch da kann ich mit mein 10Mhz Scipe nicht hinzoomen.

Nach vier Tagen endlich in die richtige Richtung gezoomt.
Und der, der meinen Hinweis als nicht lesenswert eingestuft hat, ist 
ein, na was wohl.

von di/dt (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich versteh ehrlich gesagt nicht, wo ihr auf den Bildern 100 Hz 
Netzbrumm seht? Kann mich jemand erleuchten? Die Taktfrequenz sind ja 
einige kHz, da sieht ein 100 Hz Signal bei dem Zoom doch aus wie ein DC 
Offset?

di/dt schrieb:
> Mani W. schrieb:
>> Wo siehst Du eine Totzeit?
>
> Die "Stufe" im Bilder während der On- bzw. Off-Periode sieht genau wie
> ein Interlock-Delay aus wo die Bodydiode leitet (grösserer
> Spannungsabfall der Diode im Vergleich zum eingeschalteten Schalter).

Das war natürlich falsch, ich hab in letzter Zeit zu viel mit MOSFETs 
gearbeitet die in beiden Stromrichtungen den gleichen Spannungsabfall 
zeigen. Die Stufen sieht man dann typisch, wenn der Strom vom Kanal in 
die Bodydiode kommutiert (was nur während der Totzeit passiert). Bei 
IGBTs fliesst der Strom in eine Richtung ja immer über die Diode, 
deshalb die Stufe beim Wechsel der Stromrichtung.

von Sven S. (schrecklicher_sven)


Angehängte Dateien:

Bewertung
-2 lesenswert
nicht lesenswert
di/dt schrieb:
> Ich versteh ehrlich gesagt nicht, wo ihr auf den Bildern 100 Hz
> Netzbrumm seht? Kann mich jemand erleuchten?

Aber gerne! Siehe Bild.

von Uwe S. (bullshit-bingo)


Bewertung
0 lesenswert
nicht lesenswert
di/dt schrieb:
> da sieht ein 100 Hz Signal bei dem Zoom doch aus wie ein DC
> Offset?

Nein. Wie sollte das Oszi sowas denn deiner Meinung nach darstellen?
Es ist ja nicht auf die 100Hz getriggert, also bildet es diese 
"Sinuskurve" mal hier, mal da auf dem Bildschirm ab. Ergibt optisch eine 
helle Fläche über die entsprechende Amplitude.

von Sven S. (schrecklicher_sven)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Schon wieder ein "nicht lesenswert".
Na gut, dann erkläre ich es halt für Dummies. Ich schreibe auch gaanz 
langsam:
Den Strahl des Oszis habe ich rot nachgezeichnet. Bei "max" befindet 
sich der Strahl während dem Scheitelpunkt der Netzspannung = maximale 
Spannung. Bei "min" befindet sich der Strahl während der minimalen 
Spannung zwischen den Scheitelpunkten. Der Abstand zwischen "max" und 
"min" ist die Brummspannung.
Weil die abgebildete Frequenz um etliches höher liegt, als 100Hz, und 
der Strahl entsprechend oft getriggert wird, durchläuft er während einer 
Periode der Netzsp. jeden Zwischenwert. Nun sehen wir wegen dem 
Nachleuchten des Bildschirms, der Trägheit des Auges, der 
Belichtungszeit beim Fotografieren  eine Fläche.

: Bearbeitet durch User
von Alexander S. (shivero)


Bewertung
-1 lesenswert
nicht lesenswert
Sven S. schrieb:
> Schon wieder ein "nicht lesenswert".
> Na gut, dann erkläre ich es halt für Dummies. Ich schreibe auch gaanz
> langsam:
> Den Strahl des Oszis habe ich rot nachgezeichnet. Bei "max" befindet
> sich der Strahl während dem Scheitelpunkt der Netzspannung = maximale
> Spannung. Bei "min" befindet sich der Strahl während der minimalen
> Spannung zwischen den Scheitelpunkten. Der Abstand zwischen "max" und
> "min" ist die Brummspannung.
> Weil die abgebildete Frequenz um etliches höher liegt, als 100Hz, und
> der Strahl entsprechend oft getriggert wird, durchläuft er während einer
> Periode der Netzsp. jeden Zwischenwert. Nun sehen wir wegen dem
> Nachleuchten des Bildschirms, der Trägheit des Auges, der
> Belichtungszeit beim Fotografieren  eine Fläche.

Trotz der etwas anmutenden Art muss ich sagen diese Erklärung hat Hand 
und Fuß, und ich muss sagen dass nun jedereins verstehen kann warum der 
100Hz Ripple bei der Frequenz so dargestellt ist. Das deckt sich auch 
damit, dass der Balken sich in verschiedenen Lastverhältnissen 
verändert, je nach dem wie viel Strom aus den Kondensatoren gezogen wird 
desto dicker/weniger Dick erscheint der Balken, weil bei einer hohen 
Stromaufnahme die Kondensatoren kaum noch eine Chance haben die 
Sinushalbwellen zu glätten

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.