Forum: Mikrocontroller und Digitale Elektronik RMD6300 RFID Leser / 24V


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von snoopy (Gast)


Lesenswert?

Hallo ich habe ein kleines Problem mit einem RMD6300 RFID Leser.
Habe den auf nem Arduino Nano drauf, und der liest das auch alles brav 
ein.

Sobald ich aber die Versorgungsspannung auf ein 24V Netzteil mit einem 
R-78E-1.0 hänge, der mir die 5V macht und ich das USB Kabel abhänge, 
dann funktioniert alles ganz normal nur der RMD6300 liefert nichts mehr 
zurück.

Ich habe danach einen 100nF, 100µF Elko und 10µF Tantal  hängen in der 
5V Leitung (im Moment direkt beim RMD 6300)

Hat da noch wer ne Idee wie ich das stabil zum laufen bringen kann?

von snoopy (Gast)


Lesenswert?

Hat niemand einen Tipp was und wie ich es noch probieren kann?

Habe mal statt dem R-78E-1.0 einen RS3-2405S verwendet selbes problem.
In Serie (auf der 24V und dann auf der 5V eine 68H Induktivität 
dazwicshen) dann einen Kerko 100nF und einen Tantal 10µF von 5V gegen 
Masse)

Hab leider kein Oszi zum messen von der Versorgungsspannung

Ich brauche das ganze nur einmal - also für ein einzel Gerät (bzw zwei 
mal) da wäre es mir egal, wenn ich einen teureren Wandler brauche.
Würde ich dort 230V haben, würde ich ein 0815 USB Netzteil nehmen, habe 
aber leider nur 24V zur Verfügung.

von snoopy (Gast)


Lesenswert?

meine 68µH und nicht 68H

von Hmmm (Gast)


Lesenswert?

snoopy schrieb:
> Hat niemand einen Tipp was und wie ich es noch probieren kann?

Deinen Aufbau überprüfen. Wenn auch auf kurze Distanz nichts gelesen 
wird, dürfte das nicht nur etwas Ripple sein.

snoopy schrieb:
> Hab leider kein Oszi zum messen von der Versorgungsspannung

Das ist schlecht. Zeigt denn zumindest ein Multimeter rund 5V an?

von snoopy (Gast)


Lesenswert?

Ja das Multimeter zeigt ziemlich genau die 5V an

Habe ja schon den R-78E-1.0 mit 5V (gespeist mit 24V)
dann den RS3-2405S
und jetzt zum testen einen R-78E-1.0 mit 24V -> 9V und dahinter einen 
7805.
immer mit einigen Kondis dazwischen probiert.

Sobald ich dann das USB Kabel einstecke sonst alles gleich lasse dann 
geht es dann wird was gelesen (Der Arduino schaltet immer automatisch um 
zwischen Vin und USB) sprich ich lasse die 5V die von den 24V erzeugt 
werden immer drauf, und stecke das USB dazu oder weg.

Im Minutentakt schickt der Arduino dann auch noch einen Ping und 
Temperatur werte weiter - diese kommen IMMER an egal welche 
Versorgungsspannung.

von Hmmm (Gast)


Lesenswert?

Ist die Masseverbindung. zwischen Arduino und RFID-Platine OK? Nicht 
dass die evtl. erst über den USB-Anschluss hergestellt wird und 
ansonsten fehlt.

von snoopy (Gast)


Lesenswert?

Ja wenn die nicht OK wäre würde der ja nie gehen oder?

Der RFID LEser hängt ja am Arduino also am 5V + GND.

Versorgt wird der Arduino am VIN + GND

von Hmmm (Gast)


Lesenswert?

snoopy schrieb:
> Ja wenn die nicht OK wäre würde der ja nie gehen oder?

...oder nur dann, wenn die Masse über eine andere Verbindung kommt, z.B. 
USB. Daher meine Frage.

snoopy schrieb:
> Der RFID LEser hängt ja am Arduino also am 5V + GND.

Ohne Oszi wird es verdammt schwierig, das Problem weiter einzugrenzen. 
Du könntest mal mit einem Logic Analyzer prüfen, ob der RFID-Reader 
wirklich keine Daten liefert.

von snoopy (Gast)


Lesenswert?

So ich habe mir nun mal einen neuen anderen RFID LEser bestellt.

Einen ID-20LA --- mal schauen ob der sich besser verhält :/

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.