Forum: Analoge Elektronik und Schaltungstechnik Red Pitaya mit falsch gestecktem Logikanalysatormodul


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Gerald K. (geku)


Bewertung
0 lesenswert
nicht lesenswert
Leider isr das Stecksystem des Red Pitaya (125-14) nicht sicher gegen 
versetztes Aufstecken von Submodule (Kontur der Buchse ist länger als 
der Stecker). Gestern ist mir dieses Mahlheur passiert. Jetzt bin ich 
dabei den entstandenen Schaden zu ermitteln.

Ist jemand das gleiche Missgeschick passiert?

Es zeigten sich folgende Effekte :

- der Red Pitaya läuft hoch, braucht dabei wesentlich länger.

- es lassen sich nicht alle Applikationen starten (v 1.03)

_Oszilloskopbetrieb mit eigenem Generator am Eingang zeigt folgendes 
verhalten_ :

- Sinuskurve am oberen Wendepunkt ist verzerrt

- Rechtecksignal zeigt starkes Überschwingen

- ab 20Mhz wird das Sinussignal als gerade Linie angezeigt

Ist es grundsätzlich so, dass der Red Pitaya oberhalb von 10MHz keinen 
sauberen Sinus mehr anzeigen kann (125Msamples/s)?

_Spektrumanalyserbetrieb mit eigenem Generator am Eingang zeigt 
folgendes verhalten_ :

- Sinussigal erzeugt sehr viele Oberwellen (1. Oberwelle ist um 40dB 
kleiner als die Grundwelle)

-  Grundrauschen liegt bei -80dB

Generell kommt mir vor, dass das FPGA heißer als zuvor wird.

Als nächstes schaue ich mir die Funktion des LA Aufsatzes an.

Man kann dem Gerät nicht mehr trauen. Eine kurze Unaufmerksamkeit und 
das Gerät wird zum teuren Elektronikschrott.

: Bearbeitet durch User
von Gustl B. (-gb-)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Miss mal alle Spannungen der Versorgungen wenn man da rankommt.

Auf der Unterseite 
https://www.hamspirit.de/wp-content/uploads/2015/03/RED_PITAYA_NEU_04.png 
sind einige Testpunkte und bei der Oberseite gibt es offensichtlich 
verschiedene Versionen. Einmal wurden zwei DCDC Regler für 4 Spannungen 
verwendet 
https://upload.wikimedia.org/wikipedia/commons/0/0f/RedPitaya_STEMLab_FPGA_v1.1_topview.jpg 
und ein andermal ein einzelnder DCDC für die 4 Spannungen siehe Anhang.
Da kannst du jeweils an den Ausgangskondensatoren messen ob da eine 
Spannung anliegt.

https://upload.wikimedia.org/wikipedia/commons/0/0f/RedPitaya_STEMLab_FPGA_v1.1_topview.jpg 
da ist unten links vor dem Ethernet noch ein DCDC, da kannst du an den 
Elkos messen.

---------------------------------------
Was ist das denn für ein beknacktes Forum, ich musste das Bild in den 
Anhang packen weil das bei https://www.circuitspe_c i a l i 
s_ts.com/content/336886/STEMLAB_125-14_DiagnosticKit-1.jpg liegt, "_" 
von mir eingefügt und die Leerzeichen im bösen Wort auch. Dabei wäre 
"cia" noch deutlich gefährlicher.

von Gerald K. (geku)


Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:
> Miss mal alle Spannungen der Versorgungen wenn man da rankommt.

Die beiden Spannungen (5V und -3,3V) auf Pin 1 und 2 sind in Ordnung. 
Diese beiden Spannungen sind vermutlich am Aufsteckprint mit I/Os 
verbunden worden.

von Gustl B. (-gb-)


Bewertung
0 lesenswert
nicht lesenswert
Da müssten noch mindestens 1.0V und 1.8V sein. Und vielleicht sogar eine 
negative Versorgung. Miss mal über den Ausgangskondensatoren der DCDC 
Regler.

: Bearbeitet durch User
von Gerald K. (geku)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:
> Da müssten noch mindestens 1.0V und 1.8V sein

Diese Spannungen habeich nicht gesehen.

von Gustl B. (-gb-)


Bewertung
0 lesenswert
nicht lesenswert
Ne die sind auch nicht auf den Headern, aber die gehen zum FPGA.

Und miss nicht auf der Oberseite an den Kondensatoren neben den DCDC 
Reglern, sondern auf der Unterseite. Die haben die Ausgangskondensatoren 
der Regler auf die Rückseite gesetzt. Das sind rechts 
https://www.hamspirit.de/wp-content/uploads/2015/03/RED_PITAYA_NEU_04.png 
die vier großen Kreamikkondensatoren die um ±45° gedreht sind und 
vertikal untereinander sitzen.

: Bearbeitet durch User
von Gerald K. (geku)


Bewertung
0 lesenswert
nicht lesenswert
Danke für den Tipp, werde ich noch machen. Wenn des FPGA betroffen ist, 
kann ich eine Reperatur vergessen. Ich komme erst nächste Woche dazu und 
werde ein Oszilloskop und eine  Signalgenerator zur Hilfe nehmen. Leider 
habe ich keinen Schaltplan vom LA-Aufsteckmodul.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.