Forum: Analoge Elektronik und Schaltungstechnik Upcycling defekter TV als LED licht


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Enno W. (ewx)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!

Ich möchte einen defekten LED TV (Display gebrochen) als Wandlampe 
weiternutzen.

Dafür habe ich die oberste Schicht des Fernsehers entfernt und beim 
Anmachen leuchtet es auch bereits sehr schön... :)

Aber:
Der Fernseher besteht ja grob gesagt aus vier Teilen:
- Bildschirm
- Power supply (vestel 17IPS61-3)
- Mainboard
- led inverter (vestel 17CON07-2)

Das Mainboard brauche ich eigentlich nicht. Leider funktioniert das 
Licht nur, wenn das Mainboard mit dem Stromversorgungsboard verbunden 
ist. Ist auch irgendwie klar, denn von dort kommt ja der Befehl zum 
Einschalten, Helligkeit usw.

Zwei Fragen dazu:

1)
Ich möchte wenn möglich gerne die vorhandene Stromversorgung nutzen. Hat 
jemand einen Tipp, wie ich sie nutzen kann und trotzdem das Mainboard 
entferne?

2)
Wenn das nicht geht, wäre meine Idee, eine Stromversorgung passend zum 
LED Inverter zu bauen (12,5V + 5V Steuerung)


Ich kenne mich nicht wirklich mit Elektronik aus. Ja, ich weiß, es ist 
gefährlich, als Laie an Elektronik "herumzuprobieren". Über Tipps wäre 
ich dennoch dankbar.

Danke und Gruß
Enno

von hinz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Hat der Fernseher denn auch einen Namen?

von Heinz R. (heijz)


Bewertung
1 lesenswert
nicht lesenswert
Das sind doch nur paar viele LEDs in Reihe

Hatten es mal mit einem 80" Display versucht, der hatte ca. 320V pro 
LED-Strang, haben einfach gleichgerichtetet Netzspannung angeschlossen

Aber das icht wird Dir nicht gefallen, viel zu kaltweiss

Wir haben das Teil dann letztendlich entsorgt

von Sam W. (sam_w)


Bewertung
0 lesenswert
nicht lesenswert
Enno W. schrieb:
> Ich möchte wenn möglich gerne die vorhandene Stromversorgung nutzen. Hat
> jemand einen Tipp, wie ich sie nutzen kann und trotzdem das Mainboard
> entferne?

Schau dir mal das 6-polige Kabel (5x schwarz, 1x rot) genauer an. Es 
sieht so aus, als ob je zwei Pins für die Spannungsversorgung genutzt 
werden. Bleiben noch 2 Pins für z.B. Steuersignale.

Die Steurbefehle für das Anschalten des Netzteils UND die Signale für 
das Einstellen der Helligkeit am LED-Inverter kommen über den 
Platinensteckverbinder. Hier müsstest du die Leitungen "Aussortieren", 
die der Spannungsversorgung des Mainboards dienen. Dann bleiben ein paar 
Pins für Steuersignale übrig. Dann schauen, ob evtl. 1-2 direkt zum 
LED-Inverter-Anschluss "durchgereicht" werden. Die restlichen dienen der 
Kommunikation zwischen Mainboard und Netzteil. Da gilt es dann den zu 
finden, der das (Haupt-) Netzteil starten lässt.

von Enno W. (ewx)


Bewertung
1 lesenswert
nicht lesenswert
hinz schrieb:
> Hat der Fernseher denn auch einen Namen?

Ich nenne ihn Erwin. ;)
Ich denke nicht, dass das Modell in diesem Fall wichtig ist, aber es 
handelt sich um einen Telefunken L24H189B2.

von Enno W. (ewx)


Bewertung
0 lesenswert
nicht lesenswert
Heinz R. schrieb:
> Aber das icht wird Dir nicht gefallen, viel zu kaltweiss
Werden wir sehen. Und wenn ich es nur als Arbeitsleuchte verwende...
> Wir haben das Teil dann letztendlich entsorgt
Immerhin ausprobiert...

von Enno W. (ewx)


Bewertung
0 lesenswert
nicht lesenswert
Sam W. schrieb:
> Enno W. schrieb:
>> Ich möchte wenn möglich gerne die vorhandene Stromversorgung nutzen. Hat
>> jemand einen Tipp, wie ich sie nutzen kann und trotzdem das Mainboard
>> entferne?
>
> Schau dir mal das 6-polige Kabel (5x schwarz, 1x rot) genauer an. Es
> sieht so aus, als ob je zwei Pins für die Spannungsversorgung genutzt
> werden. Bleiben noch 2 Pins für z.B. Steuersignale.
Ja, das würde ich als option 2 machen. Die belegung hatte ich irgendwo 
gefunden, aber jetzt nicht mehr. Ich meine:
VCC
VCC
5V on-off
5V dimmen
GND
GND

> Die Steurbefehle für das Anschalten des Netzteils UND die Signale für
> das Einstellen der Helligkeit am LED-Inverter kommen über den
> Platinensteckverbinder. Hier müsstest du die Leitungen "Aussortieren",
> die der Spannungsversorgung des Mainboards dienen. Dann bleiben ein paar
> Pins für Steuersignale übrig. Dann schauen, ob evtl. 1-2 direkt zum
> LED-Inverter-Anschluss "durchgereicht" werden. Die restlichen dienen der
> Kommunikation zwischen Mainboard und Netzteil. Da gilt es dann den zu
> finden, der das (Haupt-) Netzteil starten lässt.
Das Aussortieren ist das eine Problem. Wie finde ich das heraus? Das 
andere: was mache ich, wenn ich die richtigen gefunden habe?

von hinz (Gast)


Bewertung
3 lesenswert
nicht lesenswert
Enno W. schrieb:
> Ich nenne ihn Erwin. ;)

Hurra!


> Ich denke nicht, dass das Modell in diesem Fall wichtig ist,

Du bist also Experte...


> aber es handelt sich um einen Telefunken L24H189B2.

Und schon hab ich die Belegung und Funktion des Steckers zwischen 
Netzteil und Mainboard. Aber da du ein Experte bist...

von Enno W. (ewx)


Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Enno W. schrieb:
>> Ich nenne ihn Erwin. ;)
>
> Hurra!
>
>
>> Ich denke nicht, dass das Modell in diesem Fall wichtig ist,
>
> Du bist also Experte...
Nein. Bin ich nicht. Hatte ich aber auch geschrieben.
>
>> aber es handelt sich um einen Telefunken L24H189B2.
>
> Und schon hab ich die Belegung und Funktion des Steckers zwischen
> Netzteil und Mainboard. Aber da du ein Experte bist...
Ich meinte die Belegung des LED inverters.
Ich wollte dir nicht auf den Schlips treten, was ich offensichtlich 
getan habe...

von Enno W. (ewx)


Bewertung
0 lesenswert
nicht lesenswert
Ich nahm an, dass die verbauten Einzelteile, die auf dem Foto 
ersichtlich sind und teilweise von mir genannt wurden, wichtiger sind, 
als der Modellname. Sehe jetzt aber auch erst, dass das foto extrem 
verkleinert wurde...

Beitrag #6386953 wurde vom Autor gelöscht.
von Enno W. (ewx)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ok. das war ja anscheinend ein wirklich effektiver Auftritt von mir...
Erster Beitrag und schon alle vor den Kopf gestoßen.

Wie du schon geschrieben hast, Heinz: das Licht ist wirklich nicht sehr
gemütlich. Es ist sehr kalt/ blau. Als Arbeitsleuchte wäre das
vielleicht ok, aber als "Beleuchtung" kann ich das in der Tat auch nicht
empfehlen.

ich bin nun immer noch auf der Suche, welche Pins ich "kurzschließen"
muss, damit das Board den Strom an den LED Inverter weiterreicht.
Wahrscheinlich reicht auch ein Überbrücken gar nicht, sondern es müssen
5V an den (die?) entsprechenden Pins gelegt werden.

Vielleicht kann mir hier noch jemand einen Tipp geben?

Danke und ein schönes Wochenende!
~Enno

von batman (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Meist werden die Funktionen durch Masseverbindung umgeschaltet, also 
klemm erstmal ein paar Massedrähte über 1k-Widerstände an STBY und DIM. 
Vielleicht geht dir dann schon ein Licht auf.

von Enno W. (ewx)


Bewertung
0 lesenswert
nicht lesenswert
batman schrieb:
> Meist werden die Funktionen durch Masseverbindung umgeschaltet, also
> klemm erstmal ein paar Massedrähte über 1k-Widerstände an STBY und DIM.
> Vielleicht geht dir dann schon ein Licht auf.
Danke! Das probiere ich!

von Enno W. (ewx)


Bewertung
0 lesenswert
nicht lesenswert
Funktioniert leider nicht... :(

von Sam W. (sam_w)


Bewertung
0 lesenswert
nicht lesenswert
Enno W. schrieb:
> Wahrscheinlich reicht auch ein Überbrücken gar nicht, sondern es müssen
> 5V an den (die?) entsprechenden Pins gelegt werden.

Das Bild mit der Pinbelegung ist ja schonmal aufschlussreich.
Vermutlich werden BL_ON-OFF und PWM_DM direkt auf den Stecker zum 
LED-Inverter weitergeleitet.

Im Standy-Zustand liegen 5V an +5V_STBY an. Über den Pin ST_BY wird das 
Hauptnetzteil mit den 12V aktiviert.
Der Pin ST_BY muss dafür entweder auf GND gezogen oder gegen 5V (ggfs. 
auch 3,3V) gezogen werden.
1k gegen GND ist mitunter etwas zu viel, vielleicht mal mit 100-220 Ohm 
versuchen.
Wenn du ein Multimeter hast: Messen, welche Spannung an ST_BY gegen GND 
anliegt. Wenn 3,3-5V, dann muss der Pin zum Starten auf GND.

Dann sollten die 12V vorhanden sein. Dann kann man mit den passenden 
Signalen den LED-Inverter aktivieren.

Welche Signale zum Aktivieren des LED-Inverters erforderlich sind, 
kannst du auch mit 12V aus dem Labornetzteil ausprobieren.
Bei ersten Versuchen würde ich GND oder 3,3V wählen und an BL_ON-OFF und 
PWM_DM anlegen. Evtl. sind es auch 5V, aber mit 3,3V geht sicher 
ersteinmal nichts kaputt und funktionieren müsste es wahrscheinlich 
auch. Eine durchgehende Gleichspannung am Dimmeingang stellt dabei 100% 
PWM dar, also volle Leuchtkraft.

von batman (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich gucke mir da die Ausgangstreiber an den Steuerpins auf der 
Hauptplatine an. Waren bei mir Low Side OC BJT => also aktiv-LO 
Steuerung des Inverters, abgeklemmt HI.

von Anselm (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Den DIM Eingang würde ich ja via 1kOhm gegen +5V legen, sonst passiert 
sicher nichts.

von batman (Gast)


Bewertung
0 lesenswert
nicht lesenswert
to dim (engl.) = verdunkeln

von Sinus T. (micha_micha)


Bewertung
0 lesenswert
nicht lesenswert
Liefert das Netzteil überhaupt Spannung, wenn das Mainboard nicht 
angeschlossen ist? Möglicherweise wird es vom Mainboard erst aus dem 
Standby geweckt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.