Forum: PC Hard- und Software Probleme mit Grafiken in Openoffice


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Thomas Z. (usbman)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe hier ein Writer Dokument bestehend aus einem Haufen Tabellen 
und ein paar PNG Grafiken. Die Datei ist knapp 1MB groß die Grafiken 
sind nachweislich im Dokument eingebunden.

Bei dieser Datei kommt es immer wieder mal vor das plötzlich die 
Grafiken verschwinden. Im Positionsrahmen steht dann Ladefehler. Ansicht 
kein großes Problem einfach das Dokument neu laden und alles ist wieder 
ok.

Das Problem ist wenn man das Dokument speichert wenn die Grafiken nicht 
sichtbar sind fehlen diese hinterher. Da ich vorwiegend an den Texten 
und Tabellen arbeite, merke ich unter Umständen nicht wenn die Grafiken 
verschwinden. Ich hab natürlich schon gegoogelt und das scheint öfters 
mal ein Problem zu sein. Eine Lösung hab ich aber auch im OpenOffice 
Forum nicht gefunden.

Wie es genau zu dem Fehler kommt kann ich nicht genauer bestimmen, ich 
habe aber das Gefühl dass es wohl mit dem Standby Mode von Win(10) 
zusammen hängen könnte.

Kann das jemand bestätigen?

Thomas

von Poster (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
In windows xp hatte ich so was ähnliches schon mal. Dokument in PDF 
umgewandelt und abgespeichert. Danach war alles o.k.

von Einer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Poster schrieb:
> In windows xp hatte ich so was ähnliches schon mal. Dokument in PDF
> umgewandelt und abgespeichert. Danach war alles o.k.

Danach kann man es ja auch noch so gut bearbeiten.
Oder warum meinst du das er es neu speichert.
Oder meinst du evtl. RTF, das kann schon einiges bereinigen, beschert 
einem aber auch neue Probleme.

von Mike (Gast)


Bewertung
3 lesenswert
nicht lesenswert
Welche Open-Office Version? Auf Linux?

Probiere mal mit aktuellem Libre-Office.
https://www.libreoffice.org/discover/libreoffice/

von Thomas Z. (usbman)


Bewertung
0 lesenswert
nicht lesenswert
Mike schrieb:
> Welche Open-Office Version? Auf Linux?

Ver 4.1.5 unter W10. Wenn man den Meldungen in den Foren trauen kann 
existiert das Problem schon ziemlich lange. Ich hatte auch einen Hinweis 
gefunden, dass das Problem in LibreOffice auch existiert, hab das aber 
noch nicht ausprobiert.

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
Vielleicht ist die Datei etwas beschädigt. Öffne Sie mal in einer 
Bildverarbeitung und Speicher sie neu ab.

von Nano (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Thomas Z. schrieb:
> Ver 4.1.5 unter W10. Wenn man den Meldungen in den Foren trauen kann
> existiert das Problem schon ziemlich lange.

Dann sollte es auch einen Bugreport dafür geben.
Such mal danach und guck, ob es einen Workaround dafür gibt.


Ansonsten habe ich mal kurz grob geguckt, was man so findet, vielleicht 
passt einer davon:
https://bz.apache.org/ooo/show_bug.cgi?id=117071
https://bz.apache.org/ooo/show_bug.cgi?id=84891
https://bz.apache.org/ooo/show_bug.cgi?id=115994
https://bz.apache.org/ooo/show_bug.cgi?id=43833
https://bz.apache.org/ooo/show_bug.cgi?id=116143
https://bz.apache.org/ooo/show_bug.cgi?id=126756

Wenn nein, dann eröffne einen und schreib einen. Vergiss nicht, die 
Bugnummer dann auch in diesem Thread anzugeben, das ist dann für die, 
die in 5 Jahren das gleiche Problem haben und dann hier landen.


Ansonsten könntest du noch machen was Thomas O. bereits vorgeschlagen 
hat.
PNG bietet allerdings noch ein paar weitere Möglichkeiten.

Du könntest bspw. den Alphakanal entfernen und schauen ob das etwas 
ändert.
Ebenso gibt's für PNG die Möglichkeit, die Auflösung als Wert in der 
Datei abzuspeichern, dann muss das ladende Programm die Auflösung nicht 
selbst ermitteln. Vielleicht tut es das nämlich nicht noch einmal, wenn 
du es bereits geladen hast und vielleicht triggert das den Bug wenn du 
scrollst oder irgendwas mit der Datei machst. Das wäre zwar ein Schuss 
ins Blaue, wäre aber eine Erklärung.
Wenn das der Fall sein sollte, dann solltest du das dringend in den 
Bugreport reinschreiben.
Ebenso könntest du die PNG Datei ohne Adam7-Interlacings abspeichern und 
es mit einer PNG Datei ohne dieses probieren.
Ein Farbmodiwechsel von 16 Bit pro Kanal auf 8 Bit könnte vielleicht 
auch helfen.
Falls das PNG Bild nur aus wenigen Farben besteht, könntest du es auch 
als BMP oder GIF Datei abspeichern. Das wäre dann ein Workaround, der 
mit etwas Glück den Bug nicht triggert.

von Peter E. (Firma: S&P) (eosangel)


Bewertung
1 lesenswert
nicht lesenswert
Ich habe den Tip bekommen die Grafik copy/paste in Draw einzufügen. Draw 
speichern und dann wieder zurück in Writer.
das hat funktioniert, warum auch immer.

Ich arbeite mit Libre Office unter Fedora32 (KDE)

Peter

von Thomas Z. (usbman)


Bewertung
0 lesenswert
nicht lesenswert
Nun ja solange ich den Fehler nicht sicher reproduzieren kann, ist ein 
Bug Report ziemlich nutzlos. Das Dokument ist im nativen odt Format, was 
ja nur ein zipfile mit Unterordner ist. Wenn ich das File in WinRAR 
anschaue sehe ich auch den Pictures Ordner mit den PNGs darin.

Eine Spekulation meinerseits ist nun, dass eben wenn der Laptop aus dem 
Standby Mode aufwacht, in manchen Fällen die Grafiken nicht mehr aus dem 
File geladen werden. Deshalb auch die Anzeige LoadError.

Im Moment behelfen ich mir so dass ich alle Textänderungen an einer 
Kopie mache und ab und an das Original Dokument lade und die Änderungen 
dort hinein kopiere. Danach mach ich das Original sofort wieder zu. 
Export nach PDF klappt ansonsten problemlos.

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
Gibt eine Einstellung bezüglich Bildercache diesen evtl.mal erhöhen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.