Forum: Fahrzeugelektronik Flackern beim Motorstart von LED Innenraumbeleuchtung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Olli Z. (z80freak)


Angehängte Dateien:

Bewertung
-3 lesenswert
nicht lesenswert
Ich habe mir für eine Innenraumbeleuchtung im Dachhimmel eines Fahrzeugs 
eine LED-Cluster Platine genommen und mit einem Brückengleichrichter und 
nachfolgender KSQ versorgt (meinen Schaltplan habe ich hier als Bild 
beigefügt).
Der Brückengleichrichter soll mir einmal eine Verpolungssicherheit 
(Komfort) bieten, aber auch die Schaltung und vor allem die LEDs gegen 
negative Transienten beim Start schützen.
Der 100 nF am Eingang soll Oberwellen im Bordnetz von der Schaltung fern 
halten.
Die KSQ ist so dimensioniert das der Gesamt-LED-Strom ca. 150 mA 
beträgt.

Grundsätzlich funktionieren die LEDs, jedoch flackern diese beim 
anlassen des Motors, mal mehr mal weniger stark.

Ich habe dann über ein Netzteil verschiedene Eingangsspannungen angelegt 
und die Vbe von T2 gemessen:
Vin  Vbe
8V    0mV
9V   18mV
10V 230mV
11V 600mV
..
40V 600mV

Damit ist klar warum diese flackern, denn beim anlassen kann die 
Bordspannung durchaus kurzzeitig unter 9V sinken.

Aber wo ist mein Dimensionierungsfehler?

Die KSQ sollte den Strom ja immer so regeln das er nahezu unabhängig von 
der Eingangsspannung (Vcc) gleich bleibt. Durch den Brückengleichrichter 
verliere ich 1,4 Volt von Vcc. An den (weißen) in Reihe geschalteten 
LEDs fallen nochmal ca. 6 Volt davon ab. Die Basis-Emitter-Spannung von 
T1 muss mind. 0,7 Volt betragen damit die KSQ regelt. Somit benötigt die 
Schaltung rein rechnerisch mind. 1,4 + 6 + 0,7 = 8,1 Volt um überhaupt 
arbeiten zu können.
Habe ich das soweit alles richtig verstanden?

: Bearbeitet durch User
von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Da habe ich wohl in der Dimensionierung einen Fehler...?!

Du rechnest mit 3V für die Leds, ich sehe aber je 2 Leds in Serie.

von Anonym (Gast)


Bewertung
-11 lesenswert
nicht lesenswert
Ich würde dir empfehlen, nicht an deiner Fahrzeugelektronik 
rumzufummeln, wenn du schon daran scheiterst, die Versorgung auszulegen.

Beitrag #6395250 wurde vom Autor gelöscht.
Beitrag #6395253 wurde vom Autor gelöscht.
von MaWin (Gast)


Bewertung
4 lesenswert
nicht lesenswert
Olli Z. schrieb:
> meinen Schaltplan habe ich hier als Bild beigefüg

LEDs direkt parallel ?
Und sicherlich ungepaart und ohne enge thermische Kopplung.
Bitte lass das jemanden bauen, der Grundlagen der Elektronik kennt.
Klar setzt das Licht aus, wenn die Bordspannung unter
3.6+3.6+0.7+0.4+0.7(ist MB6S nicht ein Schottkygleichrichter ? Bin zu 
faul zum Nachgucken)+0.7 = 9.7V fällt, der winzige Kerko kann die Zeit 
nicht überbrücken.

Aber in einem ordentlichen Auto mit funktionierendem Akku, angezigener 
Polklemme, nicht-korrodiertem Massekabel sollt das bei den aktuellen 
Temperaturen auch nicht passieren. Also frisch mal dein Auto auf.

von Olli Z. (z80freak)


Angehängte Dateien:

Bewertung
3 lesenswert
nicht lesenswert
Jörg R. schrieb:
> Du rechnest mit 3V für die Leds, ich sehe aber je 2 Leds in Serie.

AARGH, wieso ist man selbst manchmal so blind?! Es sind sogar 3 LEDs in 
Reihe (siehe geänderten Schaltplan). Danke für den Wink mit dem 
Brückenpfeiler! :-)

Damit erklärt sich dann auch die Mindestspannung von 12 Volt, denn die 
LEDs allein brauchen ja schon 9 Volt und dann nochmal die 2,1 Volt für 
die den Rest der Schaltung, macht 11,1 Volt. Noch etwas Toleranz dazu...

Ok, also muss ich das umbauen, am besten so das nur je 2 LEDs in Reihe 
sind. Der Stromfluß muss dann aber auch anders dimensioniert werden. Im 
Moment gehen ja ca. 150 mA durch insgesamt 6 Stränge, also ca. 25 mA pro 
Strang (1 Strang = 3 LEDs in Reihe).
Wenn ich nun auf 2 LEDs in Reihe verkürze erhalte ich 9 Stränge aus den 
insgesamt 18 LEDs. Jeder Strang zieht nach wie vor 25 mA, also wären es 
insgesamt dann 9x 25 mA = 225 mA.

von Jörg R. (solar77)


Bewertung
1 lesenswert
nicht lesenswert
Olli Z. schrieb:
> AARGH, wieso ist man selbst manchmal so blind?! Es sind sogar 3 LEDs in
> Reihe (siehe geänderten Schaltplan). Danke für den Wink mit dem
> Brückenpfeiler! :-)

Beachte auch den Kommentar von MaWin. Ich würde Leds nicht parallel 
schalten, auch nicht gruppenweise. Spendiere jedem Strang einen eigenen 
kleinen Vorwiderstand um die Toleranzen der Leds auszugleichen. In 
deiner Schaltung kann es passieren dass erst ein Strang ausfällt, weil 
dort eine Led kaputt geht. Dann fallen nach und nach auch die anderen 
Stränge aus weil die KSQ den Strom durch die verbliebenen Stränge 
treibt. Muss nicht passieren, kann aber;-)

Weshalb nimmst Du so viele Einzel-Leds, anstatt eine mit entsprechender 
Leistung?

: Bearbeitet durch User
von Olli Z. (z80freak)


Bewertung
-4 lesenswert
nicht lesenswert
MaWin schrieb:
> Olli Z. schrieb:
>> meinen Schaltplan habe ich hier als Bild beigefüg
>
> LEDs direkt parallel ?
Natürlich. Oder hast Du jemals Cluster-Lampen gesehen die anders 
aufgebaut sind? Wie gesagt, ich habe eine fertige Platine, darauf sind 
die LEDs so bestückt wie sie bestückt sind. Ändern kann ich daran wenig.

> Und sicherlich ungepaart und ohne enge thermische Kopplung.
Gepaart, naja, thermisch gekoppelt JA, da als SMD auf Platine mit großer 
Massefläche aufgelötet.

> Bitte lass das jemanden bauen, der Grundlagen der Elektronik kennt.
Na, wenn Du so schlau bist dann mach doch mal einen Gegenvorschlag?!

> Klar setzt das Licht aus, wenn die Bordspannung unter
> 3.6+3.6+0.7+0.4+0.7(ist MB6S nicht ein Schottkygleichrichter ? Bin zu
Nein

> der winzige Kerko kann die Zeit nicht überbrücken.
Wenn Du meinen Text gelesen hättest wüsstest Du das der dafür auch nicht 
gedacht ist.

: Bearbeitet durch User
von Olli Z. (z80freak)


Bewertung
0 lesenswert
nicht lesenswert
Jörg R. schrieb:
> Beachte auch den Kommentar von MaWin. Ich würde Leds nicht parallel
> schalten, auch nicht gruppenweise. Spendiere jedem Strang einen eigenen
> kleinen Vorwiderstand um die Toleranzen der Leds auszugleichen. In

Wie ich ja schon schrieb ist die LED Platine so aufgebaut. Die wurde 
zuvor nur mit einem Vorwiderstand betrieben. Wobei das dann eher ein 
Glühfaden war als ein Vorwiderstand ;-) Und das kam nicht von MIR so, 
sondern war so verbaut! Daher habe ich diesen durch eine KSQ ersetzen 
wollen. Aber auch um das flackern weg zu bekommen beim starten. Einige 
Sekunden nach dem Start wird die Lampe dann ohnehin automatisch 
abgeschaltet.

> deiner Schaltung kann es passieren dass erst ein Strang ausfällt, weil
> dort eine Led kaputt geht. Dann fallen nach und nach auch die anderen
Ist mir schon klar :-)

LEDs in Reihe geht halt aufgrund der relativ geringen Bordspannung nur 
in geringem Umfang, also eigentlich ja nur 2 Stück. Der Rest muss 
parallel. Und für jeden Strang eine eigene KSQ halte ich echt für 
übertrieben. Die LEDs durch andere zu ersetzen ebenfalls.

von Sebastian S. (amateur)


Bewertung
1 lesenswert
nicht lesenswert
Da liegt so einiges im Argen!
100 nF die irgendetwas bei 150 mA bewirken sollen????
Das was 100 nF schlucken kann sollten die Konstantstromquelle und die 
Dioden abkönnen. Oops!

Konstantstromquelle hin oder her, wer sagt denn den Dioden, wie sie den 
Strom verteilen sollen? Zugegeben lt. Datenblatt und bei dummer 
Simulation geht das ganze recht gut, aber ich würde nicht darauf wetten. 
Oops!

von Schukostecker (Gast)


Bewertung
-3 lesenswert
nicht lesenswert
Was soll eigentlich der Brückengleichrichter (ausser den 
Spannungsabfall) in einem Gleichspannungsnetz bewirken? 2 von 4 Dioden 
sich unbenutzt.

von Sebastian S. (amateur)


Bewertung
2 lesenswert
nicht lesenswert
Der Brückengleichrichter erspart sorgfältiges arbeiten und ordentliche 
Kennzeichnung der Anschlüsse.
Darüber hinaus hilft er beim Flackern indem er die Versorgungsspannung – 
unnötig - um zwei Diodendurchflussspannungen reduziert.

von HildeK (Gast)


Bewertung
3 lesenswert
nicht lesenswert
Schukostecker schrieb:
> Was soll eigentlich der Brückengleichrichter

Der nutzt die wenige Energie aus, die die negativen 100V-Pulse oder mehr 
liefern (ISO irgendwas). Eine einfach Diode sperrt die einfach ungenutzt 
weg.
SCNR.

von Witzbold (Gast)


Bewertung
-4 lesenswert
nicht lesenswert
Ja, aber.
Wer laesst schon den ganzen Tag sein Auto an.
Ich hatte mal einen Karren der hat beim Anlassen das Radio
stummgeschaltet. Voellig unzumutbar!

von michael_ (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Witzbold schrieb:
> Wer laesst schon den ganzen Tag sein Auto an.

Mit Start/Stop durch die Innenstadt. Oder im Stau.

von Olli Z. (z80freak)


Bewertung
-1 lesenswert
nicht lesenswert
Ich sags gern nochmal, für diejenigen die etwas mehr als dumme Sprüche 
auf Lager haben sollten...

Die Anordnung der Dioden war gegeben (auf Platine aufgelötet).
Bis dato wurde die Leuchte durch einen Vorwiderstand betrieben (ab 
Werk).
Es ist kein überwachtes oder sicherheitsrelevantes Bauteil.
Die Leuchte ist an solange das Fahrzeug steht, nach dem aufsperren und 
etwas nach dem absperren, sowie etwas nach dem Start.
Ich habe die Möglichkeit alles zu ändern was geht oder sinnvoll ist.
Zugegeben wollte ich den Aufwand gering halten, daher nur eine KSQ.

von Witzbold (Gast)


Bewertung
0 lesenswert
nicht lesenswert
> für diejenigen die etwas mehr als dumme Sprüche
> auf Lager haben sollten...

Jaja, vermutlich flackert die Originalleuchte aber auch
wenn der Anlasser dreht.
Da hilft dann nur ein DC/DC-Wandler, der mit weniger Spannung
am Eingang, die KSQ noch mit genug Spannung versorgen kann.
Wenn man genaues wissen will, sollte man den Spannungsverlauf
vorher wenigstens mal mit dem Oszi begutachten.
Alles andere sind doch nur Mutmassungen.

von Schukostecker (Gast)


Bewertung
-4 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Ich sags gern nochmal, für diejenigen die etwas mehr als dumme Sprüche
> auf Lager haben sollten...
>
> Die Anordnung der Dioden war gegeben (auf Platine aufgelötet).
> Bis dato wurde die Leuchte durch einen Vorwiderstand betrieben (ab
> Werk).
> Es ist kein überwachtes oder sicherheitsrelevantes Bauteil.
> Die Leuchte ist an solange das Fahrzeug steht, nach dem aufsperren und
> etwas nach dem absperren, sowie etwas nach dem Start.
> Ich habe die Möglichkeit alles zu ändern was geht oder sinnvoll ist.
> Zugegeben wollte ich den Aufwand gering halten, daher nur eine KSQ.

Du hast leider immer noch nicht erklärt, welchen Sinn der 
Brückengleichrichter haben soll.

von Olli Z. (z80freak)


Bewertung
2 lesenswert
nicht lesenswert
Schukostecker schrieb:
> Du hast leider immer noch nicht erklärt, welchen Sinn der
> Brückengleichrichter haben soll.

Ich nicht, aber jemand anderes bereits. Aber für Dich gern nochmal: Das 
ist eine Graez-Brücke und die dient dazu die Polarität unabhängig von 
dem Eingang zu machen. Am BR ist an + immer +, egal wie rum man die 
Eingangsseite dreht. Das ist "Einbaukomfort", weil man nicht auf 
polarität achten muss und damit gleichzeitig Verpolungsschutz. Eine 
einfache Diode würde letzteres auch tun.
Ein evtl. noch angenehmer Nebeneffekt ist, das auch eine negative 
Eingangsspannung, wie sie z.B. beim anlassen im Bordnetz vorkommen kann, 
zur Versorgung der Schaltung dient.

von Olli Z. (z80freak)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die Platine inzwischen modifiziert sodass ich nun keine 6 
Stränge á 3 LEDs in Serie mehr habe, sondern 9 Stränge á 2 LEDs. Dadurch 
sinkt die minimale Betriebsspannung von 11 auf 8 Volt (ab 7 Volt gehen 
die LEDs einigermaßen hell an, aber 8 Volt fließt der Nennstrom).

Vorher waren 6x3 LEDs und rechnerisch flossen 175 mA durch alle 6 
Stränge: Iges = 0,7 V / (R2+R3) = 0,7 V / 4 Ohm = 0,175 A
Istr = Iges / 6 = 0,03 A
Nun ist Iges = 0,03 A * 9 = 0,27 A und damit muss (R2+R3) = 2,6 Ohm 
sein.

Die Verlustleistung vom Widerstand beträgt dabei Pr = 0,7 V * 0,27 A = 
0,189 Watt, ein 1/4 Watt-Widerstand sollte also ausreichend sein.

Ich habe die Schaltung jetzt am Netzmal mal mit 16 Volt über eine Stunde 
betrieben und ich finde nirgens eine Stelle die Wärmer als 36 Grad wird. 
Angemessen am zur verfügung stehenden Gehäuse scheint mir das ok zu 
sein.

Morgen werde ich das im Auto mal ausprobieren ob es immer noch flackert.

Und ja, wenn ich die Platine nun eh schon drunter hab könnte ich auch 
eine neue entwerfen. Die Anzahl der LEDs muss aber fast sein, weil ich 
sonst eine Lichtleitoptik bräuchte um die Leuchtkraft über die benötigte 
Fläche/Länge zu erzeugen. Das wäre eher ungünstig... daher meine Frage: 
Wie würdet ihr denn die 18 LEDs beschalten? Mit einer Reihe sicher 
nicht?!
Evtl. 6 in Reihe (18-22 Volt mittels Step-Up Regler erzeugen und dann 
pro Reihe eine eigene KSQ? Damit der Step-Up nicht "flackert" müsste der 
ja ebenfalls in der Lage sein die Zielspannung aus 8 bzw. besser 6 Volt 
zu generieren.

von michael_ (Gast)


Bewertung
-5 lesenswert
nicht lesenswert
Du hast ja gar keine Ahnung von Elektronik.
Wegen mir kannst du ja die Greatz-Brücke drin lassen, wo du das auch in 
einen alten BMW von 1950 einbauen kannst.

Aber tausche deinen 100n C gegen einen 10000µ aus.
Das entschärft dein Problem deutlich.

von michael_ (Gast)


Bewertung
-6 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Ein evtl. noch angenehmer Nebeneffekt ist, das auch eine negative
> Eingangsspannung, wie sie z.B. beim anlassen im Bordnetz vorkommen kann,
> zur Versorgung der Schaltung dient.

Was soll das denn? Lass die Finger davon!
Kommt niemals vor!

von Witzbold (Gast)


Bewertung
1 lesenswert
nicht lesenswert
> minimale Betriebsspannung von 11

Da hast du den Murx ja selber verbrochen.
Die Graetz wuerde ich auch durch genau 1 Schottky ersetzen.
Das gibt dann noch 1 Volt von oben.

von Nichtverzweifelter (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Will er doch nicht, er möchte eine auch verpolt angeschlossen trotzdem 
funktionsfähige Beleuchtung.
Dabei wäre das Flackern doch ein "feature" für die sternhagelvollen 
Passagiere, "jetzt gehts loooos"...

von Mani W. (e-doc)


Bewertung
-2 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Ein evtl. noch angenehmer Nebeneffekt ist, das auch eine negative
> Eingangsspannung, wie sie z.B. beim anlassen im Bordnetz vorkommen kann,
> zur Versorgung der Schaltung dient.

Ach!

Darum nur ein kleiner C mit 100nF und volle Kostenersparnis...

;-)

von Bernd K. (bmk)


Bewertung
-1 lesenswert
nicht lesenswert
Positive Betrachtung:
"Ich habe eine hervorragende Kontrollfunktion für den Anlassvorgang 
generiert, indem die Innenraumbeleuchtung während dem Anlassvorgang bis 
zum Starten des Motors für 1-2 Sekunden als Indikator flackert."

Negative Betrachtung:
"In meinem Club haben sich alle über meine Unfähigkeit amüsiert, während 
des Anlassvorgangs die Innenraumbeleuchtung konstant leuchten zu 
lassen."

Die Wahrheit liegt wahrscheinlich irgendwo dazwischen.

von Sebastian S. (amateur)


Bewertung
-2 lesenswert
nicht lesenswert
Wenn Du den Witz zum Laufen bringst:
Reg Dich bitte nicht über die stark differierende Helligkeit der 
einzelnen Diodenpaare auf, eventuell brennen die Hellsten ja auch bald 
durch.

von Schukostecker (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Aber für Dich gern nochmal: Das ist eine Graez-Brücke und die dient dazu
> die Polarität unabhängig von dem Eingang zu machen.

Die Funktion eines Brückengleichrichters ist bekannt, aber der Einsatz 
in dieser Schaltung und Erklärung (negatve Spannung beim Anlassen..) ist 
natürlich absoluter Blödsinn.

Preisfrage: Wieviele der professionell entwickelten Komponenten, die 
in einem Auto am 12V-Bordnetz hängen, haben wohl einen 
Brückengleichrichter im Versorgungsspannungspfad (Generator 
ausgenommen)?

von Jürgen von der Müllkippe (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Witzbold schrieb:
> Die Graetz wuerde ich auch durch genau 1 Schottky ersetzen.

Und dann noch einen 4700uF dahinter, der die Spannung für 1 bis 2 
Sekunden speichern kann. Ein Rückfluss des Stroms in den Anlasser wird 
durch die Schottky verhindert. Sollte sich die Spannung am Elko nach 
einer kurzen Zeit doch leicht verringern, sorgt die KSQ trotzdem für 
konstante Helligkeit.
Mehr als 2 LEDs in Serie sollten es dann aber nicht sein.

von Philipp G. (geiserp01)


Bewertung
-1 lesenswert
nicht lesenswert
Lass doch den blöden Gleichrichter und mach stattessen eine flinke 
Sicherung am Eingang, und direkt danach eine Surpressor Diode und einen 
2200uF/60V Elko.

von Soul E. (souleye) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:

> Natürlich. Oder hast Du jemals Cluster-Lampen gesehen die anders
> aufgebaut sind? Wie gesagt, ich habe eine fertige Platine, darauf sind
> die LEDs so bestückt wie sie bestückt sind. Ändern kann ich daran wenig.

Da kommt es drauf an wo Du den Cluster her hast und wie sehr Du dem 
Hersteller vertraust. Hella darf das, Osram auch. Die lassen sich die 
LEDs so anliefern wie sie auf dem Wafer nebeneinandergesessen haben, und 
dann ist auch parallelschalten zulässig. Für Eigenbauten mit Teilen vom 
Gurt gilt das nicht, und für Konstruktionen die der Chinese gelötet hat 
meist auch nicht. D.h. der macht das so, verwendet aber keine passend 
selektierten LEDs.


Wenn es flackerfrei sein soll, dann schalte das Zeug in Reihe und setz 
die Spannung mit einem Boost-Converter hoch. Den kann man auch auf 
Konstantstrom regeln. Application Notes zum Thema LED-Backlight gibt es 
einige, der Converter muss halt automotive-tauglich sein (damit man das 
Gefrickel mit "Schutzschaltungen" nicht braucht).

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Wie gesagt, ich habe eine fertige Platine, darauf sind die LEDs so
> bestückt wie sie bestückt sind. Ändern kann ich daran wenig

Ok, dann hoffen wir mal, dass deren Hersteller die LEDs ausreichend gut 
gepaart hat und thermisch gekoppelt hat.

Olli Z. schrieb:
> wieso ist man selbst manchmal so blind?! Es sind sogar 3 LEDs in
> Reihe.
> Damit erklärt sich dann auch die Mindestspannung von 12V

Ok, damit hat sich das Verhalten erklärt, aber plötzlich kannst du doch 
was am vorgegebenen LED Cluster machen ?

Olli Z. schrieb:
> also muss ich das umbauen, am besten so das nur je 2 LEDs in Reihe sind

Aussagen so weich wie Wackelpudding. Bau dabei wenigstens 
Stromverteilungswiderstände ein, oder pro Strang eine 
Konstantstromquelle, gibt's ja auch fertig als CAT4004A o.ä.

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
Soul E. schrieb:

> Für Eigenbauten mit Teilen vom Gurt gilt das nicht,

Wenn man wirklich einen Gurt bekommt und nicht einzelne LEDs
"aus dem Kasten", besteht zumindest eine gewisse Chance, das
die LEDs auch auf dem Wafer nebeneinander saßen. Verlassen
würde ich mich darauf aber nicht, sondern besser nachmessen.
Da sowieso nur eine Einfach-Konstantstromquelle verwendet wird,
würde ich pro Strang eine eigene KSQ vorsehen.

von Witzbold (Gast)


Bewertung
0 lesenswert
nicht lesenswert
> einen Gurt bekommt

Ich habe hier div. LED auf "Rolle".
Die sind auch nicht gleicher als wenn sie aus dem
Schuettgutcontainer waeren.
Die Rollen sind auch nicht vom Chinesen und die
LED grundsaetzlich in einer Typklasse.

von Olli Z. (z80freak)


Bewertung
0 lesenswert
nicht lesenswert
MaWin schrieb:
> Ok, damit hat sich das Verhalten erklärt, aber plötzlich kannst du doch
> was am vorgegebenen LED Cluster machen ?
Ja, anfangs wollte ich die Platine mit den aufgelöteten LEDs nicht 
anfassen, denn dazu muss das Lampengehäuse zerlegt werden und da ist 
immer die Gefahr das war abbricht oder reißt. Zudem muss man 
Leiterbahnen unterbrechen und mit Adern neu verlegen um die Verschaltung 
zu ändern.

Da ich nun aber keinen anderen Weg sah habe ich es dennoch getan. Also 
nicht "plötzlich" sondern eher "zwangsläufig" ;-)

> Aussagen so weich wie Wackelpudding. Bau dabei wenigstens
Ich würde eher sagen das ich, im Gegensatz zu manch anderem hier, 
durchaus empfänglich bin für gute Argumente und Vorschläge :-)

> Stromverteilungswiderstände ein, oder pro Strang eine
> Konstantstromquelle, gibt's ja auch fertig als CAT4004A o.ä.
Auch das wäre nun eine Option, obwohl man dann wenigstens 5 solcher 
Treiber bräuchte (beim SOT23 Gehäuse). Vielleicht gibt es ja auch was 
"gebräuchlicheres" was man auch bei Reichelt oder RS-Components 
findet...

von Olli Z. (z80freak)


Bewertung
0 lesenswert
nicht lesenswert
Witzbold schrieb:
> Die Rollen sind auch nicht vom Chinesen und die
> LED grundsaetzlich in einer Typklasse.
Wo sollen die denn sonst produziert worden sein als in China? ;-)
Ja, Selektion ist schon wünschenswert, aber ich bezweifle das in 
Konsumer-Lampen aller Art (angefangen vom Hausleuchtmittel bis hin zu 
LED-Taschenlampen) eine Selektion stattfindet... das könnte und wollte 
sicher kaum einer bezahlen.

von Jürgen von der Müllkippe (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Olli Z. schrieb:
> Ja, Selektion ist schon wünschenswert,

Papperlapapp. Für die Linearisierung genügt auch schon ein 10 Ohm 
Widerstand in jedem Strang. Da fallen bei 25mA gerade mal 0,25V ab. Das 
sollte reichen. Verheizen müssen die auch fast nix (0,00625W).

von Olli Z. (z80freak)


Bewertung
0 lesenswert
nicht lesenswert
Dieser 1-Kanal Regler scheint mir auch ganz gut geeignet zu sein 
(BCR420UW6), benötigt (oder bietet) jedoch einen externen 
Stromeinstell-Widerstand (Default ist 10 mA) und kostet run 20 Cent:
https://www.reichelt.de/led-treiber-konstantstromregler-sot-26-bcr-420uw67-dii-p216660.html

Oder diesen, fast gleich günstigen Regler (NSI 45020 AT1G):
https://www.reichelt.de/led-treiber-1-kanal-sod-123-nsi-45020-at1g-p189099.html
Der wird wie ein Vorwiderstand eingesetzt, bestechend simpel.

von Jürgen von der Müllkippe (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Olli Z. schrieb:
> NSI 45020 AT1G

Berücksichtige die Dropspannung von 1,8V!

von Olli Z. (z80freak)


Bewertung
0 lesenswert
nicht lesenswert
Jürgen von der Müllkippe schrieb:
> Olli Z. schrieb:
>> NSI 45020 AT1G
> Berücksichtige die Dropspannung von 1,8V!

In der Tat. Da ist der BCR420 mit 0,9 Volt schon deutlich besser.

von Mani W. (e-doc)


Bewertung
-1 lesenswert
nicht lesenswert
Mani W. schrieb:
> Darum nur ein kleiner C mit 100nF und volle Kostenersparnis...
>
> ;-)

Hat das irgend Wer ernst genommen?

von Jürgen von der Müllkippe (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Mani W. schrieb:
> Hat das irgend Wer ernst genommen?

Nö. War aber lustig 👍

von Witzbold (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
> eine Selektion stattfindet... das könnte und wollte
> sicher kaum einer bezahlen.

Wie sollte der Chiphersteller wohl die Funktion eines Die pruefen?
Richtig, Strom drauf und messen wie hell es leuchtet.
Natuerlich wird dabei gleich mit selektiert.
Und wo es gar nicht leuchtet, kann er sich das Gehaeuse sparen.

von Philipp G. (geiserp01)


Bewertung
0 lesenswert
nicht lesenswert
michael_ schrieb:
>> Ein evtl. noch angenehmer Nebeneffekt ist, das auch eine negative
>> Eingangsspannung, wie sie z.B. beim anlassen im Bordnetz vorkommen kann,
>> zur Versorgung der Schaltung dient.
>
> Was soll das denn? Lass die Finger davon!
> Kommt niemals vor!

Wenn er am Dach schweißt schon. Ansonsten eher weniger.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.