Forum: HF, Funk und Felder Rohde Schwarz CMT-54 -- RF-Eingänge nicht umschaltbar


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Giovanni D. (damicogi)


Bewertung
0 lesenswert
nicht lesenswert
Guten Tag
Habe neulich einen R&S CMT-54 erstanden. Er ist mit vielen Optionen 
ausgestattet. Soweit ich das Gerät habe testen können (ich habe es seit 
erst ein paar Tage) funktioniert es über den Eingang 1 (Hauptbuchse RF 
50 Ohm) korrekt. Über den 2. Eingang (Empfindlicher Eingang 50 Ohm) ist 
das Gerät jedoch völlig taub. EIne weitere Beobachtung war, dass wenn 
ich den Eingang 2 selektierte, die LED korrekt angesteuert wurden. Der 
Umschaltrelay war jedoch nicht zu hören und Buchse 1 (Eingang 1) blieb 
trotzdem aktiv!
Ich studierte das Schaltbild und war der Meinung, es müsse etwas mit der 
Analogplatte nicht stimmen. Also baute ich diese aus und schloss sie 
über einen passenden Verlängerungsadapter wieder an. Dadurch bekam ich 
Zugang zu allen Komponenten dieses Moduls. Zuerst prüfte ich die 
Spannung am Relay K5, der die Umschaltung der Eingänge realisiert. Der 
Wert an der Anode von D4 lag bei beinahe 0V. Die Umschaltung über den 
Bedienungsknopf an der Frontplatte des Gerätes hatte keinen Einfluss auf 
diesen Spannungswert. Das Realy reagierte überhaupt nicht. Da das 
Umschalt-Relay K5 über den Ausgang Q1 (Pin4) des Schieberegisters D97 
(HC4094) kontrolliert wird prüfte ich die Spannung direkt am Pin 4. Da 
war die Spannung ca. 5V. Auch hier blieb die Spannung unverändert bei 
disem Pegel stehen unabhängig davon, welchen Eingang gewählt wurde. Die 
LEDs auf dem Bedienungsfeld des Gerätes reagierten tadellos. In der Tat 
blieb jedoch das Relay ohne Reaktion. Eigentlich hätte, gemäss 
Schaltbild, das Relay bei einer Spannung von 5V am Pin 4 des ICs D97 
über den darauffolgenden Komparator N10 und Transistorpärchen Q11/Q10 
mit einer Spannung von ca. +12V angesteuert werden müssen und demzufolge 
die Eingangsumschaltung ermöglichen. Was war da faul? Beim genauen 
Hinsehen, stellte ich fest das die Leiterbahn, welche vom Pin 4 des ICs 
D97 zum Komparator N10 führt unterbrochen war. Das merkwürdige war, dass 
der Unterbruch durch ein kleines Loch absichtlich gemacht wurde! Kein 
Wunder blieb die Umschaltfunktion aus. Im ersten Moment dachte ich 
nichts dabei. Ich überbrückte den Unterbruch mit einem dünnen 
Silberdraht. Diese Intervention führte dazu, dass nun der RF-Eingang 2 
dauernd aktiv geschaltet wurde und eine Umschaltung auf Eingang 1 nicht 
möglich war. Zumindest passten nun die Spannungswerte mit der Funktion 
überein...Ein Schwacher Trost. Nun konzentrierte ich meine weitere 
Untersuchung in Richtung D97. Weshalb steuerte dieser den Ausgang Q1 
(Pin 4) nicht gemäss Wahl des Einganges durch den entsprechenden 
Schalter? D97 ist ein Schieberegister, der die Daten seriell vom 
Mikroprozessor kriegt und diese dann parallel zur Ansteuerung 
verschiedener Peripherien ausgibt. Also untersuchte ich mit einem 
Digitaloszilloskop die 3 Signale Data, Clock und Strobe. Ich stellte 
fest, dass das Bitmuster im seriellen Datenstrom sich nicht änderte, 
wenn ich die Umschalttaste betätigte. Was nun? Passt die Analog-Einheit 
meines CMT-54 nicht mit der Firmware des Mikroprozessors zusammen?
Ich hoffe, dass in diesem Forum jemand ist, der mir bei dieser 
Fehlersuche helfen kann. Vielleicht hat jemand Ähnliches festgestellt. 
Vielleicht ist sogar ein Mitarbeiter der R&S, der mitliest...
Zu all dem was ich geschrieben habe, kann ich Bilder liefern, falls das 
hilft.

Ich bedanke mich schon jetzt für jeden Hinweis und jede Unterstützung. 
Das Gerät scheint mir zu wertvoll, um es einfach auf die Seite zu 
stellen.

Viele Grüsse aus dem Emmental (Schweiz)
Giovanni, HB9EKH

von Petra (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Hast Du schon mal 99 Spec (Reset) versucht? Die Software ist nicht die 
stabilste.
Meist ist der Eingangsverstärker durch Überlastug kaputt. Schau Dir mal 
diesen Teil genauer an. Das kannst Du nur mittels Extender auf dem Modul 
nachmessen.

von palmvin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
(K)= Würze.

von palmvin (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Giovanni D. schrieb:
> Über den 2. Eingang (Empfindlicher Eingang 50 Ohm) ist
> das Gerät jedoch völlig taub.

Giovanni D. schrieb:
> ...{einen viel zu langen Roman}...

> Ich überbrückte (die Unterbrechung) ...
> ... Diese Intervention führte dazu, dass nun der RF-Eingang 2
> dauernd aktiv geschaltet wurde und eine Umschaltung auf Eingang 1 nicht
> möglich war.

Giovanni D. schrieb:
> Passt die Analog-Einheit
> meines CMT-54 nicht mit der Firmware des Mikroprozessors zusammen?

Petra schrieb:
> Die Software ist nicht die stabilste.
> Meist ist der Eingangsverstärker durch Überlastug kaputt.

Hallo Hans,
Deine Romankunst in allen Ehren, aber kilometerlange Diskurse schrecken 
ab und die Leser schlafen ein.ein.

von damicogi (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Hallo Petra
Vielen Dank für Deine Rückmeldung. Leider brachte ein reset nichts. Ich 
habe jedoch good News. Das Problem, das ich beschrieben hatte, lag an 
einem Datenbus-Konflikt verursacht durch das Option-Modul B10 (SSB 
Analyse-Modul). Nach Entfernung dieses Moduls lässt sich die Umschaltung 
beider Eingänge problemlos tätigen.
Nun bleibt mir zu untersuchen, was mit dem Option Modul B10 nicht gut 
ist. Hoffe am Wochenende etwas Zeit zu finden. Werde auf jeden Fall 
berichten.
Gruss
Giovanni, HB9EKH


PS @palmvin (Gast): Hoffe, Du bist wieder wach... :-) Vielleicht hast Du 
mir auch in Zukunft irgendwelche nützliche Tips...

von Petra (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich denke Du solltest Dich mal an den RS Support wenden, die wissen 
vermutlich noch welche Software zu Deinem CMT passt. Davon gibt es eine 
sehr viele, die jeweils unterschiedliche Konfigurationen unterstützen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.