Forum: PC Hard- und Software Linux: Systemsabotage nach disable motd.service


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Mister A. (mratix)


Bewertung
-2 lesenswert
nicht lesenswert
Cannonical treibt einen nicht nur auf den Gipfel... sondern schubst dann 
herunter.

Es gibt ja zahlreiche Hinweise wie das motd fachmännisch stillgelegt 
werden soll bzw. darf.
cat /etc/default/motd-news
ENABLED=0

Dann kann man noch Feinselektieren, wieviel Rest-Unnütz man verträgt.
chmod -x /etc/update-motd.d/*
Auch damit ist nicht Schluss oder Ruhe. Es wird weitertelefoniert.

Wagt man es den Service abzuschalten
sudo systemctl status motd.service 
 motd.service
   Loaded: masked (/dev/null; bad)
   Active: inactive (dead)

Haut man sich so einiges um die Ohren. Das nächste upgrade streckt dann 
nur noch die Zunge heraus und tut scheinheilig "oh, ein gaaanz 
kritischer unlösbarer Zustand ist eingetreten..."
sudo apt-get dist-upgrade
(gekürzt)
Es wurden 303 MB in 36 s geholt (8.384 kB/s).                                  
Extrahiere Vorlagen aus Paketen: 100%
Vorkonfiguration der Pakete ...
(Lese Datenbank ... 291164 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../base-files_9.4ubuntu4.13_amd64.deb ...
Failed to stop motd-news.timer: Unit motd-news.timer not loaded.
dpkg: Warnung: Unterprozess altes pre-removal-Skript gab den Fehlerwert 5 zurück
dpkg: stattdessen wird Skript aus dem neuen Paket probiert ...
Failed to stop motd-news.timer: Unit motd-news.timer not loaded.
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/base-files_9.4ubuntu4.13_amd64.deb (--unpack):
 Unterprozess neues pre-removal-Skript gab den Fehlerwert 5 zurück
/usr/bin/deb-systemd-helper: error: unable to read motd-news.timer
Failed to get unit file state for motd-news.timer: No such file or directory
motd-news.timer is a disabled or a static unit, not starting it.
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/base-files_9.4ubuntu4.13_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Das war's - Friss oder stirb... Pakete bekommst du keine mehr.
Einzeln kann man natürlich jedes Paket aktualisieren, die base-files 
jedoch nicht :)

von Jim M. (turboj)


Bewertung
1 lesenswert
nicht lesenswert
Hau das doch einfach mal bei denen in den Bugtracker rein.

von Heiner (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Mister A. schrieb:
> Es gibt ja zahlreiche Hinweise wie das motd fachmännisch stillgelegt
> werden soll bzw. darf.

Google: "ubuntu motd disable"

Nach 5 Treffern hatte ich keine Lust mehr. Vorgeschlagen wird einiges, 
das du probiert hast, einiges, das du nicht probiert hast 
(/etc/pam.d/sshd, ~/.hushlogin), und so weit nirgends, den service zu 
töten. Das ist einfach der falsche Weg.

Und dann mal wieder zum allgemeinen Gejammer: Ubuntu ist (absichtlich!) 
kein sauberes, schlankes Minimalsystem. Wenn du diese Erwartung an ein 
Betriebssystem hast, bist du bei Ubuntu falsch. Das ist nicht schlimm 
und geht mir regelmäßig auch so, vor allem bei Servern. Man kann sich 
aber nicht ernsthaft darüber beschweren, dass man mit einer Gabel so 
schlecht Suppe essen kann - das war nie der Plan!

von Markus (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Heiner schrieb:
> Und dann mal wieder zum allgemeinen Gejammer:

Wieso Gejammere, außer Meldungen anzeigen macht der Service doch gar 
nichts?
Weshalb führt ausgerechnet das Deaktivieren eines solch sinnlosen 
Services zu derartigen Fehlermeldungen?
Mit schlankem Minimalsystem o.ä. hat das nichts zu tun.

von Markus (Gast)


Bewertung
1 lesenswert
nicht lesenswert
motd.service scheint nicht der richtige Service gewesen zu sein (?):

https://raymii.org/s/tutorials/Disable_dynamic_motd_and_motd_news_spam_on_Ubuntu_18.04.html#toc_3

von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
Markus schrieb:
> motd.service scheint nicht der richtige Service gewesen zu sein
Richtig, wie man oben sieht, versucht er
Failed to stop motd-news.timer: Unit motd-news.timer not loaded.
dpkg: stattdessen wird Skript aus dem neuen Paket probiert ...
Failed to stop motd-news.timer: Unit motd-news.timer not loaded.
/usr/bin/deb-systemd-helper: error: unable to read motd-news.timer
zu starten.

Ich habe alle motd-Services stillgelegt. Weil so eine vertuschelte 
Sauerei möchte ich nicht haben. Wir sind nicht bei Windows.

Mittlerweile habe ich etwas mehr aus dem Weg geräumt, weil er immer 
wieder Teile davon rekonstruierte. Das Gerüst scheint denen besonders 
wichtig zu sein.

Jim M. schrieb:
> Hau das doch einfach mal bei denen in den Bugtracker rein.
Seit 2018 gibt es Einträge. Sie werden von den Devs einfach ausgesessen 
oder kurzerhand plattgestempelt.

Ich bin für meinen Teil mit Ubuntu fertig. Werde kurzerhand zu Debian 
umschwenken, wo ich bischen Grafik brauche. Aber langfristig muss was 
anderes her.

: Bearbeitet durch User
von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
Heiner schrieb:
> Und dann mal wieder zum allgemeinen Gejammer: Ubuntu ist (absichtlich!)
> kein sauberes, schlankes Minimalsystem. Wenn du diese Erwartung an ein
> Betriebssystem hast, bist du bei Ubuntu falsch.
Seit etwa 10 Jahren bin ich auf Ubuntu. Seit 2-3 Jahren macht es keinen 
Spaß mehr. Zuerst habe sie "uns" Gnome2/3 weggenommen, dann ging alles 
schnell.

Das ist kein Gejammer "ich kenne mich nicht aus, weil ich ein besseres 
Windows haben wollte". Linux ist das einzige was (mir) bleibt.

von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
Markus schrieb:
> Wieso Gejammere, außer Meldungen anzeigen macht der Service doch gar
> nichts?
Na dann lies mal, was es nicht macht. Telemetrie!

von Gerd E. (robberknight)


Bewertung
0 lesenswert
nicht lesenswert
Der nächste Grund sich nach einer Alternative zu Ubuntu umzuschauen ist 
das Konzept von snap mit der darin fest verdrahteten Verbindung nur zu 
deren Servern und deren Implementation ist closed source.

Mehr Details zu dem Problem u.a. hier:
https://blog.linuxmint.com/?p=3906

von tnt (Gast)


Bewertung
1 lesenswert
nicht lesenswert
setzt es auf halten, wenn du die Änderungen bei upgrade beibehalten 
willst. apt-mark hold motd (oder wie das genaue Paket eben heißt)
Dann sollte das upgrade doch gehen.

sehe jetzt nicht nach ein wenig queerlesen wie sich das großartig von 
Debian unterscheited, hab kein ubuntu.



kannst ja zurückbauen.


unter /etc/default/         motd-news kickst du raus
unter /etc/update-motd.d/   platzierst du nur Sachen die du haben 
willst.


standard ein schlichtes uname zum login

10-uname

#!/bin/sh
uname -snrvm

die Ubuntu spez. Sachen, wenns stört weg damit.

rtfm

von Heiner (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mister A. schrieb:
> Na dann lies mal, was es nicht macht. Telemetrie!

Ja, aber diese Bezeichnung ist irreführend, wenn man mit Windows 
vergleicht, denn der Umfang ist popelig und wirkliche persönliche Daten 
werden nicht übertragen. Wenn es Canonical glücklich macht, meine uptime 
zu kennen ...

Davon abgesehen bin ich doch gar nicht dagegen, das zu deaktivieren. Ich 
sage nur:

Heiner schrieb:
> Das ist einfach der falsche Weg.

Statt also den service stillzulegen und dich später zu wundern, dass 
Ubuntu sich wundert, machst du das lieber richtig. Ansätze s.o, oder mal 
selbst suchen.


Mister A. schrieb:
> Das ist kein Gejammer "ich kenne mich nicht aus, weil ich ein besseres
> Windows haben wollte".

Nein, aber es ist das gleiche Argumentationsschema.


Mister A. schrieb:
> Linux ist das einzige was (mir) bleibt.

Ubuntu ist nicht gleich Linux und selbst wenn, wäre die Aussage noch 
falsch.

von Εrnst B. (ernst)


Bewertung
1 lesenswert
nicht lesenswert
tnt schrieb:
> setzt es auf halten, wenn du die Änderungen bei upgrade beibehalten
> willst. apt-mark hold motd (oder wie das genaue Paket eben heißt)
> Dann sollte das upgrade doch gehen.

Nö, das Problem/der Bug liegt im packaging von "base-files".
Das versucht per pre/post Script das Aktualisieren der 
Message-of-the-day während des Update-Laufs zu verhindern. Damit z.B. 
nicht genau in der Sekunde, in dem das dpkg gerade daran ruminstalliert, 
der cronjob/timer für motd losläuft.
Soweit OK.

Wenn es keinen motd-service/timer gibt, schlägt das Fehl.
Soweit auch OK.

Das base-files pre-Install-Script behandelt das als fatalen Fehler, und 
die Installation bricht ab.
Überhaupt nicht OK, bescheuerter Bug.
Wenn der Dienst schon gestoppt ist, sollte es egal sein, wenn er sich 
nicht nochmal stoppen lässt.

von Fedora (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mister A. schrieb:
> Ich bin für meinen Teil mit Ubuntu fertig. Werde kurzerhand zu Debian
> umschwenken, wo ich bisschen Grafik brauche. Aber langfristig muss was
> anderes her.

Fedora läuft bei mir dienstlich und privat.

Ansonsten würde ich die für solche fragen eher ein auf Ubuntu 
spezialisiertes Forum oder Mailingliste empfehlen.

von Andreas B. (bitverdreher)


Bewertung
-1 lesenswert
nicht lesenswert
Mister A. schrieb:
> cat /etc/default/motd-news
> ENABLED=0
> Dann kann man noch Feinselektieren, wieviel Rest-Unnütz man
> verträgt.chmod -x /etc/update-motd.d/*Auch damit ist nicht Schluss oder
> Ruhe. Es wird weitertelefoniert.
Woran machst Du das fest? ENABLED=0 sollte reichen.

Mister A. schrieb:
> Linux ist das einzige was (mir) bleibt.
Du wirst es nicht fassen, aber es gibt einige Distris mehr als Ubuntu. 
Daß gerade Ubuntu versuche es Windows gleichzutun ist ja nun nicht 
wirklich etwas Neues.
Davon abgesehen wäre es mir auch neu, daß motd irgend etwas zu 
Nichtusern des Systems sendet. Das ist meines Wissens nur eine Meldung, 
die beim einloggen angezeigt wird.

von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
Andreas B. schrieb:
> Davon abgesehen wäre es mir auch neu, daß motd irgend etwas zu
> Nichtusern des Systems sendet.
Schaue in die /etc/update-motd.d/50-motd-news.

> Woran machst Du das fest? ENABLED=0 sollte reichen.
Ich glaube irgendwo im cron oder motd-news.timer einen --force gesehen 
zu haben.
Passend dazu im 50-motd-news ein
[ "$1" = "--force" ] && FORCED=1
Und die Firewall hat regelmäßig Zugriffe auf motd.ubuntu.com gelogged.

Dann habe ich angefangen zu schrauben und an "nichts ist, wie es 
scheint" festzuhalten :)

Jetzt habe ich nur noch
-rwxr-xr-x 1 root root  126 Nov 19 06:40 00-header
-rw-r--r-- 1 root root 1157 Apr  9  2018 10-help-text
-rw-r--r-- 1 root root 4992 Aug 13 20:59 50-motd-news
-rw-r--r-- 1 root root  604 Mär 21  2018 80-esm
-rw-r--r-- 1 root root 3017 Mär 21  2018 80-livepatch
-rwxr-xr-x 1 root root   97 Nov 12  2018 90-updates-available
-rw-r--r-- 1 root root  299 Jun  3  2019 91-release-upgrade
-rw-r--r-- 1 root root  129 Nov 12  2018 95-hwe-eol
-rwxr-xr-x 1 root root  142 Nov 12  2018 98-fsck-at-reboot
-rw-r--r-- 1 root root  144 Nov 12  2018 98-reboot-required
und werde beim Login nicht zugemüllt.
Man staune was da alles an Unnütz hineingeimpft wurde.

So lange https://motd.ubuntu.com keinen Witz des Tages, Spruch des Tages 
und ähnliches unterhaltsames vs. langweiliges in kurzen 1-2 Zeilen 
liefert, bleibt es locked. Und alles was damit zu tun hat.

Eine kleine Nebenfrage: gibt es ein Konsolenwerkzug um Texte vergrößert 
in ASCII/ANSI generieren zu lassen? Ich dachte da an, den Hostnamen 
etwas auffälliger in die 00-header unterzubringen. Online-Webseiten 
dafür gibt es ja reichlich.

: Bearbeitet durch User
von jobi (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Mister A. schrieb:
> Eine kleine Nebenfrage: gibt es ein Konsolenwerkzug um Texte vergrößert
> in ASCII/ANSI generieren zu lassen? Ich dachte da an, den Hostnamen
> etwas auffälliger in die 00-header unterzubringen. Online-Webseiten
> dafür gibt es ja reichlich.

Probiere es mal mit "figlet"

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
Mister A. schrieb:
> Und die Firewall hat regelmäßig Zugriffe auf motd.ubuntu.com gelogged.

Oha, da haben die offensichtlich an diesem Dienst schön rumgeschraubt. 
Ich habe das nicht (Mint 19.3). Um aber an einen externen Server etwas 
zu senden, müssen die da noch mehr im Hintergrund gemacht haben.
Das wäre für mich ein Grund, Ubuntu von der Platte zu werfen.

von Mister A. (mratix)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
jobi schrieb:
> Probiere es mal mit "figlet"
Bingo, genau das habe ich gesucht. Danke dir.

Andreas B. schrieb:
> Oha, da haben die offensichtlich an diesem Dienst schön rumgeschraubt.
Ja, schön langsam ausgebaut. Er sendet regelmäßig auch noch die 
machine-id und eine cloud-id (was auch immer das ist, Fingerprinting). 
Zudem sorgt intern verstrickt ein force, dass der motd-cache 
aktualisiert bzw. vorgehalten wird. Egal ob man das möchte oder mit 
ENABLED=0 setzt.

Andreas B. schrieb:
> Ich habe das nicht (Mint 19.3).
Oha. Interresant.
Also meine beiden "Desktops" sind pure Ubuntu Mate. Installiert werden 
alle via Mini-netboot. Also nicht von kompletten ISO/Live-Images. Dann 
kommen viele viele einzelne Pakete, bis das System den Anforderung 
entspricht.
Nur den letzten habe ich aus einem vorgeschnürten Server-Image 
draufgezogen. Der ist sofort aus der Reihe getanzt.
Bei den Arbeitskisten habe ich immer Debian, ohne X11. Bei denen ist mir 
nichts deratziges aufgefallen.

Andreas B. schrieb:
> Das wäre für mich ein Grund, Ubuntu von der Platte zu werfen.
Ja, langsam reicht es echt. Ich vermeide die bekannte Frage welche 
distro soll ich nehmen :)

*Anbei die letzte 50-motd-news, Ubuntu 18.04.5 bionic

Nachtrag: man beachte
[ "$ENABLED" = "1" ] || exit 0
Heißt ganz klar Abbruch.
Denkste, irgendwo anders passiert das Gegenteil. Ich habe es noch nicht 
genau lokalisiert wo. (vermute mal der .timer startet es mit einem 
force). Aber auch keine Lust weiter nachzuforschen.

: Bearbeitet durch User
von Markus (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Heiner schrieb:
> Statt also den service stillzulegen und dich später zu wundern, dass
> Ubuntu sich wundert, machst du das lieber richtig. Ansätze s.o, oder mal
> selbst suchen.

Den Service stillzulegen ist eigentlich der richtige Ansatz.
In eine Konfigurationsdatei ENABLED = 0 zu schreiben, ist umständlich, 
aber auch richtig.
Aber so wie auf diversen Seiten vorgeschlagen, die Excecution Bits zu 
negieren, ist doch kompletter Mist. Das ist noch nicht einmal ein 
Ansatz, sondern pure Verzweiflung.

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
Mister A. schrieb:
> Ich vermeide die bekannte Frage welche
> distro soll ich nehmen :)
Da Du ja Ubuntu gewohnt bist: Mint (aber das nur eine Meinung von 
mindestens 20, die Du auf diese Frage bekommen wirst. ;-) )

Markus schrieb:
> Aber so wie auf diversen Seiten vorgeschlagen, die Excecution Bits zu
> negieren, ist doch kompletter Mist. Das ist noch nicht einmal ein
> Ansatz, sondern pure Verzweiflung.
Ja, wenn Ubuntu da solchen Mist baut, bleiben einem da wohl nur solche 
Möglichkeiten. So eine Distri käme mir nicht ins Haus.

von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
Markus schrieb:
> Den Service stillzulegen ist eigentlich der richtige Ansatz.
So kenne ich das auch.

> In eine Konfigurationsdatei ENABLED = 0 zu schreiben, ist umständlich,
> aber auch richtig.
Naja, es gibt so manche daemons die aktiviert werden möchten. Aber nur 
deswegen weil eine Konfiguration nötig ist.
Es gibt nur wenige die explizit deaktiviert werden sollen.

> Aber so wie auf diversen Seiten vorgeschlagen, die Excecution Bits zu
> negieren, ist doch kompletter Mist. Das ist noch nicht einmal ein
> Ansatz, sondern pure Verzweiflung.
Unter xenial habe ich die einzelnen scripte herausgelöscht. Irgendwann 
beim updaten gab es leicht-böse Meldungen zum Vermissen. Einige davon 
wurden wieder angelegt. Seit dem vermeide ich es, sie zu entfernen.

Tatsache ist, dass dieses Konstrukt im Interresse von oben, so bestehen 
soll. Und auch bei Bedarf gestartet werden soll. Und das gefällt mir gar 
nicht.

Andreas B. schrieb:
> So eine Distri käme mir nicht ins Haus.
> Da Du ja Ubuntu gewohnt bist: Mint
brrr, da hat sich so ein Vorurteil festgeschrieben. Ich müsste mich 
überwinden es nochmal anzuschauen :)

Manjaro/Arch wären so meine Kandidaten. Nur der Packagemanager gefällt 
mir nicht so recht. Naja, eigentlich nur nicht weil er beim LPIC Punkte 
gekostet hat :)

CentOS kommt garantiert nicht ins Haus.
Was ist eigentlich aus Gentoo geworden? Gibt es davon mittlerweile eine 
"precompiled" Distro oder eher immernoch source pur?

von Arno (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Im Linux-Universum am weitesten weg von Ubuntu dürfte ungefähr Slackware 
liegen ;) Da hast du die umgekehrte Herausforderung: Out of the box hast 
du nichtmal einen Benutzer, ganz zu schweigen von sowas wie auto mount. 
Der Paketmanager kann keine Abhängigkeiten, du musst selbst zusehen, 
dass alle nötigen Pakete installiert werden.

Dafür meckert der Paketmanager auch nicht, wenn beim Update irgendwelche 
Services noch laufen. Du musst selbst in Startup-Skripten herumfummeln, 
damit sie gestartet werden (und beim Update, wenn neue Startup-Skripte 
mitkommen, die Änderungen behalten). Kein systemd.

Ich nutze es seit über 20 Jahren, hab also sicher keinen guten Blick von 
außen darauf. Bin aber nach Versuchen mit Gentoo und Arch immer wieder 
"zurück" gekommen und habe mich jedes Mal gefreut, dass sich auch fünf 
Jahre nach meiner letzten Installation nicht grundlegend etwas verändert 
hatte. OK, zugegeben, die letzte stable ist auch schon vier Jahre alt, 
und wegen openssl würde ich sie nicht mehr empfehlen, sondern auf 
-current gehen. Vermutlich kommt bald 15.0...

MfG, Arno

P.S: Bitte nicht missverstehen: Das ist keine Empfehlung für jemanden, 
der sein erstes Linux installiert, und auch keine Empfehlung für 
jemanden, der eigentlich ein besseres Windows sucht. Eher für Menschen, 
die mit BSD liebäugeln, denen aber irgendwas fehlt - mich hält von BSD 
ja immer noch die anscheinend mäßige Unterstützung von suspend-to-disk 
ab.

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
Mister A. schrieb:
> brrr, da hat sich so ein Vorurteil festgeschrieben.
das wäre?

von bingo (Gast)


Bewertung
0 lesenswert
nicht lesenswert
mal eine "blöde" Frage: ich habe auch Ubuntu, seit Jahren, bei mir gibt 
es kein 'motd', ich könnte das zwar mit synaptic o.ä installieren, war 
aber bei der Standard-Installation nicht dabei.

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
bingo schrieb:
> ich habe auch Ubuntu, seit Jahren, bei mir gibt
> es kein 'motd'
Kann ich mir nicht vorstellen. motd gehört zum Debian Grundsystem.

von bingo (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Andreas B. schrieb:
> bingo schrieb:
>> ich habe auch Ubuntu, seit Jahren, bei mir gibt
>> es kein 'motd'
> Kann ich mir nicht vorstellen. motd gehört zum Debian Grundsystem.

wiki.ubuntuusers.de kennt es gar nicht, bei 4 Ubuntu-Rechnern hier 
(zuhause und Arbeit) ist es nirgends installiert. Desktop hier ist immer 
XFCE.

Ich würde mal ein 'sudo apt purge motd*' versuchen

von tnt (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mister A. schrieb:


> Man staune was da alles an Unnütz hineingeimpft wurde.
>



---

https://ubuntu.com/server/docs/pam-motd

... pam_motd executes the scripts in /etc/update-motd.d in order based 
on the number prepended to the script. The output of the scripts is 
written to /var/run/motd, keeping the numerical order, then concatenated 
with /etc/motd.tail.  ...

http://manpages.ubuntu.com/manpages/eoan/en/man5/update-motd.5.html

 Packages  should  add  scripts  directly  into /etc/update-motd.d, 
rather than symlinks to other scripts, such that administrators can 
modify or remove these  scripts  and  upgrades will not wipe the local 
changes.



Gib ihm!

von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
bingo schrieb:
> ich habe auch Ubuntu, seit Jahren, bei mir gibt
> es kein 'motd'
Kann nicht sein. Auch wenn du noch ein Ubuntu 6 hättest, wäre es unter 
/etc/default/motd. Halt nur nicht so versaut.

Andreas B. schrieb:
>> brrr, da hat sich so ein Vorurteil festgeschrieben.
> das wäre?
Na z.B. die ganzen Anfragen hier, im Forum, mein Mint tut dies und jenes 
;)

Au ja, reparier es einfach mit:
gksu killall firefox
wenn es immer noch nicht geht, melde dich möglichst grafisch als root 
an...
Da bekommt man richtig Angst beim lesen, geschweige es anzufassen.
Ich weis nicht so Recht, alles was von Ubuntu abstammt kann ja nicht 
besser sein. Die Grundlast ist halt inbegriffen.

bingo schrieb:
> Ich würde mal ein 'sudo apt purge motd*' versuchen
Das wäre wohl der Tod. Beim nächsten reboot nur noch ein
$_ blink blink

von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
tnt schrieb:
> Packages  should  add  scripts  directly  into /etc/update-motd.d,
> rather than symlinks to other scripts
Oh Mann. Ein Firefox für die Konsole.
apt-cache search motd
base-files - Verschiedene Dateien für das Debian-Basissystem
libpam-modules - Pluggable Authentication Modules für PAM
update-motd - compliments pam_motd in libpam-modules
figlet - Erzeugt aus gewöhnlichen Text ASCII-Banner aus großen Zeichen
monajat-mod - Konsolenhilfsprogramm für islamische Gebete
mythtv-status - Den Zustand eines MythTV-Backends anzeigen
sysnews - Programm zeigt Systemneuigkeiten an
xmotd - message of the day browser for X
motd-news-config - Configuration for motd-news shipped in base-files
Aha, motd-news-config ? Habt ihr sowas?

: Bearbeitet durch User
von bingo (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mister A. schrieb:
> Kann nicht sein.

Was redest Du für einen Mist, wenn das bei Dir so ist, muss das woanders 
nicht so sein. Weder auf Xubuntu 16.04 LTS (habe ich hier noch in einer 
VM), noch 18.04 LTS noch 20.04 LTS gibt es hier ein motd, weder in dem 
von Dir aufgezeigten Verzeichnis noch sonstwo auf der Platte. Ich habe 
auch ein Ubuntu Server laufen, auch ist nix. Habe gerade auch mal bei 
meiner Frau nachgesehen, auch dort Fehlanzeige.

von Εrnst B. (ernst)


Bewertung
0 lesenswert
nicht lesenswert
bingo schrieb:
> Weder auf Xubuntu 16.04 LTS (habe ich hier noch in einer
> VM), noch 18.04 LTS noch 20.04 LTS gibt es hier ein motd,

Such nochmal. z.B.

# grep motd  /etc/pam.d/*

oder:

# dpkg -S /lib/x86_64-linux-gnu/security/pam_motd.so

das gehört zu "libpam-modules", ich glaube kaum dass du deine 
(x)ubuntu(server) ohne installiert hast.

von M.M.M (Gast)


Bewertung
0 lesenswert
nicht lesenswert
bingo schrieb:
> Was redest Du für einen Mist, wenn das bei Dir so ist, muss das woanders
> nicht so sein. Weder auf Xubuntu 16.04 LTS (habe ich hier noch in einer
> VM), noch 18.04 LTS noch 20.04 LTS gibt es hier ein motd, weder in dem
> von Dir aufgezeigten Verzeichnis noch sonstwo auf der Platte. Ich habe
> auch ein Ubuntu Server laufen, auch ist nix. Habe gerade auch mal bei
> meiner Frau nachgesehen, auch dort Fehlanzeige.

Dann schau'n wir doch mal im Paket "base-files", das ganz sicher 
installiert ist:
https://packages.ubuntu.com/de/focal/base-files

und dort in "Liste der Dateien" und finden u.a.:
https://packages.ubuntu.com/de/focal/amd64/base-files/filelist

/etc/default/motd-news
/etc/update-motd.d/00-header
/etc/update-motd.d/10-help-text
/etc/update-motd.d/50-motd-news
/lib/systemd/system/motd-news.service
/lib/systemd/system/motd-news.timer
/usr/share/base-files/motd

Alles klar?

von tnt (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Mister A. schrieb:

>> Ich würde mal ein 'sudo apt purge motd*' versuchen
> Das wäre wohl der Tod. Beim nächsten reboot nur noch ein
>
$_ blink blink

:)


Das adressiert doch dein Anliegen recht genau:
https://raymii.org/s/tutorials/Disable_dynamic_motd_and_motd_news_spam_on_Ubuntu_18.04.html

Zitat


.....
Conclusion

+++++++++++
Disabling the entire dynamic-motd can be done
by commenting out two lines in /etc/pam.d/sshd:

session    optional     pam_motd.so  motd=/run/motd.dynamic
session    optional     pam_motd.so noupdate

and letting OpenSSH handle the motd. You need to put stuff in /etc/motd 
yourself for that to work. OpenSSH does this by default if that file 
exists.

+++++++++++
Disabling specific parts of the dynamic motd can be done by removing 
scripts (or making them not executable) in /etc/update-motd.d/.

+++++++++++
Disabling the pingback to the canonical mothership, the motd-news part 
can be done by changing ENABLED=1 to ENABLED=0 in 
/etc/default/motd-news.




Und es steht nat. frei skripte zu verändern, zu löschen oder eigene 
unter /etc/update-motd.d/ hinzuzufügen.

cat /var/run/motd.dynamic sollte den aktuellen Zustand anzeigen



vlt. hülfts dir weiter.

von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
tnt schrieb:
> Disabling the entire dynamic-motd can be done
> by commenting out two lines in /etc/pam.d/sshd:
>
> session    optional     pam_motd.so  motd=/run/motd.dynamic
> session    optional     pam_motd.so noupdate
Vielen Dank tnt. Das hat gefehlt.

von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe ihm den /lib/systemd/system/motd-news.timer zurückgegeben, 
jedoch disabled gelassen.
sudo apt-get dist-upgrade
(auf relevantes gekürzt)
Vorbereitung zum Entpacken von .../base-files_9.4ubuntu4.13_amd64.deb ...
Entpacken von base-files (9.4ubuntu4.13) über (9.4ubuntu4.11) ...
base-files (9.4ubuntu4.13) wird eingerichtet ...
Obsolete conffile /etc/default/motd-news has been modified by you.
Saving as /etc/default/motd-news.dpkg-bak ...
done.

Das upgrade lief endlich durch. Die /etc/default/motd-news hat er wieder 
herausgekickt.

Was für ein Horror!
Ubuntu hin, Ubunter her - ich mach jetzt format c:

Nochmal ganz großen Dank an @tnt

von Andreas B. (bitverdreher)


Bewertung
0 lesenswert
nicht lesenswert
Mister A. schrieb:
> Andreas B. schrieb:
>>> brrr, da hat sich so ein Vorurteil festgeschrieben.
>> das wäre?
> Na z.B. die ganzen Anfragen hier, im Forum, mein Mint tut dies und jenes
> ;)

Das liegt daran, daß Mint gerne von Windows Umsteigern verwendet wird, 
die dann erwarten daß Mint ein verbessertes Windows ist.
Bei mir funktioniert Mint (19.3 Mate) ganz hervorragend. Ich bin vorher 
meist auf debianoiden unterwegs gewesen. Zuletzt auch Ubuntu. Als die 
dann mit den Kacheln Windows nachgemacht hatten (11.04) war es das für 
mich. Debian selbst ist mir etwas zu altbacken. Von daher bin ich bei 
Mint hängengeblieben.

M.M.M schrieb:
> bingo schrieb:
>> Was redest Du für einen Mist,
Wer im Glashaus sitzt.....
>> wenn das bei Dir so ist, muss das woanders
>> nicht so sein. Weder auf Xubuntu 16.04 LTS (habe ich hier noch in einer
>> VM), noch 18.04 LTS noch 20.04 LTS gibt es hier ein motd, weder in dem
>> von Dir aufgezeigten Verzeichnis noch sonstwo auf der Platte. Ich habe
>> auch ein Ubuntu Server laufen, auch ist nix. Habe gerade auch mal bei
>> meiner Frau nachgesehen, auch dort Fehlanzeige.
>
> Dann schau'n wir doch mal im Paket "base-files", das ganz sicher
> installiert ist:
> https://packages.ubuntu.com/de/focal/base-files
Das hätte mich auch gewundert, wenn das bei Ubuntu anders wäre.

Mister A. schrieb:
> ich mach jetzt format c:
Wie geht das unter Ubuntu? ;-)

: Bearbeitet durch User
von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
Mister A. schrieb:
> Obsolete conffile /etc/default/motd-news has been modified by you.
> Saving as /etc/default/motd-news.dpkg-bak ...
Rafiniert verpackt, damit fliegt das ENABLED=n heraus :)

Mister A. schrieb:
> Nochmal ganz großen Dank an @tnt
Natürlich ganz großen Dank an alle Beteiligte und Beitragende. Ist 
irgendwie im Moment untergegangen.

Andreas B. schrieb:
>> ich mach jetzt format c:
> Wie geht das unter Ubuntu? ;-)
In dem man Platz im lvm (Volume group) schafft und sich dann einfach 
weitere Kandidaten (als Logical volumes) hinein installiert. Also ein 
dualboot^n.

Das machen wir heute. Geben auch dem Mint die Chance sich zu zeigen.
Nach der Installation hängt man nur noch das /home ein und es geht 
verzögerungsfrei weiter.

: Bearbeitet durch User
von Rolf M. (rmagnus)


Bewertung
0 lesenswert
nicht lesenswert
Mister A. schrieb:
> Das upgrade lief endlich durch. Die /etc/default/motd-news hat er wieder
> herausgekickt.

Hast du das irgendwo so eingestellt? Ich werde eigentlich bei jedem 
modifizierten Config-File vor dem Ersetzen gefragt, ob ich es behalten, 
durch das neue ersetzen oder es manuell mergen möchte.

von Mister A. (mratix)


Bewertung
0 lesenswert
nicht lesenswert
Rolf M. schrieb:
> Hast du das irgendwo so eingestellt? Ich werde eigentlich bei jedem
> modifizierten Config-File vor dem Ersetzen gefragt, ob ich es behalten,
> durch das neue ersetzen oder es manuell mergen möchte.
Eigentlich nicht. Er fragt ja auch immer brav. Nur hier nicht :)

Ich glaube zuständig dafür ist "dialog" u.ä., je nach dem was 
eingestellt ist.
sudo dpkg-reconfigure dialog

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.