Forum: Fahrzeugelektronik Opel Omega Tacho ohne ABS ansteuern


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Peter M. (peter37)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe einen Omega B V6 Tacho den ich ohne ABS zum Laufen bekommen 
möchte in einem Sonderfahrzeug.
Ich nutze als Motorsteuerung eine Ecumaster.
Habe bereits einen induktiven Omega ABS Sensor in der Motorsteuerung 
drin und funktioniert.
Es gibt nun einen speedometer Ausgang an der Motorsteuerung. Diesen habe 
ich aktiviert.

Problem => Der Tacho bewegt sich nicht.

Grundsätzlich stelle ich mir die Frage ob ich die Platine vom Cockpit 
richtig angeschlossen habe. Siehe Foto.
In diesem Fall für Tacho und Kilometerzähler insgesamt 7 Anschlüsse von 
der Platine sowie 12V, Masse und Tachosignal (grau).
Die 7 Anschlüsse von der Platine habe ich mir rausgemessen von dieser 
Folienplatine auf der Gehäuserückseite des Originalcockpits.

Laut Schaltplan nutze ich für den Platinenanschluss
Masse - Pin 26
Tachosignal - Pin 23
12Volt - Pin 25
An Pin 22 scheint ein Kurbelwellensignal anzuliegen, brauche ich das für 
den Tacho ?

Evt. hat das schon jemand ausprobiert ?
Wäre klasse ein paar Tipps zu bekommen.

Grüsse

von Stefan L. (stefan_l134)


Bewertung
0 lesenswert
nicht lesenswert
Kannst du deine Schaltpläne mal posten? Wie sieht das Originalsignal im 
Omega aus? Passen Pegel und Signalform die vom ECUMaster kommen?

von Peter M. (peter37)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Im Anhang die Schaltpläne. Ich hoffe das reicht fürs erste.

Der Ausgang des VSS Signals am Omega ABS sollte ein 12V Rechtecksignal 
sein.
Der Output am Ecumaster ist ein Rechtecksignal. Mit welcher Spannung ist 
nicht dokumentiert. 5 oder 12V. Ich habe kein Oszi.

von Stefan L. (stefan_l134)


Bewertung
0 lesenswert
nicht lesenswert
Peter M. schrieb:
> Der Output am Ecumaster ist ein Rechtecksignal. Mit welcher Spannung ist
> nicht dokumentiert. 5 oder 12V. Ich habe kein Oszi.

Das würde ich als erstes mal versuchen herauszufinden. Vielleicht kannst 
du dir irgendwo ein Oszi ausleihen?

EDIT: In der Anleitung der EMU-Classic steht: "
Tacho output function is used to control electronic tachometers. Based 
on engine speed, the EMU generates a square wave signal with a frequency 
proportional to the crankshaft speed. The tachometer should be connected 
to AUX 4 which is equipped with a 10K pullup resistor connected to + 
12V. If any other output than AUX 4 is used, an external pullup resistor 
must be used."

Zuerst mal gibt das Steuergerät hier nur ein Kurbelwellensignal aus, 
aber egal. Benutzt du AUX 4? Ansonsten musst du wohl einen externen 
Pull-Up Widerstand einsetzen.

: Bearbeitet durch User
von Peter M. (peter37)


Bewertung
0 lesenswert
nicht lesenswert
Stefan L. schrieb:
> Peter M. schrieb:
>> Der Output am Ecumaster ist ein Rechtecksignal. Mit welcher Spannung ist
>> nicht dokumentiert. 5 oder 12V. Ich habe kein Oszi.
>
> Das würde ich als erstes mal versuchen herauszufinden. Vielleicht kannst
> du dir irgendwo ein Oszi ausleihen?

Ja, werde ich tun. Melde mich wieder

Danke + Grüsse

von Peter M. (peter37)


Bewertung
0 lesenswert
nicht lesenswert
Auf meinem AUX4 liegt der Drehzahlmesser.
Ich möchte den AUX1 für speedometer nutzen.
Die Doku sagt:
Speedometer output function is used to operate an electronic 
speedometer. On the basis of vehicle speed, it generates a square wave 
signal with a frequency proportional to the vehicle speed. The 
speedometer can be connected to one of the outputs for Stepper motor or 
free INJECTOR/AUX

von Stefan L. (stefan_l134)


Bewertung
0 lesenswert
nicht lesenswert
"Injectors and AUX outputs are Low side type (switch to ground)."

Also brauchst du da einen Pull-Up-Widerstand gegen +12V.

von Peter M. (peter37)


Bewertung
0 lesenswert
nicht lesenswert
Stefan L. schrieb:
> "Injectors and AUX outputs are Low side type (switch to ground)."
>
> Also brauchst du da einen Pull-Up-Widerstand gegen +12V.

Ok. Super. Danke für den Tipp !

von Stefan L. (stefan_l134)


Bewertung
0 lesenswert
nicht lesenswert
Sag bescheid ob es geklappt hat!

von Peter M. (peter37)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Pull up so realisieren ?

von Stefan L. (stefan_l134)


Bewertung
0 lesenswert
nicht lesenswert
Ja

von Peter M. (peter37)


Bewertung
0 lesenswert
nicht lesenswert
Ausprobiert. Keine Reaktion am Tacho.
Habe einen 2KOhm Widerstand verwendet.
Habe das Multimeter an den aux drangehängt. Rennt zwischen ca. 2-10 Volt 
rauf und runter ohne Fahrzeugbewegung.

Update: Habe alles nochmal rausgemessen. Tatsächlich habe ich mich 
verzählt wegen einem nicht belegtem Pin. Kl30 und Gnd waren um einen Pin 
versetzt.....

Jetzt bewegt sich der Zeiger wenn man anschliesst. So eine Art 
Referenzfahrt schätze ich.
Jedoch weiterhin kein Zeigerausschlag bei Radbewegung.
Einmal mit Pull up probiert und einmal ohne. Ergebnis ident.

Was kommt als nächstes, Oszi ?

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.