Forum: Analoge Elektronik und Schaltungstechnik Gleisbesetzmelder Modellbahn


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Christian S. (christian364)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich bin neu hier, 57 JAhre alt, habe eine HTL-Ausbildung in den 80igern 
des letzten Jahrhunderts genossen, jedoch im Prinzip ein Laie auf dem 
Gebiet, jedoch lernfähig.

Ich versuche gerade für meine Modellbahnanlage eine Relais-Stellwerk zu 
bauen. Dazu benötige ich auch eine Gleisbesetztmeldung.
Ich habe im Netz dazu eine Schaltung gefunden, mir IN-Multisim 
runtergeladen und die Schaltung dort nachgebaut. Dort geht sie auch in 
eine Fahrtrichtung.

Es gibt aber Abschnitte bei der Anlage, wo in beide Richtungen gefahren 
werden soll. Somit ist eine Umpolung der Fahrspannung notwendig. Sobald 
ich die Fahrspannung umpole wir der Testlauf im Multisim abgebrochen. 
Vermutlich habe ich dann einen Kurzschluß, komm aber noch nicht drauf 
wie ich da die Schaltung dazu aufbauen muss um das zu ermöglichen

Hab von dieser Schaltung 1 Bild angehängt

Zur Erklärung:

U7 sind die 5V durch Widerstand gedrosselte Überwachungsspannung für die 
Besetztmeldung wenn keine Fahrspannung anliegt und ein Zug z.B. vor 
einem Signal steht, dass auf Halt ist.

S1 ist Signalschalter (offen Signal halt)
V2 ist der Trafo und R4 ist regelbare Fahrspannung daraus
R1 und S2 sind Widerstand der Lok bzw. wenn S1 offen ist kein Zug in dem 
Bereich

Kann mir jemand einen Tip geben wie ich das Problem lösen kann.

lg
Christian

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
1 lesenswert
nicht lesenswert
Christian S. schrieb:
> Ich habe im Netz dazu eine Schaltung gefunden

Verlinke das bitte mal. Dein 'Schaltplan' ist jedenfalls schwer zu 
entziffern.
Grundsätzlich kann man eine Prüfspannung aufs Gleis geben und schauen, 
ob Strom fliesst. Das kann man z.B. ganz simpel mit einem kleinen 
12-18V/20mA Lämpchen realisieren, das leuchtet, wenn Prüfstrom fliesst. 
Oder auch mit LED  (lies Optokoppler) und vorgeschaltetem 
Brückengleichrichter.

von MaWin (Gast)


Bewertung
3 lesenswert
nicht lesenswert
Christian S. schrieb:
> Hab von dieser Schaltung 1 Bild angehängt

Wahnsinn.

LEDs ohne Vorwiderstand,
ein heilloses Durcheinander von tausenden von Bauteilen,
und das willst du pro Gleis aufbauen ?

Christian S. schrieb:
> Relais-Stellwerk

Nicht ernsthaft, das war schon der Bahn zu teuer.
Nicht ohne Grund hat sich heute die digitale Modelllbahn durchgesetzt. 
Da kann sigar ein Tablet-Computer die Gleisbildstellwerksteuerung mit 
Fahrstrassenbelegung übernehmen, keine Knöpfe mehr.

Christian S. schrieb:
> Kann mir jemand einen Tip geben wie ich das Problem lösen kann.

Offenkundig baust du eine Gleichstrombahn ohne Mittelleiter, analog 
gesteuert. Da ist natürlich das Problem, dass man ohne Spannung auf dem 
Gleis nicht erkennen kann ob ein Stromverbraucher draufsteht. Man muss 
also eine Spannung aufs Gleis legen, nur bei geringer Spannung brummt 
die Lok, um gleich darauf loszufahren, und bei noch geringerer Spannung 
stören eventuell Gleichrichterdioden in der Lok so dass gar kein Strom 
fliesst.

Es gibt bei diesem Steinzeit-Zeugs keine sinnvolle (einfache, 
kurzschlussrobuste) Möglichkeit, bau Lichtschranken oder Magneten und 
Reedschalter dran.

Selbst gepulste Erkennung (1ms eine Prüfspannung alle 10s anlegen) hat 
Probleme mit der Generatorspannung fahrender Loks, Kurzschlüssen 
entgleister Züge  und die Fahrspannung müsste während des Testintervalls 
abgeschaltet werden, pro Streckenabschnitt.

Sinnvoll umsetzbar wird das erst, wenn die Fahrspannungserzeugung selbst 
elektronisch (PWM) realisiert wird. Zumal auch erst dann eine 
elektronisch schnelle Strombegrenzung eingebaut werden kann und nicht 
alle Teile auf zig Ampere Kurzschlussstrom ausgelegt werden müssten.

von Christian S. (christian364)


Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Hallo!

Die findet man hier 
http://www.gotthardbahn.ch/8_modellbahn/elektronik/8-elektronik.htm Dann 
auf Gleisbesetzmelder klicken.

Die Verbindungspunkte auf der Zeichnung sind etwas klein und man erkennt 
schwer wo Verbindung sind, gebe ich zu. Die Voltmeter werden wohl auch 
etwas verwirren.

Ich häng mal ein besseres Bild an. Dort wo sich Verbindungen kreuzen, 
habe ich jetzt einen Bogen in eckiger Form gemacht. Mal sehen ob es 
jetzt verständlicher ist.

Diese Schaltung ist schon auf einer Platine gelötet und live getestet. 
Zug steht bzw. fährt am Gleis ein eine Richtung und die LED für die 
Besetzmeldung leuchtet. Mein Problem ist die andere Fahrtrichtung.

lg
Christian

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
1 lesenswert
nicht lesenswert
Christian S. schrieb:
> Ich häng mal ein besseres Bild an.

Damit du selber durchblickst (und wir auch), strukturiere das doch mal 
ein wenig. Also z.B. die Stromversorgung ganz links, dann die Gleise mit 
oder ohne Verbraucher und dann die Auswerteschaltung.
Der LM7805 freut sich sicher über einen Stützkondensator 100nF am 
Ausgang. Und ja, wenn der Fahrstrom umgepolt wird, musst du auch die 
Prüfspannung aus dem LM7805 umpolen.

von Christian S. (christian364)


Bewertung
-5 lesenswert
nicht lesenswert
Hallo!

Was ich wie und wo baue ist wohl meine Sache.
Eine LED mit 5V braucht wohl keinen Vorwiderstand bei 5V 
Spannungsversorgung.

Also ich sehe da nur einige Bauteile die auch bezeichnet sind. Einige 
davon sind im fertigen Zustand nicht auf der Platine, da sie von außen 
über Anschlüsse kommen.

Ich benötige für den Bahnhof und alle möglichen Fahrstraßen 73 Relais.

Von dieser Besetzmeldung brauche ich 39 Ausgänge zu einer LED. ca. 10 
davon sind nur ein eine Fahrtrichtung, der Rest soll in beide 
Fahrtrichtungen gehen.

Ich bin Stellwerkswärter bei der U-Bahn in Wien. Dort wird elektronisch 
gearbeitet, bzw. noch Relaistellwerke elektronisch fernbedient.

Die Anlage soll für die Pension sein und ich will oldschool arbeiten auf 
der Anlage.

von Joachim B. (jar)


Bewertung
4 lesenswert
nicht lesenswert
Christian S. schrieb:
> Was ich wie und wo baue ist wohl meine Sache.

dann frage nicht!

Es gibt zwar LED direkt für 5V mit integriertem Vorwiderstand, aber für 
den MOC8101 gilt das nicht!

MaWin schrieb:
> Wahnsinn.
>
> LEDs ohne Vorwiderstand,

von Christian S. (christian364)


Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
 Und ja, wenn der Fahrstrom umgepolt wird, musst du auch die
> Prüfspannung aus dem LM7805 umpolen.

Hallo und Danke! das ist mal ein Ansatz mit dem ich arbeiten kann. Ist 
ja auch logisch, aber als Laie steht man halt manchmal auf der Leitung.

lg
Christan

von Wolfgang P. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hast du die Schiene auch wie in diesem Bild verdrahtet?
http://www.gotthardbahn.ch/8_modellbahn/elektronik/gbm/anschluss.gif

von Christian S. (christian364)


Bewertung
-3 lesenswert
nicht lesenswert
Hallo mal an alle die da schreiben.

Einige sind wohl nicht gut drauf.

Ich hab am Anfang angegeben, dass ich zwar Grundkenntnisse vor vielen 
Jahre erlangt habe, aber im Prinzip Laie bin.

Einige Antworten hier und Kommentare sind ein Witz.

Nochmal:

Ob ich ein Relaisstellwerk bauen will, da ich beruflich viele Jahre 
damit zu tun hatte oder nicht sollte wohl mir überlassen sein. Ich weiß, 
dass es z.B. mit Uhlenbrock und anderen tolle Systeme gibt, wo ich dann 
über den PC die Anlage steuern kann. Das mache ich in meinem Beruf den 
ganzen Tag, außer ich bin auf den Außenstellwerken die noch nicht 
elektronisch sind. Das will ich in meinem Hobby nicht. Ob das jetzt 
veraltet ist oder nicht wird wohl egal sein. Das ist HOBBY!!!!!!

Bis jetzt hab ich eine vernünftige Antwort bekommen für die ich mich 
bedanke.

Ich bin hier wohl im falschen Forum gelandet. Satt Hilfestellung mal 
fest draufhauen.

Auf wiedersehen und Danke fürs Gespräch!

von Christian S. (christian364)


Bewertung
-2 lesenswert
nicht lesenswert
Wolfgang P. schrieb:
> Hast du die Schiene auch wie in diesem Bild verdrahtet?
> http://www.gotthardbahn.ch/8_modellbahn/elektronik/gbm/anschluss.gif

Ich habe die erste Platine so wie in diesem und weiteren Bildern 
aufgebaut, jedoch nur eine Abschnitt, also 1 GBM.

Diese Schaltung funktioniert so nicht.
Daher habe ich die nun über Multsim nachgebaut und verändert bis sie 
läuft. jedoch nur in eine Richtung.

Ich werden den Hinweis mit der Umpolung des LM7805 mal umsezten.

Jetzt muss ich dann mal in die Arbeit. Die U-Bahn wartet.

von Joachim B. (jar)


Bewertung
1 lesenswert
nicht lesenswert
Christian S. schrieb:
> Satt Hilfestellung mal
> fest draufhauen.

statt danke, erst mal fest draufhauen?

Christian S. schrieb:
> Was ich wie und wo baue ist wohl meine Sache.

und das auf deutliche Hinweise!

von Wolfgang P. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Habe das gerade mal in LTSPice simuliert die orginal Schaltung 
funktioniert, in beide Fahrtrichtungen.

von christian@ing-schneider.at (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Wolfgang P. schrieb:
> Habe das gerade mal in LTSPice simuliert die orginal Schaltung
> funktioniert, in beide Fahrtrichtungen.

Umpolung der Überwachungsspannung auch gemacht? Möglich, dass dort mein 
Fehler ist.

Wenn ich bei Multisim die beiden gegenläufigen Dioden einbaue, geht dort 
nichts mehr.

Ich muss mir das in einer ruhigen Stunde nochmal ansehen.

von HildeK (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Wolfgang P. schrieb:
> Habe das gerade mal in LTSPice simuliert die orginal Schaltung
> funktioniert, in beide Fahrtrichtungen.

Poste doch mal einen Screenshot deiner Schaltung ...

von Zeno (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Und ja, wenn der Fahrstrom umgepolt wird, musst du auch die
> Prüfspannung aus dem LM7805 umpolen.

Nö muß er nicht, wenn er sich an die Vorgaben der Orginalschaltung hält. 
5V ist an dieser Stelle zuviel. Laut Orginalartikel darf die 
Prüfspannung maximal 3V betragen. Die Prüfspannung dient ja nur dazu 
einen Strom fließen zu lassen, wenn die Fahrspannung abgeschaltet ist - 
Polarität ist an dieser Stelle egal, da die Schaltung auf positive als 
auch negative Spannung reagiert.

Wozu sollen denn die Schalter und der Regelwiderstand 50Ohm gut sein? Im 
Orginal sind sie jedenfalls nicht vorhanden. Auch den 50Ohm Widerstand 
R1 gibt es im Orginal nicht.
Wenn mir das Verständnis für eine Schaltung fehlt, dann baue ich die 
erst mal so wie in der Orginalquelle beschrieben auf und lasse auch 
keine Bauteile (C3 im Orginal) weg, auch wenn diese Bauteil sich 
bezüglich des geschilderten Fehlers nicht auswirken wird. Also erst mal 
ein Stück Gleis nehmen und alles so wie im Orginal beschrieben aufbauen. 
Man muß ja keine Lok aufsetzen, ein einfacher Wagen mit Beleuchtung tut 
es. Wenn alles funktioniert und man dann hoffentlich die Schaltung auch 
verstanden hat, kann man es nach eigenem Gusto ändern/ergänzen.

Die Schaltzeichnung im Orginal ist schon schwierig zu lesen, weil die 
dort gewählte Darstellung der Schaltung bei uns eher unüblich ist. 
Allerdings hat es der TO geschafft das Ganze noch unübersichtlicher zu 
machen. Wenn man die Schaltung nicht wirklich verstanden hat, mach es 
der Schaltplan des TO gewiß nicht leichter.

von Zeno (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Christian S. schrieb:
> Matthias S. schrieb:
>  Und ja, wenn der Fahrstrom umgepolt wird, musst du auch die
>> Prüfspannung aus dem LM7805 umpolen.
>
> Hallo und Danke! das ist mal ein Ansatz mit dem ich arbeiten kann. Ist
> ja auch logisch, aber als Laie steht man halt manchmal auf der Leitung.

Nein muß er nicht! Man lese hier 
http://www.gotthardbahn.ch/8_modellbahn/elektronik/8-elektronik.htm 
nach. Der Autor hat die Schaltung eigentlich gut beschrieben.

von Zeno (Gast)


Bewertung
1 lesenswert
nicht lesenswert
christian@ing-schneider.at schrieb:
> Wenn ich bei Multisim die beiden gegenläufigen Dioden einbaue, geht dort
> nichts mehr.

Nicht simulieren einfach mal mit einem Stück Gleis, einem Wagen mit 
Beleuchtung und 1:1 wie im Orginaltitel aufbauen und durchtesten.

von Wolfgang P. (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Nicht schön, aber immerhin

von Zeno (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Korrektur:
Im Orginal steht, die Prüfspannung muß mindestens 3V betragen. Die 5V 
des TO sollten also funktionieren.

Ich denke mal der Fehler hat sich durch schlecht gezeichneten Plan 
eingeschlichen. Da sieht mit Verlaub gesagt keine Sau durch.

von Christian S. (christian364)


Bewertung
-2 lesenswert
nicht lesenswert
Zeno schrieb:

>
> Wozu sollen denn die Schalter und der Regelwiderstand 50Ohm gut sein? Im
> Orginal sind sie jedenfalls nicht vorhanden. Auch den 50Ohm Widerstand
> R1 gibt es im Orginal nicht.
>

Die Gleisanschlüsse sind Links von R1 und rechts von S2.

wie im ersten Beitrag geschrieben:

R1 = Widerstand der Lok wenn sie am Gleis steht
S2 = geschlossen: Lok (Fahrzeug) steh am Gleis -->LED1 leuchtet
Offen: kein Fahrzeug am Gleis --> LED1 aus

nur so kann ich auf der Schaltung den Kreislauf schließen um ein 
Ergebnis zu erzielen.

Die Spannungsversorgung ist extern über fertige stabile Netzteile 
aufgebaut und wird durch Anschlüße an die Platine gebracht. Ich bin mir 
sicher, dass auf meiner Zeichnung bzgl. Spannungsversorgung 
Verbesserungsbedarf herrscht. Aber sie dienen dort nur um die Funktion 
zu testen.

Ich habe über Multisim keine 3V Versorgung für die Überwachungsspannung 
gefunden und deshalb die 5V und 100kOhm nachgeschaltet.

von Christian S. (christian364)


Bewertung
-2 lesenswert
nicht lesenswert
Zeno schrieb:

> Ich denke mal der Fehler hat sich durch schlecht gezeichneten Plan
> eingeschlichen. Da sieht mit Verlaub gesagt keine Sau durch.


Schau mal bitte den Plan von Beitrag 4 an.

Ich denke, dass man da den Lauf erkennen kann. Soviele Bauteile sind es 
wohl wirklich nicht.

von Christian S. (christian364)


Bewertung
-1 lesenswert
nicht lesenswert
Zeno schrieb:
> christian@ing-schneider.at schrieb:

> Nicht simulieren einfach mal mit einem Stück Gleis, einem Wagen mit
> Beleuchtung und 1:1 wie im Orginaltitel aufbauen und durchtesten.

Habe ich mit der Schaltung vom gotthardbahn.ch gemacht, da es nicht ging 
mehrmals alle Leitungen und Anschlüsse verfolgt.

Nochmals Schritt für Schritt gelötet. Wieder nichts. Keine 
Besetzmeldung. Zug fährt, aber angezeigt wird nichts.

Darum habe ich die Schaltung versucht zu simulieren und anzuschließen 
wie beim Löten um ev. einen Fehler von mir zu finden.

Das in eine Richtung funktionierende Ergebnis ist das Bild.

Jetzt geht es mir nur mehr um die Umpolung.

von Christian S. (christian364)


Bewertung
-1 lesenswert
nicht lesenswert
Wolfgang P. schrieb:
> Nicht schön, aber immerhin

Ich glaube ich komme der Sache näher. Prüfspannung darf nur anliegen, 
wenn keine Fahrspannung anliegt und umgekehrt. Umpolung der Fahrspannung 
hat keine Auswirkung , da nur immer eines von beiden da ist VF oder VÜ. 
Oder bin ich da schon wieder auf dem Holzweg?

In der Anschlusszeichnung für die Gleis bei gotthardbahn.ch sehe ich 
keine Trennung sondern ein gleichzeitiger Anschluss.

von Wolfgang P. (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Der 10k Widerstand sorgt schon dafür das Gleichzeitiges anliegen kein 
Problem ist.

von Christian S. (christian364)


Bewertung
-1 lesenswert
nicht lesenswert
Wolfgang P. schrieb:
> Der 10k Widerstand sorgt schon dafür das Gleichzeitiges anliegen kein
> Problem ist.

In der Skizze von dir sehe ich aber nur den Eingang vom Gleis und ohne 
weitere Auswertung des Signals vom OpAmp. Ist also nur eine 
Einzelschaltung.

Bau bitte mal die Schaltung mit LTSPice weiter aus wie in der ganzen PDF 
von gotthardbahn.ch

Ich bin neugierig was da rauskommt.

Es hängt von den Gleisen bis zum Transistor ja alles auf gleicher Masse. 
Wenn man die Spannung umdreht, dann geht der Transistor aber nicht mehr, 
da ja Plus von der anderen Richtung kommt.

von Wühlhase (Gast)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Ich habe die letzten Kommentare mal übersprungen, da schien nicht viel 
Diskusionswertes dabei zu sein.

@Christian: Der Umgangston hier ist relativ normal. Manche verstehen 
halt nicht, wie man nicht schon als Elektroniker auf die Welt gekommen 
ist.

Da du schreibst daß du Laie bist, kurz etwas Theorie. Zum besseren 
Verständnis: Löse dich von dem Gedanken, daß man immer irgendwo Spannung 
anlegen muß um etwas zu messen. Vor allem: Vergiß die Kausalkette 
"Spannung liegt an" -> "Strom fließt".
Sondern freunde dich damit an, daß Spannung und Strom jeweils gemeinsam 
auftreten. Ohne Ursache-Wirkung-Beziehung zueinander.

Es ist zwar richtig: Du kannst eine Prüfspannung anlegen und schauen ob 
ein Strom fließt.
Alternativ kannst du aber auch direkt einfach einen Strom treiben und 
schauen, ob dieser fließt. Es ist weitaus einfacher, einen Strom durch 
die Gleise zu treiben, der jedoch gering genug ist, die Geschwindigkeit 
der Lokomotive nur unmerklich zu beeinflussen. Und schon gar nicht, die 
Lokomotive ungewollt fahren zu lassen. Z.B. 0,1mA.

Eine Schaltung, die dies leistet, ist hier erklärt:
https://dieelektronikerseite.de/Lections/Konstantstromquelle%20-%20Immer%20das%20Gleiche.htm

Diese Schaltung baust du so um, daß die Gleise dort hängen wo die LED 
sitzt. Was wichtig ist: Die Versorgung deiner Schaltung und die 
Eisenbahn dürfen kein gemeinsames Potential haben. Zur Not muß also ein 
DC-DC-Wandler rein, der eine galvanische Trennung mitbringt.

Solange die Versorgungsspannung deiner Stromquelle jetzt größer ist als 
die Spannung an deinen Eisenbahnschienen, kann also dein eingestellter 
Strom fließen. Und den wiederum kannst du z.B. mit einem Schmittrigger 
über einem Shunt detektieren.

von Christian S. (christian364)


Bewertung
0 lesenswert
nicht lesenswert
Wühlhase schrieb:

>
> Es ist zwar richtig: Du kannst eine Prüfspannung anlegen und schauen ob
> ein Strom fließt.
> Alternativ kannst du aber auch direkt einfach einen Strom treiben und
> schauen, ob dieser fließt. Es ist weitaus einfacher, einen Strom durch
> die Gleise zu treiben, der jedoch gering genug ist, die Geschwindigkeit
> der Lokomotive nur unmerklich zu beeinflussen. Und schon gar nicht, die
> Lokomotive ungewollt fahren zu lassen. Z.B. 0,1mA.
>

Das mit dem Strom hab ich ja so halbwegs. Darum ist ja auch der 100k in 
der ÜV drinnen, damit die Lok nicht fährt.

Die Trennung der Massen war schon mal ein Gedanke. Ich scheitere aber an 
der Umsetzung der Trennung und vorallem wo.

Das mit dem Gleis hab ich nicht verstanden. Dort wo die LED ist soll das 
Gleis hin? wie kommt dann was über die Schaltung zum OpAmp?

Steh jetzt neben mir!!

von Christian S. (christian364)


Bewertung
0 lesenswert
nicht lesenswert
Christian S. schrieb:

>
> Das mit dem Gleis hab ich nicht verstanden. Dort wo die LED ist soll das
> Gleis hin? wie kommt dann was über die Schaltung zum OpAmp?
>

Ich glaub jetzt hab ichs, aber brauch noch etwas Bestätigung meines 
Gedankenganges.

Einen DC/DC Wandler am Ausgang vom Gleis (rechts vom Schalter S2). Eine 
Seite davon auf Masse für die Fahrspannung die anderen Seiten geht zur 
Schaltung vor C1. Alle Massen aus der Schaltung dann auf die richtige 
Seite des DC/DC Wandlers. Dann wären die mal getrennt.

Jetzt hänge ich noch an der Versorgung des LM324D. Der muss ja nun auch 
in diesem "neuen" Kreis hängen.

von Entspannungswandler (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ein netteres Forum weil Anmeldezwang:
https://www.1zu160.net/scripte/forum/index.php

von Zeno (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Entspannungswandler schrieb:
> Ein netteres Forum weil Anmeldezwang:
> https://www.1zu160.net/scripte/forum/index.php

Ich meine bei Deiner Schaltung werden letzendlich alle Spannungen aus 
einer Spannungsquelle gewonnen und das ist der Fehler.
Für die Versorgungsspannung (des IC) und Prüfspannung wäre das OK, aber 
die Fahrspannung muß eine eigene Spannungsquelle sein, welche nur 
ausgangsseitig einseitig mit dem Bezugspotential (Masse) verbunden ist.

Noch was: Zeichne den Schaltplan um. Er ist wirklich schwer zu lesen. 
Nimm das Orginal und mach bei allen elektrischen Verbindungen einfach 
einen Punkt. Bei den Leitungskreuzungen läßt Du einfach den Bogen weg.

von Zeno (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Falsches Zitat in meinem letzten Post. Wollte eigentlich den TO 
zitieren.

von Wühlhase (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Christian S. schrieb:
> Die Trennung der Massen war schon mal ein Gedanke. Ich scheitere aber an
> der Umsetzung der Trennung und vorallem wo.

Hier findest du etwas:
https://www.reichelt.de/wandler-module-dc-dc-c7241.html?&nbc=1

Massetrennung mag erstmal etwas irreführend klingen, da du beide Kreise 
wieder galvanisch verbindest. Du solltest dich mal mit dem Begriff 
Bezugspotential (oft Masse oder Gnd genannt) vertraut machen. Beide 
Spannungsquellen (Eisenbahntrafo und Versorgungsspannung deiner 
Schaltung) haben ihr eigenes Bezugspotential. Um es kurz zu machen: ohne 
galvanische Trennung könnte der Strom nicht aus der Schiene auf ein 
niedrigeres Potential fließen (in meiner Schaltung oben).


Christian S. schrieb:
> Das mit dem Gleis hab ich nicht verstanden. Dort wo die LED ist soll das
> Gleis hin? wie kommt dann was über die Schaltung zum OpAmp?

Naja...wenn du die LED raus nimmst, hast du zwei offene Leitungsenden. 
Das eine Ende kommt an die eine, das andere Ende an die andere 
Fahrschiene. In meiner Schaltung oben wäre das R1. Wenn eine Lok auf dem 
Gleist steht, fließt der Strom da durch - wenn nicht, ist der Stromkreis 
offen (kein Stromfluß).

Wenn ein Prüfstrom fließt, fließt er auch den R5 ganz unten. Diesen 
kannst du detektiern. Ich habe aber vergessen, daß da auch noch ein 
Nebenstrom durch R2 fließt, ganz null würde der Strom durch R5 also nie 
werden.
Alternativ könntest du das aufbauen wie im Anhang gezeigt. Dann ist der 
Strom wirklich null, wenn keine Lok auf dem Gleisabschnitt steht/fährt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.