Forum: Mikrocontroller und Digitale Elektronik Mosfet Schaltung Raspberry Pi


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von black cable (Gast)


Angehängte Dateien:

Bewertung
-3 lesenswert
nicht lesenswert
Hallo Liebe Community,

ich habe aktuelle eine Platine mit einem selbstgemachten Layout wo sich 
darauf MosFETs: IRLB8721PBF befinden, die ich mit dem GPIO eines 
Raspberry Pi durchschalten will. Dies funktioniert auch, wenn die zu 
schaltende Spannungsquelle aus ist, jedoch raucht mir der Raspberry ab, 
wenn ich eine Spannung schalte(Sekundärspannung). Ich habs auch ohne 
Raspberry mit einer 12V Spannungsversorgung direkt auf die GPIO Ausgänge 
versucht und da hats dann auch geklappt(mit Sekundärspannung). Das 
MosFET hab ich verwendet, da es mir empfohlen wurde, jedoch finde ich es 
jetzt stutzig das der RG - Gate Resistance 2.3Ohm ist (laut Datenblatt), 
das wäre laut meinem verständnis viel zu wenig, jedoch würde der 
Raspberry ja dann schon abrauchen, wenn ich das MosFET ohne 
Sekundärspannung schalte. Ich hätte es jetzt einfach mit einem 100OHm 
Wiederstand vor dem Gate kontakt probiert, aber ich will nicht schon 
wieder ein Raspberry verlieren und ich konnte bisher nicht ausrechnen 
was dann noch für eine Spannung am Gate anliegt, da ich den Wiederstand 
vom Gate nicht kenne.

Zur Grundinformation:
Diode: SB560 DO-201
Kondensator: ist aktuell nicht verlötet
Schalteinheit: Raspberry Pi 4B
MosFET: IRLB8721PBF
Pull-Down Wiederstand: 10kOhm

Schaltung und einzel Schaltplan sind im Anhang

Danke und mit freundlichen Grüßen
Martin

von MaWin (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Ein IRLB8721 ist zwar LogicLevel nur für 4.5V spezifiziert, aber der rPi 
liefert nur 3.3V, er reicht also nicht.

Mit dem Defekte beim Ausschalten hat das nichts zu tun und die 2.3 Ohm 
Gatewiderstand sind normal und ok.

black cable schrieb:
> Ich hätte es jetzt einfach mit einem 100OHm Wiederstand vor dem Gate
> kontakt probiert

Kann man machen, auch egal, hilft nix macht aber auch nix kaputt.

black cable schrieb:
> Kondensator: ist aktuell nicht verlötet

Welcher auch immer, den zwischen + und - der 24V kann ein Problem sein, 
wenn der beim Abschalten fehlt.

von black cable (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo MaWin,

vielen Dank für deine schnelle Antwort.
lt. dem Datenblatt vom MosFET ist der Gate Treshold Voltage zwischen 
1.35 - 2.35V. Hab ich da was falschen verstanden? Sollte der MosFET dann 
nicht bei 2.35V zuverlässig durchschalten?
LINK zum Datenblatt: 
https://asset.conrad.com/media10/add/160267/c1/-/en/000161166DS01/datenblatt-161166-infineon-technologies-irlb8721pbf-mosfet-1-n-kanal-65-w-to-220ab.pdf

Der Wiederstand wär dann ja dafür da das der Raspberry nicht gleich 
durchbrennt, das wird angeblich gerne bei Bastelschaltungen verwendet. 
Ich bin mir nicht sicher aber der Raspberry muss ja fast durch den GPIO 
kontakt durchbrennen.

Der Kondensator ist nur zum Glätten einer PWM auf der Netzteill Seite, 
jedoch wäre ich zunächst mal froh wenn der Raspberry das MosFET mit der 
Last durchschaltet.

von kenny (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der mosfet fängt bei Ugsth erst an zu leiten. Wann er sicher welchen 
Stom schaltet findet man meist in den Diagrammen.

Was mich wundert ist GND an-24V.
Ist das ein Fehler, oder so gewollt?

von black cable (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Kenny,

ok, also ist dieser MosFET für mein Bedürfnis der falsche?
Ich muss nur 2.5A für 500ms und dann 1.25A schalten, ist diesr dann 
Trotzdem Termisch überlastet?

Die 24V- hab ich nur gezeichnet das man erkennt das diese zu den 24V+ 
gehören.

Hast du eine Ahnung warum der Raspberry durchbrennt?

von Gerald K. (geku)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
MaWin schrieb:
> Ein IRLB8721 ist zwar LogicLevel nur für 4.5V spezifiziert, aber der rPi
> liefert nur 3.3V, er reicht also nicht.

Die Kurve im Datenblatt zeigt, das bei 3V typisch 2A geschaltet werden 
können, oder irre ich mich?

Ich würde zum Schutz des RPI zwei Schottky Dioden mit möglichst geringem 
Uf mit Vorwiderstand vorsehen.
Eine Diode mit Anode am IO und Kathode an +3V3 und die zweite Diode mit 
Kathode am IO und mit der Anode an GND. Wenn keine PWM dann, sollen 1k 
(zw. Gate und 10k)in Ordnung sein.

: Bearbeitet durch User
von black cable (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Gerald,

wo genau sollten die Schottkey Dioden verbaut werden?

Gerald K. schrieb:
> MaWin schrieb:
>> Ein IRLB8721 ist zwar LogicLevel nur für 4.5V spezifiziert, aber der rPi
>> liefert nur 3.3V, er reicht also nicht.
>
> Die Kurve im Datenblatt zeigt, das bei 3V typisch 2A geschaltet werden
> können, oder irre ich mich?

Die MosFETs wären eh nur kurze Zeit eines Spannung ausgesetzt und 
könnten sich dann wieder abkühlen, falls diese warm werden.

> Ich würde zum Schutz des RPI zwei Schottky Dioden mit möglichst geringem
> Uf mit Vorwiderstand vorsehen.
> Eine Diode mit Anode am IO und Kathode an +3V3 und die zweite Diode mit
> Kathode am IO und mit der Anode an GND.

Ok, also die zwei Dioden sollten vermeiden das der Strom in den 
Raspberry fließen soweit ich das verstanden hab?

> Wenn keine PWM dann, sollen 1k (zw. Gate und 10k)in Ordnung sein.

Ich würde jedoch gerne ein PWM Signal darüber schalten, was müsste ich 
dann noch beachten

von MaWin (Gast)


Bewertung
1 lesenswert
nicht lesenswert
black cable schrieb:
> Sollte der MosFET dann nicht bei 2.35V zuverlässig durchschalten?

Nein, wie geschrieben fängt er da erst an schwach zu leiten.

Keine Ahnung, warum dieser Datenblattlesefehler so hartnäckig in den 
Köpfen der Hobbyisten rumgeistert.

Gerald K. schrieb:
> Die Kurve im Datenblatt zeigt, das bei 3V typisch 2A geschaltet werden
> können, oder irre ich mich?

Ja. Kurven sind 'typisch'. Fur die 3V Kurve können je nach Exemplar auch 
2.1 oder 4.2V nötig sein

Garantiert ist nur der RDS(on) Wert bei angegebener UGS Spannung.

von Gerald K. (geku)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
black cable schrieb:
> wo genau sollten die Schottkey Dioden verbaut werden?

siehe Beilage

black cable schrieb:
> Ok, also die zwei Dioden sollten vermeiden das der Strom in den
> Raspberry fließen soweit ich das verstanden hab?

Die Durchlassspannung der Substratdioden des MC sollte höher sein als 
die der Schottkydioden ( z.B. MBR0520LT1G Very Low Forward Voltage 
(0.38 V Max @ 0.5 A, 25°C)

black cable schrieb:
> Ok, also die zwei Dioden sollten vermeiden das der Strom in den
> Raspberry fließen soweit ich das verstanden hab?

Dazu muss Durchlassspannung der Schottkydioden kleiner als die der 
Substratdioden sein.

black cable schrieb:
> Ich würde jedoch gerne ein PWM Signal darüber schalten, was müsste ich
> dann noch beachten

Dann muss der Vorwiderstand kleiner sein, um das Gate möglichst schnell 
umladen zu können. Die Frage ist ob der Ausgang des MC's ausreichend 
ist.

Der FET hat laut Datenblatt über 1nF Gatekapazität. Diese muss vom 
Ausgange über den 1k Widerstand umgeladen werden. Damit ist die 
Schaltzeit übern Daumen ~ 1nF x 1k > 1us !!!

: Bearbeitet durch User
von Forist (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
black cable schrieb:
> ich habe aktuelle eine Platine mit einem selbstgemachten Layout

Und wo ist der Schaltplan dazu

> Schaltung_einzeln.png
EINMAL bei der Wahl des Dateiformates nachzudenken, ist doch wohl nicht 
sooh schwierig. Keiner legt hier Wert auf die verlustfreie Reproduktion 
der Textur deiner Malstiftspitze.

> Schaltung_Platine.png
Da hast du die falsche Datei erwischt. Das ist ein Layout - dazu auch 
noch völlig vergittert.

> Dies funktioniert auch, wenn die zu
> schaltende Spannungsquelle aus ist, jedoch raucht mir der Raspberry ab,
> wenn ich eine Spannung schalte(Sekundärspannung).

Dann solltest du vielleicht den KOMPLETTEN Schaltplan inklusive 
Anschluss an der RaspberryPi und Verdrahtung der Stromversorgung zeigen, 
oder meinst du, irgend jemand kann den aus deinem vergitterten Layout 
extrahieren.

black cable schrieb:
> lt. dem Datenblatt vom MosFET ist der Gate Treshold Voltage zwischen
> 1.35 - 2.35V. Hab ich da was falschen verstanden?

Ja, die U_GS_th sagt, ab wann der FET ANFÄNGT zu leiten, nicht wann er 
durchgeschaltet ist.

von Gerald K. (geku)


Bewertung
0 lesenswert
nicht lesenswert
Forist schrieb:
> Ja, die U_GS_th sagt, ab wann der FET ANFÄNGT zu leiten, nicht wann er
> durchgeschaltet ist.

Im Datenblatt ist sogar angegeben welcher Strom bei U_GS_th fließt:
ID = 25μA

von Forist (Gast)


Bewertung
0 lesenswert
nicht lesenswert
black cable schrieb:
> Schottkey Dioden

Der Namensgeber des Diodentyps hieß Walter Hans Schottky

black cable schrieb:
> Wiederstand
> ...
> Wiederstand
> ...
> Pull-Down Wiederstand: 10kOhm

black cable schrieb:
> Wiederstand

widerlich :-(

Hast du mal geprüft, ob du die FET (S1..S7 ?) richtig rum angeschlossen 
hast? Von welcher Seite bestückst du die - hoffentlich von unten?

von Forist (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Gerald K. schrieb:
> Im Datenblatt ist sogar angegeben welcher Strom bei U_GS_th fließt:
> ID = 25μA

Umgekehrt wird da ein Schuh draus.
V_GS(th) ist als diejenige Spannung definiert, die für einen I_D von 
25µA angelegt werden muss.

von black cable (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Forist schrieb:
> black cable schrieb:
>> ich habe aktuelle eine Platine mit einem selbstgemachten Layout
>
> Und wo ist der Schaltplan dazu

Auf dem PCB Layout sind alle Verbindungen der Platine ersichtlich, ich 
kann mein Schaltplan Layout gerade nicht finden, daher hab ich bei der 
einzelnen Schaltung mich auf einfache Mittel verlassen.

>> Schaltung_einzeln.png
> EINMAL bei der Wahl des Dateiformates nachzudenken, ist doch wohl nicht
> sooh schwierig. Keiner legt hier Wert auf die verlustfreie Reproduktion
> der Textur deiner Malstiftspitze.

Da muss ich dir leider recht geben, ein Profi macht das gewieß anders.
Ich hoffe jedoch das Ihr meine gedanken zu meinem Layout versteht.

>> Schaltung_Platine.png
> Da hast du die falsche Datei erwischt. Das ist ein Layout - dazu auch
> noch völlig vergittert.

ok, welches Format verlangst du den?

>> Dies funktioniert auch, wenn die zu
>> schaltende Spannungsquelle aus ist, jedoch raucht mir der Raspberry ab,
>> wenn ich eine Spannung schalte(Sekundärspannung).
>
> Dann solltest du vielleicht den KOMPLETTEN Schaltplan inklusive
> Anschluss an der RaspberryPi und Verdrahtung der Stromversorgung zeigen,
> oder meinst du, irgend jemand kann den aus deinem vergitterten Layout
> extrahieren.

okok, ich habs jetzt verstanden

> black cable schrieb:
>> lt. dem Datenblatt vom MosFET ist der Gate Treshold Voltage zwischen
>> 1.35 - 2.35V. Hab ich da was falschen verstanden?
>
> Ja, die U_GS_th sagt, ab wann der FET ANFÄNGT zu leiten, nicht wann er
> durchgeschaltet ist.

von Forist (Gast)


Bewertung
0 lesenswert
nicht lesenswert
black cable schrieb:
> Auf dem PCB Layout sind alle Verbindungen der Platine ersichtlich

Man darf schon anfangen zu suchen, was dein MOSFETs sind. Und von 
welcher Seite du die bestückst hast, ist völlig unklar.

> ok, welches Format verlangst du den?

Ich verlange gar nichts. Ich gebe dir nur den Tipp, deine Daten 
möglichst handlich und übersichtlich zu präsentieren. Der beim Hochladen 
von Dateianhängen gezeigte Hinweis verrät dir die Dateiformate. Für 
deine Malerei mit nicht klaren Linien empfiehlt sich JPG, für das Layout 
ist PNG ok. Das merkst du schon an der Dateigröße, wenn du es mal anders 
speicherst und dir die Bildqualität im Verhältnis zur Größe ansiehst.
Keiner, der vielleicht mit begrenztem Datenvolumen, Übertragungsrate 
oder schlechter Anbindung hier liest, hat Lust, unnötig Daten herunter 
zu laden.

Und je handlicher dein Anliegen rüber kommt, um so mehr Hilfe kannst du 
erwarten.

Dein Layout zeige einfach ohne die hier völlig nutzlosen Gitterlinien. 
Die interessieren im Zusammenhang mit deiner Fragestellung wirklich 
niemanden und sorgen nur für unnötiges Wirrwarr im Bild.

von Gerald K. (geku)


Bewertung
0 lesenswert
nicht lesenswert
black cable schrieb:
>> Ja, die U_GS_th sagt, ab wann der FET ANFÄNGT zu leiten, nicht wann er
>> durchgeschaltet ist.

Genau genommen kann bei U_GS_th = 0, abhängig von der 
Sperrschichttemperatur (Tj=125°C), schon ein Leckstrom von bis zu 150µA 
fließen (siehe Datenblatt). Es ist immer die Frage was man als leitend 
bezeichnet.

: Bearbeitet durch User
von Forist (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gerald K. schrieb:
> Genau genommen kann bei U_GS_th = 0, abhängig von der
> Sperrschichttemperatur (Tj=125°C), schon ein Leckstrom von bis zu 150µA
> fließen (siehe Datenblatt).

Genau genommen bezieht sich Datenblattangabe zur U_GS_th (1.35 - 2.35V) 
auf eine Temperatur von 25°C, wie dick und fett in der 
Tabelleüberschrift angegeben ("Static @ TJ = 25°C (unless otherwise 
specified)") und spezifiziert die Spannung bei einem I_D von 25µA.

von black cable (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Gerald K. schrieb:
> Forist schrieb:
>> Ja, die U_GS_th sagt, ab wann der FET ANFÄNGT zu leiten, nicht wann er
>> durchgeschaltet ist.
>
> Im Datenblatt ist sogar angegeben welcher Strom bei U_GS_th fließt:
> ID = 25μ

Gerald K. schrieb:
> black cable schrieb:
>> wo genau sollten die Schottkey Dioden verbaut werden?
>
> siehe Beilage
>
> black cable schrieb:
>> Ok, also die zwei Dioden sollten vermeiden das der Strom in den
>> Raspberry fließen soweit ich das verstanden hab?
>
> Die Durchlassspannung der Substratdioden des MC sollte höher sein als
> die der Schottkydioden ( z.B. MBR0520LT1G Very Low Forward Voltage
> (0.38 V Max @ 0.5 A, 25°C)

ok, meinst du damit das für die Dioden D1 und D2 (lt. deinem Schaltbild) 
z.B.: ein MBR0520LT1G verbaut werden sollte?
Und welche Funktion übernehmen diese zwei Dioden im Detail?

> black cable schrieb:
>> Ok, also die zwei Dioden sollten vermeiden das der Strom in den
>> Raspberry fließen soweit ich das verstanden hab?
>
> Dazu muss Durchlassspannung der Schottkydioden kleiner als die der
> Substratdioden sein.

Was genau ist den jetzt eine Substratdiode? Ist diese im Mosfet drinen?
Und ist meine Freilaufdiode für meinen Einsatzzweck die richtige?

> black cable schrieb:
>> Ich würde jedoch gerne ein PWM Signal darüber schalten, was müsste ich
>> dann noch beachten
>
> Dann muss der Vorwiderstand kleiner sein, um das Gate möglichst schnell
> umladen zu können. Die Frage ist ob der Ausgang des MC's ausreichend
> ist.

Was genau meinst du mit dem Ausgang des MC's?

> Der FET hat laut Datenblatt über 1nF Gatekapazität. Diese muss vom
> Ausgange über den 1k Widerstand umgeladen werden. Damit ist die
> Schaltzeit übern Daumen ~ 1nF x 1k > 1us !!!

Ok, der Vorwiedertand könnte ich jedoch falls nötig auf 100Ω reduzieren 
oder ist dieser dann zu klein für den Raspberry.

Danke und mfg
Martin

von Forist (Gast)


Bewertung
0 lesenswert
nicht lesenswert
black cable schrieb:
> Vorwiedertand

https://de.wikipedia.org/wiki/Elektrischer_Widerstand

Hast du inzwischen mal geprüft, ob der FET in der richtigen Orientierung 
eingelötet ist (Photo)?

von ACDC (Gast)


Bewertung
1 lesenswert
nicht lesenswert
MaWin schrieb:
> Ein IRLB8721 ist zwar LogicLevel nur für 4.5V spezifiziert,

Das liegt daran, dass Logic Level vor 30 jahren eben 5V waren und nicht 
3,3V
Und auch da hat schon nur gerade so funktioniert.

von black cable (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Forist schrieb:
> black cable schrieb:
>> Vorwiedertand
>
> https://de.wikipedia.org/wiki/Elektrischer_Widerstand
>
> Hast du inzwischen mal geprüft, ob der FET in der richtigen Orientierung
> eingelötet ist (Photo)?

ja, hab ich mehrfach geprüft. Da hab ich beim Layout der Platine einen 
Fehler gemacht und den S8 um 180° verkehrt gezeichnet, jedoch hab ich 
den richtig rum verlötet.

von Stefan H. (stefan_hb)


Bewertung
0 lesenswert
nicht lesenswert
Ich weiß zwar nicht wieso über das Gate ein so großer Impuls an den 
Raspi kommt und diesen zerstört (kann ja nur über die 
Gate-Drain-Kapazität kommen, sollte aber von der Freilaufdiode 
unterdrückt werden), aber die Beschaltung mit Schottky-Dioden als 
"stärkere" Substratdioden ist genauso ungünstig, weil der Impuls dann 
über D1 in die 3,3V-Versorgungsspannung gepumpt wird. Diese wird von 
einem Schaltregler erzeugt, welcher jedoch nur Strom liefern, aber nicht 
ableiten kann. Somit wird der Raspi wieder zerstört.
Besser wäre eine Suppressordiode am IO nach GND, die den Impuls 
ableitet. Ich habe jetzt nicht nach einer passenden gesucht, es müßte 
eine für 3,3V sein. Sind die Raspi-IOs eigentlich 5V-tolerant? 
5V-Suppressordioden gibt es auf jeden Fall.

von Gerald K. (geku)


Bewertung
0 lesenswert
nicht lesenswert
Stefan H. schrieb:
> Diese wird von einem Schaltregler erzeugt, welcher jedoch nur Strom
> liefern, aber nicht ableiten kann.

Das mag richtig sein, aber die Kondensatoren und dIe Last des Prozessor 
dämpfen die Spannungspitzen erheblich. Bei 24V über 1k sind es 20mA, die 
werden vom Prozessor übernommen, also das NG um diesen Betrag entlastet. 
Es braucht kein Strom ins NG abfließen.

Die internen Schutzdioden im Prozessor machen nichts anderes, schaffen 
aber bei weitem den Strom nicht. Diesen übernehmen dann die externen 
Schottkydioden.

: Bearbeitet durch User
von Uwe D. (monkye)


Bewertung
0 lesenswert
nicht lesenswert
Stefan H. schrieb:
> eine für 3,3V sein. Sind die Raspi-IOs eigentlich 5V-tolerant?
NEIN, auf keinen Fall.

Hast Du mal geprüft ob einer der FET's "ein Ding weg hat"? Was auch sein 
kann: Eine Brücke zwischen der 24V Schiene und einem der 
RasPi-Anschlüsse. (Stichwort: Durchmessen der Platine)

von Uwe D. (monkye)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
black cable schrieb:
> Forist schrieb:
>> black cable schrieb:
>> Hast du inzwischen mal geprüft, ob der FET in der richtigen Orientierung
>> eingelötet ist (Photo)?
>
> ja, hab ich mehrfach geprüft. Da hab ich beim Layout der Platine einen
> Fehler gemacht und den S8 um 180° verkehrt gezeichnet, jedoch hab ich
> den richtig rum verlötet.

Hast Du für den RasPi auf der GPIO_OUT Seite Lötstifte und auch etwas 
drauf? Vielleicht bin ich ja zu blind, aber für mich sieht das komisch 
aus mit den zwei Steckerleisten - weil dort permanent die Gefahr besteht 
das ein Pin das falsche Signal bekommt. (3,3V und 5V liegen einander 
gegenüber)

NACHTRAG: Bild angehangen. Der Stift 1 ist bei beiden Leisten links!

: Bearbeitet durch User
von drm (Gast)


Bewertung
0 lesenswert
nicht lesenswert
1. ein GPIO vom Raspberry darf nur mit max. 5mA belastet werden, sonst 
kaputt
2. ein GPIO vom Raspberry kann nur 3,3V liefern, eine höhere 
Eingangsspannung als 4,2V -> kaputt ( auch bei nur kurzen Pulsen )
3. ein GPIO eines R-Pi kann man nur selten direkt zum Treiben eines FETs 
benutzen, ein OpAmp als Impendanzwandler dazwischenschalten ist Pflicht. 
Spannungserhöhung auf 5V und Stromausgang von 125mA ist damit leicht 
möglich und man kann dann N-FETs schalten ( Bezug zu Gnd ). P-FETs sind 
eine andere Geschichte/Beschaltung.
4. die Grenzspannung am Gate "FET zu/offen" ist kein Durchschalten des 
FETs.
5. die Gatespannung am FET muss die Spannung erreichen an dem der 
Durchgangswiderstand Drain-Source im FET am niedrigsten ist wenn man den 
FET als Schalter verwenden will ( Daumenwert: maximale Gatespannung/2 )

von drm (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
RTF datenblatt

von Stefan H. (stefan_hb)


Bewertung
1 lesenswert
nicht lesenswert
drm schrieb:
> ein OpAmp als Impendanzwandler dazwischenschalten

Das würde ich nur machen, wenn ich einen OpAmp aus der Bastelkiste 
unbedingt "verbasteln" will, die meisten können auch keine hohen Ströme 
liefern bzw. fangen bei Überlastung an zu schwingen. Für diesen Zweck 
gibt es Gate-Treiber-IC's, und die sind auch nicht viel teurer. Nicht zu 
vergessen ist daß der Gate-Treiber bei PWM-Ansteuerung die gesamte 
Steuerleistung in Wärme umwandelt, weswegen viele Treiber-IC's ein 
Wärmeableitpad an der Unterseite haben. Die Verlustleistung ist dann

P=U*Qg*f

wobei U die Treiberspannung, Qg die Gateladung und f die PWM-Frequenz 
ist.

von Gerald K. (geku)


Bewertung
0 lesenswert
nicht lesenswert
drm schrieb:
> RTF datenblatt

Ist eine "Ultra-Low Gate Impedance" wirklich eine "Benefit"?

Die Ursache ist die große Gatefläche und damit die große Kapazität.

von drm (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>Ist eine "Ultra-Low Gate Impedance" wirklich eine "Benefit"?
der TO wäre schon froh wenn er seinen R-Pi nicht killt und der FET ganz 
durchschaltet, alles andere ist erst mal egal

von Uwe D. (monkye)


Bewertung
0 lesenswert
nicht lesenswert
drm schrieb:
>>Ist eine "Ultra-Low Gate Impedance" wirklich eine "Benefit"?
> der TO wäre schon froh wenn er seinen R-Pi nicht killt und der FET ganz
> durchschaltet, alles andere ist erst mal egal

Der FET ist doch nur dann ein Problem, wenn die Peaks über 30V liegen. 
Aber beim Einschalten ohne aktive Relais?

Also ich glaube das der TO hat entweder die Platine noch nicht 
vollständig geprüft oder einen Dreher bei den Steckern...

von Stefan ⛄ F. (stefanus)


Bewertung
1 lesenswert
nicht lesenswert
Zwischen Raspi und Gate würde ich 330Ω Widerstände schalten, damit 
dessen Ausgänge durch das Umladen der Gate-Kapazitäten nicht überlastet 
werden.

Lass mich raten: Der Raspi geht erst kaputt, wenn viele Ausgänge 
gleichzeitig geschaltet werden, richtig?

Man könnte das "schalten" ja erstmal ganz ohne Last testen und dabei die 
Spannungen an den GPIO Pins mit einem Oszilloskop prüfen. Wenn du den 
trigger auf steigende Flanke 4V einstellst, wird das Oszilloskop 
wunderbare Schnappschüsse von der Überspannung machen, falls vorhanden.

Danach nochmal mit einer einfachen kleinen ohmschen Last testen (z.B. 
LEDS mit Vorwiderstand).

Danach ist man schon viel schlauer.

von drm (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
>Zwischen Raspi und Gate würde ich 330Ω Widerstände schalten, damit
der FET auch wirklich langsam schaltet und an der Verlustleistung stirbt

>mit einer einfachen kleinen ohmschen Last testen
ob es bei einer induktiven Last keine Probleme gibt. Super Plan.

>Danach ist man schon viel schlauer.
Nein

von black cable (Gast)


Bewertung
0 lesenswert
nicht lesenswert
drm schrieb:
>> Zwischen Raspi und Gate würde ich 330Ω Widerstände schalten,
> damit
>> der FET auch wirklich langsam schaltet und an der Verlustleistung stirbt
>
>> mit einer einfachen kleinen ohmschen Last testen
>> ob es bei einer induktiven Last keine Probleme gibt. Super Plan.
>
>> Danach ist man schon viel schlauer.
>> Nein

Hatte leider viel um die Ohren und habs jetzt verschwitz euch zu 
antworten. Ohne Last(ohne Spule) schaltete das MosFET wunderbar, die 
Platine hab ich durchgemoßen, selbstverständlich auch die Mosfets, war 
aber alles nach meinem Verständnis OK. Die Pins an dem Raspberry Stecker 
an der Platine sind alle ok und haben auch keine Verbindung zueinander. 
Bei einem Test konnte ich mit einem 1kOhm Wiederstand am Raspberry GPio 
Pin, sowie auf GND die Spule wunderbar durchschalten. Ich denke mal das 
ich die Verbindung vom RPI-GND zur Platine herausnehme und diese mit 
einer Verbindung mit einem 1kOhm Wiederstand ersetzte. Danach kann ich 
dann mal testen ob PWM klappt und wie heiß die MosFETs werden, im 
schlimmsten Fall werd ich eben nur klüger;)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.