Forum: Analoge Elektronik und Schaltungstechnik Panasonic ADP1171 Drucksensor reagiert nicht


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von M. G. (ixil96)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte den ADP1171 für eine Druckmessung verwenden und bekomme aber 
zwischen den Pins +Output und -Output keine Spannungsänderung wenn ich 
den Druck z.B. durch reinpusten in einen angeschlossenen Silikonschlauch 
erhöhe.

Die Pins 1 und 6 der Brücke habe ich wie in der Abbildung gebrückt.

Kann mir da jemand weiter helfen?

von Werner H. (werner45)


Bewertung
0 lesenswert
nicht lesenswert
Das liegt daran, daß der Sensor für 500 kPa (5 bar) ausgelegt ist, Du 
muß so stark reinblasen, daß der Silikonschlauch platzt...

von Günni (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wenn ich mich richtig erinnere ist der Sensor für 5 Atmosphären Druck 
als Reifendrucksensor ausgelegt. Eventuell ist Pusten einfach nur zu 
schwach ??? (Wer kann schon einen Reifen aufpusten?)

von Gerald K. (geku)


Bewertung
0 lesenswert
nicht lesenswert
Günni schrieb:
> Wer kann schon einen Reifen aufpusten?

Ich glaub da ist es eher umgekehrt,

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Günni schrieb:
> Wer kann schon einen Reifen aufpusten?

Das Michelin-Männchen!

von M. G. (ixil96)


Bewertung
0 lesenswert
nicht lesenswert
Ja mir ist schon klar, dass ich hier keinen Überdruck von 1Bar durch 
reinblasen erzeugen kann, aber dass sich überhaupt nichts tut ist 
merkwürdig.

Mittlerweilen habe ich meinen kleinen Airbrushkompressor angeschlossen 
und den Druck auf 2Bar erhöht. Aber hier tut sich auch nichts.

Messe ich die Spannung zwischen Pin 3 und (1,6) kann ich keine 
Spannungsdifferenz mit zunehmenden Druck feststellen.

Messe ich die Spannung zwischen Pin (1,6) gegen GND, dann habe ich hier 
2,5V was ja passen würde. Erhöhe ich den Druck, dann ändert sich hier 
auch der Spannungsabfall gegen GND.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
1 lesenswert
nicht lesenswert
M. G. schrieb:
> Messe ich die Spannung zwischen Pin (1,6) gegen GND

Dann miss doch mal zwischen 3 und GND und appliziere Druck.

von M. G. (ixil96)


Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> M. G. schrieb:
>> Messe ich die Spannung zwischen Pin (1,6) gegen GND
>
> Dann miss doch mal zwischen 3 und GND und appliziere Druck.

Zwischen Pin3 und GND kann ich nichts messen (wie wenn der Pin floaten 
würde)
Hab den Sensor auch bereits ausgetauscht...

von hinz (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Pins falsch zugeordnet?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
1 lesenswert
nicht lesenswert
hinz schrieb:
> Pins falsch zugeordnet?

Sieht mir auch so aus. Der einzige Pin ohne Verbindung ist Pin 4 und 
wenn man beide Pinreihen vertauscht (3 mit 4 tauscht), passiert genau 
das, was der TE misst.
Beachte: die Pinbelegung ist bei ADP4xxx genau spiegelbildlich zu 
ADP1xxx.

: Bearbeitet durch User
von M. G. (ixil96)


Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> hinz schrieb:
>> Pins falsch zugeordnet?
>
> Sieht mir auch so aus. Der einzige Pin ohne Verbindung ist Pin 4 und
> wenn man beide Pinreihen vertauscht (3 mit 4 tauscht), passiert genau
> das, was der TE misst.
> Beachte: die Pinbelegung ist bei ADP4xxx genau spiegelbildlich zu
> ADP1xxx.

Ja, genau so ist es auch!
Danke für eure Hilfe :-)

Super gemacht PANASONIC - Wäre gut wenn da mal jemand das Datenblatt 
berichtigen würde!

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
1 lesenswert
nicht lesenswert
M. G. schrieb:
> Wäre gut wenn da mal jemand das Datenblatt
> berichtigen würde!

Wieso? Ich habe nach Datenblatt die Belegung rausgefunden. Scheint also 
alles richtig zu sein - und ich habe deine Schaltung nicht gesehen.

von M. G. (ixil96)


Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> M. G. schrieb:
>> Wäre gut wenn da mal jemand das Datenblatt
>> berichtigen würde!
>
> Wieso? Ich habe nach Datenblatt die Belegung rausgefunden. Scheint also
> alles richtig zu sein - und ich habe deine Schaltung nicht gesehen.

Dann schau noch mal auf den ADP11xx (PF Typ). Da ist +Output auf Pin3 
und -Output auf Pin1 und Pin6

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.