Forum: Mikrocontroller und Digitale Elektronik H-Brücken mit MC33887


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Michi H. (rovbau)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen
Ich verwende den MC33887 wie in der Applikation im Foto.

-Steuerspannung 5Volt/Gnd für IN1, IN2, D1

-V+ 12Volt

-RLast Halogenlampe 1.5A at 100% Einschaltzeit

-PWM Signal an D2

Die Schaltung funktioniert ca. 2min danach nur noch in eine "Richtung". 
In die Gegenrichung fliesst der ganze Strom direkt über den IC nach GND 
ab.
Es scheint als ob die "unteren" FET defekt und im leitenden Zustand 
sind.

Kann jemand erkennen was ich hier falsch mache?

PWM an D2 lässt die Brücke in den high-impedance modus wechseln. Bei 
rein ohmischer Last sollte dies ja kein problem darstellen?!

von MaWin (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Michi H. schrieb:
> Kann jemand erkennen was ich hier falsch mache?

Eine 12V wohl 20W Halogenlampe hat einen Kaltwiderstand von 0.6 Ohm, im 
Einschaltmoment fliessen 20A. Der Chip hat zwar eine Strombegrenzung bei 
5.2A, aber nur durch PWM, es fliesst also bis zur nächsten Flanke 
trotzdem zu hoher Strom. Die Strombegrenzung funktioniert nur bei 
induktiven Lasten (Motor) nicht bei deiner Lampe.
Zudem hat er eine Kurzschlusserkennung bei 11A, aber wenn der Strom auf 
11A begrenzt wird, steigt die Hitze im Ausgangstransistor. Dagegen hat 
der Chip einen Übertemperaturschutz, aber wenn die Uberlastung zu 
schnell erfolgt, muss die Wärme etst vom Ausgangstransistor zum Sensor 
kommen, bis dahin hat es den MOSFET wohl schon gebraten.

Du brauchst einen stärkeren Chip, einen Vorwiderstand vor der Lampe, 
oder eine Drossel vor der Lampe die zu schnellen Stromanstieg verhindert 
oder ein Netzteil das nur 5A schafft ohne zu grosse Ausgangselkos.

von Michi H. (rovbau)


Bewertung
0 lesenswert
nicht lesenswert
MaWin

Danke für die Hinweise. Kaltwiderstand macht Sinn, das sehe ich sogar am 
Analogen Amp-Meter.

Leider hats die IC auch mit einem DC Motor verbraten, hier vermutlich 
wegen fehlenden Schutzdioden?! und/oder Strom da der Motor auch 3-4 Amp 
aufnimmt.

Gar nicht so einfach einen IC zu finden der 3-5A PWM an 12Volt kann.
L62xx sind ja auch nur bis 2-3 Amp

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.