Forum: PC-Programmierung Portweiterleitung auf Raspberry PI mit Fritzbox 7590 funktioniert nicht


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Mike (Gast)


Lesenswert?

Hallo zusammen!

Ich habe mir schon echt viel gegoogelt, komme aber leider nicht weiter. 
Kann mir auch nicht erklären woran es liegt und bitte daher euch um 
kurzen Input.

Ich möchte einen Raspberry PI ans Internet hängen. Erstmal nur für SSH.
Standardbenutzer ist deaktiviert, Neuer User mit sicherem Passwort ist 
erstellt und wird für SSH benutzt. Port für SSH ist auch geändert.
Lokal funktioniert das auch perfekt auf dem neuen Port.

Am Router (Billig-Router von "PYUR") in der einen Wohnung ist es kein 
Problem und ich komme mit Portfreigabe von extern drauf.

In der anderen Wohnung (mit Fritzbox 7590) funktioniert es nicht. Ich 
habe eine Portfreigabe erstellt und aktiviert. Diese wird mir bei 
"Diagnose" auch angezeigt. IPv4 und IPv6, beides erstellt.
Trotzdem komme ich von extern nicht auf den Raspberry Pi. Auch 
onlinedienste wie canyouseeme.org finden keinen offenen Port.

Was übersehe ich? Muss man irgendwo noch eine zusätzliche Einstellung 
aktivieren?

Viele Grüße,
Mike

von Hmmm (Gast)


Lesenswert?

Mike schrieb:
> Was übersehe ich?

Evtl. hast Du in der einen Wohnung kein vollwertiges IPv4, sondern 
Carrier Grade NAT. Gerade bei Kabelanbietern ist das sehr verbreitet.

von Mike (Gast)


Lesenswert?

Hmmm schrieb:
> Mike schrieb:
>> Was übersehe ich?
>
> Evtl. hast Du in der einen Wohnung kein vollwertiges IPv4, sondern
> Carrier Grade NAT. Gerade bei Kabelanbietern ist das sehr verbreitet.

Wie erkenne ich das?
Die Wohnung wo es geht ist Kabel.
Die Wohnung wo es nicht geht ist DSL von 1&1.

Viele Grüße,
Mike

von Mike (Gast)


Lesenswert?

Aha. Scheint der "DS-Lite-Tunnel" zu sein?
Danke für nix, 1&1. Aber dann weiss ich wenigstens, warum es nicht geht 
und an welcher Stelle ich weiterprobiere.

Danke, Hmmm, für den Hinweis! :-)

von 100Ω W. (tr0ll) Benutzerseite


Lesenswert?

Mike schrieb:
> Danke für nix,

Warum?
Freigaben mit IPv6 sollten doch gehen?

von Hmmm (Gast)


Lesenswert?

Mike schrieb:
> Wie erkenne ich das?

Du kannst z.B. in der Routeroberfläche nachgucken, welche IPv4-Adresse 
er zugeteilt bekommen hat, und mit der vergleichen, die Dienste wie 
wieistmeineip.de anzeigen.

Wenn die unterschiedlich sind, ist NAT im Spiel.

Mike schrieb:
> Aha. Scheint der "DS-Lite-Tunnel" zu sein?
> Danke für nix, 1&1.

Bisher habe ich bei 1&1 nur echtes IPv4 von der Telekom gesehen, aber 
evtl. kaufen die auch woanders ein.

Hast Du auch keinen Port genommen, der gerne wegen Missbrauchs gesperrt 
wird, z.B. 139 oder 445?

von Mike (Gast)


Lesenswert?

Hmmm schrieb:
> Hast Du auch keinen Port genommen, der gerne wegen Missbrauchs gesperrt
> wird, z.B. 139 oder 445?

Ja :-)

Hmmm schrieb:
> Du kannst z.B. in der Routeroberfläche nachgucken, welche IPv4-Adresse
> er zugeteilt bekommen hat, und mit der vergleichen, die Dienste wie
> wieistmeineip.de anzeigen.

Er bekommt gar keine IPv4 Adresse?!

100Ω W. schrieb:
> Freigaben mit IPv6 sollten doch gehen?

Schau ich an, danke für den Tipp!

Mike

von Hmmm (Gast)


Lesenswert?

Mike schrieb:
> Er bekommt gar keine IPv4 Adresse?!

Bleibt das auch nach einem Neustart so?

Auf den ersten Blick sieht das nach einem Fehler aus, aber wenn das eine 
für 1&1 angepasste Fritzbox ist, kann das auch eine NAT-Variante sein.

von Marco H. (damarco)


Lesenswert?

https://de.wikipedia.org/wiki/IGD-Protokoll

Sollte die FRITZ!Box können.... ob es die Gegenseite auch kann???

: Bearbeitet durch User
von (prx) A. K. (prx)


Lesenswert?

Marco H. schrieb:
> Sollte die FRITZ!Box können.... ob es die Gegenseite auch kann???

Fritz kann es, aber das reicht natürlich nicht. Vodafone Kabel aus dem 
KabelBW/Unitymedia-Erbe kann es beispielsweise nicht, und daher geht 
nix.

Das betrifft natürlich keine alten Kabelanschlüsse mit reinem IPv4.

: Bearbeitet durch User
von (prx) A. K. (prx)


Angehängte Dateien:

Lesenswert?

Hmmm schrieb:
> Bleibt das auch nach einem Neustart so?

Wenn man auf die Einstiegsseite vom Fritz schaut, steht es direkt da.

von (prx) A. K. (prx)


Lesenswert?

Wenn man nicht per IPv6 arbeiten kann/will, weil man beispielsweise im 
Mobilfunknetz in IPv4 festhängt, kann man sich einen IPv4 Port mieten, 
der an IPv6 weiterleitet:
https://www.feste-ip.net/dslite-ipv6-portmapper/allgemeine-informationen/

Alternativ gibts bei IONOS einen VServer für 1€/Monat, mit dem man so 
etwas per TCP-Forwarder selber stricken kann. Der ist zwar mit 0,5 GB 
RAM und 20 GB Disk nicht doll ausgestattet, aber dafür reicht das ja.

: Bearbeitet durch User
von Outi O. (outlaw)


Lesenswert?

Du kannst bei 1&1 relativ einfach von DS-Lite auf DS umstellen lassen.
Ich würde das im offiziellen Forum (wie viele andere auch) per Beitrag 
mit Option der Weiterleitung an den Support machen.

Oder Du rufst halt bei denen an.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.