Forum: Platinen EAGLE: symbol mit Cut/Paste kopieren


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Christoph K. (chriskuku)


Angehängte Dateien:

Lesenswert?

Bei diesem gelegentlichen Arbeiten mit EAGLE vergißt man immer wieder, 
wie man es mal erfolgreich gemacht hat. So geht es mir im Moment.
Ich möchte einen Sicherungshalter, der zwei Pads für die Halteklammern 
hat, so ändern, daß beide PADs mit einem Potential Verbindung haben, 
sonst bekomme ich immer DRC-Fehler und kann auch jeweils an den zweiten 
PAD beim Routen nicht andocken.

Jetzt habe ich in meiner eigenen Bibliothek ein neues DEVICE kreiert und 
wollte dem Device mit COPY/PASTE, genauso, wie ich es beim Footprint 
gemacht habe, die Symbolzeichnung zuordnen. Habe also über das 
Symbol-Icon im Device-Editor das Symbol aufgerufen, GROUP ALL gemacht 
und COPY.

Will ich das jetzt in die Symbolzeichnung im Device-Editor einfügen, 
bekomme ich das beigefügte Bild. (EAGLE 9.6.2, macOS Big Sur).

Weiß jemand Rat?

von Zeno (Gast)


Lesenswert?

Laut Fehlermeldung kopierst Du ja auch ein Device. Du mußt im 
Symboleditor das vorhandene Symbol öffnen und gruppieren. Das kannst Du 
dann kopieren. Danach legst Du im Symboleditor ein neues Symbol an und 
fügst das Kopierte ein.

Christoph K. schrieb:
> der zwei Pads für die Halteklammern
> hat, so ändern, daß beide PADs mit einem Potential Verbindung haben,
> sonst bekomme ich immer DRC-Fehler
Verstehe ich nicht. Wieso muß das mit einem Potential verbunden sein? Du 
fügst eine Sicherung im Schaltplan ein und selbige hat halt verschiedene 
Footprints u.a. auch Deinen. Der DRC-Fehler muß eine andere Ursache 
haben. Was sagt er denn?

von Christoph K. (chriskuku)


Lesenswert?

Zeno schrieb:
> Laut Fehlermeldung kopierst Du ja auch ein Device. Du mußt im
> Symboleditor das vorhandene Symbol öffnen und gruppieren. Das kannst Du
> dann kopieren. Danach legst Du im Symboleditor ein neues Symbol an und
> fügst das Kopierte ein.
>

Das mache ich ja. Ich habe das DEVICE im Bibliothekseditor geöffnet.
Die Symbolfläche ist leer. Jetzt habe ich oben ja drei Icons:
Device, Footprint, Symbol.
Wie kriege ich jetzt das Symbol in das Device?


Ach, ich glaube, ich hab's gefunden. Ich muß auf ADD Part links klicken.


> Christoph K. schrieb:
>> der zwei Pads für die Halteklammern
>> hat, so ändern, daß beide PADs mit einem Potential Verbindung haben,
>> sonst bekomme ich immer DRC-Fehler
> Verstehe ich nicht. Wieso muß das mit einem Potential verbunden sein? Du
> fügst eine Sicherung im Schaltplan ein und selbige hat halt verschiedene
> Footprints u.a. auch Deinen. Der DRC-Fehler muß eine andere Ursache
> haben. Was sagt er denn?

Wenn ich für die Netzklasse "MAINS" z.B. 200mil angebe, dann meckert DRC 
(und wird auch sofort rot schraffiert angezeigt), daß die zwei Pads zu 
nah aneinander seien, weil das eine PAD potentiallos ist. Und auch beim 
Routen wird nicht an das "floatende" PAD angedockt. Blöd konstruiert, 
dieser Si-Halter, weshalb ich den Footprint ändern wollte.

: Bearbeitet durch User
von Wolfgang (Gast)


Lesenswert?

Christoph K. schrieb:
> Wie kriege ich jetzt das Symbol in das Device?

Mit Add Part

von Christoph K. (chriskuku)


Lesenswert?

Wolfgang schrieb:
> Christoph K. schrieb:
>> Wie kriege ich jetzt das Symbol in das Device?
>
> Mit Add Part

Ja, hatte ich ja selbst schon herausgefunden und auch geschrieben. Danke 
trotzdem.

von michael_ (Gast)


Lesenswert?

Christoph K. schrieb:
> und kann auch jeweils an den zweiten
> PAD beim Routen nicht andocken.

Es gibt da eine definition für die Pad.
Irgendwas mit +?, müßte nachsehen.
Dann sind die Pad gleichwertig.
Bei der Erstellung natürlich noch richtig zuweisen.
Schau mal ins Tutorial.

Mindestens bei meiner alten Version ist das so.

von michael_ (Gast)


Angehängte Dateien:

Lesenswert?

Ich weiß aber nicht, ob es dein Problem ist.
Evtl. müssen die im Biblio-Layout noch verbunden sen.

von Christoph K. (chriskuku)


Lesenswert?

michael_ schrieb:
> Ich weiß aber nicht, ob es dein Problem ist.
> Evtl. müssen die im Biblio-Layout noch verbunden sen.

Danke. Das war's. Man muß dann beim Connect des jeweiligen Signals die 
PADs mit Klick-Shift auswählen, so daß beide PADs das jeweilige Signal 
zugewiesen bekommen.

von Christoph K. (chriskuku)


Lesenswert?

Es stellte sich heraus, daß man ein Signal beim Connect mehreren PADs 
zuweisen kann. Also war die Einführung der Spezial-Signalnamen (mit dem 
@) nicht nötig.

: Bearbeitet durch User
von Falk B. (falk)


Lesenswert?

Christoph K. schrieb:
> Es stellte sich heraus, daß man ein Signal beim Connect mehreren PADs
> zuweisen kann.

Nennt sich append. RTFM.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.