mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500: Was für einen RS232 > USB Adapter??


Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

also wir haben uns im Klassenverband das STK500 gekauft, damit wir das
in der Schule gelernte zu hause vertiefen können.

Leider haben die meisten von uns keine RS232 Schnittstelle mehr an
ihren Laptops(ich auch nicht).

Jetzt haben einige das schon mit diesen günstigen USB>RS232 Adaptern
versucht doch leider funktionieren die nicht.

Ich für meinen Teil hätte auch gerne eins, was ich in meinem Koffer(in
dem ich alles verbaut habe) integrieren könnte.

Naja da ich noch Schüler bin sollte das auch nicht so viel kosten. Also
schmerzgrenze sag ich mal 30€.

MFG, Hannes

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich kenne einen, der sicher funktioniert, ist allerdings von
Conrad, daher mit 40€ recht teuer: 982417 - 62
Ansonsten solltest du dich vlt. mal bei FTDI umsehn. Da gibt's ICs für
genau diesen Zweck. Sowas kannste dann auch besser irgendwo verbauen.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also bei mir werkelt "USB SERIELL" von Reichelt (9,95 Euro) am STK500
ohne Probleme. Ob das "USB2 SERIELL" (11,90) auch funktioniert,
entzieht sich meiner Kenntnis.

...

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gibts noch mehr vorschläge?

MFG, Frank

Autor: Sonic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keinen PROLIFIC USB1.1 nehmen, der USB 2.0 funktioniert eher (ca. 13€
bei Reichelt)

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was passiert beim Prolific USB 1,1?

Autor: Sonic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Seltsamerweise TX vom PC aus möglich (Laptop geht), RX geht nix! Keine
Ahnung (oder Lust nachzuforschen) warum.

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einige Adapter haben noch 'versteckte' Einstellungen: im
Gerätemanager, Eigenschaften der ser. Schnitttstelle, dann im Tab
'Erweitert'. Vielleicht lässt sich da bei den nicht funktionierenden
Adaptern was verbessern?
Habe hier auch die Reichelt Adapter und die funktionieren.

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du mußt noch das SP2 zum AVRStudio installieren, dann gehts.

Mehr als 10,-€ würde ich nicht ausgeben.

Ich hab den von Reichelt und den von K&M, beide gehen wie dumm.


Peter

Autor: Ulrich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe auch den von Reichelt und das funtzt mit avrstudio und avrdude
usw. problemlos

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Funktionieren die auch mit dem CodeVisionAVR?

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
up

Autor: >Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
up

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einfache Lösung:

Geh' zum Blödmarkt, frag' den Verkäufer. Dann kauf das Ding unter
Vorbehalt (mit schriftlich zugesicherter Geld-zurück-Garantie). Dann
probiere es aus und wenn es nicht geht, dann bring es zurück und lass
Dir Dein Geld wiedergeben.

Der von mir genannte Adapter funktioniert mit AVR-Studio, mit dem
Terminalprogramm von WIN98SE und mit (unter VB6) selbstgeschriebenen
Programmen. Ob er mit Codevision funktioniert, weiß ich nicht, denn ich
nutze Codevision nicht und werde es auch nicht wegen Deiner Frage
installieren und ausprobieren.

...

Autor: LUXI (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin, also ich hab den "USB2 SERIELL" von Reichelt der Funktioniert bei 
mir nicht.

Autor: Stufff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gibt es zufällig jemand, bei dem der "USB2 SERIELL" von Reichelt 
funktioniert? Da hier geschrieben wird er geht nicht und in einem 
anderen Thread steht, er würde funktionieren.

Autor: armin_r (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bei mir funktioniert er.
Hab inzwischen zwei Adapter von Reichelt aber komplett unterschiedliche 
Modelle. Beide haben den proflific chipsatz, der garantiert geht (genau 
wie der ftdi).

Mein erster billig Adapter von ebay hat auch nicht gewollt (obwohl 
proflic chipsatz). Also besser keinen 2€ Adapter holen, sonst zahlt man 
u.U. zweimal.

Autor: Jürgen R. (hobbyloeter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Also bei mir werkelt "USB SERIELL" von Reichelt (9,95 Euro)

Bei mir leider nicht. Hab mir den gerade vor kurzem bestellt.
So langsam hab ich von diesem sch*** 'Profilic' die Schnauze voll! Wenn 
das überhaupt was kann, könnte mir dann mal jemand sagen, was genau? 
Also das STK500 mit'm PC verbinden schonmal net...

Autor: Micha68 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Pearl USB -> 2x seriell funktioniert. Somit hat man auch gleich die 
zusätzliche serielle Schnittstelle des STK500 am PC :)

http://www.pearl.de/a-PE3740-1414.shtml

gruss,
Micha68

Autor: pillepalle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin

hab grad mal mein AVR 500 mit dem USB-Adapter von Profilic getestet
geht mit AVR-Studio 4.15 einwandfrei , keine Probleme.

Autor: pillepalle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so sieht es mit dem Testprg. von LibUSB aus :
http://libusb-win32.sourceforge.net/


bus-0/\\.\libusb0-0004--0x067b-0x2303     067B/2303
- Manufacturer : Prolific Technology Inc.
- Product      : USB-Serial Controller
  wTotalLength:         39
  bNumInterfaces:       1
  bConfigurationValue:  1
  iConfiguration:       0
  bmAttributes:         a0h
  MaxPower:             50
    bInterfaceNumber:   0
    bAlternateSetting:  0
    bNumEndpoints:      3
    bInterfaceClass:    255
    bInterfaceSubClass: 0
    bInterfaceProtocol: 0
    iInterface:         0
      bEndpointAddress: 81h
      bmAttributes:     03h
      wMaxPacketSize:   10
      bInterval:        1
      bRefresh:         0
      bSynchAddress:    0
      bEndpointAddress: 02h
      bmAttributes:     02h
      wMaxPacketSize:   64
      bInterval:        0
      bRefresh:         0
      bSynchAddress:    0
      bEndpointAddress: 83h
      bmAttributes:     02h
      wMaxPacketSize:   64
      bInterval:        0
      bRefresh:         0
      bSynchAddress:    0

Autor: Jürgen R. (hobbyloeter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> geht mit AVR-Studio 4.15 einwandfrei , keine Probleme.

Wie hast Du das genau gemacht? Mußtest Du noch was bei den 
COM-Einstellungen in der Systemsteuerung verändern, oder geht das 
einfach so?
Also ich verwende Version 4.12 vom AVR-Studio und es gibt nur Frust...
Hab mir jetz mal noch den AVRISP mkII besorgt. Da brauch ich das ganze 
Adapter-Gerümpel nicht.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Gibt es zufällig jemand, bei dem der "USB2 SERIELL" von Reichelt
>funktioniert? Da hier geschrieben wird er geht nicht und in einem
>anderen Thread steht, er würde funktionieren.

Bei mir funktioniert er. Ist ein FT232RL drin. Treiber gibts aktuell bei 
ftdichip.com

Autor: Jürgen R. (hobbyloeter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Bei mir funktioniert er. Ist ein FT232RL drin. Treiber gibts aktuell bei
> ftdichip.com

Wann hat Du den denn gekauft? Hab nämlich schon hier gelesen, daß es da 
anscheinend Unterschiede gibt. Vielleicht hat 'Tante Angelika' da mal 
was umgestellt ?!?!
Bei mir ist ein Chip von Prolific drin.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der FT232-Wandler ist dunkelbraun transparent und leuchtet blau. Die 
USB-Strippe ist abnehmbar, so daß der Wandler direkt an gut zugängliche 
USB-Buchsen gesteckt werden kann. Gekauft vor etwa 1/2 Jahr.

Autor: Compiler Error (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese Adapter benutze ich schon seit vielen Jahren problemlos.
Klappkomputer-> PCMCIA USB2.0-> 4fach USB-HUB-> 2 USB-Seriell Konverter.
Nur die COM Ports muß man sich in der Gerätesteuerung noch passend 
einstellen. OS W2K.
Ansonsten einschalten und vergessen. freu

Autor: Jürgen R. (hobbyloeter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> 2 USB-Seriell Konverter.
Warum 2 konverter für EIN STK500?
Oder muß man "RS232 CTRL" UND "RS232 SPARE" belegen?

> Nur die COM Ports muß man sich in der Gerätesteuerung noch passend
> einstellen.
Ja, wie und wo denn? Ich verwende XP Home.

Würde mich freuen, wenn mir jemand hierüber Auskunft geben könnte!

Autor: bluppdidupp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich benutze das Kabel von pollin (721 034) ohne Probleme

Autor: Compiler Error (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Warum 2 konverter für EIN STK500?
Einer zum Programmieren und einer für die Ser. Schnittstelle zur 
allgemeinen Kommunikation.
Die eingebaute Ser. im Klappkomp. habe ich irgendwann geschrottet.

COM einstellen:
Arbeitsplatz > rechte Mtaste > Eigenschaften > Hardware > Geräte-Manager 
> COM und LPT
zumindest bei W2K.

Autor: neuer Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Warum 2 konverter für EIN STK500?
>Einer zum Programmieren und einer für die
>Ser. Schnittstelle zur allgemeinen Kommunikation.

Mit Bootloader aber nicht notwendig.

Gruß

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen R. wrote:
>> Also bei mir werkelt "USB SERIELL" von Reichelt (9,95 Euro)
>
> Bei mir leider nicht. Hab mir den gerade vor kurzem bestellt.
> So langsam hab ich von diesem sch*** 'Profilic' die Schnauze voll!

Solange Du nicht sagst, was nicht geht oder welche Fehlermeldung kommt, 
kann Dir keiner helfen.

Bei mir laufen jedenfalls alle USB-RS232 wie dumm.
Was steht denn im Gerätemanager unter COMs?

COM erstmal nur 1..9 benutzen, ab 10 ist ne spezielle Syntax nötig.

Und natürlich die Anwendungen erst starten, wenn der USB-RS232 schon 
steckt, sonst kann die ihn natürlich nicht finden.


Peter

Autor: Jürgen R. (hobbyloeter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Solange Du nicht sagst, was nicht geht oder welche Fehlermeldung kommt,
> kann Dir keiner helfen.

Das isses ja genau: Es kommt keine Fehlermeldung, sonst hätt ich ja 
wenigstens einen gewissen Anhaltspunkt für die Fehlersuche.
Also, hier nochmal genauer: Der Prolific-Adapter scheint vordergründig 
zu funktionieren. Ich hab den Treiber istalliert. Wenn ich ihn ins USB 
einstecke, wird er im Geräte-Manager als COM5 geführt. Wenn ich 
daraufklicke kommt ein Fenster, in dem steht: "Das Gerät ist 
betriebsbereit."
OK, denk ich mir, dann muß es ja gehen. Aber wenn ich im AVR-Studio das 
STK500 connecten will und die erforderlichen Daten in den Dialog eingebe 
und danach auf 'Connect...' klicke, tut sich einige Sekunden gar nix. 
Dann kommt das vorige Fenster wieder zum Vorschein. Ich kann das 
Spielchen theoretisch bis ins Unendliche treiben...

Weiß mir jemand von Euch hierfür einen Rat?

Danke schonmal!

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen R. wrote:
> Also ich verwende Version 4.12 vom AVR-Studio und es gibt nur Frust...
warum verwendest du keine aktuelle version?

> OK, denk ich mir, dann muß es ja gehen. Aber wenn ich im AVR-Studio das
> STK500 connecten will und die erforderlichen Daten in den Dialog eingebe
> und danach auf 'Connect...' klicke, tut sich einige Sekunden gar nix.
was "gibst" du da ein?

schon mal versucht, mit einem terminalprogramm bei kurzgeschlossenen 
pins 2 und 3 (RX, TX) zeichen zu senden?
wenn das nicht funktioniert, hast du ein treiberproblem.

was vllt sonst noch interessant sein könnte:
STK500USB-Adapter

Autor: Jürgen R. (hobbyloeter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> OK, denk ich mir, dann muß es ja gehen. Aber wenn ich im AVR-Studio das
>> STK500 connecten will und die erforderlichen Daten in den Dialog eingebe
>> und danach auf 'Connect...' klicke, tut sich einige Sekunden gar nix.
> was "gibst" du da ein?
Gut, eingeben ist vielleicht zu viel gesagt. In den Menüs stell ich das 
STK500 und als COM-Port COM5 ein. Mehr net...

> schon mal versucht, mit einem terminalprogramm bei kurzgeschlossenen
> pins 2 und 3 (RX, TX) zeichen zu senden?
> wenn das nicht funktioniert, hast du ein treiberproblem.
Gute Idee. Wie sieht denn da genau die Verkabelung aus? Welche Adern muß 
ich aus dem Stecker rausführen/kurzschließen?

Den Selbstbau-Adapter muß ich mir mal genauer anschauen. Danke für den 
Tip!

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe am Wochenende mal mein STK500 angeworfen, ewig nicht benutzt, nur 
mit dem Dragon programmiert.

Aktuelles AVR-Studio, STK500 an COM1 vom Notebook wie immer und und es 
passierte... nichts...
Effekt wie oben, Auto-Suche - Denkpause - Auswahlliste, mit direkter 
Angabe der COM1 genauso.

Wollte das Ding schon ungnädig in die Ecke werfen und den HV-Prog-Kram 
am Dragon anwerfen als mir so ein Gedanke kam:

Firmwareupdate mit AVR-Prog nach Anleitung zu Fuß gemacht,
STK aus, STK ein, Auswahl im Studio angeklickt und... STK500 da als sei 
nichts gewesen.

Vermutung: Atmel muß es irgendwi geschafft haben, daß irgendwelche alten 
Firmwareversionen des STK500 im aktuellen Studio kein Update auslösen 
und andererseits das Teil mit zu alter Firmware nicht mehr connected.

Vielleicht hilft es ja einem der hier geplagten?

Gruß aus Berlin
Michael

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen R. wrote:
>> schon mal versucht, mit einem terminalprogramm bei kurzgeschlossenen
>> pins 2 und 3 (RX, TX) zeichen zu senden?
>> wenn das nicht funktioniert, hast du ein treiberproblem.
> Gute Idee. Wie sieht denn da genau die Verkabelung aus? Welche Adern muß
> ich aus dem Stecker rausführen/kurzschließen?
TX liegt an pin 3 und rx an pin 2. wenn du die beiden verbindest, 
solltest du deine gesendeten daten als echo 1:1 zurückbekommen.

> Den Selbstbau-Adapter muß ich mir mal genauer anschauen. Danke für den
> Tip!
ist ja auch von mir =)

Autor: Jürgen R. (hobbyloeter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael!

Na also, noch ein Leidensgenosse ;-)

> Firmwareupdate mit AVR-Prog nach Anleitung zu Fuß gemacht,
> STK aus, STK ein, Auswahl im Studio angeklickt und... STK500 da als sei
> nichts gewesen.

Das hab ich ausch schon gemacht. Mit dem AVRISP mkII. Hat aber nix 
gebracht. Immernoch gleicher Fehler. Verwendest Du auch einen Adapter?
Ich glaub, ich werd mir mal die neuseste Version des AVR-Studios ziehen.

Viele Grüße!
J.R.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.