Forum: Platinen Paste unsichtbar Altium 21


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Altiumanwender (Gast)


Lesenswert?

Hi

Ich habe ein Problem mit Altium und zwar habe ich ein Projekt, bei dem 
es mir keinen Top/Bottom Paste oder Solder anzeigt.

In der Library verfügen die verwendeten Bauteile aber über einen Paste 
bzw. Solder, das habe ich überprüft. Sobald ich die Teile im Projekt 
verwende, sehe ich keinen Paste oder Solder.

Ich behaupte, dass es irgend eine Einstellung ist oder Altium etwas 
zerschossen hat.

Ich habe folgendes versucht:

Ein neues Projekt erstellt und die verwendeten Bauteile dort eingefügt 
-> Altium zeigt Paste und Solder an.
Ein anderes Projekt geöffnet, wo selbe Bauteile verwendet wurden -> wird 
auch alles angezeigt.
Ich habe auch eine Kopie des PCB files erstellt, dieses abgekoppelt und 
aus dem Projekt eine Library erstellt -> Alle Bauteile enthalten einen 
Solder und Paste: Altium scheint zu erkennen, dass es ein Paste gibt, 
zeigt es mir aber im Projekt nicht an oder wenn Gerberdaten erstellt 
werden ebenso nicht...

Was ist das Problem? Kann man den Solder oder Paste irgendwie 
deaktivieren?
Ich wäre um Hilfe sehr dankbar, ich würde das Design nur ungern neu 
machen.

: Verschoben durch Moderator
von Wühlhase (Gast)


Lesenswert?

Schau mal in die View Configuration und sieh dort mal nach, ob der Layer 
sichtbar geschaltet ist.

von Taz G. (taz1971)


Lesenswert?

und check mal denn Layer Stack

von Altiumanwender (Gast)


Lesenswert?

Wühlhase schrieb:
> Schau mal in die View Configuration und sieh dort mal nach, ob der
> Layer
> sichtbar geschaltet ist.

Hallo Wühlhase

Ja das ist er, aber er zeigt mir nichts an.
Was gibt es noch?

von Der müde Joe (Gast)


Lesenswert?

Auch mal die Rules überprüfen, da kann man separat das Erscheinungsbild 
des Löstops und Lotpaste beeinflussen, bis hin zur Unsichtbarkeit.

von Altiumanwender (Gast)


Angehängte Dateien:

Lesenswert?

Der müde Joe schrieb:
> Auch mal die Rules überprüfen, da kann man separat das
> Erscheinungsbild
> des Löstops und Lotpaste beeinflussen, bis hin zur Unsichtbarkeit.

hallo

wo kann man das genau machen in den Rules? Ich finde da sonst nichts 
ausser solder und paste mask

von Wühlhase (Gast)


Lesenswert?

Altiumanwender schrieb:
> Wühlhase schrieb:
>> Schau mal in die View Configuration und sieh dort mal nach, ob der
>> Layer
>> sichtbar geschaltet ist.
>
> Hallo Wühlhase
>
> Ja das ist er, aber er zeigt mir nichts an.
> Was gibt es noch?

Ist er dort aktiviert oder deaktiviert? Wenn er aktiviert ist, dann 
kannst du den Paste Mask Layer auch unten in der Leiste auswählen.

Wenn er dir dann nichts anzeigt, ist auch nichts drin.

von Altiumanwender (Gast)


Angehängte Dateien:

Lesenswert?

Wühlhase schrieb:
> Altiumanwender schrieb:
>> Wühlhase schrieb:
>>> Schau mal in die View Configuration und sieh dort mal nach, ob der
>>> Layer
>>> sichtbar geschaltet ist.
>>
>> Hallo Wühlhase
>>
>> Ja das ist er, aber er zeigt mir nichts an.
>> Was gibt es noch?
>
> Ist er dort aktiviert oder deaktiviert? Wenn er aktiviert ist, dann
> kannst du den Paste Mask Layer auch unten in der Leiste auswählen.
>
> Wenn er dir dann nichts anzeigt, ist auch nichts drin.

Genau, ich habe jetzt etwas herausgefunden. Ich lege das Bauteil 
Ausserhalb von der Boardgeometrie und das paste ist zu sehen, lege ich 
es auf das Board ist nichts zu sehen... Was ist das und wie bekomme ich 
das weg?

von Taz G. (taz1971)


Lesenswert?

Layer Stack geprüft ?

von Altiumanwender (Gast)


Angehängte Dateien:

Lesenswert?

Taz G. schrieb:
> Layer Stack geprüft ?

Hallo Taz, ja ich bin gerade zufällig drauf gekommen. Ich habe 
probeweise den Layerstack nochmals aufgebaut. Sobald ich den Layerstack 
aufbaue und die 1. beiden oberen Schichten Polymide1 und Adhesive 5 
hinzufüge, sehe ich kein Paste und Solder mehr.

Wie soll ich das denn sonst machen, ich brauche die obersten beiden...
Jemand eine Idee?

von Gerhard H. (ghf)


Lesenswert?

Ich hatte es mit dem AD16, dass auf dem top level keine Strings 
dargestellt wurden. Die waren unsichtbar, aber anclickbar wenn man 
wusste wo.
Ich habe das dann irgendwann aufgegeben und meine strings in den 
Bestückungsdruck verschoben.

Beim Umstieg auf AD20 war der Effekt dann einfach weg.
Keine Ahnung, warum.

Beim Upgrade auf AD21 im Januar gab's dann einen Sofort-Crash wenn ich
ein Projektfile aufgemacht habe. Schdoc und layout alleine ging. Das war
ansteckend, wenn man die files danach mit AD20 aufgemacht hat.
AD16 war immun. Ich habe den AD21 dann mal 3 Monate weggelegt, und siehe 
da, bei AD21.03 war's dann OK.

Diese Woche hat sich rausgestellt, dass AD21.x Gerberfiles falsch 
einliest, die mit Keysight-Software gemacht wurden. Der Gerbv, der bei 
meiner LinuxMint-Distribution einfach so dabei war, konnte das 
problemlos korrekt darstellen. Und ein Mikrowellen-Filter als Gerber in 
den Decal-Editor einzulesen ist anscheinend überhaupt nicht vorgesehen. 
Ich will das bisschen Kupfer von so einem electromagnetic-optimiertem 
Filter aber als Bauteil, und bitteschön ohne Fummelei von Hand.

Ich habe die Faxen dicke und 0 Bock, weiter den Betatester zu spielen.

Gerhard

von Gerhard H. (ghf)


Lesenswert?

Bei Layer 1 steht statt Polyimide nur Polymide.
Ich kann nicht nicht beurteilen, ob das da was ausmacht.

Gerhard

von Altiumanwender (Gast)


Lesenswert?

Gerhard H. schrieb:
> Ich hatte es mit dem AD16, dass auf dem top level keine Strings
> dargestellt wurden. Die waren unsichtbar, aber anclickbar wenn man
> wusste wo.
> Ich habe das dann irgendwann aufgegeben und meine strings in den
> Bestückungsdruck verschoben.
>
> Beim Umstieg auf AD20 war der Effekt dann einfach weg.
> Keine Ahnung, warum.
>
> Beim Upgrade auf AD21 im Januar gab's dann einen Sofort-Crash wenn ich
> ein Projektfile aufgemacht habe. Schdoc und layout alleine ging. Das war
> ansteckend, wenn man die files danach mit AD20 aufgemacht hat.
> AD16 war immun. Ich habe den AD21 dann mal 3 Monate weggelegt, und siehe
> da, bei AD21.03 war's dann OK.
>
> Diese Woche hat sich rausgestellt, dass AD21.x Gerberfiles falsch
> einliest, die mit Keysight-Software gemacht wurden. Der Gerbv, der bei
> meiner LinuxMint-Distribution einfach so dabei war, konnte das
> problemlos korrekt darstellen. Und ein Mikrowellen-Filter als Gerber in
> den Decal-Editor einzulesen ist anscheinend überhaupt nicht vorgesehen.
> Ich will das bisschen Kupfer von so einem electromagnetic-optimiertem
> Filter aber als Bauteil, und bitteschön ohne Fummelei von Hand.
>
> Ich habe die Faxen dicke und 0 Bock, weiter den Betatester zu spielen.
>
> Gerhard

Ich verstehe dich.
Wobei ich sagen muss, dass ich mit Altium 18 oder so, weiss nicht mehr 
welche Version das war, derartige Probleme nie hatte.
Jetzt funktioniert alle 2 Tage irgendetwas funktionstechnisch nicht und 
die Updates werden auch nicht durchgeführt, auch manuell nicht.
Das mit dem Layerstack und den FPCs, wenn sie es schon anbieten sollte 
dann aber schon funktionieren.. auch wenn es neu ist.

von Gerhard H. (ghf)


Lesenswert?

Aaarghh, jetzt hab' ich noch ein größeres Gedicht dazueditieren wollen
und kann's nicht posten weil zwischenzeitlich jemand anderes gepostet 
hat.
Der Text ist natürlich weg.

Um es kurz zu machen, bei Polyimid-Platinen muss man sehr darauf achten,
dass einem niemand abgelaufene Prepregs andreht. Die haben ein sehr
kurzes Leben im Regal und delaminieren dann wenn die teuren Virtexe
schon draufgelötet sind.

: Bearbeitet durch User
von Taz G. (taz1971)


Lesenswert?

Altiumanwender schrieb:
> Taz G. schrieb:
>> Layer Stack geprüft ?
>
> Hallo Taz, ja ich bin gerade zufällig drauf gekommen. Ich habe
> probeweise den Layerstack nochmals aufgebaut. Sobald ich den Layerstack
> aufbaue und die 1. beiden oberen Schichten Polymide1 und Adhesive 5
> hinzufüge, sehe ich kein Paste und Solder mehr.
>
> Wie soll ich das denn sonst machen, ich brauche die obersten beiden...
> Jemand eine Idee?

Dein Adhesive Layer liegt quasi auf Solder und Paste, daher werden die 
Lagen verdeckt. Ich habe keine Erfahrung mit solchen Lagen. Aber ich 
denke so eine Lage findet man nicht im View Panel, abschalten oder 
transparent schalten geht also nicht. Ich schätze das ist aber nur eine 
Darstellungssache und die Gerber Dateien werden richtig erzeugt. Zum 
Check der Solder/Paste Lagen einfach mal temporär die Adhesive Layer 
deaktivieren.

von Altiumanwender (Gast)


Lesenswert?

Taz G. schrieb:
> Altiumanwender schrieb:
>> Taz G. schrieb:
>>> Layer Stack geprüft ?
>>
>
>
> Dein Adhesive Layer liegt quasi auf Solder und Paste, daher werden die
> Lagen verdeckt. Ich habe keine Erfahrung mit solchen Lagen. Aber ich
> denke so eine Lage findet man nicht im View Panel, abschalten oder
> transparent schalten geht also nicht. Ich schätze das ist aber nur eine
> Darstellungssache und die Gerber Dateien werden richtig erzeugt. Zum
> Check der Solder/Paste Lagen einfach mal temporär die Adhesive Layer
> deaktivieren.

Habe ich gerade ausprobiert, Gerberdaten sind dann mit diesen Lagen 
falsch und werden nicht angezeigt.. :(, ich muss da tricksen, Adhesive 
einblenden, Layer Stack im Boardbereich einfügen, Adhesive deaktivieren 
und Herstellerdaten erzeugen..

von Taz G. (taz1971)


Lesenswert?

@Altiumanwender
Ich hätte gern mehr geholfen, aber wie gesagt ich habe keine Erfahrungen 
mit diesen Kleber Lagen. Aber ich hoffe, dass Dir mein Hinweis auf den 
Layer Stack doch irgendwie weiter geholfen hat.

MFG
Taz

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.