Forum: Analoge Elektronik und Schaltungstechnik Woher Eingangsschwingung am Buck


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von A. S. (rava)


Angehängte Dateien:

Lesenswert?

Ich habe mir vor einigen Wochen meine erste Experimentierplatine mit 
einem RT8298 Step-Down Converter ausgelegt. Der Schaltplan folgt mehr 
oder weniger dem Datenblatt.

Ich betreibe den Regler bei 18-20V Eingang und 4-7V Ausgang. Da komme 
ich mit einer 250W/24V Halogenlampe als Last auf etwa 4-5A Strom als 
ordentlicher Belastungstest.

In meinen ersten Messungen hatte ich ziemliche Schwingungen am Ausgang. 
Diese lagen bei ca. 30kHz bei einer Amplitude von ca 0.7V (siehe 
IMG_0399). Der Regler arbeitet übrigens intern mit 600kHz.

Nach kurzer Rücksprache hier im Board habe ich mal eine dynamische 
Auslegung durchgerechnet. Dazu habe ich vereinfacht einen Regler im 
voltage-mode angenommen.
Hierbei ist herausgekommen, dass das Gesamtsystem tatsächlich ein 
instabiles Polpaar aufweist, das sich mit einem Kondensator parallel zu 
RV1 für weite Arbeitsbereiche stabilisieren lässt.

Ich habe 5nF gewählt und damit reduziert sich die Amplitude der 
Schwingung am Ausgang - je nach Arbeitspunkt - auf deutlich unter 100mV. 
Damit könnte ich leben.

Allerdings habe ich weiterhin starkes Schwingen am Eingang. Abhängig von 
der Ausgangsspannung schwankt die Frequenz zwischen 20 und 50 kHz. Die 
Amplitude würde ich mit über 2V als Schmerzhaft bezeichnen. Signalmäßig 
sehe ich verschiedenste Sägezähne (IMG_6244) und auch harmonischere 
Schwingungen (IMG_6246).

Experimente bisher:
* 1000µF am Eingang blocken alles ab. Aber laut Datenblatt sollen 20µ 
Kermamik reichen und bekämpfe ich da nicht eher nur die Symptome? Nach 
meinen Messungen bräuchte ich mindestens 470µF. Das finde ich zu viel.
* Ein Wechsel der Spannungsquelle ändert nichts.


Wie würdet ihr das angehen? Ich habe noch ein pdf von TI gefunden, in 
dem ein mathematisches Modell für current mode Regler beschrieben wird, 
aber irgendwie leuchtet mir eine genauere Rechnung nicht als sinniger 
nächster Schritt ein. Ich habe eher das Gefühl, die meisten Nutzer 
rechnen bei DCDC gar nichts. Ein Spice-Modell gibt's aber für den Chip 
nicht.

Woher kommen denn die langsamen Schwingungen überhaupt? Also mit anderen 
Worten: welche Übertragungsfunktion will ich überhaupt kompensieren? Der 
Regler pumpt doch am Eingang mit 600kHz Strom ab. Der Ausgang steht 
einigermaßen stabil am Oszi. Wo "schwingt" die Energie hin? In die 
Spule?

von Bernd G. (Firma: Bannerträger des Fortschritts) (berndg)


Lesenswert?

Zeig mal deine Zuleitungen zum Wandler (Querschnitt, Länge).
Woraus speist du deine Schaltung?
Zeig mal ein Bild deines Aufbaus.

: Bearbeitet durch User
von Gustl B. (gustl_b)


Lesenswert?

Zeig mal das Layout oder ein Foto der Schaltung. Das kann hier sehr 
wichtig sein.

von Xerxes (Gast)


Lesenswert?

Hi.
Welche Kondensatoren sind denn am Eingang angeschlossen?
Spannung, Typ, Bauform

Im Datenblatt werden X5R Kerkos vorgeschlagen . Bei denen bleibt von den 
10uF nicht mehr viel übrig wenn diemit Spannung beaufschlagt werden.

Bei 600kHz Schaltfrequenz ist das korrekte Layout und die Bauteilauswahl 
entscheidend.

von A. S. (rava)


Angehängte Dateien:

Lesenswert?

aw crap. Layout vergessen.

Das Layout enthält noch einiges an Hühnerfutter, das sich als unnötig 
herausgestellt hat und mittlerweile aus dem Schaltplan rausgenommen 
wurde. Deswegen hängt auch noch der Shunt oben im Schematic.

Ich habe die beiden 600kHz-Stromschleifen in blau eingezeichnet. Das 
einzige, was noch ein Problem sein könnte: der Pfad zur Spannungsmessung 
mittels RV1 und R12 ist etwas lang. Ich habe das organge markiert

Spannungszufuhr läuft über normale Bananenstecker. Bei 1.5A am Eingang 
eher zweitrangig, oder?

: Bearbeitet durch User
von A. S. (rava)


Angehängte Dateien:

Lesenswert?

hier die Caps am Eingang und am Ausgang.


> Bei 600kHz Schaltfrequenz ist das korrekte Layout und die Bauteilauswahl
> entscheidend.

können Layout und Bauteile allein 50kHz-Schwingungen verursachen, wenn 
das Ding mit 600kHz läuft?

: Bearbeitet durch User
von Mark S. (voltwide)


Lesenswert?

A. S. schrieb:
> hier die Caps am Eingang und am Ausgang.
>
>
>> Bei 600kHz Schaltfrequenz ist das korrekte Layout und die Bauteilauswahl
>> entscheidend.
>
> können Layout und Bauteile allein 50kHz-Schwingungen verursachen, wenn
> das Ding mit 600kHz läuft?
Durchaus. Voltage mode sieht auf den ersten Blick zwar immer so schön 
einfach aus - neigt aber zur Instabilität, sog subharmonischen 
Oszillationen. Schon kleine Störungen auf dem feedback-Eingang können 
hier alles verderben. Habe zu dem Thema auch mein Lehrgeld bezahlen 
müssen...

: Bearbeitet durch User
von Der Zahn der Zeit (🦷⏳) (Gast)


Lesenswert?

A. S. schrieb:
> * 1000µF am Eingang blocken alles ab. Aber laut Datenblatt sollen 20µ
> Keramik reichen und bekämpfe ich da nicht eher nur die Symptome?
Die sollen nur die 600 kHz von der Versorgung freihalten. Das heißt 
nicht, dass mit 20µ im Eingang bei der Versorgung jetzt alles andere 
egal ist.

>  Nach meinen Messungen bräuchte ich mindestens 470µF. Das finde ich zu viel.
Na, dass ist doch eine heiße Spur! Eine Quelle mit niedrigerer Impedanz 
beseitigt das Phänomen - habe ich das richtig verstanden?

Wenn ich das richtig erkannt habe, führst du die Versorgung über 2 KLEPS 
30 zu. Die sind ziemlich hochohmig.

> * Ein Wechsel der Spannungsquelle ändert nichts.
Wenn du die auch über die KLEPS 30 anschließt, würde ich das genau so 
erwarten.

A. S. schrieb:
> Allerdings habe ich weiterhin starkes Schwingen am Eingang
Das ist doch der Beweis, dass die Quelle (incl. Kabel und KLEPS 30) 
alles andere als ausreichend niederimpedant (kann man das sagen?) bei 
Frequenzen von einigen 10 kHz ist.

von Gustl B. (gustl_b)


Lesenswert?

Mark S. schrieb:
> Schon kleine Störungen auf dem feedback-Eingang können hier alles
> verderben.

Genau diesen Feedback Pfad finde ich auch eher lang. Die Induktivität 
unnötig groß. Und Thermals würde ich rund um Schaltregler ausschalten, 
die machen die Anbindungen eher kaputt. Es hat auch einen Grund warum 
der Spannungsteiler für das Feedback nahe am Feedback Pin sitzen sollte. 
Denn dann ist der Weg zwischen Spannungsteiler und FB Pin kurz und auf 
diesem Weg kann das besonders leicht gestört werden. Zwischen Vout und 
Spannungsteiler ist das recht robust gegen Störungen weil das eine 
starke Quelle treibt.

von Gustl B. (-gb-)


Lesenswert?

Der Zahn der Zeit (🦷⏳) schrieb:
>>  Nach meinen Messungen bräuchte ich mindestens 470µF. Das finde ich zu viel.
> Na, dass ist doch eine heiße Spur! Eine Quelle mit niedrigerer Impedanz
> beseitigt das Phänomen - habe ich das richtig verstanden?

Nicht unbedingt. Das Problem kann auch erst hinter dem Regler oder eben 
durch schlechte Regelung entstanden sein. Aber ja, die Eingangskapazität 
sollte genug Ladungen speichern können für einen Schalttakt wenn ich das 
richtig verstanden habe. Dann sollte man Keramikkondensatoren noch etwas 
deutlich überdimmensionieren.

von Xerxes (Gast)


Angehängte Dateien:

Lesenswert?

A. S. schrieb:
> hier die Caps am Eingang und am Ausgang.

Auf der Seite von Murata findet man interessante Daten über diesen 
Kondensator. (siehe Anhang)

Da bleibt bei 20V nicht viel mehr als 1uF über.
Da muss auf jeden Fall mehr C dran.

von Gustl B. (-gb-)


Lesenswert?

So groß muss die Kapazität gar nicht sein. Wichtig ist - so mein 
Verständnis - dass die zwischen zwei Schaltvorgängen wieder aufgeladen 
wird und genug Ladungen für jeweils einen Schaltvorgang speichern kann.

Kann man das so rechnen?

5 A am Ausgang, 18 V am Eingang, 600 kHz Schaltfrequenz also
(5 A*1 s/600000)/18 V = 463 nF

Ob die Eingangskapazität passt kann man aber nachmessen, da misst du mit 
dem Oszi direkt über dem Eingangskondensator und schaust ob da die 
Spannung einbricht. Das sollte nicht der Fall sein oder nur minimal.

Aber: Wird da wirklich genug Strom angeliefert? Auf deinem Foto zeigt 
das Netzteil 1,35 A bei 19 V. Das kann passen wenn der Regler nur 4 V 
und 4 A liefern muss, kann aber auch nicht passen wenn 7 V und 5 A 
gefordert sind.

von Matthias L. (Gast)


Lesenswert?

>18V Eingang und 7V Ausgang. ... 5A Ballast

Ergibt einen durchschnittlichen Eingangsstrom von 2A. Bei d=39% ergibt 
das Peaks von 5,2A für 650ns (600kHz = 1,7µs)

Somit "sieht" der Eingangs-C einen Strom von
-3,2A für 650ns
+ 2A  für   1µs
welches einer Ladung von Q = 2µJ entspricht.

Bei 20µF Eingangs-C würde das ein dU von 100mV erzeugen. Der C wäre also 
groß genug, unter der Bedingung, das die 20µF effektiv wirken und das 
Anbindung Ce->IC->Spule->Ca->return induktionsarm genug ist.

von Fritz (Gast)


Lesenswert?

Hast Du vielleicht so etwas wie "DC Link hochkapazitiver
Folienkondensator" im Zufalls-Repertoire (Bauteilkiste)?

Damit könnte man schön ausprobieren, ob die Oszillationen
eher durch die hohe Kapazität des Elkos oder eher durch
dessen ESR abgeschwächt werden.

(Indem man den DC-Link statt des Elkos an den Eingang
setzt - dieser hat den besagten ESR nicht, aber hohe C.)

Kurz zu den verw. KerKos: Bei mir kommen zwar auch X5R
zum regelmäßigen Einsatz, aber regelmäßig mit weniger als
halber Nennspannung beaufschlagt und dann noch 2-3faches
der in Switcher-Datenblättern anggbn. Nenn-Kapazität.

Das Hauptproblem des Layouts hast Du ja schon erkannt.

von A. S. (rava)


Lesenswert?

Mark S. schrieb:
> Voltage mode sieht auf den ersten Blick zwar immer so schön
> einfach aus - neigt aber zur Instabilität, sog subharmonischen
> Oszillationen.

um Missverständnisse zu vermeiden: den voltage mode habe ich als 
Vereinfachenden ersten Schritt gerechnet. Der Regler arbeitet aber 
ausschließlich im current mode.

Der Zahn der Zeit (🦷⏳) schrieb:
> Eine Quelle mit niedrigerer Impedanz
> beseitigt das Phänomen - habe ich das richtig verstanden?

Wenn ich die 1000µF auf anderen Seite des Kabels, am Netzteil reinhänge, 
verschwinden die niederfrequenten Schwingungen nicht. Aber ist damit 
wirklich sicher gesagt, dass das Kabel ein Problem ist?
Ich habe ja schließlich auch ein anderes Netzteil ausprobiert. Das war 
ein Schaltnetzteil für die Wand. Das habe ich einfach mit Litze 
angeklemmt, aber vermutlich war die Litze wirklich etwas dünn.
Dennoch, ich sehe immer noch nicht, wie das Kabel für 1.5A zu dünn sein 
soll. Seid ihr euch da sicher? Und würde nach der Theorie ein anderes, 
z.B. kürzeres Kabel dann nicht eine völlig andere Frequenz erzeugen?

Wenn ich die beiden Leitungen bei 1.5A kurz schließe, messe ich 230mV.

Gustl B. schrieb:
> Genau diesen Feedback Pfad finde ich auch eher lang. Die Induktivität
> unnötig groß. Und Thermals würde ich rund um Schaltregler ausschalten,
> die machen die Anbindungen eher kaputt. Es hat auch einen Grund warum
> der Spannungsteiler für das Feedback nahe am Feedback Pin sitzen sollte.

Naja, sehr viel kürzer geht aber auch nicht; villeicht könnte man 
nochmal 20% Leitungslänge sparen; und der Spannungsteiler ist schon 
ziemlich weit "links", also am Pin. Ein paar mm kann man 
zugegebenermaßen noch rausholen. Aber viel wird's nicht.

Warum darf die Induktivität nicht zu groß sein? Ich habe einfach mit der 
Untergrenze vom Datenblatt gearbeitet und dann großzügig aufgerundet. 
Was spricht dagegen das so zu machen?

Ah Moment, der Wert ist ja gar nicht im Schaltplan. Ich habe eine Bourns
SRP1265C-220M mit 22µH verbaut. Das sind nicht 220µH! Trotzdem zu viel?

Xerxes schrieb:
> interessante Daten über diesen
> Kondensator.

okay, das überrascht mich. Aber 10µF Elko ändern am Ergebnis fast gar 
nichts. Man braucht schon eher 100µF bis man an der Signalform etwas 
sieht.

Außerdem ist mir immer noch nicht klar, wie ein zu kleines C solch 
niederfrequente Schwingungen verursacht. Ich hätte erwartet, dass da 
dann wieder eher 600kHz Überhand nehmen. Zugegebenermaßen, man sieht da 
ja auch ganz amtliche Spikes auf den Fotos, also werden die Keramiken in 
der nächsten Iteration auf jeden Fall größer!

Gustl B. schrieb:
> Wird da wirklich genug Strom angeliefert?

der Strom sollte passen. In dem Fall ist die Spannung <5V.

von Fritz (Gast)


Lesenswert?

A. S. schrieb:
> Aber 10µF Elko ändern am Ergebnis fast gar nichts.

Vielleicht zu hochohmig. Und 10µF FolKo? (Oder mehrere
kleinere FolKos parallel?) - möglichst kurz und nieder-
induktiv mit den Eingangs-Cs verbunden

A. S. schrieb:
> Außerdem ist mir immer noch nicht klar, wie ein zu kleines C solch
> niederfrequente Schwingungen verursacht.

Zusammen mit Zuleitung "Pumpen" des Reglers/der Regelung.
Das passiert natürlich mow weit unterhalb f_Schalt, die
ist dabei nicht "das Problem".

von Fritz (Gast)


Lesenswert?

Die hochohmige Zuleitung mal viel niederohmiger machen.

von Fritz (Gast)


Lesenswert?

A. S. schrieb:
> Warum darf die Induktivität nicht zu groß sein? Ich habe einfach mit der
> Untergrenze vom Datenblatt gearbeitet und dann großzügig aufgerundet.
> Was spricht dagegen das so zu machen?
>
> Ah Moment, der Wert ist ja gar nicht im Schaltplan. Ich habe eine Bourns
> SRP1265C-220M mit 22µH verbaut. Das sind nicht 220µH! Trotzdem zu viel?

Ich sehe im Datenblatt 2,2µH...

Außerdem ist das "special Feature" eines Current Mode
Reglers das "Cycle-by-Cycle Current Limit" - das heißt
Du brauchst auch nicht wie bei einem LM2596 oder so
eine L, deren I_sat >= des Current Limits ist, damit
der Konverter kurzschlußfest ist - dieses_IC fährt
stattdessen sogar Pulsdauer und Frequenz runter.

Die L ist also zu hoch (Induktivität), und auch zu
"stark" (sie soll nur den im Normalbetrieb auftretenden
I_rms thermisch vertragen, und beim I_peak nicht voll
sättigen).

Daß sie im Ergebnis "riesig" ist, wundert nicht sehr.
Geh mal nach dem Datenblatt, welche Werte kommen raus?

(Das überlasse ich mal Dir, habe ich also auch nicht
"zur Sicherheit schon mal durchgearbeitet" - ich bin
auch so sicher, daß hier 'ne kleinere reichen würde.)

Und daß eine riesige Bauform "im Weg stehen kann"...
(und auch die SRF - hm - etwas niedrig ist für 600kHz)
so etwas kommt vor, und/aber darf verbessert werden. ;)

von Fritz (Gast)


Lesenswert?

Ach ja:

https://www.mouser.de/datasheet/2/54/Bourns_SRP1265C_datasheet-1775834.pdf

Die vorletzte im Datenblatt auf Seite 1.

von Purzel H. (hacky)


Lesenswert?

Es ist aber schon klar wie ein Schaltregler funktioniert ?
Wenn du von 24V auf 6V runtergehst, ist das Einschaltverhaeltnis 1/4. 
Die 4A am Ausgang muss das Powersupply waehrend der 25% trotzdem 
liefern. Eigentlich mehr. Denn waehrend der nichtleitungsphasen musst du 
auch liefern...
Mit einen 1.5A Netzteil ist da nichts.

: Bearbeitet durch User
von Roland E. (roland0815)


Lesenswert?

Eingangsfilter vergessen.

von Der Zahn der Zeit (🦷⏳) (Gast)


Lesenswert?

A. S. schrieb:
> Wenn ich die 1000µF auf anderen Seite des Kabels, am Netzteil reinhänge,
> verschwinden die niederfrequenten Schwingungen nicht.
Genau das habe ich vorausgesagt - oder, genau genommen, vermutet.

> Aber ist damit wirklich sicher gesagt, dass das Kabel ein Problem ist?
Nein, die Kabel sind es vermutlich nicht. Ich "sage voraus": Es sind die 
KLEPS 30 am Ende de Kabels. (Hinweis für die, die die Dinger nicht 
kennen: KLEPS 30 sind "Klemm-Prüf-Spitzen" der Fa. Hirschmann, die vor 
einigen Jahren oder Jahrzehnten ziemlich populär waren. Die sind im 
flexiblen Teil so hochohmig, dass sie bei einigen Ampere heiß werden. 
Mir ist deswegen bei einigen die Isolation geschmolzen.)

(Wer findet den Satz mit 3½ mal "die" hintereinander?)

von Mohandes H. (Firma: مهندس) (mohandes)


Lesenswert?

Der Zahn der Zeit (🦷⏳) schrieb:
> (Wer findet den Satz mit 3½ mal "die" hintereinander?)

'Hinweis für die, die die Dinger nicht kennen' -> 'Hinweis für alle, die 
solche Dinger nicht kennen'. ;-)

Kannte ich tatsächlich noch nicht (die Klemmen schon, aber nicht die 
Bezeichnung), wieder was gelernt.

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Lesenswert?

A. S. schrieb:
> * 1000µF am Eingang blocken alles ab.
> Aber laut Datenblatt sollen 20µ Kermamik reichen
Laut Datenblatt "reichen" für die Funktion des Reglers diese mickrigen 
Kondensatoren. Und funktionieren tut er ja eigentlich durchaus.

> Aber laut Datenblatt sollen 20µ Kermamik reichen
Welche Kondensatoren hast du denn da tatsächlich drin? Welche 
Spannungsfestigkeit haben die? Denn 20µF X7R sind nur bei 1V Messpannung 
20µF. Bei der Maximalspannung des Kondensators sind davon nur noch etwa 
6µF übrig.

> und bekämpfe ich da nicht eher nur die Symptome?
Nein, ich sehe die mickrige Eingangskapazität und die hochohmige 
Zuleitung  als Ursache. Und wenn mit einem anständigen Pufferkondensator 
der Ripple verschwindet, dann ist das schon der Beweis dafür.

: Bearbeitet durch Moderator
von ElektroFH (Gast)


Lesenswert?

Viele gute Punkten sind oben schon erwähnt.

Ich habe noch einen zusätzlichen (obwohl ein paar Mal kurz gesagt):
Der IC selber kann auch seinen Senf dazu geben.

Ich schließe mich an Lothar M.
Das Datenblatt ist schon "merkwürdig".
Das Teil erwähnt nur Raum-temperatur Specs im DB.
Und das sogar nur mit sehr wenigen min/max..
Ich hoffe das ist nicht für Industrie-Elektronik :-)

von A. S. (rava)


Angehängte Dateien:

Lesenswert?

Der Zahn der Zeit (🦷⏳) schrieb:
> Ich "sage voraus": Es sind die KLEPS 30 am Ende de Kabels.

Wenn ich die beiden in den Kabelkurzschluss mit rein hänge, werden aus 
den 230mV in Summe 310mV. Also ja, die Steigerung ist groß für die kurze 
Kabelstrecke (15cm), aber ist das wirklich zu viel Spannungsabfall? Alle 
meine Kabel kommen zusammen auf 200mR.

Wenn ich das richtig sehe, haben die Caps bei der Problemfrequenz einen 
viel höheren ESR: 
https://www.murata.com/en-eu/products/productdetail?partno=GRM21BR6YA106ME43%23

Fritz schrieb:
> Und 10µF FolKo? (Oder mehrere kleinere FolKos parallel?)

Habe ich tatsächlich ein paar ganz unten in der Kiste gefunden. Wenn ich 
da etwa 20µF dazu hänge (sehr hübsch), dann sind die Schwingungen 
deutlich reduziert. Laut meinen Messungen bleiben von den 2V noch 0.4V 
Amplitude übrig.

Das ist schonmal ein großer Erfolg. Ich denke, ich werde dann in der 
nächsten Iteration 47µF bei der korrekten Spannung einplanen! Danke!

Trotzdem bin ich mir sicher, wenn ich von Anfang an die richtigen caps 
drin gehabt hätte, würde ich jetzt hier stehen und fragen, ob man noch 
etwas verbessern kann?

Fritz schrieb:
> Die L ist also zu hoch (Induktivität), und auch zu
> "stark" (sie soll nur den im Normalbetrieb auftretenden
> I_rms thermisch vertragen, und beim I_peak nicht voll
> sättigen).

seltsam. Als ich hier zuletzt gefragt habe, hieß es, das wäre schon 
okay.
Kannst du nochmal erklären, warum die Induktivität nicht zu groß sein 
darf?

Je nach Parameter in der Auslegungsrechnung mach dem Datenblatt komme 
ich schon auf 10µH - da finde ich 22µH nicht übertrieben, da ja oft mal 
20% Toleranz drin sind.

Über den Sättigungsstrom, denke ich, kann man wirklich reden. Es stimmt 
schon, dass die Spule nicht bis 2*I_rms voll läuft. Meine Überlegung 
war, dass der Maximalstrom des Reglers die Spule nicht in die Sättigung 
bringen soll. Der Maximalstrom sind 10A, laut Tabelle auf Seite 5 im 
RT8298 Datenblatt.

Die SRF liegt bei 7MHz. Darauf habe ich tatsächlich nicht geachtet. Wie 
sollte man die denn wählen?

ElektroFH schrieb:
> Ich hoffe das ist nicht für Industrie-Elektronik :-)

keine Sorge. Mein Geld verdiene ich mit etwas, das ich kann :P

: Bearbeitet durch User
von Mark S. (voltwide)


Lesenswert?

Eine zu große Spule als Ursache des Problems würde ich ausschließen.

von Christian S. (roehrenvorheizer)


Lesenswert?

>Habe ich tatsächlich ein paar ganz unten in der Kiste gefunden. Wenn ich
da etwa 20µF dazu hänge (sehr hübsch), dann sind die Schwingungen
deutlich reduziert.

Es geht eben nichts über eine möglichst niederohmig zugeführte 
Betriebsspannung, wenn man einen Regler, hier insbesondere einen 
Schaltregler, damit versorgen möchte. Das kann auch nicht die Nähe zum 
hier verwendeten höherwertigen DSO aus vergangenen Jahrzehnten wieder 
wett machen.

Zusatz: Die Niederohmigkeit sollte im relevanten Frequenzbereich gegeben 
sein und nicht durch hochinduktive Kabel zunichte gemacht werden.

mfG

: Bearbeitet durch User
von Olaf (Gast)


Lesenswert?

> Woher kommen denn die langsamen Schwingungen überhaupt? Also mit anderen
> Worten: welche Übertragungsfunktion will ich überhaupt kompensieren?

Der Regler selbst stellt am Eingang einen negativen Widerstand da und
kann deshalb dort schwingen. Ich hab dazu vor ein paar Monaten mal
irgendein Paper oder eine Applikation gelesen. Leider weiss ich nicht
mehr genau was das war.
Ich glaube Wuerth hatte auch ein Video wo sie das mal kurz angesprochen 
haben.

Olaf

von Stefan ⛄ F. (stefanus)


Lesenswert?

A. S. schrieb:
> Aber laut Datenblatt sollen 20µ Kermamik reichen

Wenn deine Versorgung eine stabile Spannung liefert. Tut sie aber in 
deinem Fall nicht. Diese Prinzipschaltbilder gehen immer von einer 
idealen Quelle direkt an den Eingangsklemmen aus.

Selbst wenn du eine dicke Batterie als Quelle verwenden würdest, müsste 
man immer noch die Wirkung der Zuleitungen berücksichtigen. Je höher die 
Schaltfrequenz, umso problematischer. Bei meinen Basteleien (auf 
Lochraster) verwende ich daher immer Schaltregler mit höchstens 100kHz.

Gustl B. schrieb:
> So groß muss die Kapazität gar nicht sein. Wichtig ist - so mein
> Verständnis - dass die zwischen zwei Schaltvorgängen wieder aufgeladen
> wird und genug Ladungen für jeweils einen Schaltvorgang speichern kann.

Das würde auf ein zyklisches Auf- und Entladen hinaus laufen, was das 
Oszilloskop gezeigt hat.

A. S. schrieb:
> Alle meine Kabel kommen zusammen auf 200mR...
> Der Maximalstrom sind 10A

200mΩ · 10A = 2V (kein Zufall)

Langer Rede, kurzer Sinn: Viel mehr Kapazität am Eingang halte auch ich 
für richtig.

von Teo (Gast)


Lesenswert?

A. S. schrieb:
> Problemfrequenz

Soi ma an Jager rufen?! ;D

Stefan ⛄ F. schrieb:
> Langer Rede, kurzer Sinn: Viel mehr Kapazität am Eingang halte auch ich
> für richtig.

Wenn Ihm das nich sein NT Killt!

von Fritz (Gast)


Lesenswert?

Ruhig Blut, er will ja höhere C_ein verwenden...

A. S. schrieb:
> Fritz schrieb:
>> Und 10µF FolKo? (Oder mehrere kleinere FolKos parallel?)
>
> Habe ich tatsächlich ein paar ganz unten in der Kiste gefunden. Wenn ich
> da etwa 20µF dazu hänge (sehr hübsch), dann sind die Schwingungen
> deutlich reduziert. Laut meinen Messungen bleiben von den 2V noch 0.4V
> Amplitude übrig.

Vielleicht liegt es (der Rest) nur noch an den langen
Anschlußdrähten, und mit den 47µF ist alles weg.

A. S. schrieb:
> bei der korrekten Spannung

(die da wäre? ;) bitte eindeutig ausdrücken)

> Fritz schrieb:
>> Die L ist also zu hoch (Induktivität), und auch zu
>> "stark" (sie soll nur den im Normalbetrieb auftretenden
>> I_rms thermisch vertragen, und beim I_peak nicht voll
>> sättigen).
>
> seltsam. Als ich hier zuletzt gefragt habe, hieß es, das wäre schon
> okay.
> Kannst du nochmal erklären, warum die Induktivität nicht zu groß sein
> darf?

Sie "steht einem kompakteren Layout etwas im Weg". ;)

> Je nach Parameter in der Auslegungsrechnung mach dem Datenblatt komme
> ich schon auf 10µH - da finde ich 22µH nicht übertrieben, da ja oft mal
> 20% Toleranz drin sind.

Und wieso sollten (gesetzt den Fall, man möchte oder
braucht >= 10µH) dazu 15µH -20% nicht reichen?

Und dann noch das miteinbezogen:

> Über den Sättigungsstrom, denke ich, kann man wirklich reden. Es stimmt
> schon, dass die Spule nicht bis 2*I_rms voll läuft. Meine Überlegung
> war, dass der Maximalstrom des Reglers die Spule nicht in die Sättigung
> bringen soll. Der Maximalstrom sind 10A, laut Tabelle auf Seite 5 im
> RT8298 Datenblatt.

Das ist bei diesem Reglertyp unnötig. Hier darf man
die Drossel so dimensionieren, wie dargelegt. Daß
sie thermisch I_rms verträgt, ist das wichtigste -
die übertragene Leistung bei Kurzschluß begrenzt
dieses IC durch starke Absenkung der Schaltfrequenz.

Also könnte sie viel kleiner. (I_sat ist übrigens
auch nicht der Wert, bei dem nichts mehr übrig ist
von der L, sondern ein Wert relativ nahe I_rms -
bei welchem die L (laut Datenblatt) 30% gesunken
ist... was kein echtes Problem darstellt.)

> Die SRF liegt bei 7MHz. Darauf habe ich tatsächlich nicht geachtet. Wie
> sollte man die denn wählen?

Ich suche mir ehrlich gesagt möglichst welche aus im
Bereich SRF ca. 20fache (oder mehr) Schaltfrequenz.

Erhöhte Koppelkapazität (Förderung von Instabilität,
und auch erhöhte - unnötige - Verluste) und deutlich
höhere L als nötig (Reaktion langsam) sollten sich
eben nicht zu negativ auswirken.

(Nur, wenn ich nichts finde, nehme ich auch mal was
mit z.B. nur 15facher Schaltfrequenz - im Notfall.)

Zu Marks Einwurf:
Dieses Problem mag vielleicht nicht speziell dadurch
verursacht werden (also eine Drossel kleinerer Bauart
mit 15µH und z.B. 7A I_rms würde sicher nicht alles
ändern), aber positiv wirkt sich das auch nicht aus.

Und wer weiß, ob ein viel kleinerer Footprint nicht
sogar zu deutlicher Erleichterung beim Neudesign d.
Layouts

(das ich Dir vor der Anfertigung noch mal hier zur
Diskussion zu stellen rate)

führen würde.

Was ich grade noch gelesen habe (zuerst übersehen):

A. S. schrieb:
> wie das Kabel für 1.5A zu dünn sein soll

Bei Schaltwandlern wird doch in der Einschaltphase
die Drossel (mit U_ein als "treibende Spannung") auf-
geladen - d.h. es fließt mindestens 1/Tastgrad des
durchschn.-Eingangsstromes (bzw. der Ausgangsstrom)
währenddessen.

Und da eben nicht (oft "reichlich" dimensionierte)
Elkos wie bei niederfrequenter schaltenden Wandlern
dort sitzen, kommt es auf die (Rest-)Kapazität der
KerKos und die Impedanz der Zuleitung sehr stark an.

Daß o.g. KLEPS sich ebfs. negativ auswirken, glaube
ich sofort - ich habe keine, aber vertraue DZDZ.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.