Forum: Fahrzeugelektronik Gasgriff und Bremsgriffe E-Scooter elektrischer Aufbau


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Wegstaben V. (wegstabenverbuchsler)


Lesenswert?

mir ist vor kurzem ein E-Scooter "Xiaomi Mi 1S" zugelaufen.

Ausser einem mächtig schlappen Akku konnte ich (auch bei Probefahrten um 
den Block) nichts fehlerhaftes identifizieren.

Ich Depp hab den Roller draussen stehen lassen, in der Annahme das er 
wasserdicht sei ... war er nicht. Ein kräftiger Sturzregen hat ihn im 
Display Bereich absaufen lassen. So stand er seit 3 Tagen im Hof, und 
litt still vor sich hin.

Heute wollte ich mich noch mal dran geben (den Roller nutzen). Das 
Display ("Cockpit") war schon an, als ich das Teil aus der Ecke geholt 
habe. Ich konnte es nicht mehr ausschalten, und sah unter dem 
Displayglas ein kleines Wassertröpfchen. oh, oh, das bedeutet nix gutes.

ich konnte mit dem Scooter fahren (Gasgriff hat reagiert), aber war 
anscheinend im "ECO" Modus (d.h. langsame Beschleuingung, geringere 
Endgeschwindigkeit etc)

Also auf der Werkbank den Display-Deckel abgemacht, ausgepustet mit 
Luft.

Das Display ging dann aus, aber geht nicht mehr an.

Beim Einschalten blinkt die Rückleuchte 33 mal, das ist wohl ein Signal 
das was "mit der Verkabelung" nicht in Ordnung sei.

--> Hat jemand hier Ahnung, welche elektrischen Komponenten im Gsgriff 
bzw. in den Bremsgriffen (re und li) verbaut sind? Es geht jeweils PLUS, 
MASSE und SIGNAL? zu den genannten Komponenten.

Das wass ich da mit dem Multimeter ausmesse, scheint widersprüchlich zu 
sein

: Bearbeitet durch User
von Dieter (Gast)


Lesenswert?

Wegstaben V. schrieb:
> Ich Depp

Eigentor!

Wegstaben V. schrieb:
> Also auf der Werkbank den Display-Deckel abgemacht, ausgepustet mit
> Luft.

Hingen da die Kabel mit Spannung noch dran?

Wegstaben V. schrieb:
> Das Display ging dann aus, aber geht nicht mehr an.

Widerspruechlich ist das.

von Wegstaben V. (wegstabenverbuchsler)


Lesenswert?

Dieter schrieb:

> Hingen da die Kabel mit Spannung noch dran?

Yepp, da hätte ich dran denken sollen. ERST Spannungsfrei, dann an die 
Schaltung. Mist.

> Widerspruechlich ist das.

naja, im ersten Moment war die Display Anzeige noch ok. Tachostand, 
Ladestand. Ich konnte ja sogar noch fahren. Nur der Bedienknopf des 
Displays reagierte nicht (mehr).

Die Verbindung zwischen dem Display und dem Haupt-Steuersystem (im 
Fusstritt-Bereich) läuft über 4 Leitungen. Das kann nur +, gnd, RX und 
TX sein.

Auf der Display-Platine selbst ist ja auch noch ein Prozessor drauf, er 
wird die "sensorik" auswerten (Gas, Bremse) und die "Aktorik" (Anzeige, 
LED-Scheinwerfer) steuern.

Da das Display beleuchtet war und das Scooter reagierte, muss + und gnd 
"gut" gewesen sein. Da ich Gas geben konnte, und die veränderte 
Geschwindigkeit auf dem Display angezeigt wurde, muss RX und TX "gut" 
gewesen sein.

Ich befürchte allerdings, das die Displayplatine nunmehr gehimmelt ist.

fieserweise finde ich nur "Dashboard" für die Xiaomi M365 Modelle. Das 
S1 hat 4 E/A STecker: Gasgriff, Lampe, und ZWEI Bremsgriff-Sensoren. Die 
365er haben nur EINEN Bremsgriff-Sensor.

Vom Display sehen beide Modelle sich sehr ähnlich. Die S1-Platinen 
erkennt man an SIEBEN anstelle von SECHS Lötkontakten an der Oberkante 
der Platine (bei den 88 Ziffern)

====
Nachtrag:
VERDAMMT!
Da scheine ich aber mächtig Pech gehabt zu haben, und das Problem/der 
Schaden ist größer als gedacht! Grade hab ich folgendes gefunden:

https://rollerplausch.com/threads/xiaomi-m365-classic-pro-cfw-erstellen-flashen-drv-bms-ble-pro-dashboard.8/

und auf meiner Platine steht drauf: SCO BLE V3.2
.. mir schwant übles.

: Bearbeitet durch User
von Helge (Gast)


Lesenswert?

Ist denn sicher nirgendwo mehr Restfeuchtigkeit oder ggf. schwach 
leitende Ablagerungen?

von Wegstaben V. (wegstabenverbuchsler)


Lesenswert?

ich lasse den jetzt erst mal 2 Tage in Ruhe durchtrocknen. Vielleicht 
fängt er sich noch.

Was ich mittlerwiele rausgefunden habe: Anscheinend kann man (derzeit) 
die defekte Platine (genau dieses Platinen-Modell) NICHT kaufen.

Es sol jedoch möglich sein, die Platine eines nahezu ähnlichen M365 
Scooters umzuflashen mit einem ST-Link-Interface, und dort die S1 
Software drauf zu machen.

von Ralf X. (ralf0815)


Lesenswert?

Helge schrieb:
> Ist denn sicher nirgendwo mehr Restfeuchtigkeit oder ggf. schwach
> leitende Ablagerungen?

Woher soll der TE das wissen? :-)

Wir hatten in den 80ern eine Filiale, die von einem 
"Jahrhunderthochwasser" betroffen war und bis 1,35m kplt. unter Wasser 
(braune Drecksbrühe) stand.
Daher vorher in der Stadtgeschichte noch niemals vorgekommen, habe ich 
es auch versäumt, den Versicherungsumfang auf dieses Ereignis zu prüfen, 
das Risiko war nicht enthalten. :-(

Also galt da Schadensbegrenzung:
Mit weiteren MA bei sinkenden Wasserstand von Feuerwehr oder THW 
"Anglerhosen" ausgeliehen und per Schlauchboot hingefahren worden und 
sofort angefangen, alles ersteinmal selbst in der Drecksbrühe zu 
spühlen, damit sich keine Ablagerungen bilden.
Später dann natürlich mit Leitungswasser ausgespritzt, anschliessend 
mehrfach in leitungswassergefüllten Schäferkästen gespült.
Im Laufe der nächsten Tage kam alles in andere (trockene und gut 
belüftete) Räume, natürlich geöffnet/teilzerlegt und möglichst obtimal 
plaziert, teilweise Lüfter, Heizer, etc. unterstützt.
Und dann hiess es einfach nur noch abwarten und ja nichts zu früh 
elektrisch zu testen.

Das positive Ergebnis hat selbst mich massiv erstaunt und meine 
Erwartungen weit übertroffen!
Technisch wurden alle Geräte gerettet, überwiegend optische Schäden 
verblieben an Spannplattengehäusen und LS-Pappen.
Darunter befanden sich dann TV, Monitore, Standboxen, usw.
Nach ausgiebigen Tests konnte alles wieder in den Verkauf, natürlich mit 
deutlichem Rabatt, Hinweis auf Wasserschaden und ausdrücklich 
verlängerter Garantie.
Mir ist kein Fall bekannt, wo es bei diesen Teilen zu einer 
Inanspruchnahme der damals ungewöhnlichen Garantie kam.

Ich beschreibe diesen Fall so ausführlich, weil viel zu viele meinen, 
man müsste etwas nur einfach trockenpusten und dann den nächsten Versuch 
starten, wenn etwas an Stellen nass wurde, wo es nicht sein sollte.
Typisch heute, das in die Notebooktastatur gelaufene Heiss- oder 
Kaltgetränk, das ins Wasser gefallene Handy, etc..

von Helge (Gast)


Lesenswert?

Ich hatte nachgefragt, weil ich die Tage eine reparatur hier hatte. 
'Nur' eine Eismaschine. Die funktionierte immer so lange, bis der 
Eisbehälter grad gefroren war. Der Fehler wurde ausgelöst durch Betauung 
der nicht mehr 100% suberen Bedienplatine. Nur ganz wenig Staub, der 
schwach leitfähig wurde.

von Ralf X. (ralf0815)


Lesenswert?

Helge schrieb:
> Ich hatte nachgefragt, weil ich die Tage eine reparatur hier
> hatte.
> 'Nur' eine Eismaschine. Die funktionierte immer so lange, bis der
> Eisbehälter grad gefroren war. Der Fehler wurde ausgelöst durch Betauung
> der nicht mehr 100% suberen Bedienplatine. Nur ganz wenig Staub, der
> schwach leitfähig wurde.

Mal ganz ehrlich:
Sowas ordentlich dokumentiert, auch mit ggf. ersten Irrungen und 
Fehlversuchen, als TIPP hier einzustellen, wäre bedeutend wertvoller 
gewesen, als Dein Thread, dass Du es geschafft hast, ein Gerätegehäuse 
von allen Bestandteilen ausser dem dem NT zu befreien.
Und da Du eh weisst, dass Deine (einzige?) Cam scheinbar im Arsch ist, 
solltest Du ggf. mal ne Weile darauf verzichten, hier neue Arschbilder 
einzustellen, bis Du etwas neues gefunden hast.
Ausser, wenn es unheimlich pressiert.. :-)

von Dieter (Gast)


Lesenswert?

Ralf, warum so aggressiv?
Schlafprobleme, weil Du vielleicht in einem anderen Thread bei 
Unsachlichkeiten erwischt worden bist, oder das Gewitter Dich nicht 
ruhig schlafen laesst, Deine Frau Dich wegen Deines Schnarchens aufs 
Schlafsofa verbannt hat. ...

von Wegstaben V. (wegstabenverbuchsler)


Angehängte Dateien:

Lesenswert?

Helge schrieb:
> Ich hatte nachgefragt, weil ich die Tage eine reparatur hier hatte.
> ...
> Der Fehler wurde ausgelöst durch Betauung
> der nicht mehr 100% suberen Bedienplatine. Nur ganz wenig Staub, der
> schwach leitfähig wurde.

Ich habe die Platine selbst schon trocken geföhnt. Obwohl eine kleine 
Bluetooth Platine huckepack auf der Hauptplatine sitzt, glaube ich eher 
nicht daran, das sich darunter noch Wasser befindet. Aber wer weiss?

Die Elektrolyse hat zumindest ein Bein von einem Kondensator vernascht, 
ich muss da mal gründich nachsehen was da los ist unter/bei den SMD 
Bauteilen.

Die Platine hat wohl auch ein ST-Link, mit dem man diese neu flashen 
könnte.

--> ich hab mir jetzt mal bei ALiexpress so einen Adapter bestellt. Mal 
schauen ob der funktioniert, oder nur e-Schrott ist.

https://de.aliexpress.com/item/4001025262808.html

: Bearbeitet durch User
von Wegstaben V. (wegstabenverbuchsler)


Lesenswert?

Neuigkeiten von der Platine:

Vermutlich hat es da "nur" durch Elektrolyse ein paar Leiterbahnen und 
Kontakte aufgefressen. ich arbeite mich nun durch dei Schaltung

--> SOT23, Marking Code: 1CBT. Was ist das, wer hat ein Tip (ich 
vermute: Spannungsregler

von Wegstaben V. (wegstabenverbuchsler)


Lesenswert?

so, der Fehler ist behoben. Es war die Lühse, die Elektro-Lühse!

Es waren Kontakte/Leiterbahnen aufgefressen worden. Diese konnte ich 
flicken, und nun geht wieder alles.

Ich hab auch die ANtwort drauf, was da wohl in Bremse und Gas verbaut 
ist: Vermutlich Hall-Sensoren.

Und der Regler ist wohl ein SPX3819, und der war in Ordnung.

--

PS: Braucht jemand einen noch eingepackten und ungenutzten ST-Link 
Adapter gegen Anschaffungskosten?

: Bearbeitet durch User
von Wegstaben V. (wegstabenverbuchsler)


Lesenswert?

> Braucht jemand einen noch eingepackten und ungenutzten ST-Link
Adapter gegen Anschaffungskosten?

schubs ...

den ersten ST-Link Adapter hatte ich via Amazon und deutschen Absender 
recht schnell erhalten. Heute kam der zweite Adapter (direkt bei Ali 
bestellt) an.

nunmehr habe ich zwei Stück ST-Link V2, von denen ich möglicherweise 
maximal einen nutzen würde.

für 6 EUR incl. Versandkosten würde ich einen abgeben. Noch eingepackt, 
Farbe wählbar zwischen rot und blau.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.