Forum: PC Hard- und Software Komisches Mainboardboot - AMD Ryzen


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Max K. (pilzsporenwirt)


Lesenswert?

Hallo.

Im Video 
https://drive.google.com/file/d/1_T6Z_aOlpeHCxiGWNHK6CUahwJPcz0rM/view?usp=drivesdk 
bei Sekunde 7, gehen die Lüfter wieder aus. Und bei Sekunde 12 wieder 
an. Für 60 FPS @ 1080p bitte downloaden: 
https://drive.google.com/uc?id=1_T6Z_aOlpeHCxiGWNHK6CUahwJPcz0rM&export=download

Das was im Video zu sehen ist, passiert immer wenn, ich die elektrische 
Power Unit, erst wieder mit Elektrizität speise, kurz bevor ich das 
Mainboard einschalte. Also nach dem Ausschalten, schalte ich immer die 
Steckdosenleiste aus. Lasse ich die Steckdosenleisten nach dem 
Ausschalten, bis zum Anschalten unterbrechungsfrei an, also bleibt die 
elektrische Power Unit immer gespeist, entsteht das komische 
Bootphänomen nicht.

Im Ende des Videos wird dann, dass OS gestartet. Das LCD zeigt auch die 
CPU Temperatur an aber das offset beginnt nicht bei null.

Das Mainboard und die CPU ist AMD Ryzen Threadripper. Der Flüssige 
Speicher - RAM - ist ECC geschaltet. Die Elektrizität ist Haushaltsstrom 
in Deutschland. Die elektrische Power Unit ist ein digitales Corsair 
HX850i.

Darüber hinaus kriege ich unregelmäßig ein pfiebenden Crash. War früher 
öfter, inzwischen nur noch ca. alle 20 bis 30 Stunden ab Kaltstart und 
Neustart. Windows Ruhezustand benutze ich aber oft. Also beginnt die 
Zeit nach einem Start aus dem Ruhezustand nicht wieder bei null.

Die eingebauten flüssigen Speicher - RAM - haben sich bei mehreren 
Testungen als nicht korrupt erwiesen. Die SSD wo das OS gespeichert ist, 
scheint auch fehlerfrei.

Die Batteriespeisung im Mainboard ist gegeben. Die Uhrzeit und das Datum 
sind normal.

: Bearbeitet durch User
von Achim M. (minifloat)


Lesenswert?

Max K. schrieb:
> Das was im Video zu sehen ist, passiert immer wenn, ich die elektrische
> Power Unit, erst wieder mit Elektrizität speise, kurz bevor ich das
> Mainboard einschalte. Also nach dem Ausschalten, schalte ich immer die
> Steckdosenleiste aus.

Mit der Interpunktion kann ich dir leider nicht helfen. Na gut, ich 
versuche es 'mal:

Wenn die PSU am Strom bleibt, bleibt das Powermanagement initialisiert.

Wenn die PSU vom Strom getrennt wurde, wird das Powermanagement neu 
initialisiert.

mfg mf

von Max K. (pilzsporenwirt)


Lesenswert?

Achim M. schrieb:
> Wenn die PSU am Strom bleibt, bleibt das Powermanagement initialisiert.
>
> Wenn die PSU vom Strom getrennt wurde, wird das Powermanagement neu
> initialisiert.
>
> mfg mf

Also die PSU startet neu und nimmt dabei dem Mainboard die elektrische 
Speisung kurz weg, was zu einem BIOS Neustart führt? Ist das bei 
digitalen PSUs immer so oder ist Powermanagement ein optionales feature? 
Unabhängig ob Multi- oder Single-Rail?

von Schlaumaier (Gast)


Lesenswert?

Den selben Theater hatte ich bei meinen alten Asus Board in ähnlicher 
Form.

Wenn der Saft richtig weg war Rechner aus. (Ohne Steckerziehen) blieb 
das Board immer mit CPU-FAN Fehler stehen. Wenn ich dann auch den 
Reset-Taster drückte, lief es sauber durch.

Ich durfte nur keine Festplatte > 2 TB dranhängen. ;) Die hat das Bios 
auch nicht gefressen.

Ich habe mich mit mir selbst geeinigt, das die Lüfter zu langsam 
gestartet sind, und das Bios der Meinung war, sie wären zu langsam. Bei 
den Reset danach hatten die Lüfter noch Schwung um kamen so schneller in 
die Gänge, und das Bios hat die Speed erkannt.

Ich denke auch, das dein Powermanagement die Lüfter prüft und dabei sie 
kurz neu startet, um Fehlmeldungen zu entdecken. Kein Strom = andere 
Drehzahl = Lüfter läuft. Jedenfalls so in der Art.

von bluppdidupp (Gast)


Lesenswert?

Asus-Mainboard? Ggf. zuletzt angezeigten Q-Code checken: 
https://www.asus.com/en/support/FAQ/1043948/
Könnte auch sein, dass er da regulär Memory Training macht (und das 
sonst weglässt sofern er noch am Saft war)

von Achim M. (minifloat)


Lesenswert?

Max K. schrieb:
> ist Powermanagement ein optionales feature?

Optional ist das seit ATX schon nicht mehr. Das tolle Power- und 
Thermal-Management ist ein eigener kleiner Computer mit kleinem 
Betriebssystem und kleiner Applikation. Der muss halt erstmal starten. 
Und bevor der hochgefahren ist, sind die Lüfter vorsichtshalber auf 
Vollgas.
Dann kommt nach dem eigenen Start das Betriebssystem vorbei und 
initialisiert den beim Treiber laden nochmal neu. Nochmal Vollgas.

Wenn du den Saft an lässt, bleibt die Standby-Versorgung der PSU an. 
Damit bleibt auch die Konfiguration des Powermanagement erhalten.

mfg mf

: Bearbeitet durch User
von Roland E. (roland0815)


Lesenswert?

Das ein Mainboard eigentlich auch ohne Prozessor funktioniert ist wohl 
für die Meisten neu.

Natürlich hindert nichts die Mainboarddesigner daran, Basisfunktionen 
wie Kühlung (Lüfter), Versorgungen und alles was am SM-Bus hängt direkt 
nach dem Anlegen der StandByspannung zu prüfen und Betriebsbereit zu 
machen. Praktisch ist der Rechner ja an, sobald Strom anliegt. Nur die 
CPU, Chipsatz mit Anhängen und RAM ist angehalten.

von Michael U. (amiga)


Lesenswert?

Hallo,

Roland E. schrieb:
> Das ein Mainboard eigentlich auch ohne Prozessor funktioniert ist wohl
> für die Meisten neu.
welches denn und was heit funktioniert für Dich?

> Natürlich hindert nichts die Mainboarddesigner daran, Basisfunktionen
> wie Kühlung (Lüfter), Versorgungen und alles was am SM-Bus hängt direkt
> nach dem Anlegen der StandByspannung zu prüfen und Betriebsbereit zu
> machen. Praktisch ist der Rechner ja an, sobald Strom anliegt. Nur die
> CPU, Chipsatz mit Anhängen und RAM ist angehalten.

Hilfs-Controller gibt es oft auf aktuellen Boards, öfter sogar 8Bit-AVR.
Insofern stimmt es daß z.B. Lüfter u,ä, direkt bei Anschalten der 
Netzspannung geprüft werden. Versorgt wird das aus den 5V StandBy des 
Netzteils, der Rest ist aus wenn der Rechner komplett runtergefahren 
wird.
Angehalten wird da nichts, das wäre bei Ruhezustand u.ä., aber das ist 
dann nicht runtergefahren.

Gruß aus Berlin
Michael

von X2 (Gast)


Lesenswert?

Mein Tipp wäre, der Rechner macht bei jedem Start, wenn das Netzteil aus 
war, Speichertraining. Normalerweise passiert das, wenn die CMOS 
Batterie leer ist. Aber du sagst ja die wäre gut.

von Rudi Ratlos (Gast)


Lesenswert?

Grundsätzlich:
wird über "5V_STD_BY" das Board eingeschaltet über die PWR-Pins, die das 
Netzteil einschalten.
Dann beginnt der Power-ON--Self-Test (POST). Die CPU läuft jetzt auf 
100%, darum auch der Lüfter auf Vollgas. Es wird -jedesmal- das ganze 
System abgefragt, ob es mit der gespeicherten Konfiguration 
übereinstimmt. Tauschst oder entfernst eine Festplatte, dauert das 
'Einlesen' (Booten) eben (viel) länger.

Schaltest das Netzteil ein, muß es erstmal "5V_STD_BY" bereitstellen. 
Dann schaltest 'es' ein, es läuft aber erst an --und das ist je nach 
Netzteil eben unterschiedlich-- manche ohne Last, manche bei 5V manche 
bei 12V und manche brauchen auf ALLEN Spannungen-eine Last-- und danach 
erst kann das Board starten, wenn alle Sannungen da sind. Konkret ist 
das ein gegenseitiger Regelprozess. Wie das mit "digitalen" Netzteilen 
läuft, kann ich nicht sagen. Aber nachdem es schon bei "analogen" 
Netzteilen so ein komplizierter Regelvorgang ist ..

Außerdem hängt der ganze Start-Vorgang auch wesentlich am UEFI/BIOS und 
damit auch am Board/Prozessor. , weshalb 'alles normal ist' . Mein(e) 
FX-8320 starten auch anders (wie ein Düsenjet) als Intel-CPUs .


Ich kann auf deinem Video nichts Außergewöhnliches entdecken. Die 
POST-Prozesse werden angezeigt, laufen normal. Da alles normal läuft, 
würde ich mir keine Sorgen machen.
Warum sich der Lüfter aus-einschaltet wird wohl am POST liegen. Schau 
einfach mal im Manual, was die zeitlich zuständigen 'Codes' genau 
bedeuten, dann weißt auch sofort, wann und warum irgendwelche 'Probleme' 
auftreten. Dafür ist dieses Zeug ja da!

von Rudi Ratlos (Gast)


Lesenswert?

Das Board fährt hoch bis 'b7' ... und schaltet bei '05'  auf 'RESET'
offensichtlich. Also was bedeutet '05' genau

von Rudi Ratlos (Gast)


Lesenswert?

Spiel dein Video einfah in Super-Zeitlupe ab,
könnte auch '55' sein, aber soviele POST-codes gibts ja sowieso nicht !

von Rudi Ratlos (Gast)


Lesenswert?

Wenn das zu nihts führt:
Nach reiflicher Überlegung, da der reboot nur nach PowerOff auftritt,
könnte es sich auch um eine Einstellung in einem -flüchtigen- Speicher 
handeln.
Für windoof gibts spezielle Einstellungen, da dieses (früher mal) im 
"Ultra-Fast"-Mode booten kann, was nur ein StandBy-Trick ist/war, also 
eine Überprüfung zu einem "Temp-Speichern" führt und dann nochmal 
rebootet wird/werden muß.
Diese Einstllungen verschwinden aber bei PowerOff.

Überprüfe also noch jene UEFI-Einstellungen, die zu win8 und winX 
gehören. Dazu gehören auch "SecureBoot" und so unnützer Scheiß. Mit dem 
die 'Proprietären' die Macht über deinen PC erlangen wollen ... wollten 
.

von Reinhard S. (rezz)


Lesenswert?

Max K. schrieb:
> Der Flüssige Speicher - RAM - ist ECC geschaltet.

Seit wann ist RAM flüssig?

Schlaumaier schrieb:
> Wenn der Saft richtig weg war Rechner aus.

Das muss an dir liegen, bisher liefen alle meine Rechner auch ohne 
Strom.

Achim M. schrieb:
> Das tolle Power- und
> Thermal-Management ist ein eigener kleiner Computer mit kleinem
> Betriebssystem und kleiner Applikation. Der muss halt erstmal starten.
> Und bevor der hochgefahren ist, sind die Lüfter vorsichtshalber auf
> Vollgas.

Alternativ kann man das auch als Funktionsüberprüfung via Drehzahl 
sehen.

> Dann kommt nach dem eigenen Start das Betriebssystem vorbei und
> initialisiert den beim Treiber laden nochmal neu. Nochmal Vollgas.

Ist mir bisher nicht begegnet.

: Bearbeitet durch User
von Michael X. (Firma: vyuxc) (der-michl)


Lesenswert?

Rudi Ratlos schrieb:
>  Also was bedeutet '05' genau

Suspend state 5. Also power off.

von Rudi Ratlos (Gast)


Lesenswert?

Michael X. schrieb:
> Suspend state 5. Also power off.

Also eh richtig.
Interessant ist, zu diesem Biostar-Board (AMD-A4),
da (war) genau dasselbe : Es fährt rauf bis zur Anzeige -
dann bootet es nochmal - und !dann erst! fährt es durchrauf.
Habs ja 200mal gestartet in wenigen Tagen !

Möglicherweise! ist das ein AMD-Spezifikum.

von Rudi Ratlos (Gast)


Lesenswert?

Vielleicht werden im *CPU(-Cache)* irgendwelche 'Daten' vorrätig 
gehalten, da das Board ja via 5V_SB dauerversorgt wird, welche zur 
korrekten!! Funktion NB/SB notwendig sind. Diese sind dann bei Power-OFF 
verschwunden.

Ist nur eine Vermutung, aber seltsam ist dieser Doppel-BOOT jedenfalls.

von Rudi Ratlos (Gast)


Lesenswert?

Oder anders ausgedrückt:
Ein (AMD-)PC kann grundsätzlich nur 'warm' booten , niemals 'kalt'.

von Rudi Ratlos (Gast)


Lesenswert?

Um den Beweis für diese kecke Behauptung zu führen - oder
um dieses Phänomen, sofern es unerwünscht ist, zu vermeiden -

Man hängt einfach einen Super-Cap an die 5V_SB Leitung ...


und schaut wie lange er die 5V hält.

von Schlaumaier (Gast)


Lesenswert?

Rudi Ratlos schrieb:
> dann bootet es nochmal - und !dann erst! fährt es durchrauf.
> Habs ja 200mal gestartet in wenigen Tagen !
>
> Möglicherweise! ist das ein AMD-Spezifikum.

Ich tippe eher auf eine Sicherheits-Schaltung.

Wenn beim ersten mal er die zu hoche Übertacktung im Bios erkennt und 
dann erkennt das diese Werte den Prozessor überlasten startet er neu und 
senkt die Leistung ab.

Machen viele Programme doch auch. "Diese Änderungen erfordern einen 
Neustart.". Hat mir mein Windows-10 nach 6 Wochen aus, heute 2 x gesagt 
;)

Ich würde man die Bios-Batterie tauschen und dann im Bios die Werte für 
Taktrate etc. ändern. Vielleicht hilft auch ein Bios-Update.

Ist aber nur eine logische Vermutung.

von Michael X. (Firma: vyuxc) (der-michl)


Lesenswert?

Rudi Ratlos schrieb:

> Interessant ist, zu diesem Biostar-Board (AMD-A4),
> da (war) genau dasselbe : Es fährt rauf bis zur Anzeige -
> dann bootet es nochmal - und !dann erst! fährt es durchrauf.

Manche Register brauchen einen Powercycle zum Konfigurieren

> Möglicherweise! ist das ein AMD-Spezifikum.

Oder Bios-Hersteller.

von Rudi Ratlos (Gast)


Angehängte Dateien:

Lesenswert?

Schlaumaier schrieb:
> Ist aber nur eine logische Vermutung.

Die einzige "logische Vermutung" lautet : Was soll das mit : 5V_SB ?
Wozu braucht ein PC --Dauerstrom ?


Michael X. schrieb:
> Manche Register brauchen einen Powercycle zum Konfigurieren

Wäre eine mögliche Erklärung!
Das Problem ist ja, daß ein PC im Inneren eine irrsinnig riesige Welt 
ist. Man weiß also nicht genau, was in der NB/SB genau passieren muß, 
damit der Zweck erreicht wird. Und das Booten selbst ist ein irrsinnig 
schneller Vorgang, der schwer beobachtbar ist .

> Oder Bios-Hersteller.
Glaube ich nicht.
Ich habe leider beim ASRock (intel J3455M) nicht auf dieses 
Doppel-Booten  geachtet, ((habe ja beide Boards für LM2596-Betrieb 
vorgesehen und auch betrieben)) , der hing auf "PWR_OK" mit 5V ... das 
Biostar aber auf "5V_SB" .
!Offensichtlich! ist es bei mehreren Boards so, daß ohne 5V_SB das Board 
doppelbootet. Daher wird der PC gar nie "ausgeschaltet" sondern bleibt 
immer (im Stand-By) "eingeschaltet" und verbraucht Strom. Aber wo geht 
der Strom hin?


Hat ein PC-Netzteil Strom, liefert es (bloß) sofort Dauerstrom an 5V_SB 
.
Über PS#ON + GND schaltet man es dann EIN. Dazu braucht man keinen PC . 
PWR_OK (vmtl. TTL-Pegel-Signal: 3,3-5V) ) signalisiert dem Board, daß 
das Netzteil korrekt arbeitet. Manche Boards brauchen diese Leitung, 
manche aber offensichtlich nicht. Bei 5V_SB bin ich im Zuge dieser 
Diskussion aber unsicher geworden, da manche diese Leitung zum STARTEN 
NICHT brauchen, wofür diese genau dienen soll


Bastler-Hinweis: Läßt es sich (ohne PC! als Labor-Netzteil, etc..) so 
nicht einschalten, gibts wegen der vielen "Retourleitungen" nicht mehr 
viel umzubauen. Bei manchen muß nämlich an sämtlichen ATX-Anschlüssen 
(HP,Compaq) eine Last hängen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.