Forum: Analoge Elektronik und Schaltungstechnik Displayschaden durch neues Display


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Dietmar P. (wodipo)


Angehängte Dateien:

Lesenswert?

Hallo Zusammen,

kann jemand dieses Fehlerbild zuordnen? Es ist ein Motoradcomputer bei 
dem das Display erneuert wurde.
Ohne das ein ersichtlicher Fehler gemacht wurde, ergibt sich plötzlich 
dieser Bildschirminhalt. Das Gerät lief vorher, bis auf fehlenede Zeilen 
im Display.

Das Display ist auch handempfindlich, irgendwo schwirrt HF rum. Wenn man 
es mit der Hand an den Anschlüsse "bedämpft" kann das halbe "Bild", 50%, 
plötzlich verschminden. Kein Wackelkontakt.

von H. H. (hhinz)


Lesenswert?

Dietmar P. schrieb:
> Kein Wackelkontakt.

Ein dauerhaft fehlender Kontakt!

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Offener Anschluss, vermutlich an einer Datenleitung. Kann eine schlechte 
Lötstelle sein oder auch eine durchgerissene Leiterbahn.

von Dietmar P. (wodipo)


Lesenswert?

Das wäre dann eine Erklärung.
Ich fürchte das Board ist ein Multilayer (4-fach), wo sich innere 
Lage(n) in der Durchkontaktierung abgelöst haben könnten, weil es schon 
mal repariert wurde.

von Hp M. (nachtmix)


Lesenswert?

Matthias S. schrieb:
> Offener Anschluss,

Oder ein Kurzschluss.
Der Anschluss des Kabels sieht etwas, nun ja, gewöhnungsbedürftig aus, 
und auch die Verbindungen zwischen den Platinen entsprechen nicht dem 
üblichen Standard.

P.S.: Vielleicht entfernst du einfach mal die verlorenen blanken 
Drahtenden, von denen eines oberhalb des Displays zu sehen ist.

: Bearbeitet durch User
von Franz M. (elmo64)


Lesenswert?

Dietmar P. schrieb:
> Ohne das ein ersichtlicher Fehler gemacht wurde, ergibt sich plötzlich
> dieser Bildschirminhalt.

Wenn das so wäre, hättest du keinen Grund hier um Hilfe bitten.

> kann jemand dieses Fehlerbild zuordnen? Es ist ein Motoradcomputer bei
> dem das Display erneuert wurde.

Hast du ein Originalersatzteil oder ein sicher kompatibles benutzt, oder 
nur ein beliebiges, das zufällig ähnlich aussieht? Wir reden hier 
immerhin vom Automotive-Bereich mit vielen kundenspezifischen Lösungen.
Ist die Pinbelegung identisch und/oder richtig verdrahtet?(!!!!!!!!)
Verbindungen auf Kurzschlüsse überprüft und Durchgepiept?
Bei identischer Pinbelegung alles nochmal entfernen und geeignete 
Verbindungsmöglichkeiten anstelle von Einzeladern benutzen.
Natürlich könnte auch ein Schaden durch ESD entstanden sein.

Dietmar P. schrieb:
> Ich fürchte das Board ist ein Multilayer (4-fach), wo sich innere
> Lage(n) in der Durchkontaktierung abgelöst haben könnten

Falls du nicht zu heiß gelötet hast und die Platine mechanisch belastet 
wurde, hierbei meine ich vor allem das Auslöten des alten (THT?) 
Displays ohne geeignetes Equipment, sollte da nichts defekt sein.

: Bearbeitet durch User
von Peter D. (peda)


Lesenswert?

Sehr vertrauenswürdig sehen die 16 roten Drähte an der Unterkante aber 
nicht aus. Ich würde das alles nochmal auslöten, säubern und neu 
einlöten. Falls das Litze ist, würde ich besser Volldraht nehmen 
(Tefzeldraht).

Und ein Foto posten, wo man auch was erkennen kann.

von Stefan ⛄ F. (stefanus)


Lesenswert?

Mich macht das Stück blanker draht stutzig, dass da auf dem Tisch liegt.

Hat die Platine mal darauf gelegen? Oder auf einem anderen Stück Metall?

Wer so unsauber arbeitet, darf sich nicht wundern.

von Dietmar P. (wodipo)


Angehängte Dateien:

Lesenswert?

Super,
danke euch.
Ich kenne jetzt nicht die physikalische Ursache bei so einem grafischen 
Display (Multiplex?), das eine einzelne fehlende Verbindung so eine 
Verwürfelung im Display ergeben kann.

Unter dem Mikroskop habe ich eine 0,5mm breite angekratzte Leiterbahn 
gefunden, die beim Silikonwegkratzen der alten Verkabelung entstanden 
ist. Siehe weisser Pfeil.
Es funktioniert wieder.

von Klaus W. (mfgkw)


Lesenswert?

Dietmar P. schrieb:
> Es funktioniert wieder.

Schön!

Aber schön aussehen tut die Stelle nicht wirklich.
Ist das so korrodiert? Vielleicht würde ich das vor dem Einbau erstmal 
wieder etwas sauber machen, Flußmittelreste ordentlich abwaschen und 
vielleicht etwas konservieren.

Auf dem Motorrad korrodiert das sonst gleich weiter und wird dann auch 
nicht mehr alt.

von Dietmar P. (wodipo)


Lesenswert?

Die Stelle ist mit dem roten Draht gebrückt.

Weiss noch jemand, warum bei einer einzigen Unterbrechung der ganze 
Displayinhalt verwürfelt wird?

von Stefan ⛄ F. (stefanus)


Lesenswert?

Dietmar P. schrieb:
> Weiss noch jemand, warum bei einer einzigen Unterbrechung der ganze
> Displayinhalt verwürfelt wird?

Eins der (vermutlich) 8 Bits hängt in der Luft. Es reagiert daher auf 
Radiowellen ebenso wie auf Berührung indem es zufällige Werte annimmt. 
Denn jede offene Leitung ist eine Antenne. Dementsprechend werden die 
Kommandos und Nutzdaten der Übertragung verwürfelt.

: Bearbeitet durch User
von Klaus W. (mfgkw)


Lesenswert?

Stefan ⛄ F. schrieb:
> Dietmar P. schrieb:
>> Weiss noch jemand, warum bei einer einzigen Unterbrechung der ganze
>> Displayinhalt verwürfelt wird?
>
> Eins der (vermutlich) 8 Bits hängt in der Luft. Es reagiert daher auf
> Radiowellen ebenso wie auf Berührung indem es zufällige Werte annimmt.
> Denn jede offene Leitung ist eine Antenne. Dementsprechend werden die
> Kommandos und Nutzdaten der Übertragung verwürfelt.

Oder ein Bit eines jeden Datenworts und/oder Adresse ist immer 0 oder 1.
Das muss gar nicht in der Luft hängen.

von Dietmar P. (wodipo)


Lesenswert?

Auch wenn alle Anschlüsse dran sind, habe ich auch schon mal eine 
(HF-)Handempfindlichkeit festgestellt, dass je nach Lage und kapazitiver 
Bedämpfung des Displays Segemente anfangen zu flackern.

Ist das der extremen Hochohmigkeit oder Gleichrichtereffekten der 
Datenleitungen geschuldet und "üblich" bei Grafikdisplays?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Dietmar P. schrieb:
> und "üblich" bei Grafikdisplays

Das hängt weniger mit Displays als mit der CMOS Technologie im 
Allgemeinen zusammen. CMOS hat sehr hochohmige Eingänge, verbraucht u.a. 
deswegen sehr wenig Strom, ist aberauch deswegen empfindlich gegenüber 
offenen Leitungen und herumschwirrenden Feldern.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.