Forum: Mikrocontroller und Digitale Elektronik Heizungsregler auf Basis eines Atmel Mega128


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Naj H. (janiiix3)


Angehängte Dateien:

Lesenswert?

Hallo Community,

ich habe hier vor mir einen Heizungsregler ohne Schaltplan.
Was ich bis jetzt herausfinden konnte ist das die Versorgungsspannungen 
alle vorhanden sind, ich den Atmel ohne Probleme auslesen kann.

Das Problem ist folgendes..
Ein Relais auf der Leistungsplatine wird zyklisch angesteuert, circa 
jede Sekunde.
Das Display blinkt auch nur und zeigt nichts weiter an.. Als wenn es 
überhaupt nicht korrekt initialisiert werden könnte.
Leider komme ich an den Controller für das Display und den Atmel nicht 
näher dran da das Display auf der Platine verlötet ist und nicht gerade 
wenig Pins hat und dort drunter sich die Logik befindet.

Leider habe ich nur Fotos und ein Video welches ich nur zur Verfügung 
stellen könnte..

Hat jemand vielleicht einen Tipp?

von Thomas F. (igel)


Lesenswert?

Naj H. schrieb:
> Ein Relais auf der Leistungsplatine wird zyklisch angesteuert, circa
> jede Sekunde.
> Das Display blinkt auch nur und zeigt nichts weiter an.. Als wenn es
> überhaupt nicht korrekt initialisiert werden könnte.

Elkos der Spannungsversorgung tauschen.

von A. H. (pluto25)


Lesenswert?

Betriebspannung mit nem Ozzi prüfen. Vielleicht verursacht das Relas 
einen Unterspannungsreset?

von Pandur S. (jetztnicht)


Lesenswert?

Wenn das Display nichts zeigt koennte die Kontrastspannung verschoben 
sein. Wie mein Vorposter meinte : Speisung kontrollieren

von Naj H. (janiiix3)


Lesenswert?

Hallo,

es funktioniert wieder. Mal wieder viel zu kompliziert gedacht.
Nach dem Gleichrichter das LN angeschlossen und Steuerung funktioniert 
wunderbar.
Es war der 470µF Elko. Danke!

von Kurzwelle (Gast)


Lesenswert?

Spannungsversorgung.
Die Kopfzelle auch mal prüfen

von Kurzwelle (Gast)


Lesenswert?

Sicher das der ohne Sensoren überhaupt anläuft?
Womöglich prüft er danach und zeigt deshalb dieses Verhalten.
Bau ihn in die Heizung ein und prüfe, das ist sein gewohntes Umfeld.
Oder erzählst Du uns nicht die ganze Geschichte?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.