Forum: Analoge Elektronik und Schaltungstechnik Gabellichtschranķe tcst2103 soll Masse schalten


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Alex J. (hoer173)


Lesenswert?

Moin moin

Folgendes Problem:

2 Gabellichtschranken werden als Index (1 Schlitz) und Drehencoder (90 
Bohrungen) an einer Drehbank verwendet.

Durch das Index Signal ist es möglich die Z Achse mit der Spindel zu 
synchronisieren um Gewinde zu drehen.

mit dem Drehencoder kann man zb die X achse mit der Spindel 
Synchronisieren um ein 6 Kant zu drehen.

naja Orginal waren ps4001 verbaut die aber leider nicht mehr ganz sauber 
liefen.

ersetzt wurden diese durch tcst2103 Gabellichtschranken.

das Signal schicke ich 2 mal durch einen Schmitt Trigger 74c14.

Am ende bekomm ich dann ein sauberes Rechtecksignal.

Dieses Signal muss nun auf die Schnittstellenkarte gelegt werden.

Die Schnittstellenkarte erwartet am Eingang ein GND Signal.

Ich hab diverse Standart Opv hier, Transistoren npn pnp, Optokoppler, 
Lm320 lm321 lm322 lm393 uvm.

Nun ist die frage... wie realisiere ich das???

Drehzahlen sind 10-2000Umin.

bei 90 Bohrungen.. 180000 Signale in 1Min.


danke

von Katzenjammer (Gast)


Lesenswert?

Alex J. schrieb:
> Ich hab diverse Standart Opv hier, Transistoren npn pnp, Optokoppler,
> Lm320 lm321 lm322 lm393 uvm.
>
> Nun ist die frage... wie realisiere ich das???

Am einfachsten wohl mit dem npn Transistor

Alex J. schrieb:
> bei 90 Bohrungen.. 180000 Signale in 1Min.

Die 3 kHz Das dürften weder für die Transistoren noch für die 
Optokoppler ein Problem sein. Wenn Du keine optische Trennung brauchst, 
dann wäre das wohl am einfachsten mit einem invertierenden 
Schmitttrigger umzusetzen...
In Deinem Fall also nicht zwei 74HC14 Gatter hintereinander, sondern nur 
einmal.

Ansonsten wohl ein npn Transistor...

von H. H. (Gast)


Lesenswert?

Alex J. schrieb:
> naja Orginal waren ps4001 verbaut die aber leider nicht mehr ganz sauber
> liefen.
>
> ersetzt wurden diese durch tcst2103 Gabellichtschranken.

Einfach durch passende ersetzen: OPB853

von Alex J. (hoer173)


Lesenswert?

Danke euch beiden.

wie verschalte und beschalte ich den den npn? bc337 wäre wohl i.o. oder?

danke für eure mühe

von Stefan F. (Gast)


Lesenswert?

Alex J. schrieb:
> wie verschalte und beschalte ich den den npn? bc337 wäre wohl i.o. oder?

Zeige doch erstmal die Schaltung, wo das integriert werden soll. Nur 
dann kann man einen hilfreichen konkreten Vorschlag machen.

von Katzenjammer (Gast)


Lesenswert?

1
 
2
                                  VCC
3
                                   |
4
                                 [100K]
5
                                   +-------> Output
6
[74HC14]------>[5K]-----> (Basis)-<
7
                                   |
8
                                   |
9
                                  GND

von Stefan F. (Gast)


Lesenswert?

Katzenjammer schrieb:
> 100K

Sicher 100k? Ich hätte hier eher 2,2kΩ oder so ähnlich erwartet.

von Michael M. (Firma: Autotronic) (michael_metzer)


Lesenswert?

Stefan ⛄ F. schrieb:
> Katzenjammer schrieb:
>
>> 100K
>
> Sicher 100k? Ich hätte hier eher 2,2kΩ oder so ähnlich erwartet.

Der Pull-Up ist vermutlich schon auf der Schnittstellenkarte mit drauf. 
Hier genügt ein BC337 mit offenem Kollektor und mit einem 4k7 
Basisvorwiderstand.

von H. H. (Gast)


Lesenswert?

Michael M. schrieb:
> Der Pull-Up ist vermutlich schon auf der Schnittstellenkarte mit drauf.

Es wäre sinnvoll dort die Spannung zu messen.

von H. H. (Gast)


Lesenswert?

Alex J. schrieb:
> Schmitt Trigger 74c14.

Wirklich einen "C"? Mit welcher Versorgungsspannung betrieben?

von Alex J. (hoer173)


Lesenswert?

vielen dank

ja 74hc14
versorgung ist am sensor und am s.trigger 5v

ich versteh nur noch bahnhof.

ich muss gnd auf den eingang legen.
zurzeit mach ich das per relais.... ist ja grütze.

relais schaltet mit den 5v.
 am relais..am einen pin gnd und am anderen der eingang an der 
schnittstelle.

: Bearbeitet durch User
von H. H. (Gast)


Lesenswert?

Alex J. schrieb:
> ja 74hc14

Also "HC", nicht "C"!


> ich muss gnd auf den eingang legen.

Und wieviel Spannung liegt dort an?

von Alex J. (hoer173)


Lesenswert?

Hc definitiv.

das hab ich nicht geprüft was anliegt da ich bisher mit dem relais zum 
ziel kam aber es ist halt nicht elegant.

im endefekt ist das eine lpt schnittstelle mit herausgeführten 
kontakten.
druckerschnittstelle.

danke

von H. H. (Gast)


Lesenswert?

Alex J. schrieb:
> das hab ich nicht geprüft

Dann mach das jetzt.

von Alex J. (hoer173)


Lesenswert?

in 2 std bin ich wieder vor ort.

dann mess ich mal.

bisher hab ich mir nie gedanken gemacht welche spannung dort anliegt.

danke

von Stefan F. (Gast)


Lesenswert?

Messe nicht nur die Spannung, sondern auch die Stromstärke, wenn du den 
Eingang durch das Multimeter (im 200mA Bereich) mit GND verbindest.

von Alex J. (hoer173)


Lesenswert?

also ich müsste aus einem pnp sensor ein npn sensor machen richtig?

danke

von H. H. (Gast)


Lesenswert?

Messen, nicht raten.

von Alex J. (hoer173)


Lesenswert?

So. sorry für die verspätung.
zwischen eingang und gnd messe ich 4.91 Volt.

schalte ich auf 200mA mit Kanal 200m werden mir 0.5 angezeigt.

da ist die überlegung einfach einen optokoppler zu nutzen wohl das 
einfachste.

oder was schlägt ihr so vor??

danke

von H. H. (Gast)


Lesenswert?

Alex J. schrieb:
> zwischen eingang und gnd messe ich 4.91 Volt.
>
> schalte ich auf 200mA mit Kanal 200m werden mir 0.5 angezeigt.
>
> da ist die überlegung einfach einen optokoppler zu nutzen wohl das
> einfachste.
>
> oder was schlägt ihr so vor??

Einfach direkt anschließen.

von Wolfgang (Gast)


Lesenswert?

H. H. schrieb:
> Es wäre sinnvoll dort die Spannung zu messen.

... und den Strom.

von jo (Gast)


Lesenswert?

Alex J. schrieb:
> Dieses Signal muss nun auf die Schnittstellenkarte gelegt werden.
> Die Schnittstellenkarte erwartet am Eingang ein GND Signal.
> Nun ist die frage... wie realisiere ich das???

Eine Diode plus Pull-up-Widerstand sollte es tun.

von H. H. (Gast)


Lesenswert?

jo schrieb:
> Alex J. schrieb:
>> Dieses Signal muss nun auf die Schnittstellenkarte gelegt werden.
>> Die Schnittstellenkarte erwartet am Eingang ein GND Signal.
>> Nun ist die frage... wie realisiere ich das???
>
> Eine Diode plus Pull-up-Widerstand sollte es tun.

Völlig überflüssig, einfach direkt dran.

von Stefan F. (Gast)


Lesenswert?

Alex J. schrieb:
> da ist die überlegung einfach einen optokoppler zu nutzen wohl das
> einfachste.

Ja sehe ich auch so.

Sorge nur dafür, dass er mit mindestens 2mA angesteuert wird, dann bist 
du auf der sicheren Seite.

von Alex J. (hoer173)


Lesenswert?

So!
ich habe mal einiges versucht.
jedoch bekomm ich kein stabiles signal!
ich werd morgen nochmal inruhe gucken.

die gabellichtschranke gibt ein extrem unsauberes signal von sich.

ich muss wohl vor dem schmitttrigger filtern.

von Alex J. (hoer173)


Lesenswert?

so freunde der sonne.

mittlerweile funktioniert alles soweit.
zumindestens auf dem breadboard.


lichtschranke auf schmitt triger von dort auf einen optokoppler rein in 
die schnittstelle.

ich muss mich mal nach einer vernünftigen lichtschranke mit darlington 
transistor umsehen.

die ps4001 die ich habe geben trotz das sie verkorkst sind ein besseres 
signalbild zum 74hc14 als diese china knaller.

tja wo bekomm ich in deutschland vernünftige her.
weder weis ich wonach ich wo suchen soll.

bei mouser gibts welche aber 20 euro versand?!

danke

von Stefan F. (Gast)


Lesenswert?

Wenn du so ein schwaches Signal hast, dass du eine Darlington Stufe und 
einen Schmitt-Trigger brauchst, dann läuft da etwas gehörig falsch.

Hast du den Transistor falsch herum gepolt? Oder betreibst du die IR-LED 
mit zu wenig Strom? Damit sich das Signal deutlich von der Umgebung 
abhebt musst du sie schon mit einigen zig mA betreiben. 50mA sind da 
nicht selten.

von Alex J. (hoer173)


Lesenswert?

Moin Stefan.

ich habe mir heute paar gedanken gemacht während ich ein getriebe 
überholt habe.

bei 5v versorgungsspannung benötige ich einen 100 ohm vorwiderstand an 
der ir led.

diese 100 ohm hab ich nicht. sonder 470 nach der ir led

fehler 1.

um das signal sauber am foto transistor auszugeben zieh ich dort mit 
einem 1kohm widerstand den Kollektor auf plus 5v.

Emitter geht auf gnd.

vielleicht fehler 2 und 3 4?

1k zu wenig?

Emitter auf gnd könnte man ja mit 2,2k versehen.

ich könnte ja noch etwas entprellen mit 1 10 oder 100 nf zwischen 
kollektor und gnd??

und dann auf den schmittrigger und den optokoppler.



denkansätze und werte sind jetzt mal aus der luft gegriffen.

vorschläge?

Danke

von Stefan F. (Gast)


Lesenswert?

Alex J. schrieb:
> 1k zu wenig?

Ja.

Auf der Ausgangsseite würde ich 10x so viel Ohm empfehlen, wie auf der 
Eingangsseite. Aber zu viel Ohm machen ihn zu träge. Das kannst du mit 
einem Oszilloskop prüfen.

von Alex J. (hoer173)


Lesenswert?

naja eibgang 100 ohm ausgang 1k ohm.
sind doch 10x mehr. oder denkfehler....

danke für deine hilfe

von Alex J. (hoer173)


Lesenswert?

alles für die katz...

es läuft null...

bei 80 umin zeigt er 80 an springt auf 45666 und dann mal wieder 80 und 
56721 usw.

zum kotzen.

bräuchte eibfach mal ein schaltbild damit ich hier was zustande 
bekomme....

:(

von Wolfgang (Gast)


Lesenswert?

Alex J. schrieb:
> es läuft null...

Dann zeig mal, wie deine Schaltung derzeit aussieht.

von Alex J. (hoer173)


Angehängte Dateien:

Lesenswert?

setze ich fen 100nf ein beruhigt sich alles..
funktioniert...

optimierung wäre was anderes

danke

von Michael M. (Firma: Autotronic) (michael_metzer)


Angehängte Dateien:

Lesenswert?

Alex J. schrieb:
> optimierung wäre was anderes

Vielleicht könnte man R2 mit R3 vertauschen und C1 (10n) an den Eingang 
vom Schmitt-Trigger schalten, weil die 100nF den Ausgang des 7414 zu 
stark belastet.

Alex J. schrieb:
> schalte ich auf 200mA mit Kanal 200m werden mir 0.5 angezeigt.

Dann sollte noch der 4k7 auf 2k2 verkleinert werden.

von Alex J. (hoer173)


Lesenswert?

aus reiner neugierde.

warum r2 und r3 tauschen?

warum 4,7k durch 2,2k ersetzen?

würde ich gern verstehen. danke

von Michael M. (Firma: Autotronic) (michael_metzer)


Lesenswert?

Alex J. schrieb:
> warum r2 und r3 tauschen?

Damit das Auf- und Entladen des 10n in etwa die gleiche Zeit benötigt, 
sonst würde das Entladen 10 mal schneller sein.

Alex J. schrieb:
> warum 4,7k durch 2,2k ersetzen?

Weil der Schmitt-Trigger mindestens 2/3 von 5V benötigt um schalten zu 
können.

von Wolfgang (Gast)


Lesenswert?

Alex J. schrieb:
> setze ich fen 100nf ein beruhigt sich alles..
> funktioniert...

Der hat direkt am Ausgang nichts zu suchen.

Hast du einen Kondensator direkt an den Versorgungspins vom 74HC14?

von Alex J. (hoer173)


Lesenswert?

ok ich werde es morgen ab 15 uhr probieren.

also jetzt hab ich ein stabiles signal.
aber ich hab nur bissel basic wissen.

was könnte ich noch machen?

10nf hab ich nicht... mmmh ich berichte morgen mittag.

danke aufjedenfall!

von Alex J. (hoer173)


Lesenswert?

Wolfgang schrieb:
> Alex J. schrieb:
>> setze ich fen 100nf ein beruhigt sich alles..
>> funktioniert...
>
> Der hat direkt am Ausgang nichts zu suchen.
>
> Hast du einen Kondensator direkt an den Versorgungspins vom 74HC14?

nein

welche grösse?
den 100nf wollt ich an den eingang setzen wie der kollege schrieb

von Michael M. (Firma: Autotronic) (michael_metzer)


Lesenswert?

Alex J. schrieb:
> den 100nf wollt ich an den eingang setzen wie der kollege schrieb

4k7 und 100nF ergibt eine Grenzfrequenz von 340Hz! Das ist zu wenig für 
2000 1/min mit 90 Löchern. Damit kannst du nur bis 200 1/min erfassen. 
Deswegen die 10nF.

von Alex J. (hoer173)


Lesenswert?

ich hab 1 schlitz und 90 löcher
der schlitz ist weiter auserhalb.

diesen muss ich erstmal auswerten. die löcher sind später interessant. 
mit einer weiteren lichtschranke.

derzeit geht es nur um den schlitz....

2400 umin sollten mit einem schlitz ja so ausreichend sein.

soll ich trotzdem den 100nf gegen 10nf ersetzen?

4,7k ohm gegen 2,2k ohm und r2 mit r3 tauschen sowie den cap am eingang! 
nicht am ausgang?

trotz des wechsels von r2 und r3,  4,7k gegen 2,2k tauschen?

vielen dank

von Stefan F. (Gast)


Lesenswert?

Alex J. schrieb:
> naja eibgang 100 ohm ausgang 1k ohm.
> sind doch 10x mehr. oder denkfehler....

Ja passt dann.

Aber 470Ω am Eingang und 1kΩ am Ausgang wird nur mit Glück 
funktionieren.

Überprüfe die Signale (auch nach dem Tiefpass) mit einem Oszilloskop. 
Sonst riskierst du, dass es jetzt gerade geht, aber nächste Woche 
vielleicht nicht mehr.

Wenn du keins hast und die Kosten scheust, dann kaufe dir wenigstens ein 
DSO-150.

von Alex J. (hoer173)


Lesenswert?

moin stefan.

etwas weiter oben hab ich den aufbau gepostet.

darunter ein post mit änderungen die ich später vornehme.

100 ohm zu 1k hab ich nicht mehr!


oszi hab ich. billiges china usb 2 kanal.

danke

: Bearbeitet durch User
von H. H. (Gast)


Lesenswert?

Wie war denn die ursprüngliche Gabellichtschranke angeschlossen?

von Alex J. (hoer173)


Lesenswert?

die war an der cnc einheit von emco angeschlossen.

ging auf ein 17c14 und ab zum prozessor.
aber das ist halt so nicht möglich.

vorwiderstand waren 330 ohm für 2 lichtschranken.

ich hab auch alles da bis auf 0.1nf ....

erstmal kaffee und dann ab in den keller die schaltung ändern.

von H. H. (Gast)


Lesenswert?

Alex J. schrieb:
> die war an der cnc einheit von emco angeschlossen.

Die bist der König der Salamitaktik!

von Alex J. (hoer173)


Lesenswert?

was isen salamitaktik.

die orginal lichtschranken sind angeschliffen und das gehäuse 
verschmorrt... reibung..hitze...

reibung weil die encoderscheibe nicht Ausgerichtet war.. denke ich.

ich hab die nc steuerung entfernt.
die im titel erwähnten lichtschranken verbaut.

derzeit geht es nur um die eine Lichtschranke mit der ich den Index also 
ein Signal pro umdrehung auswerten möchte.

dadurch erhalte ich den spindelindex zum gewindedrehen.


ich hab geändert:
neue schrittmotoren mit treibern,
endschalter,frequenzumrichter steuerung mit pwm zu 0-10v bzw step/dir zu 
0-10v mit links rechtslauf.

alles hängt an einer druckerschnittstelle.

zwischen druckerschnittstelle und treibern,schaltern,fu usw hab ich eine 
Optokoppler Platine die mir 12 ausgänge und 5 eingänge gibt.

software ist mach3 oder linuxcnc.. jenachdem was ich grade mache.

die orginal lichtschranken sind ja per darlington beschaltet. die neuen 
nicht.

von Alex J. (hoer173)


Lesenswert?

problem ist gelöst.
ich hab einfach ein optokoppler zwischen schmitt trigger und eingang am 
board gesetzt.

der eingang auf dem bzw alle eingänge sind ohne opto.

danke

ps: beschaltung wie vorgeschlagen.

10nf,2,2k usw

von Christian M. (christian_m280)


Lesenswert?

Na ja, eine Gabellichtschranke ist ja quasi auch ein OK. Kannst nicht 
direkt von der Gabellichtschranke an den Eingang - ohne jetzt alle 
Salamischeiben zu studieren...

Gruss Chregu

von Stefan F. (Gast)


Lesenswert?

Mir leuchtet die Sache mit dem Schmitt-Trigger auch nicht ein. Wenn die 
Widerstände richtig ausgelegt sind, brauchst du den mit 99% 
Wahrscheinlichkeit nicht. Der originale Sensor ging ja auch ohne.

Der Originale Sensor hatte allerdings eine Darlington Schaltung, also 
würde ich das nachbauen um auf ähnliche Eigenschaften zu kommen.

Was ich hier stark vermisse sind Bilder vom Oszilloskop. Ich stochere 
nicht gerne blind im Nebel herum. Ich bin sicher dass die Bilder die 
Unsinnigkeit der Schaltung aufdecken würden.

von Alex J. (hoer173)


Angehängte Dateien:

Lesenswert?

die orginalschaltung verwendet einen 74hc14 2 mal hintereinander.

im anhang mal angefügt.
hier wird ein ps4001 orginal genutzt.

der alte emco steuerkasten hat extrem viele seltene bauteile.. mehrere 
r6551... etliche opv und nochmehr multiplexer demultiplexer... ich werd 
den kasten schlachten und in einzelteilen abverkaufen.

ein oszibild hab ich auf meinem anderen rechner. werde ich noch 
hochladen!!


mit dem jetzigen baustein tcst2103 funktioniert dieser aufbau nicht.
bin nicht so tief vertraut mit der materie... gebe ich zu.

liegt das am nicht vorhandenen darlington?

: Bearbeitet durch User
von Stefan F. (Gast)


Lesenswert?

Ersetze die ps4001 durch Gabellichtschranken mit Darlington Ausgang oder 
hänge einen Transistor dahinter um die Darlington Schaltung 
nachzubilden. Und dann wird das ohne weiteren Schnickschnack laufen. 
Kein Bedarf, die halbe Platine umzubauen.

von Alex J. (hoer173)


Lesenswert?

einfach ein npn so anschliessen wie im schaltbild? ohne wierstände oder 
ähnlichem?

warum prellt denn trotzdem die drehzahl?

von Wolfgang (Gast)


Lesenswert?

Alex J. schrieb:
> oszi hab ich. billiges china usb 2 kanal.

Dann benutze es. Guck dir deine Signale an.

> warum prellt denn trotzdem die drehzahl?
Poste ein Bild von deinem Eingangssignal, dass du auf die 
Schnittstellenkarte gibst. Dann lässt sich vielleicht mehr dazu sagen.

von Alex J. (hoer173)


Lesenswert?

geht los.

die drehe läuft noch ca 1 stunde.
fertige grade ein bauteil für meine platinenfräse.

video oder screenshot?

von Stefan F. (Gast)


Lesenswert?

Alex J. schrieb:
> warum prellt denn trotzdem die drehzahl?

Der originale Sensor hat ein Übertragungsverhältnis von mindestens 20% 
was ganz gut zum 4,7kΩ Lastwiderstand passt.

Der neue Sensor hat nur 5%. Sein Ausgangssignal ist daher zu schwach, um 
zuverlässige HIGH/LOW Signale zu erzeugen. Deswegen prellt er bei dir.

> einfach ein npn so anschliessen wie im schaltbild? ohne wierstände oder
> ähnlichem?

Ein gewöhnlicher kleiner NPN Transistor verstärkt ca 200x, so dass dein 
neuer Sensor damit ein Übertragungsverhältnis von 1000% bekommt. Das ist 
sehr viel mehr, als der originale. Der Sensor wird nun viel zu 
empfindlich auf wenig Licht reagieren.

Deswegen benutze besser einen Transistor mit einem geringen 
Verstärkungsfaktor, 20 zum Beispiel. Mir fällt nur gerade kein kleiner 
ein, der geeignet wäre.

Alternativ kannst du den Verstärungsfaktor durch einen Widerstand 
reduzieren, wie in 
https://www.elektronik-kompendium.de/sites/slt/0411221.htm gezeigt.

Ich kann dir keinen konkreten Wert empfehlen, dass würde ich zusammen 
mit dem Oszilloskop austüfteln.

Alternativ 2 könntest du den 4,7kΩ Lastwiderstand auf 22kΩ erhöhen. 
Allerdings wird die Schaltung dann auch empfindlicher gegen Radiowellen 
und das Timing des R/C Filters ändert sich.

von Stefan F. (Gast)


Lesenswert?

Stefan ⛄ F. schrieb:
> Deswegen benutze besser einen Transistor mit einem geringen
> Verstärkungsfaktor, 20 zum Beispiel. Mir fällt nur gerade kein kleiner
> ein, der geeignet wäre.

Habe einen: BD139

von Alex J. (hoer173)


Lesenswert?

Stefanus... du bist n geiler typ. mal ehrlich.. du hilft mir extrem 
damit.

ich habs mit einem bc337 probiert und versteh jetzt was das problem war.

ich muss mal forschen mit einem poti... 100k ohm und dann regeln bis es 
passt... poti messen.. passenden widerstand rein..

ist das der richtige weg?!

von Stefan F. (Gast)


Lesenswert?

Alex J. schrieb:
> ist das der richtige weg?!

Ja

Wer mehr Ahnung als wir beide hat kann das vermutlich gezielt 
ausrechnen. Aber das wäre ja langweilig :-)

von Alex J. (hoer173)


Lesenswert?

geil geil geil

woher kommst eigentlich?

von Stefan F. (Gast)


Lesenswert?

Alex J. schrieb:
> woher kommst eigentlich?

Aus dem Bauch meiner Mutter. Mal ehrlich, das spielt doch keine Rolle.

von Alex J. (hoer173)


Lesenswert?

:) alles gut

ich probiere später mal.

der hfe wert ist also entscheident.
verstehe.

mal sehn was mein platinenschrott hergibt.

idealerweise also einfach ein npn ranhängen ohne alles mit hfe 
idealerweise 25.

25 weil ????

alter sensor 20%
jetziger nur 5%

von Christian M. (christian_m280)


Lesenswert?

Alex J. schrieb:
> Screenshot_20210813-163837_Drive.jpg

Der Darlington ist ja verkehrt rum drinn!

Und dass die GNDs zusammengeschaltet sind, kann man nur hoffen...

Gruss Chregu

von Stefan F. (Gast)


Lesenswert?

Alex J. schrieb:
> 25 weil ????

Aus dem Bauch geraten. Transistoren mit Verstärkungsfaktor 4 wirst du 
wohl nur in einem Museum finden. Die wurden in Handarbeit geschnitzt.

von Stefan F. (Gast)


Lesenswert?

Christian M. schrieb:
> Der Darlington ist ja verkehrt rum drinn!

Ja sehe ich auch so. An den Sensoren sind im Plan die Pins 3 und 4 
falsch herum angeschlossen. Im echten Gerät haben sie es wohl richtig 
gemacht, sonst würde es nicht funktionieren.

von Alex J. (hoer173)


Angehängte Dateien:

Lesenswert?

verwirrend

von Wolfgang (Gast)


Lesenswert?

Alex J. schrieb:
> verwirrend

Was verwirrt dich?

von Alex J. (hoer173)


Lesenswert?

die pin verortung wechselt im datenblatt...

von Wolfgang (Gast)


Lesenswert?

Alex J. schrieb:
> die pin verortung wechselt im datenblatt...

omg
Das ist der Unterschied zwischen Schaltzeichen und Bauteil.

> Screenshot_20210813-163837_Drive.jpg
Und so sieht das dann aus, wenn jemand keine Ahnung von Elektronik hat 
und wild irgendetwas zusammenkopiert. Der TP mit seinen 39Ω und und 
100pF vor dem Schmitt-Trigger ist auch ein Witz.

von Alex J. (hoer173)


Lesenswert?

auf der orginal platine ist es tatsächlich so nur pin 3 und 4 sind 
vertauscht..

von Wolfgang (Gast)


Lesenswert?

Alex J. schrieb:
> auf der orginal platine ist es tatsächlich so nur pin 3 und 4 sind
> vertauscht..

Was den nun?
Entweder ist es so wie im Schaltplan gezeigt oder anders. Dann ist der 
Schaltplan falsch.

Die Zuordnung der Pin-Nummern im Datenblatt ist jedenfalls richtig und 
konsistent.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.