Forum: Mikrocontroller und Digitale Elektronik Software Elcotec Programmierer


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Jens (Gast)


Lesenswert?

Hi Leute,
also ich hab ein ganz simples Problem, ich hab einen EP IV Modular von
der Firma Elcotec "geerbt", allerdings ohne Software.
Jetzt bräuchte ich um dieses Eprom Programmiergerät noch verwenden zu
können die PC-Software, da es aber die Firma Elcotec nicht mehr gibt
stehe ich etwas doof da.
Hat jemand durch Zufall noch die Software und weiß wo ich sie im Netz
eventuell finden könnte?
Danke.
Gruß Jens

von Jörg (Gast)


Lesenswert?

Hallo Jens,
ich habe die Software und auch einen Brenner EP4 mod. Allerdings bekomme 
ich den nicht zum laufen. Ich habe immer irgendwelche runtime errors. 
Liegt sicher an der Installation. Leider kenne ich die PC Umgebung nicht 
in der er laufen soll.  Vielleicht gehts ja zusammen :-))) 
jpawink(ät)gmx.de
Schöne Grüsse

JPWink

von bernd schmidt (Gast)


Lesenswert?

hallo zusammen,
suche auch die software. habe den ep iv auch geerbt. zum wegschmeissen 
zu schade. währe super, wenn der zum laufen käme.

gruss aus solingen

schmidt

von Josh (Gast)


Lesenswert?

Hallo Jörg,
habt ihr den EP IV Universal-Prommer zum laufen gekriegt. Ich habe 
selbiges Problem mit der Software (runtime Error unter DOS) und würde 
mich über eine Lösung riesig freuen.
Für den Heimgebrauch hab ich mir mitlerweile einen Eprom-Brenner gebaut, 
ist aber voll der Kult mit dem zusammengesteckten System.

viele Grüße

Josh

von Holger K. (krulli) Benutzerseite


Lesenswert?


von Josh (Gast)


Lesenswert?

Nach langen suchen der Diskette des EP IV kann ich den
"Error 200 at 2F15:0091" bestätigen. Ich versuche mich mal an den 
Lösungsvorschlägen...

erstmal vielen Dank

Josh

von Josh (Gast)


Lesenswert?

Nach viel hin und her (was heist, unter XP den Fix "TP7TEST.EXE" in den 
Arbeitsspeicher laden und dann eprommer.exe starten bzw. unter Linux den 
Emulator dosemu installiert und dann unter "Frequenz des zu emulierenden 
Systems" 166Mhz einstellen, dann das gleiche Spielchen wie oben 
wiederholen etc.) hab ich immer die Meldung gekriegt, daß mein Port (je 
nach Verkabelung) LPT1 oder COM1 "Port not ready" ist. Der Brenner ist 
damit nicht ansprechbar und unter Win XP stürtzt das Dos-Fenster auch 
meist gleich ab (auch nach einer änderung in der Grundkonfiguration). 
Die Uhrzeit meines Komentares sollte deutlich machen, das ich noch die 
eine oder andere Zeiteinheit im Keller investiert habe, und siehe da, 
ein Pentium 1 System mit 166 Mhz und einen Dos 6.2 + ep4 Software lässt 
den Port (in meinem Versuch LPT1) als "ready" erscheinen. noch viel 
besser ist die Reaktion meines Universal-Prommers. Zwei grüne Led's 
signalisieren mir Einsatzbereitschaft und zu meiner Überraschung können 
die grünen Led's auch rot leuchten. Was ich sagen will, der Brenner 
funktioniert. Vergleichbare Brenner mit dieser Flexibiltät kosten laut 
Internet heute gut 500 Euro (allerneuste Bausteine werden vom EP IV 
logischerweise nicht mehr unterstützt).
Wenn jemand in diesem Thread seinen Brenner nicht zum laufen kriegt und 
eine Reise nach Krefeld nicht scheut, ich habe noch ein System über, 
welches dem Brenner wieder leben einhaucht... es lohnt sich :o)

PS: wem der Artikel zu euforisch wirkt, ich habe Elektrotechnik studiert 
und suchte schon seit meiner Ausbildung einen Universal-Brenner, der 
auch 8748-49 brennen kann - und obwohl die Technik schon seit Jahren in 
meinem Keller lag ist sie durch diesen Thread jetzt endlich verfügbar.

Gott sei Dank
Josh

von brenner (Gast)


Lesenswert?

hallo!
ich habe auch diesen brenner; das problem ist tatsächlich, das die soft 
mit schnellen systemen nicht mehr zurechtkommt.
das schnellste system wos läuft ist ein AMD 500 - da klappt es unter 
WIN95C hervorragend ;)

mein problem ist, das ich nicht alle module der software des prommers 
freigeschaltet habe und die firma gibts ja nun nicht mehr :(

von Frank (Gast)


Lesenswert?

Ihr könnt die Software bei 
http://www.tibu-tools.de/docs/pd1157443457.htm bekommen!

von Birol (Gast)


Lesenswert?

Hallo,

ich habe einen Elcotec Programmierer EP IV geschenkt bekommen, leider 
ohne software, kann mir jemand damit helfen. Wäre sehr nett, danke..

MfG Birol

von Gerd L. (Firma: Loch Leiterplatten) (gloch)


Lesenswert?

kann mir wer die Hardware-Unterlagen für den Elcotec EP IV zur verfügung 
stellen? Danke im Voraus.

Gerd

von Henning B. (Gast)


Lesenswert?

Hallo,

hat noch jemand die betreffende Software zur Verfügung?

Gruß

von Rufus Τ. F. (rufus) Benutzerseite


Lesenswert?

Ein paar Beiträge oberhalb Deines ist ein Link auf eine Seite, wo man 
diese Software bekommen kann.

Der funktioniert auch noch nach sieben Jahren.

von Gerd (Gast)


Lesenswert?

Hallo,

eine Antwort zum Thema Software gibt es ja schon.
Ich habe einen Programmer stehen ohne Netzteil und ohne 
Hardware-Unterlagen.
Kannst Du mir sagen welche Spannung wo anzuschließen ist?

Danke
Gerd

von Henning (Gast)


Lesenswert?

Hallo Gerd,

Hier habe ich etwas zusammengetragen, und auch die Belegung des
Netzteils aufgenommen.

http://hbaar.com/Homepage/?Bastelbude:Ger%C3%A4tschaften:elcotec_EP_IV_Prommer&normal

Gruß
Henning

von Gerd (Gast)


Lesenswert?

Hallo Henning,

vielen Dank für die schnelle und informative Antwort.
Muss jetzt mal sehen wie ich zu 20VAC komme.

Alles Gute noch zum neuen Jahr

Gerd

von Henning B. (Gast)


Lesenswert?

Mahlzeit,
ich gucke nochmal drüber, ich glaube die Wechselvolt werden sowieso 
direkt am Eingang glattgebügelt und in einen Elko geschoben. Vielleicht 
wirst du ja auch was mit DC. Ich schaue nochmal rein, und messe evtl. 
was am Elko anliegt, dann kannst du ja wahrscheinlich auch direkt mit DC 
drauf gehen.

Gruß

von Rufus Τ. F. (rufus) Benutzerseite


Lesenswert?

Henning B. schrieb:
> Mahlzeit, ich gucke nochmal drüber

Das solltest Du auch, denn auf Deiner Seite steht

12V AC  20 VA

und der Stecker ist mit

20 V AC beschriftet.

Was denn nun?

von Henning B. (henningb)


Lesenswert?

Sehr gut aufgepasst!

12V AC ist richtig!

Danke.

von Gerd (Gast)


Lesenswert?

ich habe es jetzt mal mit 12VAC versorgt. Am Elko sind 14,5V vorhanden. 
Ein 12V-Regler hat auch 12V am Ausgang. +5V sind auch an den IC's 
vorhanden. Die
Power-LED leuchtet nur schwach. Beim Einschalten der Versorgungsspannung 
leuchten die beiden LED's über den Read und Write-Tasten kurz auf. Die 
Betätigung der Tasten bewirkt nichts Sichtbares.
Leider habe ich keinerlei Unterlagen.

Es fehlt mir mindestens eine Bedienungsanleitung um feststellen zu 
können inwieweit der Programmer funktioniert. Kann mir die wer zur 
Verfügung stellen?

Besten Dank

von Henning (Gast)


Lesenswert?

Mahlzeit,

der Prommer liegt auch wieder bei mir auf dem Tisch...

Einschalten sieht bei mir genau so aus.

Drücke doch mal "Reset/Clear" und "Read" gleichzeitig, geht dann die 
grüne LED an?
Bei "Read" und "Write" rot?


Ich suche auch noch die Software...

von Gerd (Gast)


Lesenswert?

habe das Teil wo vergraben.
Melde mich demnächst, wenn ich den Versuch gemacht habe.

Gerd

von bBrenner (Gast)


Lesenswert?

Moin!
Für den Fall, dass immer noch welche den guten alten EP4 nutzen wie ich, 
mal ein paar workarounds.

Das Probelm mit der Laufzeit läßt sich leicht beheben, gibts nen Patch 
für, den ich erfolgreich getestet habe-Link mit text u. download:
http://www.kennedysoftware.ie/patchcrt.htm

Leider ist mir letzte Woche mein altes Notebook mit COM krepiert, was 
ich sonst immer für EP4 benutzt habe. Mit einem uralten Athlon 
K7-Rechner war mit etwas Bastelei der EP zwar wieder zum Laufen zu 
bringen, aber dass das der letzte Rettungsanker war, gefiel mir nicht.

Also an einem moderneren Notebook Lenovo und einem PC Athlon 64 X2 6000 
getestet unter WIN 98- das ältesete auf dem Gerät installierte BS. 
Ebenso auf dem Linux-Laptop installiert für Sachen wie diese.

Fazit: Mit einem USB-COM Digitus wird der EP4 zwar bei beiden erkannt, 
sogar die grünen LED leuchten, aber ein nicht nachvollziehbarer Fehler 
tritt bei Programmierversuchen oder Auslesen der Gerätekennung auf. 
Eepromm-BIOS-Fehler im EP4. Und das wars dann...
Mit einer COM-PCI Karte im Athlon 64 der gleiche Fehler. Natürlich alle 
PIF- usw. Einstekllungen probiert. no hope...

Aber jetzt der erfreuliche Teil:
Auf dem PC ist der EP4 gebootet mit einer WIN95-CD im DOS-Modus zum 
Laufen zu bringen. Eingestellt als AUX(iliaries) im Menu und korrektem 
Speicherbereich (9C00 bei der von mir verbauten AXIS-Com-karte; bei 
anderen wahrscheinlich anderer Speicherbereich; das läßt sich unter 
Windoof auslesen oder steht im 'Zettel')
klappts mit dem Brennen!
Nützt vielleicht dem einen odewr anderen; wennn ich nach EP4 suche lande 
ich auch immer hier ;o)

von Hubert B. (hubertb)


Lesenswert?

Hallo,
auch wenn der Beitrag schon etwas älter ist, stehe ich gerade vor dem 
Problem das ich zwar diesen Prommer gekauft habe, aber ohne Software. 
Wäre es möglich mir die SW zu mailen?

Vielen Dank im Vorraus

von Hubert B. (hubertb)


Lesenswert?

Besten Dank an die Forumsgemeinde, habe die Software erhalten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.