Forum: Analoge Elektronik und Schaltungstechnik Schaltung frisst NE555er


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Daniel G. (daniel4161)


Angehängte Dateien:

Lesenswert?

Hallo, ich habe mal wieder ein Problem mit einer NE555 Schaltung.

Ich habe mir, in Anlehnung an einen Schaltplan aus dem Internet, ein 
Zündlichstroboskop gebaut, welches zum Einstellen des Zündzeitpunktes 
bei Oldtimern/ alten Motoren benutzt wird. Dabei wird der "Impuls" am 
Zündkabel abgegriffen (nicht Direkt leitend, sondern an der Isolierung 
des Kabels, höchswahrscheinlich das E-Feld des Impulses)

Die Schaltung besteht im Wesentlichen aus einem NE555 (CMOS version, als 
Monoflop), welcher vom "Impuls" der Zündkerze getriggert wird und über 
einen Transistor ein paar LEDs anschaltet. Die Pulsdauer kann noch über 
ein Poti verstellt werden.

Die Schaltung funktioniert grundsätzlich, ich habe sie auch schon am 
Motor mehr oder weniger erfolgreich betrieben, nur geht dauernd der 
NE555 kaputt und ich weiß nicht warum. (Die LEDs, die ja normalerweise 
aus sind sind dann dauerhaft an, ein neuer Chip schafft dann Abhilfe). 
Der Transistor (BC337) ist offensichtlich nicht betroffen. Ausgang 3 am 
NE wird vom Transistor mit 10 mA belastet, Grenze des NEs sind ja auch 
10mA.

Meine Vermutung liegt eher auf der Triggerseite. Hier habe ich schon 
verschiedene Möglichkeiten ausprobiert, stochere aber im Dunkeln, da ich 
keine Ahnung habe, wie die Auswertung des "Impulses" genau funktionieren 
soll. Ich habe hier verschiedene Varianten ausprobiert, ich glaube aber 
dass der NE hier trotzdem von zu starken Impulsen "zerschossen" wird, 
obwohl er nicht leitend an die Zündspule angeschlossen ist. Kann das 
Sein? Irgendwo habe ich gelesen, dass der "Impuls" Kapazitiv 
ausgekoppelt wird, aber wie funktioniert das genau?

Ich hoffe, jemand kennt sich mit dieser Antennentechnik besser aus als 
ich :)
Vielen Dank und VG
Daniel



PS, Anbei der Schaltplan mit zwei Varianten, die ich probiert habe.

: Bearbeitet durch User
von Thomas W. (goaty)


Lesenswert?

Probier doch mal eine Schutzbeschaltung des Triggereingangs mit Dioden 
nach 0V und +12V um Überspannungen abzuleiten. Vielleicht hilft das 
schon.

http://www.elektronik-kompendium.de/public/schaerer/ovprot.htm

: Bearbeitet durch User
von Prokrastinator (Gast)


Lesenswert?

Daniel G. schrieb:
> nur geht dauernd der
> NE555 kaputt und ich weiß nicht warum.

Du lieferst den Zündimpuls direkt an einen hochohmigen Trigger Eingang, 
ohne jeden Vorwiderstand, ohne jede Schutzbeschaltung und wunderst Dich 
wirklich das der das mit dem frühen Tod quittiert?

Jeder Eingang des NE555 darf maximal VCC sehen.

von Mark S. (voltwide)


Lesenswert?

Ja, das ist durchaus nachvollziehbar. Du verwendest die CMOS-Version und 
hast keinerlei Maßnahmen gegen "latchup" vorgesehen.
Zu allererst packe vor den Triggereingang einen Serienwiderstand von 
z.B. 10 kOhm zu  Begrenzung der dynamischen Stromspitzen welche den 
latchup triggern.
Des weiteren begrenze den Versorgungsstrom auf Werte <200mA mit einem 
Serienwiderstand von 50..100 Ohm. Dann sollte nichts mehr passieren.
Alternativ ist der bipolare NE555 in dieser Hinsicht deutlich robuster.

von MaWin (Gast)


Lesenswert?

Daniel G. schrieb:
> Ich habe mir, in Anlehnung an einen Schaltplan aus dem Internet, ein
> Zündlichstroboskop gebaut,

So so, da dürfte schon beim ersten Blick an Hand der direkten 
Parallelschaltung von 4 LEDs klar sein, dass der Erbauer keine Ahnung 
von Elektronik hatte.

Daniel G. schrieb:
> Ausgang 3 am NE wird vom Transistor mit 10 mA belastet, Grenze des NEs
> sind ja auch 10mA.

Nein, 200mA, vermutlich lassen sich die LEDs, jede mit ihrem eigenen 
Vorwiderstand, auch ohne Transistor betreiben, aber egal, ist nur die 
Vermeidung von  überflüssigem Aufwand.

Kritischer ist das 'Induktionskabel'. Was soll das sein ? Ein ums 
Zündkabel gewickelter kapazitiver Aufnehmer ? Ein Draht direkt zum 
Unterbrecherkontakt ?

Der sieht wie ein Einfallstor für zerstörerische Impulse aus, wenigstens 
ein Vorwiderstand und Schutzdioden sollten sein.

von Mohandes H. (Firma: مهندس) (mohandes)


Lesenswert?

Natürlich stirbt der 555 ständig. Das liegt nicht an der 
Ausgangsbeschaltung sondern daran daß er vom Induktionskabel ohne jeden 
Schutz getriggert wird.

Thomas W. schrieb:
> http://www.elektronik-kompendium.de/public/schaerer/ovprot.htm

Dort ist es ja gut beschrieben. Ein Vorwiderstand (10k) und dahinter 
zwei (schnelle) Dioden gegen +12V und Gnd. 1N4148 ist der Klassiker.

von Mohandes H. (Firma: مهندس) (mohandes)


Lesenswert?

Daniel G. schrieb:
> obwohl er nicht leitend an die Zündspule angeschlossen ist. Kann das
> Sein?

Ja natürlich. Leider schreibst Du nicht wie das Signal von der Zündspule 
ausgekoppelt wird. Offensichtlich kapazitiv. An einer Zündspule 
entstehen sehr hohe Spannungen die über eine Kapazität 1:1 direkt an den 
Triggereingang des 555 gehen.

von Daniel G. (daniel4161)


Lesenswert?

Danke für die schnellen Antworten!

Das mit den Schutzdioden klingt einleuchtend, werde ich auf jeden fall 
probieren.


Prokrastinator schrieb:
> Du lieferst den Zündimpuls direkt an einen hochohmigen Trigger Eingang,
> ohne jeden Vorwiderstand, ohne jede Schutzbeschaltung und wunderst Dich
> wirklich das der das mit dem frühen Tod quittiert?
Nein, wie schon gesagt ist das Zündkabel nicht direkt angeschlossen. Da 
wäre ja klar, dass er sofort kaputt geht.

MaWin schrieb:
> Parallelschaltung von 4 LEDs
Ist bei mir sowieso anders, dürfte aber auch nix damit zu tun haben.

MaWin schrieb:
> Nein, 200mA,

Sicher? es gibt nämlich eine CMOS und eine Bipolare Version vom NE555, 
die CMOS kann nur 10mA ausgsang, die Bipolare 200mA. ich glaube ich habe 
die CMOS version. Dürfte ja aber in beiden Fällen dann passen.

MaWin schrieb:
> Kritischer ist das 'Induktionskabel'. Was soll das sein ? Ein ums
> Zündkabel gewickelter kapazitiver Aufnehmer ? Ein Draht direkt zum
> Unterbrecherkontakt ?
Genau das frage ich mich auch. Bei Professionellen Geräten gibts da ein 
kabel, was mit einer klemme am ende (sieht wirklich aus wie ne 
wäscheklammer) einfach an das Zündkabel geklemmt wird.
Unterbrecherkontakt gibt meines wissens nur bei Einzylindern. Hätte ich 
den, könnte ich ja den auswerten und den ganzen Hochspannungsmist 
umgehen.

Danke und VG Daniel

von Daniel G. (daniel4161)


Lesenswert?

Mohandes H. schrieb:
> Leider schreibst Du nicht wie das Signal von der Zündspule
> ausgekoppelt wird

Weil ich es nicht weiß...

Mohandes H. schrieb:
> die über eine Kapazität 1:1 direkt an den
> Triggereingang des 555 gehen.

Echt? das heisst ich bau noch einen Spannungsteiler davor?

von Georg M. (g_m)


Lesenswert?

Daniel G. schrieb:
> ich glaube ich habe die CMOS version

Und was ist mit dem Wissen?

von Daniel G. (daniel4161)


Lesenswert?

Mohandes H. schrieb:
> ort ist es ja gut beschrieben. Ein Vorwiderstand (10k) und dahinter
> zwei (schnelle) Dioden gegen +12V und Gnd. 1N4148 ist der Klassiker.

Das werd ich mal probieren, danke!!

von Mohandes H. (Firma: مهندس) (mohandes)


Lesenswert?

Daniel G. schrieb:
> Echt? das heisst ich bau noch einen Spannungsteiler davor?

Spannungsteiler ist nicht ratsam, wie willst Du den dimensionieren? Die 
Zündspannung ist ja nicht bekannt.

Ein Vorwiderstand und 2x 1N4148 lösen Deine Probleme. Dann wird jede 
Überspannung am Triggereingang an Gnd bzw. +12V abgeleitet.

MaWin schrieb:
> vermutlich lassen sich die LEDs, jede mit ihrem eigenen Vorwiderstand ...

Für jede LED einen eigenen Vorwiderstand wäre eine saubere Lösung weil 
die LEDs verschiedene Vorwärtsspannungen haben.

von Michael M. (Firma: Autotronic) (michael_metzer)


Lesenswert?

Mohandes H. schrieb:
> zwei (schnelle) Dioden gegen +12V und Gnd. 1N4148 ist der Klassiker.

Sind die 1N4148 denn wirklich schnell?

von Thomas F. (thomas-hn) Benutzerseite


Lesenswert?

Mohandes H. schrieb:
> Für jede LED einen eigenen Vorwiderstand wäre eine saubere Lösung weil
> die LEDs verschiedene Vorwärtsspannungen haben.

Abhängig von der Art der LEDs (und deren Flussspannung), könnte man die 
LEDs auch in Reihe schalten.

von Joachim B. (jar)


Lesenswert?


von Michael M. (Firma: Autotronic) (michael_metzer)


Lesenswert?

Joachim B. schrieb:
> 4ns

Puhh, das hätte ich so nicht gedacht. Wieder was gelernt, danke :)

von Joachim B. (jar)


Lesenswert?

Michael M. schrieb:
> Puhh, das hätte ich so nicht gedacht.

geht mir ähnlich ich hatte gedacht BA 157/159 sind schneller 500ns/125ns 
aber sie sind deutlich langsamer, dafür Hochspannung!

von MaWin (Gast)


Lesenswert?

Daniel G. schrieb:
> es gibt nämlich eine CMOS und eine Bipolare Version vom NE555,

Nein, es gibt nur einen bipolaren NE555 und der schafft 200mA.

CMOS Versionen heissen anders, LMC555 oder ICL7555.

von Stefan M. (derwisch)


Lesenswert?

Daniel G. schrieb:
> Genau das frage ich mich auch. Bei Professionellen Geräten gibts da ein
> kabel, was mit einer klemme am ende (sieht wirklich aus wie ne
> wäscheklammer) einfach an das Zündkabel geklemmt wird.

Ich verstehe das nicht ganz.
Du hast erwähnt, dass Du die Schaltung schon mit erfolg Betrieben hast.
Wenn auch nicht lange, dann war der 555 kaputt.
Aber Du musst ja auch irgendwie den Zündimpuld vom Zündkabel abgenommen 
haben.
Nicht direkt angeschlossen, das ist klar, aber wie hast du das in Deinem 
Fall gemacht (Foto?).

von Joachim B. (jar)


Lesenswert?


von MaWin (Gast)


Lesenswert?

Joachim B. schrieb:
> oder TLC555

In bipolar: 
NE555=SE555=LM555=RC555=XR555=LC555=NTE955=K3T647=MC1455/MC1555=TDB0555= 
B555=uA555=UTC555=ULY7855=K1006??1=HA17555=SG555=SN72555~=BA222 
(4.5-16V, 500kHz)

In CMOS: ICM7555 (2-18V, 1MHz Intersil), TLC551 (1-16V, 2MHz, TI), 
TLC555 (2-15V, 2.1MHz, TI), TS555 (3-16V, 2.7MHz, ST), LMC555 (1.5-12V, 
3MHz, NS), ZSCT1555 (0.9-6V, 330kHz, Zetex), ALD555 (2-12V 0.1Hz-1MHz) 
ILC555 (2-18V 200+kHz 0.2-0.6mA 20-100mA)


u.v.a.m.

von Roland F. (rhf)


Lesenswert?

Hallo,
Thomas F. schrieb:
> Abhängig von der Art der LEDs (und deren Flussspannung), könnte man die
> LEDs auch in Reihe schalten.

In der Regel verwendet man für ein Stroboskop weißes Licht. Das könnte 
bei 4 in Reihe geschaltete LEDs und 12V Betriebsspannung knapp werden. 
Alternativ kann aber auch je 2 LEDs in Reihe mit Vorwiderstand schalten 
und die beiden Reihenschaltungen dann parallel.

rhf

von Beitraszahler (Gast)


Lesenswert?

Daniel G. schrieb:
> Unterbrecherkontakt gibt meines wissens nur bei Einzylindern.

Nein, leider falsch. Den gibt es auch bei Mehrzylindern, allerdings nur 
noch bei alten Kisten, wurde ausgemustert weil es ein Verschleißteil ist 
und auf "elektronisch" umgebaut, trotzdem gibt es bei den alten Kisten 
einen Hochvolt bereich, von der Zündspule zur Zündkerze, und einen 
Niedervoltbereich, der zur Zündspule.

von Peter D. (peda)


Lesenswert?

Daniel G. schrieb:
> Die Schaltung besteht im Wesentlichen aus einem NE555 (CMOS version, als
> Monoflop)

CMOS ist deutlich empfindlicher als die BJT Version.
Die BE-Strecke eines BJTs ist quasi eine kleine Z-Diode, d.h. verträgt 
etwas Sperrstrom. Ein MOSFET brennt aber bei Überspannung einfach nur 
durch.

Wie ja schon gesagt wurde, mach ne Schutzschaltung an den Eingang.

von Ingo W. (uebrig) Benutzerseite


Lesenswert?

Was meiner Meinung nach, auch nicht gesund ist:
C2 wird während des Ausgangspulses auf 2/3 Ub (8V) aufgeladen und dann 
ohne Strombegrenzung durch den Entladetransistor kurzgeschlossen.
Ok, kann man der Meinung sein, dass der das abkönnen muss, ein kleiner 
Strombegrenzungswiderstand würde aber den Strom dämpfen.
Überhaupt frage ich mich, warum das Zeitglied so niederohmig sein muss, 
vor Allem wenn die CMOS-Variante des 555 genutzt wird.

von Wolfgang (Gast)


Lesenswert?

Michael M. schrieb:
> Sind die 1N4148 denn wirklich schnell?

Es kommt nicht drauf an, dass sie "wirklich schnell" sind, sondern sie 
müssen nur ausreichend schnell sein, also so schnell, wie sich die Summe 
aus Eingangs- und Diodenkapazität über den Serienwiderstand umlädt.

von Jens G. (jensig)


Lesenswert?

Ingo W. schrieb:
> Was meiner Meinung nach, auch nicht gesund ist:
> C2 wird während des Ausgangspulses auf 2/3 Ub (8V) aufgeladen und dann
> ohne Strombegrenzung durch den Entladetransistor kurzgeschlossen.

Die bipolaren 555 sind üblicherweise dafür ausgelegt. Sogar weit in den 
µF-Bereich - selbst gegen 100µF als normale Elko haben die Datenblätter 
üblicherweise nix ...

>Überhaupt frage ich mich, warum das Zeitglied so niederohmig sein muss,
>vor Allem wenn die CMOS-Variante des 555 genutzt wird.

Muß nicht, aber wenn es möglichst schnelle Entladepulse sein sollen, 
dann muß man entsprechend niederohmig arbeiten.
Auserdem kann man dann nicht mehr die tollen Zeitdiagramme im Datenblatt 
nutzen, wenn die nur die "Kurzschlußvariante" berücksichtigen ...
Und die CMOS-Typen begrenzen sich idR. selbst, da muß man nicht 
künstlich begrenzen.

: Bearbeitet durch User
von Daniel G. (daniel4161)



Lesenswert?

Hallo, mal ein Update:

Die Schaltung funktioniert jetzt endlich, und das auch dauerhaft. Ich 
konnte den Zündzeitpunkt problemlos einstellen.

Ich habe jetzt letztendlich, wie oben vorgeschlagen zwei 1N4148 und 
einen Vorwiderstand von 10k eingebaut. Ich glaube der ist zwar etwas zu 
hoch, denn komme ich mit der Hand in die Nähe des Geberkabels bzw. 
dessen Ende, Bleiben die Lichtpulse aus (Weil meine Hand das E-Feld 
stört???) aber man kann damit arbeiten, Danke für die Tipps!

Anbei noch Bilder vom Gerät(Bei dem der Deckel fehlt) und vom Abgriff.

VG Daniel

Edit zum Zweiten Bild: Die Ader an der Klammer ist die Leitung mit 
vorwiderstand zum Trigger am NE555, die Zweite ader von dem Pärchen hat 
keine Funktion und ist auf der Platine einfach auf Masse gelegt. Ist das 
schlecht bzgl. der Übertragung? Könnte es natürlich auch ganz 
entfernen...

: Bearbeitet durch User
von Soul E. (souleye) Benutzerseite


Lesenswert?

Daniel G. schrieb:

> Edit zum Zweiten Bild: Die Ader an der Klammer ist die Leitung mit
> vorwiderstand zum Trigger am NE555, die Zweite ader von dem Pärchen hat
> keine Funktion und ist auf der Platine einfach auf Masse gelegt. Ist das
> schlecht bzgl. der Übertragung? Könnte es natürlich auch ganz
> entfernen...

Eigentlich ist das gut, die bringt ein bisschen Abschirmung. Sollte 
natürlich ausreichend weit vor der Klammer enden. Du kannst die Kopplung 
verbessern, wenn Du das Sensorkabel in der Klammer abknickst und ein 
paar cm parallel zum Zündkabel verlegst.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.