Forum: Platinen Altium Polygone - USB-Rule verhindert GND-Pin zu versorgen


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Klaus R. (klara)


Angehängte Dateien:

Lesenswert?

Hallo,
ich habe ein Footprint der mit einer USB Verbindung versorgt wird. 
Direkt neben dem Leiterpaar ist ein GND - Pin der mit GND verbunden sein 
sollte.

Das niederrangige Polygon umfaßt den ganzen TOP Layer, Net GND. Es wird 
"InPolygon" auf alle Second Objekte angewendet. Der Abstand Copper zu 
Track ist auf 0,203 mm festgelegt. Hier gibt es kein Problem.

Für die USB Führung habe ich kein eigenes Polygon angelegt. Ich verwende 
hier ebenfalls "InPolygon". Das Second Objekt wird jetzt über Net Class 
"USB_Cls" festgelegt. Den Abstand Copper zu Track möchte ich hier 
deutlich größer z.B. auf 0,7 mm festlegen. Das funktioniert auch prima, 
was USB betrifft.

Siehe beiliegendes Bild. Der benachbarte GND-Pin wird aber nicht mehr so 
wie die anderen mit GND versorgt. Selbst mit Leiterbahn wird der Pin 
nicht versorgt. Ich bin jetzt im Bild auf 0,3 mm heruntergegangen. Wie 
man sieht bringt dies nichts. Mit Abstand 0,203 mm ist wieder alles in 
Ordnung. Die Grenze wird wohl kurz vor 0,3 mm liegen.

Ich habe auch schon einiges probiert. Wie man sieht wollte ich für den 
Pin auch ein eigenes Polygon anlegen.

Wie kommt man da zum Ziel?
mfg klaus

von Wühlhase (Gast)


Lesenswert?

Mach es doch so wie bei den anderne Gnd-Pins: Nimm den Track da weg.

Ansonsten: Hast du in den Polygon-Optionen "Pour over same net objects" 
aktiviert?

von Klaus R. (klara)


Angehängte Dateien:

Lesenswert?

Hallo Wühlhase,

Wühlhase schrieb:
> Mach es doch so wie bei den anderne Gnd-Pins: Nimm den Track da weg.

Ohne Track war es ja zuvor. Das GND-Polygon umfasste den GND-Pin dann 
nicht. Meine Vermutung war, daß die USB Clearance für verantwortlich 
war.

Im Bild 1 habe ich das kleine Polygom über den GND-Pin gelöscht da dies 
nichts bewirkte. Das Layer Polygon mit Net GND hat als Parameter "Pour 
Over All Same Net Polygons Only". Dies ist vermutlich auch der 
Defaultwert, da ich diese Einstellung noch nie verwendet hatte, bzw. 
geändert hatte.

Im Bild 2 habe ich das Layer Polygon auf Parameter "Pour Over All Same 
Net Objects" umgestellt. Und siehe da, es funktioniert in meinem Sinn.

Offentsichtlich ist eine Rule über Net Class definiert ranghöher als 
Rules über Polygone definiert. Innerhalb von Polygonen kann ich jedoch 
Rangfolgen festlegen.

Danke für Deine Hilfe.
mfg Klaus

von Wühlhase (Gast)


Lesenswert?

Bitte sehr...schön daß es funktioniert.

Polygone sind in Altium durchaus nicht ohne...es lohnt sich, sich da mal 
die Einstellungen zu Gemüte zu führen, z.B. auch die "Remove dead copper 
islands"-Regel.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.