Forum: PC Hard- und Software Linux - Screen Dunkeltastung - wie abstellen?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Markus W. (dl8mby)


Lesenswert?

Hallo Forum,

habe seit meinen letzten OpenSuse Tumbleweed 20220103 Update
das Problem, dass mein Screen, obwohl kein Screensaver Läuft
nach einer gewissen Zeit (gefühlt 15min, noch nicht gemessen!)
dunkel wird.

Habe schon mit diversen Einstellungen der Energie-Spar-Modi gespielt
aber leider ist es mir nicht gelungen dieses Verhalten abzustellen.
Habe auch die X-Server Einstellungen meiner GC (Nvidia) durchsucht,
das hat aber auch nicht geholfen. Bin mit meinen Latein am Ende.

Ich habe einen zBook 17 von HP auf dem der 5.15.12-1-default Kernel
läuft. Als Nvidia Treiber setze ich den 470.63.01 ein und
der GC ist eine Quadro M5000M.

Kann es sein, dass eventuell ein systemd Service für dieses Verhalten
verantwortlich ist?

Die letzten beiden Jahre hatte ich dieses Verhalten nicht.
Eventuell hat ja der neue Kernel irgendwelche Neuerungen
erfahren, die dieses Verhalten verursachen.

Während ich diese Zeilen schreibe, bin ich auf die Idee gekommen
eventuell zu testen ob das Verhalten mit dem Vorgängerkernel auch
zu beobachten ist. Das habe ich noch nicht gemacht.

Danke für Eure Hilfe und sachdienliche Hinweise.

LG
Markus

von Kark II. (Gast)


Lesenswert?

Merkwürdigerweise geht es mir genauso, Ubuntu 20.04.3 LTS, Xfce, alle 
aktuellen Updates, dunkler Bildschrim ist nicht abstellbat

von db (Gast)


Lesenswert?

linux dpms disable...

von Rolf M. (rmagnus)


Lesenswert?

Ja, mal versuchen, ob es weg ist nach Eingabe von folgendem in einer 
Konsole:
1
xset s off
2
xset -dpms

von Markus W. (dl8mby)


Lesenswert?

Danke für den prompten Feedbck.

ich nehme an die o.g. Kommandos als root eingeben -richtig?

Markus

Sehe, dass es auch als normaler Nutzer akzeptiert wird.

Werde nun den Screen beobachten, wenn es klappt, wandern
die Kommandos in die .bashrc.

Markus

: Bearbeitet durch User
von Jörg E. (jackfritt)


Lesenswert?

In der bashrc werden die Befehle aber nur aufgerufen wenn du dich an der 
Console einloggst. Oder etwa auch wenn Linux bootet und du dich an 
XServer anmeldest?

von Markus W. (dl8mby)


Lesenswert?

Hallo Danke!

Hat wohl gehelfen.
Werde heute über den Tag hinweg weiter beobachten.

Infos zum Kommando s.u.

man xset
xset - user preference utility for X

s       The s option lets you set the screen saver parameters.
        This option accepts up to two numeri-
        cal  parameters, a 'blank/noblank' flag, an 'expose/noexpose'
        flag, an 'on/off' flag, ...

-dpms   The -dpms option disables DPMS (Energy Star) features.

LG
Markus

von Markus W. (dl8mby)


Lesenswert?

Noch ein Vorschlag.

Ich habe mir nun doch die systemd service angesehen
mit systemctl -a | grep .service

und in diesem Zusammenhang

systemd-backlight@backlight:acpi_video0.service
und
display-manager.service
gefunden.

Eventuell könnte man
die beiden xset Kommandos dort direkt in
den Startskripten einbauen oder falls möglich direkt
an den X-Server als Parameter übergeben.

systemctl status display-manager.service
● display-manager.service - X Display Manager
     Loaded: loaded (/usr/lib/systemd/system/display-manager.service; 
enabled; vendor preset: enabled)
     Active: active (running) since Fri 2022-01-14 07:26:16 CET; 2h 
58min ago
    Process: 1972 ExecStart=/usr/lib/X11/display-manager start 
(code=exited, status=0/SUCCESS)
   Main PID: 2021 (lightdm)
      Tasks: 5 (limit: 4915)
        CPU: 5min 14.227s
     CGroup: /system.slice/display-manager.service
             ├─2021 /usr/sbin/lightdm
             └─2028 /usr/bin/Xorg.bin :0 -seat seat0 -auth 
/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch   <== in dieser 
Zeile!!!

cat /usr/lib/systemd/system/display-manager.service

>cat display-manager.service
[Unit]
Description=X Display Manager
Conflicts=getty@tty7.service plymouth-quit.service
After=ypbind.service gpm.service time-sync.target winbind.service 
acpid.service
Wants=remote-fs.target dbus.socket systemd-user-sessions.service 
systemd-logind.service
After=remote-fs.target dbus.socket systemd-user-sessions.service 
systemd-logind.service getty@tty7.service plymouth-quit.service
OnFailure=plymouth-quit.service

[Service]
Type=forking
PIDFile=/run/displaymanager.pid
ExecStart=/usr/lib/X11/display-manager start  <== eventuell hier weitere 
P.
ExecReload=/usr/lib/X11/display-manager reload
KillMode=process

[Install]
WantedBy=graphical.target
Alias=xdm.service

oder direkt in dem /usr/lib/X11/display-manager Skript

cat /usr/lib/X11/display-manager
...
case "$1" in
    start)


im Start Abschnitt

Was wäre die günstigste Stelle?

LG
Markus

von 🐧 DPA 🐧 (Gast)


Lesenswert?

Also unter Devuan XFCE kann ich das bequem unter Einstellungen -> 
Energieverwaltungszeugs ausstellen und/oder ändern.

von buntkuh (Gast)


Lesenswert?

>>> Was wäre die günstigste Stelle?

mmh, wenn das permanent wegbleiben soll sag es dem Server.
schau nach /var/log/Xorg.0.log wo der xserver seine config hat

z.B:
Using system config directory "/usr/share/X11/xorg.conf.d"
Using a default monitor configuration.


dann nach:
/etc/X11/xorg.conf.d/10-monitor.conf

darin:

Section "Monitor"
    Identifier xy
    Option "DPMS" "false"
EndSection

...

das ist für die Verwendung des speziellen Gerät Monitor xy



ganz wegschalten,

Section "Extensions"
    Option      "DPMS" "Disable"
EndSection


++++++++++++++++++

wenn du das X11 systemdverwurschtelt beim start auf den Weg geben willst

X -dpms ....


-dpms                  disables VESA DPMS monitor control

von Markus W. (dl8mby)


Lesenswert?

Bei mir stehen die X11 Settings (OpenSuse) in

/usr/share/X11/xorg.conf.d/

dort finde ich im 50-device.conf keine Einträge - File ist bis
auf den Kommentar-Header leer.

>grep -H -n Monitor *
50-device.conf:13:#  #Option "monitor-DVI-0" "Default Monitor"
50-monitor.conf:1:# Having multiple "Monitor" sections is known to be 
problematic. Make
50-monitor.conf:6:#Section "Monitor"
50-monitor.conf:7:#  Identifier "Default Monitor"
50-screen.conf:13:#  Monitor "Default Monitor"


>grep -H -n Option *
10-libvnc.conf:16:#    Option "SecurityTypes" "VncAuth"
10-libvnc.conf:17:#    Option "PasswordFile" "/root/.vnc/passwd"
10-quirks.conf:9:        Option "Ignore" "on"
10-quirks.conf:18:        Option "IgnoreAbsoluteAxes" "off"
10-quirks.conf:19:        Option "IgnoreRelativeAxes" "off"
10-quirks.conf:28:        Option "TypeName" "TRACKBALL"
10-quirks.conf:37:        Option "TypeName" "MOUSE"
11-evdev.conf:7:        Option  "EmulateWheel"  "on"
11-evdev.conf:8:        Option  "EmulateWheelButton"    "2"
11-evdev.conf:10:        Option  "Emulate3Buttons" "on"
40-libinput.conf:12:#   Option "someoption" "value"
40-libinput.conf:38:        Option "Tapping" "On"
50-device.conf:13:#  #Option "monitor-DVI-0" "Default Monitor"
50-elotouch.conf:5:     Option "Mode" "Absolute"
50-extensions.conf:8:  Option "XFree86-DGA" "Disable"
70-wacom.conf:102:      Option "Button2" "3"

somit kommt eher 50-extensions.conf in Frarge für das Setzen
der 'Option   "DPMS" "Disable"' Option.

Habe es dort plaziert.

zuvor:
Section "Extensions"
  Option "XFree86-DGA" "Disable"
EndSection

jetzt:
Section "Extensions"
  Option "XFree86-DGA" "Disable"
  Option "DPMS" "Disable"
EndSection


Danke für den Hinweis.

Markus

von rbx (Gast)


Lesenswert?

🐧 DPA 🐧 schrieb:
> Also unter Devuan XFCE kann ich das bequem unter Einstellungen ->
> Energieverwaltungszeugs ausstellen und/oder ändern.

hatte Markus doch gemacht, s.o.

Markus W. schrieb:
> Was wäre die günstigste Stelle?

Das weiß ich nämlich auch nicht, aber z.B. für Skyrim habe ich auch xset 
- Einstellungen, die ich jedesmal, bevor ich anfange zu spielen, mit 
einem Skript starte. Da ist auch die Frage, ob man das nicht gleich in 
den Start mit einbinden kann (wie auch die Wine-Einstellungen). Aber auf 
jeden Fall geht das von der Benutzerebne aus - So zum Testen kann das 
erstmal so machen, und schauen, wie es funzt.

Wo das jetzt am besten passt, hängt wohl auch mit der Frage zusammen, 
warum das überhaupt so läuft. Da wäre dann vielleicht ein Bug-Report 
dienlicher.

von Markus W. (dl8mby)


Lesenswert?

Eine Vermutung von mir, wo der Hund begraben liegen könnte.

Da ich bei jedem OS Update (OpenSuse Tumbleweed) auch den
Nvidia-Treiber compiliere, muss ich mir auch diesen in der
neusten Version von Nvidia holen, damit er zu dem neusten
Kernel passt, der in der Rolling-Distro von OpenSuse verwendet
wird.

Damit habe ich an zwei Stellschrauben gedreht.
Einmal den Kernel von 5.15.8-1-default nach 5.15.12-1-default
geändert

/boot
>ls -l vmlinuz-5.*
-rw-r--r-- 1 root root 11440816 Jan  1 13:29 vmlinuz-5.15.12-1-default
-rw-r--r-- 1 root root 11443696 Dec 13 03:24 vmlinuz-5.15.7-1-default
-rw-r--r-- 1 root root 11440784 Dec 18 02:41 vmlinuz-5.15.8-1-default

wie auch den Nvidia Treiber von 470.86 nach 495.46

>ls -l NVIDIA-Linux*.run
-rw------- 1 mw users 271484294 Aug 25 17:52 
NVIDIA-Linux-x86_64-470.63.01.run
-rw------- 1 mw users 273149806 Nov 14 10:42 
NVIDIA-Linux-x86_64-470.86.run
-rw------- 1 mw users 280886811 Jan  5 09:06 
NVIDIA-Linux-x86_64-495.46.run

Von einer dieser beiden Stellen könnte das Verhalten herrühren.

Möglich ist auch, das generell an den X-Skripten der neuen Distri.
Änderungen stattgefunden haben, die diesen Effekt haben.

Wie gesagt die letzten beiden Jahre hatte ich dieses Problem nicht.

Nun läuft der Notebook aber ohne, dass der Bildschirm dunkeltastet
schon seit einer Stunde.

Später werde ich einen Reboot machen um zu verifizieren ob auch die
Startup-Einstellung in der X11-Config greift.

Lieben Dank allen Teilnehmern die geholfen haben das zu beheben.
Möglicherweise hilft es ja auch anderen die ihr Linux System noch
nicht so detailliert kennen und das gleiche Problem haben.

Wünsche Euch noch ein schönes WE.
Markus

von Rolf M. (rmagnus)


Lesenswert?

Jörg E. schrieb:
> In der bashrc werden die Befehle aber nur aufgerufen wenn du dich an der
> Console einloggst. Oder etwa auch wenn Linux bootet und du dich an
> XServer anmeldest?

Nein, du hast schon recht. Sowas müsste dann eher als Skript in den 
Autostart gesteckt werden. Aber wenn es auch über die Xorg-Konfig geht, 
ist das natürlich der schönere Weg.

Markus W. schrieb:
> jetzt:
> Section "Extensions"
>   Option "XFree86-DGA" "Disable"
>   Option "DPMS" "Disable"
> EndSection

Ob das funktioniert, ist fraglich. Es macht meinem Verständnis nach was 
anderes. In der Section "Monitor" sorgt es dafür, dass DPMS für diesen 
Monitor nicht aktiv ist, während es in der Section "Extensions" dafür 
sorgt, dass die dazugehörige X-Protokoll-Extension nicht aktiviert wird, 
d.h. Programme können auf die Einstellung nicht mehr zugreifen. Ob das 
heißt, dass auch das ganze Feature nicht mehr aktiv ist, geht da nicht 
so eindeutig daraus hervor.
Siehe auch man xorg.conf oder online 
https://www.x.org/releases/current/doc/man/man5/xorg.conf.5.xhtml

von foobar (Gast)


Lesenswert?

Nachdem der X-Server gestartet wurde, wird anschließend die User-Session 
auf dem gestartet.  Dabei werden verschiedene Skripte abgearbeitet (die 
dann z.B. den Window-Manager starten, etc).  Die Details sind etwas vom 
System abhängig (xinit vs xdm vs lightdm vs ...), aber üblicherweise ist 
eines davon ~/.xsession - darin können Anwender persönliche Anpassungen 
an ihrer Session vornehmen, z.B. den Screen-Saver abschalten.  Bei mir 
steht da u.A. drin:
1
xset r rate 250 30  -r 195 -r 196  b 100 880 10  s off  -dpms

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.