Forum: Platinen Altium, 2 Monitore unterschiedlicher Auflösung, Fenster verschwinden beim Verschieben


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von M.A. S. (mse2)


Lesenswert?

AD21, mal wieder ein neues Altium-Problem:
Ich hatte bis gestern zwei identische Monitore mit Full-HD-Auflösung. 
Seit gestern habe ich einen davon gegen einen 4k-Monitor ausgetauscht. 
Schiebe ich nun z.B. das Properties-Fenster oder das Projects-Fenster 
vom großen auf den kleinen Bildschirm, dann verschwinden diese auf 
Nimmerwiedersehen.

Bis jetzt bekomme ich sie nur durch Programmabbruch und Neustart wieder 
zu Gesicht.
Weiß jemand, wie man die Fenster mit weniger Aufwand wieder sichtbar 
werden lassen kann?

: Bearbeitet durch User
von M.A. S. (mse2)


Lesenswert?

War gerade erfolgreich mit folgender Prozedur:
- Das gesamte Altium-Fenster hinterherschieben (vom großen auf den 
kleinen Schirm),
- dann das entsprechende Fenster (z.B. Projects) unten bei 'Panels' 
schließen und wieder öffnen,
et voilá: es ist wieder da!

Über kurz oder lang werde ich mir wohl einen zweiten 4k-Monitor 
hinstellen...
(eher über kurz!)

von Björn G. (tueftler)


Lesenswert?

Hi!

Ja, den Fehler kenne ich...
Diesen habe ich auch Altium inkl. Video beschrieben, aber die 
interessierte es herzlich wenig.
Zwischendrin kam mal eine Marketing-Email, man solle sich bei Fragen 
überaus gerne bei dem benannten Mitarbeiter melden. Habe ich dann 
diesbezüglich gemacht, aber der Mitarbeiter hat nicht einmal auf die 
Email geantwortet.
Finde ich sehr lächerlich bei so einem Fehler.
Gut, bei dem Preis der Software muss man sich ja auch um verschwundene 
Panels nicht kümmern :(

"Falls" ich die Panels verschieben müsste, hat bisher die Sache mit dem 
Neustart geholfen.

Deinen Tipp werde ich mir auch einmal anschauen.

: Bearbeitet durch User
von M.A. S. (mse2)


Lesenswert?

Danke für Deine Antwort. Hast Du eine Subscription?

von Björn G. (tueftler)


Lesenswert?

Ja, habe ich.

von Thomas H. (thomash2)


Lesenswert?

Das ist der Grund warum ich die Subscription abgelegt habe, sie haben 
die Fehler von Version zu Version umgebaut. Gewöhnt man sich bei einer 
Version an die Workarounds dann sieht's bei der nächsten schon wieder 
anders aus - aber nicht besser.

Dennoch im Großen und Ganzen bin ich mit der Software zufrieden und 
würde sie auch weiterempfehlen. Mir reicht soweit AD17 von AD12 - AD17 
hab ich keinerlei Vorteile für mich gefunden die Upgrades haben 
irgendwie nichts gebracht.
Dinge die später hinzugekommen sind haben wir bei uns extern bereits 
anders implementiert. z.B BOM Änderungen.
Ich schätze früher oder später werde ich in den nächsten 10 Jahren wohl 
auf Kicad umsteigen (das ist soweit meine Prognose... wenn nicht dann 
bleib ich halt nach wie vor bei AD17).

von M.A. S. (mse2)


Lesenswert?

Björn G. schrieb:
> Ja, habe ich.
Dann ist das natürlich bitter, wenn man Deine Eingaben ignoriert.
Ich habe keine Subscription, ich hatte immer nur die zeitlich 
befristete, die man bekommt, wenn man Upgradet, was wir seit 2006 vier 
mal getan haben (das erste Mal war von Protel 99SE auf AD).

Ich bin im Allgemeinen nicht unzufrieden mit Altium.

Thomas H. schrieb:
> Ich schätze früher oder später werde ich in den nächsten 10 Jahren wohl
> auf Kicad umsteigen (das ist soweit meine Prognose... wenn nicht dann
> bleib ich halt nach wie vor bei AD17).
Auf KiCad würde ich umsteigen, wenn ich privat etwas machen wollte...

von Björn G. (tueftler)


Lesenswert?

M.A. S. schrieb:
> Dann ist das natürlich bitter, wenn man Deine Eingaben ignoriert.
Ja, fand ich auch nicht so prickelnd.
Die Subscription läuft noch bis Mitte des Jahren, mal schauen ob ich 
wirklich verlängere...

von Roland E. (roland0815)


Lesenswert?

Björn G. schrieb:
> M.A. S. schrieb:
>> Dann ist das natürlich bitter, wenn man Deine Eingaben ignoriert.
> Ja, fand ich auch nicht so prickelnd.
> Die Subscription läuft noch bis Mitte des Jahren, mal schauen ob ich
> wirklich verlängere...

Ja, das Voting-System für die BUGs ist ein Krampf. Ich hatte vor einiger 
Zeit mal etwas drin gewühlt, und für den selben BUG mindestens 5 
Bugreports von ebensovielen Leuten gefunden...

Altium ruht sich extrem darauf aus, dass die Nutzer (wg 
Zeitdruck/Unwissenheit) eben nicht in diesem unübersichtlichen Wust 
nachsehen, ob der BUG schon existiert und ihn dann drauf abstimmen:
"Der Fehler hat ja nur einen Vote, der ist nicht wichtig..." (frei 
Zitiert).
Und fall sdoch mal ein Fehler behoben wird, werden zwei oder drei neue 
eingebaut, die Funktionen sabotieren, welche seit jahren funktioniert 
hatten.

Mein AG hat seine Subscriptions jetzt auch gecancelt. Rausgeworfenes 
Geld...

von Wühlhase (Gast)


Lesenswert?

M.A. S. schrieb:
> War gerade erfolgreich mit folgender Prozedur:
> ...

Oh, vielen Dank für die Rückmeldung mit der Lösung. Ein feiner Zug (auch 
wenn ich selber auf absehbare Zeit davon nicht profitieren werde).


Björn G. schrieb:
> M.A. S. schrieb:
>> Dann ist das natürlich bitter, wenn man Deine Eingaben ignoriert.
> Ja, fand ich auch nicht so prickelnd.
> Die Subscription läuft noch bis Mitte des Jahren, mal schauen ob ich
> wirklich verlängere...

Der Umgang mit Bugreports von Altium war mal tatsächlich miserabel, 
wobei ich aber finde daß das seit ca. zwei oder drei Jahren deutlich 
besser geworden ist. Die Kommunikation war einfach schlecht, da es nur 
sehr selten Rückmeldungen gegeben hat. Irgendwann meinte ein Altium-MA 
auf einer Roadshow mal, daß die Kommunikation zwar zugegeben schlecht 
ist weil einfach kein Feedback kommt, aber daß die da trotzdem hinterher 
sind.

Und ich auch sagen, daß das irgendwann tatsächlich deutlich besser 
geworden ist. Und ohne Altium zu sehr in Schutz zu nehmen - immerhin 
bekommen sie Geld für ihre Arbeit - seit ich selber ein kleines 
Softwareprojekt habe, kann ich es auch gut verstehen daß auch 
Softwarefirmen Bugs, aber auch Weiterentwicklung priorisieren und 
manches dann auch hinten runterfällt, wenn es nur wenige Benutzer 
betrifft oder allgemein einfach zu lösen ist.

Zwei Bugs, die ich gemeldet habe, sind gefixt worden, ein dritter ist 
zumindest nach Aussage des Altium-MAs in Arbeit. Dieser hat nur eine 
Handvoll Stimmen bekommen (ich glaube sechs oder so), ist aber 
gravierend wenn er auftritt, wen es interessiert und Zugriff auf das 
Altium-Bugcrunchforum hat: #17756. Und wie ich beim Nachschauen sehe, 
ist der mittlerweile tatsächlich im In-Development-Status.

Seit ca. zwei Jahren bekomme ich auch öfter mal Rückmeldungen von 
Altium-MAs, wenn ich einen Bugreport aufmache. Z.B. wenn sie nähere 
Infos haben wollen um den Fehler zu reproduzieren.
Aussagekräftige und detaillierte Beschreibungen sind natürlich 
hilfreich, ich gebe da normalerweise soviele Infos wie möglich mit, fast 
immer Screenshots oder Videos, usw.

Ob einem die Bugs da schnell genug repariert werden und ob einem daß 
Geld und die Zeit das wert ist, ist halt eine Frage die sich jeder 
selbst beantworten muß. Aber ich habe genug Firmen erlebt die für 
deutlich schlechtere Produkte deutlich schlechtere Unterstützung 
anbieten. Und nicht selten auch noch mehr Geld verlangt haben.

Jedenfalls kann man meiner Meinung nach nicht (mehr) sagen, daß Altium 
seine Kunden hart ignoriert. Da steckt zwar auch etwas Eigeninitiative 
von mir als Benutzer drin, einen Bugreport aufzumachen, Screenshots, 
eine vernünftige Beschreibung usw. kostet halt etwas Zeit.
Klar kann man sich auch sagen, man bezahlt ja Geld dafür, und dann soll 
man da jetzt auch noch Zeit investieren...aber wie soll es denn sonst 
gehen?
Altium ist halt eine Softwareschmiede. Deren Entwickler bauen aber keine 
Elektronik, sondern schreiben Software. Die kennen das Programm nur aus 
Programmierersicht, das liegt in der Natur der Sache.

Und neuerdings bitten sie ja auch direkt um Kundenmeinung, bevor sie 
etwas neues implementieren. Ein Altium-MA hat vor einigen Wochen zu so 
einer Feature-Umfrage gefragt, ob jemand Interesse an einer 
Zoomkonferenz hätte für ein paar Detailbesprechungen zu so einer 
Neuimplementierung...und mich am Ende der Konferenz eingeladen, am 
Betatestprogramm teilzunehmen.

Klar, da geht natürlich etwas Zeit rein (und die bezahlt auch Altium 
nicht), aber daß die ihre Kunden so komplett im Regen stehen lassen ist 
eben auch nicht wahr.

von Wühlhase (Gast)


Lesenswert?

Ich sehe, gerade gibt es ein neues Update. Besagter Bugreport oben wurde 
in den Release Notes als repariert aufgeführt (und noch viel mehr).

von Max (Gast)


Lesenswert?

Hm
ich habe auch zwei Monitore (beide Eizo) von denen einer 4K hat.
Ich hab die Probleme nicht, bist du sicher das das Problem bei Altium 
liegt?
Benutzte AltiumVersion 22.2.1

von M.A. S. (mse2)


Lesenswert?

Max schrieb:
> Hm
> ich habe auch zwei Monitore (beide Eizo) von denen einer 4K hat.
> Ich hab die Probleme nicht, bist du sicher das das Problem bei Altium
> liegt?
> Benutzte AltiumVersion 22.2.1

Bei anderen Programmen trat das Problem nicht auf. Ich werde dies aber 
nicht weiterverfolgen, ich habe den Missstand ganz einfach gelöst: habe 
nun zwei 4k-Monitore. :)

von Björn G. (tueftler)


Lesenswert?

Max schrieb:
> Ich hab die Probleme nicht, bist du sicher das das Problem bei Altium
> liegt?
Das Problem tritt nur auf, wenn der Hauptmonitor ein 4k ist und Du die 
Panels auf einen mit kleinerer Auflösung verschiebst.
Alle 4k ist kein Problem.

von Wolfgang (Gast)


Lesenswert?

Björn G. schrieb:
> Das Problem tritt nur auf, wenn der Hauptmonitor ein 4k ist und Du die
> Panels auf einen mit kleinerer Auflösung verschiebst.
> Alle 4k ist kein Problem.

Es ist ja auch völlig abwegig, dass man Altium auf einem Laptop mit 
einem 4k-Zweitmonitor benutzt. Nicht jeder Laptop hat einen 4k 
Bildschirm.
Mit einer Anforderung "alle 4k" gibt es dann schon ein Problem.

von M.A. S. (mse2)


Lesenswert?

Wolfgang schrieb:
> Es ist ja auch völlig abwegig, dass man Altium auf einem Laptop mit
> einem 4k-Zweitmonitor benutzt.

Erstens war davon nicht die Rede. Die von mir geschilderte Situation war 
an meinem Desktop-PC im Büro, an dem ich schon immer zwei Monitore hatte 
und wo ich dann den Hauptmonitor gegen einen 4k-Monitor austauschte. 
Erstmal nur einen, um zu sehen, wie sich das macht.

Zweitens wäre das kein bisschen abwegig, in meinem Homeoffice hätte ich 
sehr leicht in diese Situation kommen können. Tatsächlich habe ich im 
Homeoffice einen (wenn auch nicht 4k-) Monitor am Laptop, der mir dort 
als Hauptbildschirm dient. Das kleine Laptop-Ding hat nicht mal Full-HD.

von Wolfgang (Gast)


Lesenswert?

M.A. S. schrieb:
> Zweitens wäre das kein bisschen abwegig, ...

Sorry, da waren die <ironie>Tags</ironie> wohl nicht deutlich genug.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.