Forum: Analoge Elektronik und Schaltungstechnik Problem mit Spannungswandler auf 555 Basis


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Christoph L. (christoph_l979)


Angehängte Dateien:

Lesenswert?

Hallo,

ich baue grade einen Nixi Tube Bausatz zusammen. Dabei ist auch ein 
Spannungswandler vorhanden, der die 12V DC Spannung vom Netzteil auf 
170V hoch wandelt.

Dies wird durch einen MosFet und einen 555 Timer gemacht. Der 555 ist 
auf 31khz eingestellt und es wird eine 100uH Spule verwendet. Hinten 
dran dann die typische Diode und der Kondensator.

Zur Spannungsregelung wird ein Spannungsteiler verwendet (mit Trimpot) 
der dann einen MPSA42 Transistor ansteuert, mit dem (soweit ich 
verstehe) ein zweiter Spannungsteiler am CTRL Eingang des 555 gesteuert 
wird um eine Referenzspannung anzulegen und so die Ausgangsspannung am 
Ausgang auf 170V einzustellen.

Soweit so gut (hoffe das ist soweit alles korrekt, bitte korrigieren, 
wenn ich das nicht ganz korrekt verstanden habe).

Nun sollte am TP1 so ~180V Leerlaufspannung anliegen (laut Anleitung). 
Mit dem Trimpot soll die Spannung an TP1 dann entsprechend eingestellt 
werden.

Problem - Meine Spannung ist bei 350V und scheint nicht geregelt zu 
werden.

Ich habe das Ding soweit analysiert wie ich konnte:

1. Ich habe Q7 mal ausgelötet und einfach mit dem Oscilloskop geschaut 
was der 555 Ausgang so macht. Der läuft schön auf 31khz mit 52% duty 
cycle. Das sieht erst mal normal aus.

2. Ich habe alle Wiederstände geprüft und vorher auch gemessen, die sind 
alle an der richtigen Stelle und sind auch in der toleranz.

3. Das Trimpot habe ich bislang noch nicht verstellt, es steht aber 
ziemlich genau auf Mitte (gemessen ~500 Ohm).

Irgendwie bin ich etwas ratlos, was jetzt dazu führt das die Spannung 
wohl nicht geregelt wird.

Irgendwie kann ich mir nicht vorstellen das Q7 defekt ist, dann würde ja 
überhaupt keine Hochwandlung passieren? Oder gibt es ein scenario, wo 
entweder immer an, oder immer aus zu dieser Spannung führen würde?

Kann Q8 das problem sein? Oder doch der 555, weil der CTRL eingang 
irgendwie spinnt?

Hoffe ihr habt da Ideen zu.

/Edit: Ich habe eine 4.5uF Kondensator bei C4 bei mir drin, aber das 
sollte keine Rolle spielen. Der ist allerdings nur bis 250V belastbar 
und wird sehr heiß (ist aber noch okay). Daher kann ich das ganze nur 
sehr sehr kurz mit Q7 eingelötet betreiben. Längere Analysen sind also 
nicht wirklich möglich ohne den zu zerstören. Leider habe ich auch 
keinen 350V Kondensator da.

Habe eben noch mal geguckt, Elkos sind auch korrekt eingebaut.

Liebe Grüße
Christoph

: Bearbeitet durch User
von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Christoph L. schrieb:
> 3. Das Trimpot habe ich bislang noch nicht verstellt, es steht aber
> ziemlich genau auf Mitte (gemessen ~500 Ohm).

Dann mach das doch mal. Erhöhst du seinen Widerstand dann sollte die 
Spannung zurückgehen. Gleichzeitig geht der Pegel am Kollektor des MPSA 
zurück. Der soll anfangen abzuregeln, sobald an seiner Basis etwa 0,6 - 
0,7V stehen. Warum die Jungs da einen 300V Transistor einsetzen, bleibt 
wohl ihr Geheimnis - sofern die Schaltung stimmt.
Generell halte ich den 555 für sowas als nicht besonders geeignet, aber 
du hast die Schaltung ja nun mal vor dir.

: Bearbeitet durch User
von Philipp G. (geiserp)


Lesenswert?

Christoph L. schrieb:
> Hoffe ihr habt da Ideen zu.

Misst Du am Ausgang der Diode (TP1)? C4 ist drin? Welche Diode hast du 
verbaut, die die angegeben ist?

: Bearbeitet durch User
von Christoph L. (christoph_l979)


Lesenswert?

Ja, ich messe am Ausgang der Diode am TP1 und C4 ist drin. Wie gesagt 
bei mir ist C4 ein 4.5uF 250V ... der sollte also möglichst nicht so 
lange auf 350V laufen. Die Diode ist eine UF4004 .. in der Bauanleitung 
ware die im Schaltplan und diese angegeben und im Kit war die UF4004 
dabei. Die ist glücklicherweise mit 400V 1A dick genug ausgelegt.

Warum die da einen 400V Transistor genommen haben weiß ich auch nicht, 
aber es gibt noch 3 davon in der Schaltung um die Annodenspannung zu 
schalten. Vermutlich wollten die nicht noch einen anderen haben und der 
tuts.

von Michael M. (Firma: Autotronic) (michael_metzer)


Angehängte Dateien:

Lesenswert?

Falls der CTRL-Eingang spinnt, dann versuche doch mal den Kollektor von 
Q8 direkt mit dem Gate des Mosfets zu verbinden. Dadurch sinkt zwar der 
Wirkungsgrad, aber evtl. funktioniert die Schaltung dann wenigstens.

Die 9V1 Z-Diode sorgt für eine bessere Temperaturstabilität. R23 muss 
dann natürlich auch von 470R auf 6k8 erhöht werden.

von Dergute W. (derguteweka)


Lesenswert?

Moin,

Michael M. schrieb:
> dann versuche doch mal den Kollektor von
> Q8 direkt mit dem Gate des Mosfets zu verbinden.

Damit dann den durchaus kraeftigen Ausgangstreiber des 555 nach GND 
kurzzuschliessen halte ich jetzt doch eher nur fuer bedingt clever.

Gruss
WK

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Michael M. schrieb:
> Falls der CTRL-Eingang spinnt, dann versuche doch mal den Kollektor von
> Q8 direkt mit dem Gate des Mosfets zu verbinden.

Nö, das probierst du besser nicht, denn damit wird die gesamte Regelung 
ausgehebelt. Im Zweifel besser mal den 555 ersetzen. Aber vorher messen 
kann nicht schaden.

von Christoph L. (christoph_l979)


Lesenswert?

Matthias S. schrieb:
> Dann mach das doch mal. Erhöhst du seinen Widerstand dann sollte die
> Spannung zurückgehen. Gleichzeitig geht der Pegel am Kollektor des MPSA
> zurück. Der soll anfangen abzuregeln, sobald an seiner Basis etwa 0,6 -
> 0,7V stehen.

Danke an alle soweit.

@Matthias, das habe ich ausprobiert. Ich habe an der Basis vom Q8 eine 
Spannung von bis zu 2.2V gemessen (TP1=370V) aber ich kann nicht 
erkennen, das das funktioniert.

Wie genau soll denn der Q8 arbeiten? Soll der einfach nur CTRL auf GND 
ziehen? Oder soll der zusammen mit R25 als Spannungsteiler arbeiten?

Jedenfalls hat er keinen erkennbaren Effekt. Wenn der 2.2V Basis 
Spannung hat, müsste der dann nicht auf jeden Fall CTL auf GND ziehen? 
Das heißt, wenn ich PIN5 messe müsste der auf GND liegen?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Christoph L. schrieb:
> Wenn der 2.2V Basis
> Spannung hat, müsste der dann nicht auf jeden Fall CTL auf GND ziehen?

Doch, das muss er tun, da er ein ganz normaler Transistor ist. Scheint 
also defekt zu sein. Mein Tipp ist, das die BE Strecke im Eimer ist.
Da er keine Hochspannung sieht, reicht da ein normaler kleiner NPN, der 
sich in der Bastelkiste finden sollte.
Achtung - die Belegung des MPSA42 ist gegenüber den normalen BC547 usw. 
verdreht, also Emitter und Kollektor sind vertauscht.

: Bearbeitet durch User
von Michael M. (Firma: Autotronic) (michael_metzer)


Angehängte Dateien:

Lesenswert?

Dergute W. schrieb:
> Damit dann den durchaus kraeftigen Ausgangstreiber des 555 nach GND
> kurzzuschliessen halte ich jetzt doch eher nur fuer bedingt clever.

Ich habe es ausprobiert, es funktioniert perfekt. Natürlich muss man am 
Ausgang vom NE555 z.B. einen 1k Widerstand setzen.

Das einzige was nicht clever ist, ist dass der Mosfet u.U. in den 
Linearbetrieb übergeht.

von Christoph L. (christoph_l979)


Lesenswert?

Okay, nochmal was gemessen.

Trimpot steht auf ziemlich hoch und erzeugt 2.1V Basisspannung an Q8.

Q8 Collector und somit auch Pin5 am 555 liegt dann auf 7.3V ... ...

Spannung nach GleichrichterDioden und Netzteilverlust liegt bei 10.7V am 
Spannungseingang.

Damit ist für den 555 die 1/3 2/3 Spannung: 3,56V und 7,13V ...

Gut das ich das gemessen habe, bin aber leider kein Stück schlauer.

von H. H. (hhinz)


Lesenswert?

Christoph L. schrieb:
> 2.1V Basisspannung an Q8.

Dann ist der kaputt.

von Christoph L. (christoph_l979)


Lesenswert?

Matthias S. schrieb:
> Doch, das muss er tun, da er ein ganz normaler Transistor ist. Scheint
> also defekt zu sein. Mein Tipp ist, das die BE Strecke im Eimer ist.
> Da er keine Hochspannung sieht, reicht da ein normaler kleiner NPN, der
> sich in der Bastelkiste finden sollte.
> Achtung - die Belegung des MPSA42 ist gegenüber den normalen BC547 usw.
> verdreht, also Emitter und Kollektor sind vertauscht.

Danke, habe noch einen S8050 gehabt, der hat eine ziemlich ähnliche BE 
Spannung ... damit funktioniert das jetzt und ich konnte die Spannung 
auf 180V einstellen.

Vielen Dank für Eure Hilfe ... Einen Schritt weiter im Projekt ;-)

von *-*-*-* (Gast)


Lesenswert?

Schaut euch mal die Schaltung an, ist eigentlich für Geigerzähler, 
Spannung kann mit Zenerdioden geregelt werden.

Beitrag "Re: Hochspannungserzeugung Geigerzähler aus 3V"

von *-*-*-* (Gast)


Lesenswert?

es muss aber ein CMOS-555 sein !

von M.A. S. (mse2)


Lesenswert?

Christoph L. schrieb:
> ich baue grade einen Nixi Tube Bausatz zusammen.
Wie schön. :)
Christoph L. schrieb:
> ... damit funktioniert das jetzt und ich konnte die Spannung
> auf 180V einstellen.
> ... Einen Schritt weiter im Projekt ;-)
Wenn alles läuft, würdest Du dann bitte 'mal ein Foto von den 
leuchtenden Nixis hochladen?!?  :)

von ArnoR (Gast)


Lesenswert?

*-*-*-* schrieb:
> es muss aber ein CMOS-555 sein !

Nein.

Die CMOS-Version war damals nur nötig, weil von 3V auf 400V gewandelt 
wurde und der bipolare 555 mit 3V gar nicht funktioniert. Bei 12V 
Versorgung geht natürlich auch der bipolare 555. Außerdem kann der 
Basiswiderstand entfallen, wenn ein Mosfet als Schalttransistor 
verwendet wird.

von ArnoR (Gast)


Lesenswert?

Christoph L. schrieb:
> ich baue grade einen Nixi Tube Bausatz zusammen. Dabei ist auch ein
> Spannungswandler vorhanden, der die 12V DC Spannung vom Netzteil auf
> 170V hoch wandelt.
>
> Dies wird durch einen MosFet und einen 555 Timer gemacht. Der 555 ist
> auf 31khz eingestellt und es wird eine 100uH Spule verwendet.

Schon wieder so eine üble Schaltung ...

Die Einschaltzeit des Mosfet ist etwa 1/(2*31kHz)~16µs. Damit ergibt 
sich ein Stromanstieg in der Drossel von ~1,93A, d.h. die 1A-Drossel 
wird weit in die Sättigung gefahren. Daran kann auch der 
"Spannungsregeltransistor" nichts ändern. Außerdem ist die BYV95C nicht 
besonders schnell und die Kombination R19/C13 frisst einen Teil der 
mühsam hochgepumpten Ladung auf. Die Schaltung hat einen ziemlich miesen 
Wirkungsgrad.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

ArnoR schrieb:
> Außerdem ist die BYV95C nicht
> besonders schnell

Geliefert wurde aber eine UF4004.

von Christoph L. (christoph_l979)


Angehängte Dateien:

Lesenswert?

Stimmt sicher alles, Beschwerden einfach an den Schaltungsersteller.

Aber aus dem Grund ist vermutlich auch eine 2A Spule drin ;-) Der 
Schaltplan scheint da nicht aktualisiert worden zu sein, und als Diode 
ist wie schon gesagt ne 4004 drin.

Ich brauche jetzt erst mal einen Ersatz für den 7805, der wird mir viel 
zu heiß. Da hängt einfach zu viel Last dran. Und mit einem 12V AC 
Netzteil (wegen der 50hz Frequenz zur Uhrstabilisierung) kommen dann da 
am 7805 schon 15V+ DC an ... da muß der ne ganz schöne Menge verheizen. 
Werden den jetzt wohl durch einen DC/DC Schaltregler umbauen.

M.A. S. schrieb:
> Wenn alles läuft, würdest Du dann bitte 'mal ein Foto von den
> leuchtenden Nixis hochladen?!?  :)

Bitteschön :-)

von Harald W. (wilhelms)


Lesenswert?

Christoph L. schrieb:

> Ich brauche jetzt erst mal einen Ersatz für den 7805,
> der wird mir viel zu heiß.

Da brauchst Du keinen Ersatz für den 7805, sondern einen Kühlkörper.

von I bims 1 N00B (Gast)


Lesenswert?

Harald W. schrieb:
> Christoph L. schrieb:
>
>> Ich brauche jetzt erst mal einen Ersatz für den 7805,
>> der wird mir viel zu heiß.
>
> Da brauchst Du keinen Ersatz für den 7805, sondern einen Kühlkörper.

Oder was von Recom als Ersatz?

von Michael M. (Firma: Autotronic) (michael_metzer)


Lesenswert?

Christoph L. schrieb:
> Bitteschön :-)

Oooh, das sieht aber sehr edel aus. Die violetten LEDs geben dem Objekt 
noch den optischen Pfiff.

von Christoph L. (christoph_l979)


Lesenswert?

Harald W. schrieb:
> Da brauchst Du keinen Ersatz für den 7805, sondern einen Kühlkörper.

Kühlkörper ist schon dran, aber so will ich das nicht in ein Gehäuse 
einbauen.

Das liegt einfach daran, daß zu viel Strom gezogen wird und der dadurch 
mit sehr viel Verlust arbeiten muß.

I bims 1 N00B schrieb:
> Oder was von Recom als Ersatz?

https://www.conrad.de/de/p/gaptec-10070273-dc-dc-wandler-print-24-v-dc-5-v-dc-1500-ma-7-5-w-anzahl-ausgaenge-1-x-1603649.html

Das hier :-)

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Christoph L. schrieb:
> Das hier :-)

Kost' hier nur die Hälfte:
https://www.pollin.de/p/gaptec-dc-dc-wandler-electronic-sip3-8-36vin-5vout-2000ma-11-5x9x17-5mm-352856
Wenn du da noch ein paar andere Sachen holst, sollte sich das lohnen.

von Manfred (Gast)


Lesenswert?

Michael M. schrieb:
> Die violetten LEDs geben dem Objekt noch den optischen Pfiff.
Die einen so, die anderen so - ich empfinde die prollig und vermisse auf 
dem Bild die Manta-Manta-Friseuse.

Christoph L. schrieb:
> Bitteschön :-)
Trotz meines Kommentars: Dein Aufbau sieht gut aus, das bekommt nicht 
jeder so hin. Die LEDs sind hoffentlich abschalt- oder dimmbar.

Christoph L. schrieb:
>> Da brauchst Du keinen Ersatz für den 7805, sondern einen Kühlkörper.

Man könnte den 7805 per Vorwiderstand entlasten.

> Das liegt einfach daran, daß zu viel Strom gezogen wird
> und der dadurch mit sehr viel Verlust arbeiten muß.

Ja, die Verlustleistung will man nicht dauerhaft abführen und zu allem 
Überfluss auch noch bezahlen müssen, da ist ein ordentlicher 
Schaltregler allemal die bessere Lösung.

Matthias S. schrieb:
> Kost' hier nur die Hälfte:
> xttps://www.pollin.de/p/gaptec-dc-dc-wandler
Kann man der Marke trauen oder gibt eher etwas mehr aus und nimmt Traco 
oder Recom?

> Wenn du da noch ein paar andere Sachen holst, sollte sich das lohnen.

Bei 7 Euro Preisdifferenz zur blauen Apotheke rechnet sich sogar eine 
Einzelbestellung.

Wenn 1 Ampere genügt, kann Reichelt für 3,45 €:
https://www.reichelt.de/dc-dc-wandler-5-w-5-v-1000-ma-to-220-lme78-05-1-0-p242853.html?&nbc=1

von ...-. (Gast)


Lesenswert?

Ich nehme gerne die MP1584 oder MP2307 als Spannungswandler, die können 
bis 3 A ab, z.B. https://www.ebay.de/itm/352884272042 oder 
https://www.ebay.de/itm/255505784627

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Manfred schrieb:
> Matthias S. schrieb:
>> Kost' hier nur die Hälfte:
>> xttps://www.pollin.de/p/gaptec-dc-dc-wandler
> Kann man der Marke trauen oder gibt eher etwas mehr aus und nimmt Traco
> oder Recom?

Ich kann sicher nicht für alle Kunden dieser Regler sprechen, aber hier 
spielen sie einwandfrei. Scheinen sogar recht unempfindlich gegen 
kapazitive Last zu sein. Praktisch ist eben das Footprint, das in den 
meisten Fällen an den Platz eines 78xx passt.

Manfred schrieb:
> Wenn 1 Ampere genügt

Unsere bayrischen Freunde liefern die 1,5A Version nicht, deswegen 
postete ich die 2A Variante.

: Bearbeitet durch User
von Christoph L. (christoph_l979)


Lesenswert?

Hab den mal bestellt ... sicher besser als das heiße Eisen da in der 
Schaltung.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.