Forum: Mikrocontroller und Digitale Elektronik LCD TV Mainboard oder T-CON defekt


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von T.N. (Gast)


Angehängte Dateien:

Lesenswert?

Hi,

hab hier ein Hitatchi U50KA6150 50" LED LCD TV, bei dem das Display 
keinen Sprung aufweist, die Hintergrundbeleuchtung leuchtet, kein Ton zu 
hören ist. Mit der FB lässt er sich An/Aus schalten. Was im defekten 
Zustand soviel bedeutet wie: LED Hintergrundbeleuchtung AN/AUS.

Netzteil: Vestel 17IPS72
Mainboard: Vesterl 17MB170
T-Con: CCPD-TC495-008 V4.0
Hab ihn hinten aufgemacht und schon verschiedene Messungen gemacht.
Vom Netzteil kommen 12V_STBY und 24V an das Mainboard.
Auf dem Mainboard sind die im PDF zu messenden Spannungen praktisch alle 
messbar. Bis auf 1V1_VDDC_CPU. Die sind nicht immer bei 1,1V sondern 
liegen manchmal auch nur bei 0,9V.

Auf dem T-CON Board kommen 12V an. Verschiedene kleine Testpunkte mit 
VCC3V3 und VCC1V8 haben auch ihre Spannungen.
Bei VGL, VGH, VCOM kenne ich mich nicht gut aus. Hier habe ich aber 
keine Spannungen außerhalb von -0,3V - +0,3V messen können. Ich meine 
hier sollten höhere Spannungen messbar sein, richtig?

Ich frage mich nun, bevor ich da noch mehr ins Detail gehe, welche 
Komponente am wahrscheinlichsten Defekt ist. Mainboard oder T-Con. 
Netzteil ergibt für mich keinen Sinn.
Oder kann doch irgendwas am Display defekt sein, was kein mechanischer 
Schaden oder kein sichtbarere mechanischer Schaden ist? Das würde man 
doch erkennen, oder?

von Thomas Z. (usbman)


Lesenswert?

nun ich würde schon auf das Mainboard tippen, Audio sollte ja bei 
defektem TCON Board noch spielen.

von T.N. (Gast)


Lesenswert?

Thomas Z. schrieb:
> nun ich würde schon auf das Mainboard tippen, Audio sollte ja bei
> defektem TCON Board noch spielen.

Also ich hab gerade mal mit der FB rumgespielt und kam wohl irgendwie in 
ein Menü, wo er dann Tastentöne am Lautsprecher quittierte. Sound 
scheint also zu gehen. Außerdem reagiert er ja auch auf Ein/Ausschalten. 
Werde es mal mit einem neuen T-Conboard probieren.

von Alexander.Ko (Gast)


Lesenswert?

T.N. schrieb:
> Bei VGL, VGH, VCOM kenne ich mich nicht gut aus. Hier habe ich aber
> keine Spannungen außerhalb von -0,3V - +0,3V messen können

Das ist nicht in Ordnung. Kommt vom MB zur Tcon Video Signal?

Ton muss funktionieren, kommt von dem MB. Tcon macht nur Video.

von T.N. (Gast)


Lesenswert?

Alexander.Ko schrieb:
> Das ist nicht in Ordnung. Kommt vom MB zur Tcon Video Signal?
Das muss ich noch prüfen. Traue mich irgendwie nicht, da mit dem 
Oszi-tastkopf an die feinen Kontakte. Möchte keinen Kurzschluss 
erzeugen.
Wie sieht denn das Signal vom MB zum T-CON aus?

> Ton muss funktionieren, kommt von dem MB. Tcon macht nur Video.
Ja Ton funktioniert insofern, dass ich Quittierungstöne der Tasten höre. 
Ich komme nur nirgendwo rein, wo ich eine Videoquelle auswählen könnte. 
Lauter / leiser geht auch bei den Quittierungstönen.

Ich hab mir ein Ersatz-T-Con mit der selben Bezeichnung bestellt. Jedoch 
von einem anderen Fernseher. Hier habe ich VGH VGL, etc. Jetzt kommen 
weiß/schwarze Streifen auf dem Bildschirm. Sind diese T-Con-Boards noch 
irgendwo kodiert und mit dem passenden Display verheiratet? Macht den 
Ersatzteilmarkt natürlich kaputt, wenn das so wäre.
Der Prozessor auf dem Board ist ein HI3231.

Weiß jemand, ob es da ein Spezialisten-Forum gibt für LCD-TV-Reparatur 
oder macht da jedes Büdchen sein eigenes Ding und sammelt nur über 
eigene Erfahrung und es findet kein Austausch statt. Der Ersatzteilmarkt 
ist ja recht groß.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

T.N. schrieb:
> Sind diese T-Con-Boards noch
> irgendwo kodiert und mit dem passenden Display verheiratet?

Das sind sie. Allerdings meistens nicht endgültig, sondern über 
Programmierung auf das passende Display. Das wird in einem EEPROM 
gesetzt, oder manchmal auch im Flash des Mainboards.
Wenn du das alte und das neue T-Con untersuchst, könntest du Glück haben 
und ein EEPROM finden. Das Video vom Scaler zum T-Con ist meist schnell 
und differentiell mit vielen Lanes, in der Art von LVDS.

T.N. schrieb:
> oder macht da jedes Büdchen sein eigenes Ding

Generell möchten die Hersteller natürlich nicht, das man die Glotze 
repariert - zumal es ja so gut wie keine Radio/Fernsehwerkstätten mehr 
gibt. Also ist es schon ein Glücksfall, wenn man Servicemanuals bekommt 
und selber sich aufmachen kann, das Dingens wieder zum Laufen zu 
bringen.

: Bearbeitet durch User
von T.N. (Gast)


Angehängte Dateien:

Lesenswert?

Matthias S. schrieb:
> Das sind sie. Allerdings meistens nicht endgültig, sondern über
> Programmierung auf das passende Display. Das wird in einem EEPROM
> gesetzt, oder manchmal auch im Flash des Mainboards.

Ach verdammt. Ich hab es geahnt. Ich hab auf dem T-Con-Board diesen 
Flash gefunden (siehe zweites Foto). Meinst du es wäre ein Versuch wert?
Teilweise haben auch die anderen Chips auf dem Ersatzboard andere 
SMD-Markings. Das Layout sieht bei beiden exakt gleich aus.
Der Flash-IC wäre ja schnell abgelötet und ausgetauscht.

Matthias S. schrieb:
> Generell möchten die Hersteller natürlich nicht, das man die Glotze
> repariert - zumal es ja so gut wie keine Radio/Fernsehwerkstätten mehr
> gibt. Also ist es schon ein Glücksfall, wenn man Servicemanuals bekommt
> und selber sich aufmachen kann, das Dingens wieder zum Laufen zu
> bringen.

Es ist zum Kotzen. Hoffentlich kommen da bald mal die entsprechenden 
Gesetzesvorschläge um den Herstellern zumindest das vorzuschreiben.
Es wird doch noch genügend Leute geben, die sich sowieso immer das 
"Neuste" kaufen werden.
https://www.elektrogesetz.de/eu-parlament-fordert-recht-auf-reparatur/

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

T.N. schrieb:
> Meinst du es wäre ein Versuch wert?

Das ist es sicher, denn es sind erstens ja nur 8 Pins und zweitens 
kannst du den Flachi ja sowieso im derzeitigen Zustand nicht benutzen. 
Zu verlieren hast du also nix.
Falls du die Möglichkeit hat, sichere beide EEPROMs auf den Rechner.

T.N. schrieb:
> kommen da bald mal die entsprechenden
> Gesetzesvorschläge

Ich gehe eine Wette ein, das das die Hersteller nur dazu auffordert, 
noch mehr zu verdonglen und das die F&E Abteilungen Druck bekommen, 
solche Reparaturen unmöglich zu machen. Bald sind in den Geräten nur 
noch COBs zu finden, mit dem Argument, das das Kosten spart...

: Bearbeitet durch User
von T.N. (Gast)


Lesenswert?

Matthias S. schrieb:
> Das ist es sicher, denn es sind erstens ja nur 8 Pins und zweitens
> kannst du den Flachi ja sowieso im derzeitigen Zustand nicht benutzen.
> Zu verlieren hast du also nix.
> Falls du die Möglichkeit hat, sichere beide EEPROMs auf den Rechner.

Hab mir so ein SPI/I2C EEPROM / FLASH Programmer bestellt mit Zange. Da 
werde ich das einfach auslesen und mal schauen.

Anderes Thema: Die Verbindung zwischen Mainboard und T-Con findet nach 
meiner Recherche über das Vx1 oder V-by-One Protokoll 
statt.(https://www.thine.co.jp/files/user/img/corporate/VBOSTD-V1P52-0000_Abridged%2BEdition.pdf)
Die 51 Pins aus der Spec (siehe Link) passen genau zu den 51 Pins, die 
das Flexkabel zwischen MB und T-Con-Board hat.
Beim verwendeten Prozessor Hi3231 
(https://is2.ecplaza.com/ecplaza2/products/c/c2/c2e/1639039421/4581325.jpg)
vom T-Con-Board steht da, dass er einen "8lane V-by-one input" hat.
Ich verstehe das doch richtig, dass es nur eine unidirektionale 
Verbindung ist und keine Kommunikation von T-Con-Board an den Prozessor 
gibt?
Ich habe versucht die Lanes mit dem Oszi zu untersuchen, aber ein 1Ghz 
Bandbreite Scope habe ich nicht und mit meinem 100Mhz Scope sehe ich 
praktisch single-ended gemessen nur 0V auf jeder Lane. Ich denke mal das 
ist aussichtslos.
Der Fernseher hat ja 4k und mit 8lanes müsste die Pixel-Clock laut 
Protokoll 594MHz haben.
Man könnte das natürlich als Argument nehmen um sich ein 1Ghz Scope 
anzuschaffen, aber nein :) das ist dann doch zu viel des Guten.

Außerdem hatte ich mit dem defekten T-Con einmal die situation, dass ich 
ein Teil des Menüs auf dem Bildschirm gesehen habe und ja Ton und 
Anschalten funktioniert. Ich gehe stark von defektem T-Con Board aus. 
Leider wird es das passende vermutlich nie für mich geben mit so einem 
Exokten wie dem Hitachi.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

T.N. schrieb:
> Ich verstehe das doch richtig, dass es nur eine unidirektionale
> Verbindung ist und keine Kommunikation von T-Con-Board an den Prozessor
> gibt?

Naja, was soll der auch gross an den Scaler schicken? Sein Job ist es, 
die Daten zu demultiplexen und ans Display zu schicken. Das ist im 
grossen und ganzen ein einfacher, wenn auch datenintensiver Job, den er 
vermutlich mit Hilfe eines kleinen MC onchip initialisiert und dann stur 
ausführt. Im EEPROM steht dabei, wie die Geometrie und das Datenformat 
für die Spalten- und Zeilentreiber auszusehen hat. So ist es für die 
Hersteller recht einfach, verschiedene Panels anzutreiben.

T.N. schrieb:
> mit so einem
> Exokten wie dem Hitachi

Naja, auch die grosse Hitachi kocht mit Wasser. Sie müssen sich an das 
halten, was die Panels brauchen und das unterscheidet sich nicht so viel 
von LG, Samsung, Panasonic oder Sony. Das sie dabei ihre eigenen Chips 
verwenden, kann man bei der Grösse der Firma schon verstehen.

: Bearbeitet durch User
von T.N. (Gast)


Lesenswert?

Matthias S. schrieb:
> Naja, was soll der auch gross an den Scaler schicken?

Naja, ich dachte da an irgendwelchen Austausch von 
Seriennummern/Schlüsseln, damit der Hersteller erschwert / verhindert, 
dass Ersatzteile vertrieben werden. Wie du schon sagtest. Das wäre 
natürlich überhaupt nicht zu rechtfertigen, aber bis das jemand 
herausfindet, vergehen auch Jahre in der der Hersteller munter weiter 
Geschäfte machen kann. Ich gebe aber zu, dass das sehr bösartig wäre und 
vermutlich hohe Verbraucherschutzklagen zur Folge hätte. War nur so eine 
Idee.

Matthias S. schrieb:
> Naja, auch die grosse Hitachi kocht mit Wasser. Sie müssen sich an das
> halten, was die Panels brauchen und das unterscheidet sich nicht so viel
> von LG, Samsung, Panasonic oder Sony. Das sie dabei ihre eigenen Chips
> verwenden, kann man bei der Grösse der Firma schon verstehen.

So wie ich das verstanden habe, verwenden sie ja gar nicht ihre eigenen 
Chips sondern lassen eben von Vestel bauen mit Chips, die auch bei 
Telefunken und Philipps verwendet werden (laut meinen Recherchen zu dem 
T-Con-Board).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.