Forum: HF, Funk und Felder Bluetoothempfang nach einbau in Metallgehäuse trotz ext. Antenne schlecht


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Mike B. (mbrasch)


Lesenswert?

Moin ihrs,

Ich hatte für ein paar Wochen einen einzelnen Up2Stream Pro V3 Bluetooth 
5.0 Empfänger ohne Gehäuse mit einer kurzen Wurfantenne betrieben und 
hatte dabei eine hervorragende Verbindung ohne jegliche Aussetzer in der 
gesamten Wohnung.

Jetzt hab ich hab 3 dieser BT-Empfänger in ein 19"-Metallgehäuse gebaut. 
An dem Gehäuse hat jedes der 3 Empfänger eine eigene BT-Antenne. Dennoch 
ist die Verbindung sehr schlecht und reicht bestenfalls 4m von der 
Antenne weg. Wenn man vom Handy zuspielt, kommt es zu aussetzern, wenn 
man das Handy zu sehr festhält.

Was könnte hier das Problem sein? Sind die drei Boards in einem Gehäuse 
vielleicht ein Problem? Müsste ich die Boards voneinander abschirmen?

--
Viele Grüße
Mike

von Simulant (Gast)


Lesenswert?

Zeig mal ein Foto der 3-fach Antennenanordnung.

von Mike B. (mbrasch)


Angehängte Dateien:

Lesenswert?

Das besagte Gehäuse steht auf der Audio-Matrix. Die beiden Rechner 
dadrüber sind derzeit offline.

: Bearbeitet durch User
von Wolfgang (Gast)


Lesenswert?

Mike B. schrieb:
> Jetzt hab ich hab 3 dieser BT-Empfänger in ein 19"-Metallgehäuse gebaut.

Bluetooth ist kein Rundfunk. Auch die "Empfänger" (Slaves) senden und 
stören sich natürlich, wenn ihre Antennen dicht beieinander stehen und 
sie sich dadurch beim Senden gegenseitig die Empfänger zustopfen.

von Mike B. (mbrasch)


Lesenswert?

Ok, was wäre der Ausweg aus dieser Situation? würde es reichen, die 
Abstände zu erhöhen? Andere Antennen?

von Simulant (Gast)


Lesenswert?

Die Montage so vor der hohen Metallfront kann die Antennenfunktion 
beeinträchtigen, hast du es mal getestet mit dem Gerät solo so dass die 
Antennen freier stehen?

Aus der Produktdoku des Up2Stream kann ich nicht erkennen ob man für 
externe BT-Antenne einen Jumper/Widerstand ändern muss. Interne und 
externe Antenne parallelgeschaltet wäre falsch und die üblichen Buchsen 
trennen die interne Antenne nicht automatisch beim Einstecken eines 
externen Kabels.

Kommen die Antennen von einem vertrauenswürdigen Hersteller? Der 
Chinakram wird teilweise mit falschen Daten verkauft, teilweise stimmt 
nichtmal das Frequenzband.

von Simulant (Gast)


Lesenswert?

Um zu testen ob die 3 Geräte sich stören könntest du zwei Antennen 
abschrauben (oder besser Geräte von der Stromversorgung trennen) und 
schauen ob das einen Effekt hat auf das verbleibende Gerät.

Entkopplung benachbarter Antennen kannst du schaffen über Abstand oder 
Ausrichtung senkrecht zueinander. Letzteres verändert natürlich auch das 
Richtdiagramm.

von Mike B. (mbrasch)


Lesenswert?

Per default werden die Boards mit einer ca. 20cm Wurfantenne geliefert. 
Diese hab ich durch die externe Antenne ersetzt, die ich direkt bei 
Arylic mit bestellt habe.

Das einzelne Board, was stabil lief, hatte ich neben dem Mac mini in dem 
Rahmen stehen gehabt, mit der Wurfantenne vor den anderen Geräten 
herunterhängend.

Die 3er-Kombi hatte ich auch schon ohne die beiden oberen Geräte 
getestet. Ich hatte es auch mit der Wurfantenne heraushängend probiert.

Von irgendwelchen Jumpern oder ggf. Settings via Software hab ich auch 
nichts gesehen.

von Simulant (Gast)


Lesenswert?

Ok, dann unterstellen wir mal dass die ihre interne BT-Antenne nicht 
nutzen und der Teil zur Antennenbuchse soweit passt.

Der nächste Test wäre nun ein Board mit deiner externen Antenne am 
Gehäuse, die anderen beiden Boards dabei inaktiv.

von Mike B. (mbrasch)


Lesenswert?

Ich hab eben mal die beiden anderen Boards komplett stromlos gemacht. 
Und siehe da: die Empfangsleistung ist wieder super. Gleiches, wenn ich 
das ganz rechte ebenfalls mit einschalte (also das mittlere aus bleibt).

Nebenbei weiß ich jetzt auch, daß die Boards wohl nicht komplett inaktiv 
sind, wenn ich sie "ausschalte". :)

von Mike B. (mbrasch)


Lesenswert?

Ok, ich muss nochmal zurückrudern:

Das Signal degradiert massiv, sobald ich den Gehäusedeckel schliesse. 
Mit offenem Deckel ist der Empfang mit allen drei aktiven Empfängern 
gut.

Was passiert hier, wenn ich den Deckel schliesse? Kann das Netzteil eine 
Rolle spielen? Das ist ein MeanWell RS-15-5 (15W, 5V, 3A).



PS: wow, mir war gar nicht klar, was für ein fragiles Ding das mit dem 
Funk ist. :)

: Bearbeitet durch User
von Helmut -. (dc3yc)


Lesenswert?

Mike B. schrieb:
> mir war gar nicht klar, was für ein fragiles Ding das mit dem
> Funk ist.

Wer Funk kennt, nimmt Kabel.

Nun kennen wir deinen internen Aufbau der Box nicht. Mach doch mal ein 
Foto mit offenem Deckel. Wie hast du denn die externen Antennen 
angeschlossen? Die haben wahrscheinlich Koaxkabel. Hast du auch die 
Masse des Kabels mit angeschlossen?

von Mike B. (mbrasch)


Angehängte Dateien:

Lesenswert?

Das zweite Netzteil ist für ein Mini-Computer+SSD, worüber die 
Audio-Matrix gesteuert werden soll und diverse Dateifreigaben laufen 
sollen. – Ich hab so langsam das Gefühl, daß ich das lieber lassen 
sollte. :)

Die Spannungsversorgung hatte ich bei völliger Übermüdung mitten in der 
Nacht (Einschlafprobleme) gemacht und mittendrin erst bemerkt, daß ich 
die Farben vertauscht hatte – und hab bislang keine Zeit/Muße gehabt das 
wieder zu ändern.

Die Audio-Anschlüsse mit den Klinkensteckern muß ich auch noch ändern, 
wenn ich die passenden Pfostenstecker habe. Die Front-Taster werden auch 
erst später, wenn ich die fehlenden Teile habe, angeschlossen.

Das ist ein "einfach drauf los"-Projekt. :)

von Mike B. (mbrasch)


Lesenswert?

Helmut -. schrieb:
> Wer Funk kennt, nimmt Kabel.

Deswegen mach ich Multi-Room-Audio auch über diese alte Audio-Matrix. :)

von Simulant (Gast)


Lesenswert?

Mike B. schrieb:
> Was passiert hier, wenn ich den Deckel schliesse?

Ich würde vermuten, dass die laut Foto im Handbuch vorhandene interne 
BT-Antenne eben doch nicht abgeklemmt ist, obwohl der Hersteller 
zusätzlich eine externe Antenne mitliefert. Mit Decke ist die dann 
abgeschirmt. Als Test kannst du mal schauen, ob deine externe Antenne 
bei offenem Deckel überhaupt einen Effekt hat.

Und zeig mal ein Foto deiner Verbindung vom Board zur Antenne, um Fehler 
dort auszuschliessen.


Rant:
Leider sind viele Hersteller solcher Geräte nicht im Thema und machen 
blöde Fehler im HF-Signalpfad. Die PCB-integrierte Antenne für BT ist 
hier unverändert aus TI-Application-Note AN043 kopiert und das 
funktioniert so schon mal nicht, also möglicherweise stecken da noch 
andere Anfängerfehler im HF-Teil des Boards.

von Mike B. (mbrasch)



Lesenswert?

Ich hoffe auf den Bilder ist das drauf, was für euch interessant sein 
könnte. Ich hab bei dreien davon das Weitwinkel benutzt. Das macht 
zumindest schärfere Bilder bei der Entfernung. (bin das Gegenteil eines 
Foto-Pros)

Wenn ich es richtig verstangen habe, gibt es nur auf dem Main-Board eine 
Print-WiFi-Antenne, aber nicht auf dem BT-Board.

von Mike B. (mbrasch)


Lesenswert?

Ach, den eigentlichen Gag hab ich glatt vergessen: Antenne ist ab und 
Empfang ist super – mit offenem Deckel.

von Mike B. (mbrasch)


Lesenswert?

Ok, Leute. Das ist alles selbstverschuldet und hoffentlich ein kleiner 
Lacher:

Ich weiß nicht wieso, aber ich war von Anfang an auf dem Trichter, daß 
das kleine Aufsteck-Board das Bluetooth-Modul wäre und hatte Anfangs im 
offenen Betrieb die Wurfantenne auf dem – wie sich nun herausstellt – 
dem WLAN-Modul aufgesteckt. Und seit dem habe ich den "Fakt" nie mehr 
infrage gestellt, daß das das Bluetooth-Modul sei.

Naja, und nun fällt mir das so auf die Füsse. klatschhandvorkopf

Das kommt davon, wenn man zu sehr mit anderen Dingen beschäftigt ist und 
dieses hier eher als Fluchtmöglichkeit als 
Nicht-Schlafen-Können-Nächten-Projekt ausgeführt wird.

Ich sollte vielleicht lieber bei der Software-Seite bleiben… ;)

: Bearbeitet durch User
von Simulant (Gast)


Angehängte Dateien:

Lesenswert?

Mike B. schrieb:
> Ach, den eigentlichen Gag hab ich glatt vergessen: Antenne ist ab und
> Empfang ist super – mit offenem Deckel.

Ok, dann ist die BT-Antennen auf dem PCB eben doch nicht abgeklemmt. Das 
meinte ich mit meinen Beitrag oben:

Simulant schrieb:
> Aus der Produktdoku des Up2Stream kann ich nicht erkennen ob man für
> externe BT-Antenne einen Jumper/Widerstand ändern muss. Interne und
> externe Antenne parallelgeschaltet wäre falsch und die üblichen Buchsen
> trennen die interne Antenne nicht automatisch beim Einstecken eines
> externen Kabels.

Bei den PCB wo ich am Antennendesign beteiligt bin ist oft eine 
Lötbrücke in Form eines 0 Ohm-Widerstandes, mit dem man dem Signalpfad 
umlöten kann zwischen interner Antenne und Coaxbuchse.

Hier bei deinem PCB sind BEIDE Brücken bestückt, also für Bluetooth die 
interne Antenne und Coaxbuchse parallel. Das ist falsch!

~~~~~~~~~~~~~

Unabhängig davon bin ich aber bei deinem Foto unsicher, ob du überhaupt 
eine externe Antenne für Bluetooth angeschlossen hast? Das Board hat 
zwei Antennen, WLAN und Bluetooth. Auf deinem Foto sehe ich ein 
Coaxkabel am WLAN (!) Anschluss, aber Bluetooth doch nur die interne 
Antenne? Das geht dann mit geschlossenem Deckel natürlich nicht, wenn 
eine der beiden Antennen (WLAN + BT) in der Metallkiste abgeschirmt ist.

von Mike B. (mbrasch)


Lesenswert?

Damit hier diese BT-Boards keinen faden Beigeschmack bekommen:

Ich finde diese Empfänger klasse. Sie sind immer 
Empfangs/Pairing-Bereit. Und das allerallerallerwichtigste: sie geben 
NIEMALS einen Ton von sich, der nicht explizit über Audio eingespielt 
wird. Keine Piepser, wenn die Verbindung beendet wurde.

Ich hatte sehr lange danach suchen müssen. :)

von Simulant (Gast)


Lesenswert?

Mike B. schrieb:
> Und seit dem habe ich den "Fakt" nie mehr
> infrage gestellt, daß das das Bluetooth-Modul sei.

Nun haben wir parallel geschrieben :-)

Den in meinem vorherigen Beitrag genannten Fehler auf dem PCB 
(Parallelschaltung interne Antenne + Coax) hat aber der Hersteller zu 
verantworten, da gehören keine zwei Brücken rein sondern nur eine. 
Dadurch wird die Nutzung einer externen Bluetooth-Antenne unnötig 
verschlechtert und in deinem Szenario würden die drei internen 
BT-Antennen in der Box verkoppeln. Da müsste man also mit dem Lötkolben 
ran und den 0 Ohm zur interne Antennen rausnehmen, wenn es externe 
BT-Antennen gibt.

Viel Erfolg!

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.