Forum: Analoge Elektronik und Schaltungstechnik DC/DC 5,2V stabilisierte Spannung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Lars R. (sassl77)


Angehängte Dateien:

Lesenswert?

Hallo zusammen,

zunächst sei gesagt das ich kein gelernter Elektriker/Elektroniker bin, 
also übt bitte ein wenig Nachsicht mit mir. :)

Ich habe in meinem privaten Bastelprojekt folgende Situation. Ich 
benötige eine vom Stromverbrauch unabhängige stabile Spannungsquelle von 
am besten DC 5,1-5,2 V ( am besten halt etwas über 5V und STABIL ).
Der Strombedarf des gesamten Projekts liegt zw. 500mA und 2,5A.

Derzeit verwende ich ein Schaltnetzteil ( weil es vorhanden ist ):
https://amzn.eu/d/2M2IiMf

Dieses liefert leider nicht konstant 5V sondern je nach Last 5,2V bis 
zum teil unter 4,9V. Dieser Zustand ist für mein Vorhaben leider nicht 
hinzunehmen. Ich habe bereits versucht das Netzteil mit zusätzlichen 1mF 
ELKOS zu unterstützen, aber bei Langen Zeiten unter Last fällt die 
Spannung dennoch zum Teil unter 5V.

Ich habe mir überlegt ein anderes Netzteil zu verwenden was im Bereich 
von 12V arbeitet und eine Schaltung zur DC/DC Wandlung zu bauen. Siehe 
Anhang.
Hier wären dann noch Fragen offen:

1. reichen die 1mF ELKOS?
2. wie bekomme ich die zu erwartenen 5V auf 5,2V gehoben? Eventuell 
zusätzliche Diode zwischen GND und GND vom LM 1084?
3. bleibt bei so einer Schaltung die Spannung stabil wenn die 
Stromaufnahme steigt?

Ist das aus Eurer Sicht ein richtiger Ansatz oder gibt es ganz andere 
Empfehlungen?

Ich bin für jede Hilfe und jeden Denkanstoß sehr Dankbar.

Ich wünsche allen eine frohe Weihnachtszeit.

Grüße Lars

von Warten (Gast)


Lesenswert?

Lars R. schrieb:
> reichen die 1mF ELKOS?

Sekundärseitig sind derart große Kondensatoren nach einem Regler teils 
kritisch, würde ich genau im Datenblatt nachgeschlagen ob das so 
funktioniert. In der Regel brauchst du da deutlich weniger...

von Udo S. (urschmitt)


Lesenswert?

Lars R. schrieb:
> Dieses liefert leider nicht konstant 5V sondern je nach Last 5,2V bis
> zum teil unter 4,9V. Dieser Zustand ist für mein Vorhaben leider nicht
> hinzunehmen.

Vieleicht schilderst du einfach mal dein konkretes Problem.
0,5 bis 2,5A sind schon eine ganz Menge.
Welcher Teil deiner Schaltung/ deines Geräts muss denn so genau stabil 
sein und warum?
Eventuell reicht es nur den "empfindlichen" Teil hochstabil zu versorgen 
oder man kann die Schaltung so verändern, dass sie nicht mehr so 
empfindlich auf kleinere Spannungschwankungen reagiert.

Und bitte sage jetzt nicht dass du Leds mit Kostantspannung versorgen 
"musst".

: Bearbeitet durch User
von Michael B. (laberkopp)


Lesenswert?

Lars R. schrieb:
> Derzeit verwende ich ein Schaltnetzteil ( weil es vorhanden ist ):
> Dieses liefert leider nicht konstant 5V sondern

Nimm halt ein besseres Netzteil und nicht den Müll, der gerade rumliegt 
und spar dir nachfolgendes rumgepfusche.

Auch zu lange dünne Kabel machen bei 2A schnell 0.1V aus

https://www.amazon.de/product-reviews/B06XWRSXL9/ref=pb_allspark_dp_sims_pao_desktop_session_based_cr_sccl_3_4/000-0000000-0000000

von kenny (Gast)


Lesenswert?

Schau mal nach dem original Raspberry PI Netzteil.
Dies liefert 5,1V.

von WF88 (Gast)


Lesenswert?

Wenn du bis 2.5A brauchst, hol dir ein Netzteil, was 4A+ bringt. 
Eventuell sogar eines mit Sense Eingang für die Spannung an der Last.

So ein Netzteil regelt automatisch hich, wenn an der Last nur 4.9 
ankommen.

Schau mal bei Pollin.

Dein linearregler raucht ab, wenn er 17.5W verheizen soll. ((12-5)*2.5))

von H. H. (Gast)


Lesenswert?

WF88 schrieb:
> Dein linearregler raucht ab, wenn er 17.5W verheizen soll. ((12-5)*2.5))

Mit nicht zu kleinem Kühlkörper könnte der das schon.

von Lars R. (sassl77)


Lesenswert?

Danke für die schnellen Antworten:

@Udo S:
Es geht um eine Lüftersteuerung die über einen ESP32 geregelt wird mit 
2x5V PWM Lüftern, einem Display zur Anzeige, einem Level-Shifter zur 
Kommunikation mit dem Display und einem ADC1115 zur Spannungsmessung. 
Dazu kommen noch 3xLED und ein ein paar Widerstände.

- ESP32 mit aktiviertem WLAN ca. 200mA
- Display bei voller Helligkeit ca. 500-600mA
- 2x Lüfter bei 100% zusammen ca. 700mA

vielleicht war ich mit den 2,5A auch ein wenig zu weit ... scheinen wohl 
eher max. 1,5-1,6A zu werden.

Kritisch ist die Spannung in der gesammten Schaltung nur für die 
Drehzahl der Lüfter. Hier macht bei 100% Drehzahl ein Unterschied in der 
Spannung von 5,15V zu 4,9V ca. 120 u/min aus. Dies ist nicht gut, da die 
Drehzahl gemessen wird und mit der Soll Drehzahl verglichen wird um 
eventuelle Fehlfunktionen der Lüfter durch alter oder Dreck zu ermitteln 
und zu melden.

@Michael B
mein Netzteil ist doch auch ein MeanWell 5V aber mit 8A

@WF88
wie gesagt mein Netzteil laut angaben ein Schaltnetzteil mit 5V/8A aber 
leider ist die Spannung zu unstabil. Wenn sich die Display Helligkeit 
von 10% auf 100% erhöht und beide Lüfter auf 100% laufen geht die 
Spannung auf unter 5V runter.

von HildeK (Gast)


Lesenswert?

Lars R. schrieb:
> Dieser Zustand ist für mein Vorhaben leider nicht
> hinzunehmen.
Da würde ich gerne näheres zu der Schaltung erfahren, die so enge 
Grenzen setzt.

von HildeK (Gast)


Lesenswert?

Ok, hat sich erledigt mit deinem Post, den ich erst danach gesehen habe 
...

von Lars R. (sassl77)


Lesenswert?

Edit:

Also eigentlich brauche ich nur eine Möglichkeit dafür zu sorgen das an 
den beiden Lüftern immer möglichst stabil 5,1V anliegen.

Alle anderen Teile in der Schaltung haben mit den geringen 
Spannungsschwankungen kein Problem!

Grüße

von Lothar M. (Firma: Titel) (lkmiller) (Moderator) Benutzerseite


Lesenswert?

Lars R. schrieb:
> Es geht um eine Lüftersteuerung die über einen ESP32 geregelt wird mit
> 2x5V PWM Lüftern
Der µC kann sogar mit 3V noch gut arbeiten. Und die Lüfter kommen sicher 
mit 4,9V auch noch klar. Wo ist also das Problem?

> wie gesagt mein Netzteil laut angaben ein Schaltnetzteil mit 5V/8A aber
> leider ist die Spannung zu unstabil.
Nein, die Schaltung hat noch irgendeine Designschwäche.

Lars R. schrieb:
> ein Unterschied in der Spannung von 5,15V zu 4,9V ca. 120 u/min aus.
> Dies ist nicht gut, da die Drehzahl gemessen wird und mit der Soll
> Drehzahl verglichen wird um eventuelle Fehlfunktionen der Lüfter durch
> alter oder Dreck zu ermitteln und zu melden.
Dann miss doch einfach die Spannung ebenfalls und "korrigiere" deine 
Erwartungen an die Drehzahl. Und im Grunde ist einfach deine Toleranz zu 
eng gesetzt, also deine Anforderung an die Lüfter zu hoch.

BTW: sinkt wirklich die Spannung direkt am Netzteil? Oder hast du 
einfach nur lausig dünne Drähtchen zu deiner Schaltung verlegt?

: Bearbeitet durch Moderator
von Udo S. (urschmitt)


Lesenswert?

Lars R. schrieb:
> Kritisch ist die Spannung in der gesammten Schaltung nur für die
> Drehzahl der Lüfter. Hier macht bei 100% Drehzahl ein Unterschied in der
> Spannung von 5,15V zu 4,9V ca. 120 u/min aus. Dies ist nicht gut, da die
> Drehzahl gemessen wird und mit der Soll Drehzahl verglichen wird um
> eventuelle Fehlfunktionen der Lüfter durch alter oder Dreck zu ermitteln
> und zu melden.

Wenn die Drehzahl eh gemessen wird, kann man die Lüfter auch tatsächlich 
auf die Drehzahl regeln.
Und wenn 120U/min (von wieviel nenndrehzahl?) schon kritisch ist und man 
sowiso regelt, dann könnte man zur Versorgung der Lüfter auch eine 
höhere Spannung (z.B. 6V) nehmen und würde dann halt bei Nenndrehzahl 
keine 100% PWM sondern nur ca. 80% PWM benötigen.
Dadurch häte man immer noch Spielraum wenn sich die Lüfter 
verschlechtern.

Und über das tatsächliche Tastverhältnis bei Nenndrehzahl hätte man 
damit direkt ein Merkmal zur Beurteilung von Verschleiss/Verdrecken.

: Bearbeitet durch User
von Lars R. (sassl77)


Lesenswert?

@Lothar M
ich habe mal im Anhang eine Schaltung geschickt wie das ganze aufgebaut 
ist. Rechts der USB eingang, welcher das Relais durch schaltet kommt von 
dem zu überwachendem Gerät. Nur wenn dieses an ist soll auch die ganze 
Schaltung laufen. Die Spannung und auch den Abfall messe ich direkt am 
Netzteil rechts noch vor allen Bauteilen mit einem Multimeter ( was 
anderes habe ich leider nicht ). Aber dieses zeigt mir auch deutlich die 
Schwankungen wenn sich die Drehzahl der Lüfter oder die Helligkeit des 
Display ändert.

Das Display, der ESP32 und die Lüfter bekommen dann alle ihre 5V von der 
oberen Schine und noch der HV Eingang vom Level-Shifter.

OK ok, vielleicht bin ich wirklich etwas "zu" genau mit meiner Toleranz.

Aber dennoch bleibt meine Frage ob es eine Möglichkeit gibt die die 
Spannung an den beiden Lüftern auf "konstant" 5,1 oder wenigsten 5V zu 
bringen?

Vielen Dank für Eure Hilfe!

von Lars R. (sassl77)


Angehängte Dateien:

Lesenswert?

Sorry Schaltung vergessen :(

von Udo S. (urschmitt)


Lesenswert?

Lars R. schrieb:
> Aber dennoch bleibt meine Frage ob es eine Möglichkeit gibt die die
> Spannung an den beiden Lüftern auf "konstant" 5,1 oder wenigsten 5V zu
> bringen?

Wie in meinem vorherigen Post schon angemerkt.
Dein Ziel ist eine konstante Drehzahl. Da du schon eine PWM zur 
Steuerung hast, einen Controller zur PWM Erzeugung und auch eine Messung 
der aktuellen Drehzahl, kannst du das ganz einfach auch mit einer 
schwankenden Spannung erreichen. Du brauchst 'nur' noch das Programm das 
eine Regelung realisiert und eine Spannung die immer ausreichend hoch 
ist.

Der Ansatz ein hochgenaues Netzteil zu verwenden ist suboptimal.

von HildeK (Gast)


Lesenswert?

Lars R. schrieb:
> Derzeit verwende ich ein Schaltnetzteil ( weil es vorhanden ist ):
> https://amzn.eu/d/2M2IiMf

Also das Meanwell LPV-60-5?
Schau mal ins Datenblatt: dort steht 'Load Regulation ±6%'!
https://www.reichelt.de/index.html?ACTION=7&LA=3&OPEN=0&INDEX=0&FILENAME=A500%2FLPV-60-SPEC.pdf
Also: das Netzteil macht nach Spezifikation alles richtig, du kannst von 
ihm nicht < ±3% verlangen, dafür ist es nicht ausgelegt.

von Lothar M. (Firma: Titel) (lkmiller) (Moderator) Benutzerseite


Lesenswert?

Lars R. schrieb:
> Sorry Schaltung vergessen :(
Du kannst da nicht unbedarft 5,17V oder 5,21V hinschreiben. Mit hoher 
Wahrscheinlichkeit gibt dein Messgerät diese Genauigkeit gar nicht her. 
Ich würde bestenfalls noch der 2. Stelle trauen. Aber für mich bedeutet 
das Messergebnis in beiden Fällen und auch, wenn ich nur 4,9V messe: "5V 
sind da, alles ok!"


Lars R. schrieb:
> der Lüfter
Welche sind das denn? Und was ist die "übliche Nenndrehzahl" bei 5V?

> Die Spannung und auch den Abfall messe ich direkt am Netzteil
Und wieviel kommt davon beim Lüfter an?

: Bearbeitet durch Moderator
von WF88 (Gast)


Lesenswert?

Es gibt auch Netzteile, die man per Poti 5...15% nachstellen kann. 
Meanwell ist da ein guter Anlaufpunkt.

Das mit dem 4,9V akzeptieren scheint wohl nicht zu gehen, da ihm dann 
120rpm fehlen.

Bleiben, meiner Meinung nach, diese Möglichkeiten:

- anderes NT mit Sense Eingang
- anderes NT mit Poti zum nachstellen
- anderes NT, was nicht so sehr in die Knie geht.
- jetziges NT ändern. Im besten Fall nur eine Widerstand rund um einen 
TL431 ändern, Spannung leicht erhöhen.

: Bearbeitet durch Moderator
von HildeK (Gast)


Lesenswert?

Zum Eingangspost:

Lars R. schrieb:
> 1. reichen die 1mF ELKOS?
> 2. wie bekomme ich die zu erwartenen 5V auf 5,2V gehoben? Eventuell
> zusätzliche Diode zwischen GND und GND vom LM 1084?
> 3. bleibt bei so einer Schaltung die Spannung stabil wenn die
> Stromaufnahme steigt?

zu 1. Er will 10µF Tantal oder 50µF Aluelko am Ausgang. Etwas mehr wird 
nicht schaden.
zu 2. Es gibt den LM1084 auch in der ADJ-Ausführung. Damit kannst du 
jede Ausgangsspannung einstellen.
zu 3. Wenn richtig aufgebaut (Fühlerwiderstand nahe am Verbraucher), 
dann verspricht das Datenblatt max. 0.4% Ablage durch Lastwechsel.
Aber: das ist ein Linearregler und deine Lüfter mit 700mA Laststrom 
werden den Linearregler mächtig erwärmen. Dem solltest du dann nicht 
mehr als 7V am Eingang anbieten und dann sind es schon 1.5W.

von WF88 (Gast)


Lesenswert?

Sorry für die Überschriften, Dachte, die Raute kann man als 
aufzählungszeichen benutzen.

von Lothar M. (Firma: Titel) (lkmiller) (Moderator) Benutzerseite


Lesenswert?

WF88 schrieb:
> Dachte, die Raute kann man als aufzählungszeichen benutzen.
Nimm "-" oder "*" oder 1. 2. 3.

HildeK schrieb:
> Aber: das ist ein Linearregler und deine Lüfter mit 700mA Laststrom
> werden den Linearregler mächtig erwärmen.
Je schneller der Lüfter läuft umso wärmer wird der Spannungsregler. Der 
sollte also direkt in den Luftstrom montiert werden   ;-)

WF88 schrieb:
> da ihm dann 120rpm fehlen.
wie gesagt: von wieviel?

Oder andersrum: fehlen nur die "120rpm zur Wunschdrehzahl" oder fehlt 
tatsächlich auch der Luftstrom?
Denn ersteres ist ja nur ein mentales Problem ("ich will, was ich mir 
wünsch"). Zweiteres eine Designschwäche.

: Bearbeitet durch Moderator
von Eisbär (Gast)


Lesenswert?

Lars R. schrieb:
> Kritisch ist die Spannung in der gesammten Schaltung nur für die
> Drehzahl der Lüfter. Hier macht bei 100% Drehzahl ein Unterschied in der
> Spannung von 5,15V zu 4,9V ca. 120 u/min aus. Dies ist nicht gut, da die
> Drehzahl gemessen wird und mit der Soll Drehzahl verglichen wird um
> eventuelle Fehlfunktionen der Lüfter durch alter oder Dreck zu ermitteln
> und zu melden.

Sinkende Drehzahl durch das Alter? Wieviel Dreck gibt es denn im Stall?

Das Netzteil würde ich so belassen und die Drehzahlmessung digital 
besser auswerten. Das heißt über ein paar Sekunden mitteln und dann 
vergleichen oder einfach höhere Toleranzgrenzen vorgeben.
Oder auch die aktuelle Versorgungsspannung bei der Bewertung 
berücksichtigen.

von Lars R. (sassl77)


Lesenswert?

Ich glaube ich möchte "mental" einfach zu viel :)

@HildeK
Danke für den Hinweis mit den ±6% vom Netzteil. Hatte ich gar nicht nach 
geschaut. Aber das ist wohl auch dem geschuldet das ich einfach kein 
Elketronik Profi bin :). Ich bin aber schon davon ausgegangen das das 
Netzteil tut was es soll und verspricht.

@Lothar M
Es sind Noctua a12x25 5V PWM, welche laut Datenblatt eine max. 
Nenndrehzahl von 1900 u/min ABER mit ±10% haben. Schon aus diesem Grund 
sind meine Wünsche wohl einfach übertrieben.

Mein Gedanke war halt, am Anfang ( also wenn alles in Betrieb gehen soll 
eine Lüfter Kalibrierung zu machen, wo ich die Drehzahlen der Lüfter bei 
den unterschiedlichen PWM einstellungen ( 100% - aus in 10'er Schritten 
) erfasse und weg speicher und dann im laufe der Zeit halt immer mit den 
IST-Drehzahlen vergleiche um festzustellen ob ein Lüfter zu langsam ist, 
weil er vielleicht verdreckt oder defekt ist. Dies alles geht aus meiner 
sicht aber nur "sinnvoll" wenn immer eine konstante Spannung an den 
Lüftern anliegt.

@Udo S
Mein Ziel ist nicht die Lüfter auf eine konstannte Drehzahl zu "zwingen" 
sonder ihre IST Drehzahl mit der SOLL Drehzahl zu vergleichen um einen 
möglichen Defekt festzustellen

Grüße an alle und ich bin echt begeistert wieviel Resonanz man hier bei 
Euch bekommt :)

Wenn es also keine Sinnvolle Möglichkeit gibt dies in meinem Projekt zu 
realisieren dann werde ich wohl einfach meine Ansprüche zurück schrauben 
und sehen ob ich mit dem was ich habe eine annehmbare Lösung hin 
bekomme.

von Lars R. (sassl77)


Lesenswert?

Edit:

@Udo S
das ganze ist halt Temperatur gesteuert. Und je nach Raumtemperatur 
sollen die Lüfter entsprechend schnell oder langsam drehen.

von Lars R. (sassl77)


Lesenswert?

@Eisbär
ja wie eben geschrieben werde ich meine Erwartungen/Wünsche wohl 
reduzieren und dann läuft es genau darauf hinaus. Die Werte zur 
Ermittlung der Drehzahl werden schon jetzt natürlich über einen längen 
Zeitraum gemessen und gemittelt ;)

von Johannes F. (Gast)


Angehängte Dateien:

Lesenswert?

Lars R. schrieb:
> 1. reichen die 1mF ELKOS?

Der 1-mF-Elko am Ausgang ist Quatsch. 100 µF würden mehr als genug sein.
Am Eingang, also vor dem Regler, kommt es auf die Welligkeit der 
Spannung an. Dort muss die Kapazität so hoch sein, dass die Spannung 
nicht unter U_Ausgang + U_Dropout_min sinkt.

Lars R. schrieb:
> 2. wie bekomme ich die zu erwartenen 5V auf 5,2V gehoben? Eventuell
> zusätzliche Diode zwischen GND und GND vom LM 1084?

Eine Diode würde die Ausgangsspannung um ca. 0,6 V anheben, also zu 
viel.
Für die 700 mA der Lüfter reicht auch ein LM317 (mit entspr. 
Kühlkörper), ein Low-Drop-Regler ist bei 11 V Eingangsspannung sowieso 
nicht nötig.
Schaltung siehe Anhang: mit R1 = 220 Ω, R21 = 620 Ω und R22 = 200 Ω 
kannst du die Ausgangsspannung von ca. 4,8 V bis 6 V einstellen. 
Lastausregelung beträgt laut DB typ. 20 mV bei U_Out = 5 V.

EDIT: SVG funktioniert nicht richtig, daher nochmal als PNG im Anhang

von HildeK (Gast)


Lesenswert?

Lars R. schrieb:
> das ganze ist halt Temperatur gesteuert. Und je nach Raumtemperatur
> sollen die Lüfter entsprechend schnell oder langsam drehen.

Dann passt doch alles und ist praktisch unabhängig von den 
Spannungstoleranzen.
Du misst die Temperatur (nicht die Raumtemperatur sondern die am zu 
kühlenden Teil!) und passt die Drehzahl über PWM so an, dass eine 
Zieltemperatur nicht überschritten wird. Fertig.

von Lars R. (sassl77)


Lesenswert?

@Johannes F
Vielen Dank für Deine Erläuterung und Danke für Deine Mühe. Ich werde 
zunächst aber erstmal mit dem vorhandenen 5V Netzteil weiter machen und 
wohl damit "leben" müssen das die Spannung an den Lüftern halt etwas 
schwankt wenn sich die Helligkeit des Display ändert. Zu mind. sehe ich 
mit meinem leihenhaften Wissen über die Elektronik im Moment keine 
Möglichkeit wie ich die Spannung an den beiden Lüftern stabilisieren 
kann mit dem Netzteil das ich habe.

Grüße

von Lothar M. (Firma: Titel) (lkmiller) (Moderator) Benutzerseite


Lesenswert?

Lars R. schrieb:
> leihenhaften Wissen
Es ist ein laienhaftes Wissen, weil du ein Laie bist. Aber seis 
drum...

Dein Ziel ist im Grunde nicht, die Drehzahl zu überwachen oder die 
Drehzahl abhängig von der Raumtemperatur zu steuern, sondern du willst, 
dass nichts zu heiß wird.

Deshalb würde ich einen Temperatursensor an der kritischsten Stelle 
anbringen und die zum Ansteuern der Lüfter verwenden. Parallel dazu 
kannst du noch die Drehzahl kontrollieren und dann eine Warnung bringen 
wenn beide Lüfterdrehzahlen um mehr als 30% voneinander abweichen. 
Oder einer davon komplett stillsteht...

Eine Fehlermeldung wird aber von dem zu heißen Bauteil und dem 
Temperatursensor ausgelöst. Denn es könnte ja sein, dass das Gerät 
problemlos auch mit 1 Lüfter weiterlaufen könnte und ein Stillstand 
durch einen "Lüfterfehler" dann unsinnig wäre.

: Bearbeitet durch Moderator
von Lars R. (sassl77)


Lesenswert?

@Lothar M
Dank Dir für die korrektur meiner Rechtschreibung! Leider war das schon 
mein Leben lang ein Problem, aber solche Hinweise helfen :)

Ja ich werde es so machen und einfach meine Toleranzen in Hinsicht auf 
die erlaubten Abweichungen der Drehzahl erhöhen.

von Steve van de Grens (roehrmond)


Lesenswert?

Deine Lüfter werden die Drehzahl eh nicht exakt beibehalten. Ich schätze 
mal, dass sie im Laufe der zeit immer langsamer werden. Wenn du dann 
einen neuen Lüfter einbaust, wird dieser bestimmt eine deutlich 
abweichende Drehzahl haben, als der alte.

Du solltest ein sehr großzügiges Toleranzfenster vorsehen.

Wahrscheinlich ist die Kühlende Wirkung viel wichtiger, als die 
Drehzahl. Also messe die Temperatur der betroffenen Bauteile. Das wäre 
viel Aussagekräftiger, als die Lüfterdrehzahl.

Beim Lüfter ist eigentlich nur von Interesse, ob er sich dreht, oder 
nicht.

von Erich (Gast)


Lesenswert?

Du solltest deine Verbindungsleitungen LÖTEN und nicht über 
ausgeleihertes Steckbrett führen.

Krokoklemmen sind auch tabu.

Sinnvoll sind Drähte mit mind. 0,5 qmm, besser 0,75 qmm.
Und die sollten nicht 5 Meter lang sein.

Ggf. separate Spannungszuführung zu Lüfter und Display.

Als Netzteil sowas wie 351469 von Pollin, da ist die Ausgangsspannung 
auf 5,5 Volt einstellbar.

Gruss

von Lars R. (sassl77)


Lesenswert?

@Erich
Das ist derzeit alles gelötet auf:
https://www.amazon.de/gp/product/B07G5CHBTK/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&th=1

Als Drahtverbindungen auf der Platine habe ich 1 qmm genommen. Das 
Verbindungskabel zum Display ist ein 2,5m langes jysty 2x2x0.6 masiv.

Die Lüfter und auch das Display bekommen ihre 5V direkt von der oberen 
5V Schiene und ihren GND von der darüber liegenden GND Schiene.

Grüße

von Johannes F. (Gast)


Lesenswert?

Lars R. schrieb:
> Das ist derzeit alles gelötet auf:
> https://www.amazon.de/gp/product/B07G5CHBTK/

Ach du je ...
Den Sinn von Streifenraster hab ich noch nie verstanden. Ist mir zu 
unflexibel. Warum nicht „normale“ Lochrasterplatten und Verbindungen mit 
verzinntem Cu-Draht herstellen:
https://www.reichelt.de/lochrasterplatine-hartpapier-160x100mm-h25pr160-p8272.html
https://www.reichelt.de/kupferschaltdraht-verzinnt-0-8-mm-22-m-zinn-0-8-22m-p190455.html

von Lars R. (sassl77)


Lesenswert?

Johannes F. schrieb:
> Ach du je ...

Das ist quasi so "gewachsen" ... ich habe vorher alles zum testen auf 
nem Breadboard zusammen gesteckt und so war es für mich als Laie 
einfacher es zu übertragen. Ich perönlich finde die Dinger haben auch 
Vorteile. So habe ich z.B. eine durchgehende 5V Schiene wo ich immer 
wieder abgreifen kann. Leider sind die Dinger natürlich deutlich teurer 
als „normale“ Lochrasterplatten.

von Erich (Gast)


Lesenswert?

Lars R. schrieb:
> Die Lüfter und auch das Display bekommen ihre 5V direkt von der oberen
> 5V Schiene und ihren GND von der darüber liegenden GND Schiene.

Dann miss doch bitte während des Betriebs (Lüfter laufen) die 
Spannungsdifferenz zwischen
a) Einspeisepunkt +  von Netzteil   <-->   Ausgangsleitung +  zum Lüfter
b) Einspeisepunkt -  von Netzteil   <-->   Ausgangsleitung -  zum Lüfter

Damit zeigt sich dann der Spannungsabfall über die Platine ... die 
sicher weniger Kupfer verwendet als 0,5 qmm.
Wirst vermutlich interessante Erkenntnisse bekommen.

Gruss

von Lars R. (sassl77)


Lesenswert?

Erich schrieb:
> Dann miss doch bitte während des Betriebs (Lüfter laufen) die
> Spannungsdifferenz zwischen

ok habe ich mal gemacht ... tatsächlich gehen da schon mal um die 40mV 
verloren ( laut Multimeter was natürlich nicht sehr genau ist ) aber 
definitiv kommt am Lüfter schon mal weniger an als noch direkt am 
Netzteil zur Verfügung steht!?

von Lothar M. (Firma: Titel) (lkmiller) (Moderator) Benutzerseite


Lesenswert?

Lars R. schrieb:
> aber definitiv kommt am Lüfter schon mal weniger an als noch direkt am
> Netzteil zur Verfügung steht!?
Ja, das ist Elektronik. Du hast Leitungswoderstände, du hast 
Übergangswiderstände an Lötstellen und Kontakten.

Aber nochmal: eine Schaltung, die wegen einer Schwankung um 40mV 
irgendwelche "Probleme" macht, ist nicht korrekt ausgelegt.

Lars R. schrieb:
> Ich perönlich finde die Dinger haben auch Vorteile. So habe ich z.B.
> eine durchgehende 5V Schiene wo ich immer wieder abgreifen kann.
Allerding ist auch diese "Schiene" nicht so massiv, wie ihr Name 
vermuten lässt. Lass da mal an einem Ende 10A rein und am anderen Ende 
wieder raus und miss dann den Spannungsabfall über diesem 
Leiterstreifen.

Lars R. schrieb:
> einfach meine Toleranzen in Hinsicht auf die erlaubten Abweichungen der
> Drehzahl erhöhen.
Wie gesagt: dein eigentliches Ziel ist nicht, die Drehzahl möglichst 
"hoch" zu halten, sondern dein Ziel ist es, irgendwas zu kühlen. Und 
genau diese Temperatur musst du überwachen.

von Johannes F. (Gast)


Lesenswert?

Lars R. schrieb:
> Ich perönlich finde die Dinger haben auch
> Vorteile. So habe ich z.B. eine durchgehende 5V Schiene wo ich immer
> wieder abgreifen kann.

Wie Lothar schon schrieb, ist diese „Schiene“ wegen der Löcher nicht 
sehr „massiv“, ist also effektiv eher schmaler, als man sie für die 
Stromversorgung eigentlich gerne hätte. Auf „normalen“ Lochrasterplatten 
kann man z.B. einen 1 mm² verzinnten Kupferdraht nehmen und damit diese 
„Schiene“ herstellen. Am Anfang einfach oben und unten jeweils an beiden 
Enden der Leiterplatte festgelötet, und dann dazwischen je nach Bedarf 
mit den Bauteilen/Verbindungsdrähten verlötet. Damit dürften die 
Spannungsabfälle deutlich geringer sein.

von Lars R. (sassl77)


Lesenswert?

Hallo zusammen und frohe Weihnachten!

@Lothar M @Johannes F
danke nochmals für Eure Hinweise und ich werde mir diese zu Herzen 
nehmen. Ich werde mir vom "Weihnachtsgeld" mal ein paar Lochraster 
Platten bestellen und natürlich Draht und wenn ich schon dabei bin 
vernüftige IC Sockel für meine Bauteile. ( die kosten nur n paar Cent 
und ich kann die Bauteile so wieder raus nehmen und ich denke die 
Verbindung ist da auch besser als bei Pin-Header Leiste, wie ich sie im 
Moment verwende )

Zum Thema Lochraster Platten ... könnt Ihr da welche empfehlen die sich 
auch gut löten lassen?

Zum Thema Draht ... 1mm² verzinnt sollte wohl reichen oder?

Viele Grüße und lasst es Euch gut gehen!

von Johannes F. (Gast)


Lesenswert?

Lars R. schrieb:
> Zum Thema Lochraster Platten ... könnt Ihr da welche empfehlen die sich
> auch gut löten lassen?

Ich verwende die H25PRxxx von Reichelt.
https://www.reichelt.de/index.html?ACTION=446&LA=3&nbc=1&q=h25pr
Die sind blank kupferbeschichtet. Zur Verbesserung der Lötbarkeit kann 
man eine Schicht Lötlack
https://www.reichelt.de/flussmittel-und-lackartiges-schutzharz-loetlack-sk-10-200-ml-kontakt-227-p9485.html
aufsprühen.
Vorher, insbesondere nach längerer Lagerung (wenn das Kupfer schon etwas 
korrodiert oder verschmutzt ist), sollte die Kupferseite mit Aceton 
(Baumarkt) gereinigt werden.

von Stefan F. (Gast)


Lesenswert?

Lars R. schrieb:
> Zum Thema Lochraster Platten ... könnt Ihr da welche empfehlen die sich
> auch gut löten lassen?

Die lassen sich alle gut löten, wenn man es richtig macht.

Blankes Kupfer muss man unmittelbar vor der Verarbeitung putzen.

Ich hatte mal schlechtes Lötzinn mit Luftblasen innen drin wo eigentlich 
das Flussmittel hin gehört. Damit konnte ich nicht arbeiten.

von WF88 (Gast)


Lesenswert?

Johannes F. schrieb:
> Lars R. schrieb:
>> Zum Thema Lochraster Platten ... könnt Ihr da welche empfehlen die sich
>> auch gut löten lassen?
>
> Ich verwende die H25PRxxx von Reichelt.
> https://www.reichelt.de/index.html?ACTION=446&LA=3&nbc=1&q=h25pr
> Die sind blank kupferbeschichtet. Zur Verbesserung der Lötbarkeit kann
> man eine Schicht Lötlack
> 
https://www.reichelt.de/flussmittel-und-lackartiges-schutzharz-loetlack-sk-10-200-ml-kontakt-227-p9485.html
> aufsprühen.
> Vorher, insbesondere nach längerer Lagerung (wenn das Kupfer schon etwas
> korrodiert oder verschmutzt ist), sollte die Kupferseite mit Aceton
> (Baumarkt) gereinigt werden.

Das geht auch ohne Chemie, Schleifpapier.

von WF88 (Gast)


Lesenswert?

Stefan F. schrieb:
> Lars R. schrieb:
>> Zum Thema Lochraster Platten ... könnt Ihr da welche empfehlen die sich
>> auch gut löten lassen?
>
> Die lassen sich alle gut löten, wenn man es richtig macht.
> Blankes Kupfer muss man unmittelbar vor der Verarbeitung putzen.
> Ich hatte mal schlechtes Lötzinn mit Luftblasen innen drin wo eigentlich
> das Flussmittel hin gehört. Damit konnte ich nicht arbeiten.

Ich hatte schonmal welches, das hat "gespotzt" und "gespritzt", aber nur 
Stellenweise. Bei dem vermutete ich auch Luftblasen.

Ich habs dann mit dem Saitenschneider der Länge nach aufgeschnitten kurz 
vor dem Löten, dann war das Spotzen+Spritzen weg. Liegt jetzt als 
Notfallration in der Schublade...

von Lars R. (sassl77)


Lesenswert?

Soooo, ich hab mir mal nen Weihnachtsgeschenk bestellt :)

Hab bei Reichelt bestellt, da ich da eh Kunde bin ... mal sehen wann das 
Zeug ankommt. Leiterplatten habe ich die von RADEMACHER bestellt. Ich 
habe jetzt einfach 1mm² verzinnten Draht bestellt, ich denke mal der 
wird vom Querschnitt für das was ich mache ja wohl ausreichen!?

Ich wünsche allen ein frohes Fest!

von Johannes F. (Gast)


Lesenswert?

Lars R. schrieb:
> Ich
> habe jetzt einfach 1mm² verzinnten Draht bestellt, ich denke mal der
> wird vom Querschnitt für das was ich mache ja wohl ausreichen!?

Das kommt halt auf die Stromstärke und den tolerierbaren Spannungsabfall 
an ... so pauschal lässt sich das nicht sagen. Besser als eine 
Streifenraster-Leiterbahn dürfte es auf jeden Fall sein. Wenn es immer 
noch nicht reichen sollte, könnte man auch zwei Drähte parallel nehmen, 
einen „über“ und einen „unter“ den Löchern langgeführt ... ;-)

Frohe Weihnachten!

von Lars R. (sassl77)


Lesenswert?

Johannes F. schrieb:
> Wenn es immer
> noch nicht reichen sollte, könnte man auch zwei Drähte parallel nehmen,
> einen „über“ und einen „unter“ den Löchern langgeführt ... ;-)

Na ich will doch ab jetzt mit meiner Schaltung eh nicht mehr sooo 
"pingelig" umgehen ;)

Ich werd ja sehen was passiert!?

von PC-Freak (Gast)


Lesenswert?

WF88 schrieb:
> Ich habs dann mit dem Saitenschneider

Bist Du Gitarist?

Frohes Fest an alle hier.

von WF88 (Gast)


Lesenswert?

1mm² ist schon ne Hausnummer, da geht einiges durch, bevor du Probleme 
bekommst. In Hausinstallationen nimmt man 1.5 für 16A.

von Lars R. (sassl77)


Lesenswert?

Hallo zusammen! Ich hoffe Ihr hattet alle ein schönes Weihnachtsfest!

Ich wollte nur kurz informieren das meine Bestellungen eingegangen sind.
Ich habe jetzt folgendes Netzteil im Betrieb:

https://amzn.eu/d/fQXdq8S

Hier hab ich die Eingangs Spannung ein wenig angehoben und nun ist schon 
im jetztigen Aufbau alles stabil bei knapp über 5V.

Des weiteren habe ich meine Lieferung vom "Kumpel" Reichelt bekommen und 
werde als bald mit dem Zusammenbau auf der Lochrasterplatine beginnen. 
Mal sehen wie es dann alles läuft!

Ich werde berichten!

Ich wünsche allen einen guten Rutsch!

Grüße Lars

von HildeK (Gast)


Lesenswert?

WF88 schrieb:
> 1mm² ist schon ne Hausnummer, da geht einiges durch, bevor du Probleme
> bekommst. In Hausinstallationen nimmt man 1.5 für 16A.

Dort wird auf die Erwärmung des Drahtes geachtet, deshalb diese Werte.
Bei 5V oder kleiner ist diese Betrachtung falsch, außer dir macht es 
nichts aus, wenn am Ende ein paar Volt fehlen - genau das ist bei 230V 
relativ belanglos; bei 5V aber kriegsentscheidend.

Fazit: bei kleinen Spannungen ist der Spannungsabfall bei größeren 
Strömen das Problem, nicht die Erwärmung.

von Lars R. (sassl77)


Angehängte Dateien:

Lesenswert?

Hallo zusammen und ein gesundes neues wünsche ich!

Ich habe nun die Lochraster Platinen und alle anderen benötigten 
Bauteile zusammen und möchte demnächst mit dem Zusammenlöten beginnen.

Ich habe dazu mal einen Schaltplan erstellt und wollte Euch bitten mal 
einen Blick darauf zu werfen ob das so geht/Sinn macht. Ich bin wie 
gesat nur Laihe und wäre sehr dankbar wenn Ihr Euch das mal kurz ansehen 
könntet und mir eure Meinung sagt oder ggf. noch Verbesserungsvorschläge 
gebt.

Die Zeichnung hängt an.

Die relativ großen Vorwiderstände der LED resultieren in dem Wunsch die 
LED nicht zu hell leuchten zu lassen.

Der Spannungsteiler R5/R6 ist nach meinem Verständnis nötig, da die 
Eingänge der ADS1115 laut Datenblatt nie mehr als VDD + 0.3V bekommen 
dürfen und es aber passieren kann das nur die Spannung vom USB anliegt 
und das Netzteil aus ist. In diesem Fall ist VDD am ADS1115 ja 0V.

Funktionieren soll das ganze dann so, dass die Spannung vom USB 
Anschluss das Relais K1 schaltet welches dann die Spannung vom Nezteil 
durch schaltet und so die ganze Schaltung in betrieb geht.

Das Netzteil ist ständig an und über die USB Spannung soll halt die 
Schaltung nur laufen, wenn auch das zu kühlende Gerät läuft.

Wie immer danke ich Euch für Eure Unterstützung!

Grüße Lars

von Steve van de Grens (roehrmond)


Lesenswert?

10 kΩ vor den LEDs ist übertrieben viel, hast du das mal ausprobiert? 
Ich würde 1 kΩ nehmen, wenn sie schwach (aber indoor gut sichtbar) 
leuchten soll.

Bei der grünen LED hast du "nur" 2,2 kΩ genommen, vermutlich weil sie 
weniger effizient ist. Bedenke dabei aber, dass unser Auge auf grün 
empfindlicher reagiert. Letztendlich sehen die meisten grünen LED bei 
gleichem Vorwiderstand etwa gleich hell aus, wie rote LED. Also würde 
ich auch hier 1 kΩ empfehlen.

Mache an SDA und SCL noch Pull-Up Widerstände mit 2,2 kΩ. Die 
Widerstände auf den Modulen sind (falls vorhanden) meist recht hochohmig 
und damit Störanfällig. Vor allem in der Nähe der Bluetooth/WLAN 
Antenne.

Apropos Störungen: Der ADC wird vermutlich viel besser funktionieren 
wenn du ihm einen L/C Filter in der Spannungsversorgung spendierst. Ich 
würde 10 µH und 1 µF versuchen. Aber achte darauf, dass die Spule gut 
gekapselt ist, damit auch sie kein Signal von der Antenne aufnimmt.

: Bearbeitet durch User
von Lars R. (sassl77)


Lesenswert?

Hallo und danke für die Vorschläge!

Steve van de Grens schrieb:
> 10 kΩ vor den LEDs ist übertrieben viel, hast du das mal ausprobiert?

ja das hab ich probiert und so bei den LED die ich hier habe das Licht 
so wie ich es haben möchte ... die Schaltung liegt später in einem 
dunklen Raum und dann soll das Licht nur zu sehen sein, aber nicht 
blenden.

Steve van de Grens schrieb:
> Mache an SDA und SCL noch Pull-Up Widerstände mit 2,2 kΩ

Diese sollten dann natürlich gegen 3V3 pullen oder!? Ist ja Logig High 
vom ESP?

Steve van de Grens schrieb:
> wenn du ihm einen L/C Filter in der Spannungsversorgung spendierst

Oh man, da bin ich mit meinem Wissen leider schon überfordert :(
Ich hab mal versucht mich bei Dr. Google ein wenig zu belesen, aber 
leider verstehe ich das alles nicht wirklich :( Kannst Du mir da 
vielleicht helfen, oder aber mir eine Seite empfehlen wo ich mir das 
erlesen kann?

Vielen Dank schon mal und grüße!

von Steve van de Grens (roehrmond)


Lesenswert?

>> 10 kΩ vor den LEDs ist übertrieben viel, hast du das mal ausprobiert?
Lars R. schrieb:
> ja das hab ich probiert und so bei den LED die ich hier habe das Licht
> so wie ich es haben möchte

Na dann will ich dich nicht aufhalten.

>> Mache an SDA und SCL noch Pull-Up Widerstände mit 2,2 kΩ
> Diese sollten dann natürlich gegen 3V3 pullen oder!? Ist ja Logig High
> vom ESP?

Ja

Lars R. schrieb:
>> wenn du ihm einen L/C Filter in der Spannungsversorgung spendierst
> Oh man, da bin ich mit meinem Wissen leider schon überfordert

So wie dort gezeigt: 
https://docs.makerfactory.io/images/sensorio/mcu-VREF.png

von Lars R. (sassl77)


Lesenswert?

Ok! Vielen Dank!

Ich werd mir das dann mal an schauen.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.