Forum: PC-Programmierung Mac "Big Sur": Wemos D1 Mini nicht erkannt


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Frank E. (Firma: Q3) (qualidat)


Lesenswert?

Ich habe zu einem etwas neueren Macbook Pro mit "Big Sur" (11.7) 
gewechselt und muss nun feststellen, dass die USB-Treiber für Wemos D1 
Mini "ums Verrecken" nicht funktionieren wollen. Originale Arduinos sind 
kein Problem, einen ESP32 konnte ich mangels Verfügbarkeit zuhause noch 
nicht testen, Wemos D1 Mini ist ja ESP8266.

Ich habe bestimmt 5 verschiedene Quellen, u.a. Wemos direkt und diverse 
Hinweise aus Stack Overflow usw. verfolgt ... niente, der 
USB-Serial-Port will einfach nicht im System erscheinen. Weder im 
"Systembericht/USB", nicht in der Arduino-Umgebung und auch nicht im 
Tasmota-Flasher-Tool.

Wemos schreibt z.B. direkt auf seiner Download-Seite, dass MacOS über 
10.14 gar keinen Treiber benötigt, weil der bereits im System enthalten 
sei (wie der tatsächlich enthaltene FTDI-Treiber). Was aber definitiv so 
nicht stimmen kann, denn es erscheint nix ...

Langer Rede kurzer Sinn - kann mir hier jemand einen tatsächlich 
funktionierenden Tip geben, der das Problem "einfach so" löst? Danke!

(Und ja, ich habe die jeweils alte Version von usbserial.kext bzw. den 
Silabs-Treibern manuell bzw. mit Hilfe eines beigefügten Skripts 
deinstalliert und auch jedesmal einen Neustart gemnacht. Und in 
"Systemeinstellungen/Sicherheit" die Installation mit Admin-Passwort 
erlaubt ... Und ich habe verschiedene Wemos Minis ausprobiert, auch 
verschiedene Kabel. Die Stromversorgung über USB funktioniert).

: Bearbeitet durch User
von Frank (Gast)


Lesenswert?

Hast du den Controller an einem anderen Gerät getestet ob er überhaupt 
funktioniert?

von Frank E. (Firma: Q3) (qualidat)


Lesenswert?

Ja. An einem Mac mit "Mojave"  (10.14) wird er problemlos erkannt.

von DerEinzigeBernd (Gast)


Lesenswert?

Frank E. schrieb:
> Weder im "Systembericht/USB"

Da müsste dann aber ein unbekanntes USB-Gerät auftauchen. Von wem ist 
denn die USB-Serial-Bridge auf Deiner Platine?

von Michael H. (mha1)


Lesenswert?

Die Wemos D1 sollten einen CH340 als USB/Serial Bridge benutzen. Mangels 
CH340 kann ich leider nicht sagen, ob das mit MacOS ohne entsprechende 
Treiber funktioniert.

MacBook Pro mit MacOS 11 (Big Sur) deutet auf ein nicht zu altes MacBook 
Pro mit eventuell noch nur USB-C Ports hin. Intel oder Apple M1 Chip?

Probleme mit dem USB-Kabel, eventuellen Adaptern und dem USB-Port am Mac 
kannst Du ausschließen? MacOS ist da mitunter recht zickig.

Eine neuere MacOS Version ist keine Option für Dich? Zumindest MacOS 12 
sollte bei einem MacBook Pro mit MacOS 11 problemlos zu installieren 
sein. Testweise kann man das auch auf einer externen USB Platte/SDD 
installieren.

von DerEinzigeBernd (Gast)


Lesenswert?

Treiber von WCH gibt es hier:

http://www.wch-ic.com/downloads/CH34XSER_MAC_ZIP.html

Der ist auch für macOS 11 ("Big Sur").

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.