Forum: Platinen Bauteil erstellen - 11 Pins nur ein supply Netz


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Uwe °. (ossabow)


Angehängte Dateien:

Lesenswert?

Hallo @all,
nutze Eagle sehr selten und erstelle kaum Bauteile selbst.
An ein "ganz einfaches" habe ich mich herangewagt: Ein ist ein Blech zum 
Anschluß von Kabelschuhen mit gleicher Anzahl Pins.
Die Pins im Package sollen also ein Netz sein, im Symbol zum zeichnen 
kontaktierbar sein und "Show" die Verbindungen anzeigen.
Ich habe nichts vergleichbare in der Bib gefunden zum abgucken, wer hat 
da Tips?
CYL Uwe

von Bauform B. (bauformb)


Angehängte Dateien:

Lesenswert?

Wenn du an 11 Stellen ein wire anschließen möchtest, muss das Symbol 11 
Pins haben. Das Package hat natürlich 11 Pads, also kann man im Device 
alle 1:1 verbinden. Damit die auch mit Kupfer verbunden werden, legt man 
im Package ein Polygon im Layer 16 (meinetwegen auch im Layer 1) quer 
über alle Pads.

Im Schaltplan gibt es trotzdem noch keine Verbindung zwischen den Pins. 
Jetzt wird gemogelt: Alle Pins werden im Schaltplan ganz normal 
verbunden, und zwar innerhalb des Schaltzeichens (was normal total 
unmoralisch wäre). Damit das nicht auffällt, ändert man nachträglich die 
Strichstärke auf 0.04, also genauso dick wie die Verbindungspunkte sind 
(evt. auch noch dicker).

Edit: statt die innere Verbindung dicker zu machen, kann man auch 
nachträglich die Verbindungspunkte löschen. Elektrisch änder das nichts.

: Bearbeitet durch User
von Georg (Gast)


Lesenswert?

Bauform B. schrieb:
> Damit das nicht auffällt

Warum soll eine real existierende Verbindung nicht auffallen?

Georg

von Uwe °. (ossabow)


Lesenswert?

Danke, scheint die einzige Möglichkeit zu sein.
So hab ich es ja, dann kommen alle Abfragen wegen Netze verbinden aber 
ist ja nicht so oft.
Wofür ist das Polygon gut?

von Bauform B. (bauformb)


Lesenswert?

Uwe °. schrieb:
> So hab ich es ja, dann kommen alle Abfragen wegen Netze verbinden aber
> ist ja nicht so oft.

Irgendeine Kleinigkeit ist wohl doch anders, bei mir gibt es keine 
Abfragen.

> Wofür ist das Polygon gut?

Ich hatte gehofft, dass man dann im Board die Leiterbahnen nicht 
verlegen muss. Das klappt wohl nicht. Immerhin gibt es DRC-Fehler, wenn 
man im Schaltplan einen Pin an ein anderes Netz anschließt oder eine 
Verbindung vergisst.


Georg schrieb:
> Warum soll eine real existierende Verbindung nicht auffallen?

Ich wollte möglichst viel Ähnlichkeit mit der Vorlage, da sind die 
Verbindungen ja im Symbol-Layer gezeichnet.

von Wolfgang (Gast)


Lesenswert?

Bauform B. schrieb:
> Ich wollte möglichst viel Ähnlichkeit mit der Vorlage, da sind die
> Verbindungen ja im Symbol-Layer gezeichnet.

Welchen Grund gibt es überhaupt für so ein verkrumpeltes Symbol?
Das ist eine Buchse mit 11 verbundenen Kontakten und so kann man das 
Symbol auch zeichnen. Bei einem Transistor o.ä. geht das doch auch.

von Uwe °. (ossabow)


Lesenswert?

Bauform B. schrieb:
> Uwe °. schrieb:
>> So hab ich es ja, dann kommen alle Abfragen wegen Netze verbinden aber
>> ist ja nicht so oft.
>
> Irgendeine Kleinigkeit ist wohl doch anders, bei mir gibt es keine
> Abfragen.
Du hast als Pinfunktion nicht "sup", habe es nun auf io geändert.

von Bauform B. (bauformb)


Lesenswert?

Uwe °. schrieb:
> Du hast als Pinfunktion nicht "sup", habe es nun auf io geändert.

"io" war keine Absicht, das ist die Default-Einstellung. "pas" oder 
"pwr" sollte eigentlich bessere Fehlermeldungen geben, aber keine 
Abfrage.

von Uwe °. (ossabow)


Lesenswert?

"pwr" verbindet doch, geht gar nicht. War aber mein erster Versuch, in 
der Klemme keine aber alle pin1 aller Klemmen waren verbunden.
Für mein außergewöhnliches Bauteil gibt es keine einfache Lösung.
Per Scribt könnte die Verbindungen im Schaltzeichen für Änderungen 
deaktiviert werden, mir ist der Aufwand zu hoch (soll heißen ich kann es 
nicht).

von Bauform B. (bauformb)


Lesenswert?

Uwe °. schrieb:
> "pwr" verbindet doch, geht gar nicht.

Andererseits sollen ja alle verbunden werden...

> War aber mein erster Versuch, in der Klemme keine aber alle
> pin1 aller Klemmen waren verbunden.

Das gilt doch nur, solange kein anderes Signal angeschlossen wird? Also, 
das Symbol bekommt 11 Pins "pwr" mit den Namen "KLEMME@1" bis 
"KLEMME@11". Damit sind zunächst global alle Klemmen verbunden. Nee, ich 
geb' auf :(

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.