Forum: Analoge Elektronik und Schaltungstechnik Ausgang von Logikgatter nicht konstant


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Autodidakt (Gast)


Angehängte Dateien:

Lesenswert?

einen schönen guten Tag,


ich habe einen Oszillator auf Steckbrett aufgebaut mit einem CD40106, 
Inverter mit Schmitt Trigger Input. Ausgang über 10k Widerstand auf 
einen Ladekondensator von 100 nF.

Das Ensemble schwingt, allerdings ist auf dem gelben Plot ja zu sehen, 
dass der Ausgang ja nun nicht wirklich rechteckig ist. Ich zerbreche mir 
seit geraumer Zeit den Kopf was der grund sein könnte. Mein eigentich 
einziger Grund ist, dass der Strom zum aufladen des Kondensators zu viel 
für den Ausgang ist. Aber bei 10k Widerstand ist das doch 500uA am 
Anfang. Das ist doch viel weniger als der können müsste.... Bin ratlos 
und würde herzlich um Rat bitten... Was geht da vor? In den Videos und 
Screenshots sah der Ausgang immer sehr rechteckig aus.
Die unbenutzten Eingänge habe ich schon auf gnd gesetzt weil ich fand 
dass das sonst u.U. Probleme machen kann.

danke euch

p.s. ach ja ich habe mich für die Sektion Analog entschieden, weil meine 
Frage ja eben darum geht, dass das nicht digital am Ausgang rauskommt. 
Hoffe stimmt so

von olaf (Gast)


Lesenswert?

Datenblatt sagt das IC mindestens 500uA, typsisch 1000uA liefern kann
bei einem Vout von 4.6V. Alles klar?

Olaf

von Michael M. (michaelm)


Lesenswert?

Ein Schaltbild deines Aufbaus ist sicherlich sehr hilfreich. ;-)

von Martin (Gast)


Lesenswert?

(10:1 Tastkopf benutzt? Falls ja:) Hast Du Deinen Tastkopf abgeglichen? 
Falscher Abgleich vom Tastkopf sieht nämlich auch so aus.

von LDR (Gast)


Lesenswert?

Du hast nicht 10kOhm, sondern 1kOhm verwendet. Und der 
Ausgangswiderstand eines 40106 ist bei 5V Versorgungsspannung typisch 
400 Ohm.

von Εrnst B. (ernst)


Lesenswert?

Bastel mal einen Abblockkondensator (100nF) direkt über die 
Versorgungs-Pins des IC.

Also nicht über die ±-Schienen am Rand, Anschlussbeinchen entsprechend 
biegen und direkt über dem IC platzieren.

von LDR (Gast)


Lesenswert?

Εrnst B. schrieb:
> Bastel mal einen Abblockkondensator (100nF) direkt über die
> Versorgungs-Pins des IC.
>
> Also nicht über die ±-Schienen am Rand, Anschlussbeinchen entsprechend
> biegen und direkt über dem IC platzieren.

Foto nochmals ansehen!

von le freak (Gast)


Lesenswert?

Wo ist das Problem? das entspricht doch absolut der Spezifikation und 
die Flankensteilheit ist brauchbar. Logikbausteine garantieren ja keine 
genaue Spannung an den Ausgängen sondern nur eine Spannung im Bereich 
der Logikpegel.
Kleinerer C und grösserer R könnten Abhilfe schaffen, oder einfach einen 
Inverter nach schalten.

von Jens G. (jensig)


Lesenswert?

LDR schrieb:
> Du hast nicht 10kOhm, sondern 1kOhm verwendet. Und der
> Ausgangswiderstand eines 40106 ist bei 5V Versorgungsspannung typisch
> 400 Ohm.

So siehts aus.Würde auch zum Verhältnis der Steilheiten der "Dächer" 
passen. Und der R sieht doch mit seinen Ringen auch nicht gerade nach 
10k aus, oder?

von Stefan F. (stefanus)


Lesenswert?

Autodidakt schrieb:
> Ich zerbreche mir
> seit geraumer Zeit den Kopf was der grund sein könnte

Spannungsabfall auf dem Zuleitungen der Stromversorgung.

von Jens G. (jensig)


Lesenswert?

Stefan F. schrieb:
> Autodidakt schrieb:
>> Ich zerbreche mir
>> seit geraumer Zeit den Kopf was der grund sein könnte
>
> Spannungsabfall auf dem Zuleitungen der Stromversorgung.

Bei noch nicht mal einem halben mA? Müssen ja schlechte Leitungswege 
sein ...

von Jens G. (jensig)


Lesenswert?

Der TO könnte ja mal als Gegenbeweis einfach mal den C rausnehmen, und 
als zweiten Test ihn mal brücken. In beiden Fällen sollte sich die Kurve 
dem Rechteck nähern, und beim C-brücken einen konstanten Spannungsabfall 
oben zeigen.
Auserdem: auf dem Bild sieht es eher so aus, als ob der C und R 
überhaupt nicht miteinander verbunden wären ...

von Bernd K. (bmk)


Lesenswert?

Der CD40106 hat ja 6 Schmitt-Trigger-Inverter

Geh doch mal über 2 weitere Inverter und vergleiche
dann dieses Signal mit dem originalen.

Dann siehst du ja, ob das Laden des Kondensators reinspielt.

von Achim S. (Gast)


Lesenswert?

Jens G. schrieb:
> Der TO könnte ja mal als Gegenbeweis einfach mal den C rausnehmen, und
> als zweiten Test ihn mal brücken.

Oder er könnte einfach den versehentlich verwendeten 1kOhm Widerstand 
durch den eigentlich vorgesehenen 10kOhm Widerstand ersetzen. Dann 
bekäme er die Frequenz, die er wohl ursprünglich berechnet hat, und der 
Strom durch den Widerstand wäre wirklich deutlich unter 1mA (derzeit ist 
er darüber).

Jens G. schrieb:
> Auserdem: auf dem Bild sieht es eher so aus, als ob der C und R
> überhaupt nicht miteinander verbunden wären ...

läuft über das gelbe Kabel links vom Widerstand.

von Axel S. (a-za-z0-9)


Lesenswert?

Nicht zu vergessen ist ein CD40106 bei 5V eine lahme Krücke (der ist ja 
auch gut 40 Jahre alt). Der vergleichsweise hohe Ausgangswiderstand von 
400Ω wurde ja schon genannt.

Bau es mit einem 74HC14 auf und bemerke den Unterschied!

von PC-Freak (Gast)


Lesenswert?

Naja, ist wohl klar. Der eine Schmdler's Trigger macht halt denm Takt.

Dann klemm doch den nächsten Schmidler an den Ausgang des ersten. Dann 
wird am zweiten ein Rechteck zu sehen sein.

von Wolfgang (Gast)


Lesenswert?

Stefan F. schrieb:
> Spannungsabfall auf dem Zuleitungen der Stromversorgung.

Bei 500µA?
Da wäre es nicht so schwierig, mit dem Tastkopf direkt über der 
Versorgungsspannung zu gucken.

von PC-Freak (Gast)


Lesenswert?

Wolfgang schrieb:
> Stefan F. schrieb:
>> Spannungsabfall auf dem Zuleitungen der Stromversorgung.
>
> Bei 500µA?

Der 1K vom Ausgang zum Eingang, und dort der Kondi gegen Gnd verformt 
das Rechteck. Der Lade-Entladevorgang. Deshalb einfach einen weiteren 
Schmidler hinten dran. Da ist dann das Rechteck sauber. Garantiert.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Wenn man so viel Gatter zur Verfügung und die meisten lahmgelegt hat, 
bietet es sich an, die 5 freien Gatter parallel zu schalten und als 
Buffer zu verwenden.

von Michael M. (Firma: Autotronic) (michael_metzer)


Lesenswert?

Matthias S. schrieb:
> Wenn man so viel Gatter zur Verfügung und die meisten lahmgelegt
> hat, bietet es sich an, die 5 freien Gatter parallel zu schalten und als
> Buffer zu verwenden.

Ja, das kann man machen. Man muss nur dafür sorgen, dass alle Gatter 
gleichzeitig steilflankig angesteuert werden. Wenn man sich nicht sicher 
ist, kann man noch ein einzelnes Schmitt-Trigger Gatter davorschalten 
und somit nur die verbliebenen 4 Gatter parallel schalten.

von Autodidakt (Gast)


Lesenswert?

Hi!

Danke für eure Antworten. Hat sich eigentlich alles recht schnell 
geklärt. Olaf und LDR haben das kukrz und knapp erklärt. Seltsam, dass 
ich mir zwar in dem Datenblatt den Strom angeguckt hatte, aber nicht 
gecheckt habe, dass bei dem Strom dann halbes Volt fehlt... Muss man 
vielleicht auch üben nichts zu überlesen.
Und, ok dass ich 1K Ohm benutzt habe statt 10k sehe ich jetzt erst. Da 
ist mal ein Augenarzt Termin angesagt ;-)

Ich habe mir cmos IC gekauft, weil ich dachte das wäre für mich die 
universiellste Lösung bzgl. der Versorgungsspannung. 5V geht, 9V 
...alles kein Problem. Je nachdem wo man bastelt.

Es war ein lehrreicher Thread. Danke.

von Autodidakt (Gast)


Lesenswert?

Nachtrag: Eine Frage habe ich noch dazu: falls ich mal etwas mehr Strom 
aus einem Ausgang nehmen möchte, wie/womit kann ich das buffern? 5 mA 
für eine LED wäre ja schon schlecht. Wenn ich den Tip von einem extra IC 
mit arallelen Gattern nicht anwende. Ein Strommonster-Buffer der 4000er 
gibt es nicht?

danke

von Mohandes H. (Firma: مهندس) (mohandes)


Lesenswert?

Autodidakt schrieb:
> falls ich mal etwas mehr Strom aus einem Ausgang nehmen möchte,
> wie/womit kann ich das buffern?

Einfach einen Transistor a la BC547 dahinter schalten.

von olaf (Gast)


Lesenswert?

> wie/womit kann ich das buffern? 5 mA
> für eine LED wäre ja schon schlecht.

Du kannst bessere Leuchtdioden nehmen die mit 1-2mA schon relativ hell
sind. Ausserdem kannst du auch mehrere Gatter parallel schalten.

> Ein Strommonster-Buffer der 4000er gibt es nicht?

Ich denke eher nicht. Die klassischen 4000er waren ja auf Strom sparen
und langsam ausgelegt. Heute nimmt man ja eher HC-Gatter weil man mit 5V
ueblicherweise auskommt. Dort gibt es dann auch dicke Busdriver.

Olaf

von Michael M. (Firma: Autotronic) (michael_metzer)


Lesenswert?

Ein CD40106 kann bei 12V noch problemlos mit einer LED mit 2k2 
Vorwiderstand belastet werden. Wenn dann ein halbes Volt fehlen sollte, 
sieht man das optisch nicht.

Ich glaube die CD40xx Reihe verkraftet max. 10mA am Ausgang. Ich würde 
aber nicht mehr als 5mA entnehmen.

von LDR (Gast)


Lesenswert?

olaf schrieb:
>> Ein Strommonster-Buffer der 4000er gibt es nicht?
>
> Ich denke eher nicht. Die klassischen 4000er waren ja auf Strom sparen
> und langsam ausgelegt.

Naja, 4049/4050 können schon etwas mehr als normale Ausgänge.

von Michael M. (Firma: Autotronic) (michael_metzer)


Lesenswert?

LDR schrieb:
> Naja, 4049/4050 können schon etwas mehr als normale Ausgänge.

Bei denen ist mit 16mA pro Gatter auch schon das Ende erreicht.

von Dieter W. (dds5)


Lesenswert?

Für noch höhere Belastbarkeit sollte man den Einsatz eines ULN2003 in 
Betracht ziehen.

von olaf (Gast)


Lesenswert?

> Bei denen ist mit 16mA pro Gatter auch schon das Ende erreicht.

Es gibt aber heute Leds die kannst du mit 10mA betreiben und willst
dann da nicht mehr reinschauen weil du danach 10min gruene oder rote
Punkte siehst.

Olaf

von Michael M. (Firma: Autotronic) (michael_metzer)


Lesenswert?

olaf schrieb:
> Es gibt aber heute Leds die kannst du mit 10mA betreiben und willst
> dann da nicht mehr reinschauen weil du danach 10min gruene oder rote
> Punkte siehst.

Das stimmt. Bei den Grünen habe ich sogar 22k vorgeschaltet, weil die 
einfach zu grell strahlen (20.000 mcd)!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.