Forum: PC Hard- und Software WD Mycloud Mirror - RS232 Debug Port


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Max M. (Gast)


Angehängte Dateien:

Lesenswert?

Moin,
im zeitlichen Zusammenhang einer Fritzbox6591 Cable Installation ließ 
sich mein WD Mycloud Mirror NAS nicht mehr ansprechen.
Netzwerk LED am NAS zeigt Connect und Datentransfer.
Weder in der Fritz, noch im ext. WLAN AP taucht das WD NAS als 
Netzwerkgerät auf, auch AngryIP findet nix.
Jeder Versuch über ETH auf das NAS zu kommen scheiterte, auch die 
direkte PC Verbindung.
Auch Reset half nicht.

Ethernet defekt, war die Vermutung.
NAS filettiert, CMOS Batterie mit 2,97V fraglich, entfernt und bisher 
nicht neu eingesetzt, dabei den unbestückten debug Port gefunden.
Das Pinning rauszumessen war nicht weiter schwer, mit den Oszi die 
Baudrate abgeschätzt, 3V3 RS232 / USB Wandler angeschlossen.

1: Tx-NAS / Rx-Konverter
2: GND
3: 3,3V (NC, Wandler wird über USB versorgt)
4: frei
5: Rx-NAS / Tx-Konverter
115200bps,8,N,1 und wenn man nach dem Boot Log eine Taste drückt meldet 
sich Busybox mit root Rechten ohne Login.

Immer noch kein WD NAS in der Fritz.
Also die Fritz über das NAS angepingt.
Und jetzt passiert etwas das ich nicht verstehe:
Die Fritz antwortet auf den Ping, das WD NAS wird in die Liste der 
Heimnetzgeräte aufgenommen und nun auch bei der WIN Netzwerkfreigabe 
gefunden.
Seit dem alles knorke, das NAS lässt sich anpingen, sieht jedes Gerät im 
eigenen Netzwerk und wird über die Win Netzlaufwerkverbindung gefunden.
Aber erst seit dem Anpingen der Fritz über Busybox.
Kann mich da mal bitte jemand erleuchten?

btw.
Da das NAS hinter der Fritz Firewall hängt, für Internet gesperrt ist 
und das Heimnetz nicht verlassen kann, mache ich mir über die WD 
Backdoor nicht allzuviele Gedanken.

Grüße

von Rüdiger B. (rbruns)


Lesenswert?

Im falschen Subnetz ? Vllt. wurde durch den Ping ein ARP Request 
ausgelöst ?

von Max M. (Gast)


Lesenswert?

Könnte sein, weil die Fritz einen anderen Subnetz Bereich aufspannt als 
die olle Vodafone Gurke vorher.
Aber sollte das NAS nicht durch den DHCP Server in der Fritz automatisch 
rekonfiguriert werden?

von Hmmm (hmmm)


Lesenswert?

Max M. schrieb:
> Aber sollte das NAS nicht durch den DHCP Server in der Fritz automatisch
> rekonfiguriert werden?

Evtl. verwendet die Kiste ihre DHCP-Lease selbst dann bis zur 
Expiration, wenn das Interface zwischendurch down ist.

In dem Fall wäre der zeitliche Zusammenhang mit Deinem Ping reiner 
Zufall.

von Max M. (Gast)


Lesenswert?

Demontiert und ohne HDD kann man sich nicht über Browser einloggen.
Jetzt da es wieder komplett ist, sieht man in den System Alarmmeldungen 
das zwischenzeitlich der ETH Controller nicht gefunden werden konnte.
Mein Ping über die Kommandozeile scheint das System wohl aus dem 
Fehlerzustand gerissen zu haben.

Bei der SW fragt man sich ja manchmal was WD eigentlich zum Marktführer 
gemacht hat. Backdoor in der FW, heftige Bugs in der Benutzerverwaltung 
und ein System das sich beim ersten HW Fehler schmollend in die Ecke 
zurückzieht bis man durch die Hintertür einbricht und ihm einen Tritt 
gibt.

Naja, es erfüllt noch seinen Zweck.
Der Service Port ist jetzt von aussen zugänglich.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.