Forum: Mikrocontroller und Digitale Elektronik Unsaubere Messergebnisse mit ADS1115+Wemos D1 mini wenn gound nicht auf PE gelegt


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Christian (christian88)


Angehängte Dateien:

Lesenswert?

Hallo zusammen,

ich bin ganz neu in der µController-Welt und versuche mich gerade an ein 
paar einfachen Nachbauprojekten und etwas mehr Einblick in das Thema zu 
bekommen.

Mein Aufbau lautet wie folgt:
ESP8266 (Wemos D1 mini), daran ein ADS1115 (3,3V VCC)
Stepup Converter an 5V
daran hängt ein 4-20mA Drucksensor
zwischen Drucksensor schwarz und ground hängt ein 150Ohm Messwiderstand, 
dessen Spannungsabfall zwischen gemeinsamem ground und dem anderen Ende 
des Widerstands lese ich mit dem ADS aus.
Grundsätzlich funktioniert der Messaufbau ganz gut, besonders am Anfang 
gab es eigentlich keine auffälligen Messergebnisse. Nachdem ich mich 
nach ein paar Tagen wieder an das Projekt gewagt habe, waren plötzlich 
starke Schwankungen in der Spannungsmessung zu erkennen - auch mit dem 
ADC (A0) im ESP direkt, wobei hier die Ergebnisse bekanntermaßen noch 
unsauberer sind, der "Takt" war aber auch hier erkennbar.
Nach vielem Herumprobieren, habe ich mal versucht das Sensorgehäuse auf 
ground zu legen, was kurzzeitig eine Besserung brachte, dann aber auch 
wieder nicht.
Nach weiterem herumprobieren habe ich dann versucht, ground auf PE zu 
legen, was dann eine eindeutige und dauerhafte Besserung ergeben hat. 
Vorher waren die Schwankungen deutlich im 10mV Bereich, danach nur mehr 
im 1mV Bereich.

Ich hänge hier ein Bild zur Verdeutlichung an. Um ca. 18:34:20 in der 
Grafik habe ich die ground-PE Verbindung getrennt und schlagartig treten 
wieder Störungen auf. Ich habe es mit verschiedenen USB-Netzteilen 
probiert, verschiedene Kabel (kurze, lange) getestet, das alles macht 
keinen Unterschied. Um den Stepup-Regler auszuschließen, habe ich den 
Drucksensor auch an einen 12V Akku geklemmt und den Regler von der 
5V-Leitung getrennt, hat keinen Unterschied gebracht.

Kann mir als Einsteiger jemand erklären wo das Problem ist, und wie das 
Problem elegant in den Griff zu bekommen ist? Ich kann mir vorstellen, 
dass "ground an PE" nicht zur Standard-Vorgehensweise gehört, 
USB-Netzteile mit PE gibt es ja eigentlich nirgends. Warum hat es am 
Anfang gut funktioniert? Kann ein Defekt vorliegen?

von Wastl (hartundweichware)


Lesenswert?

Christian schrieb:
> Mein Aufbau lautet wie folgt:

Bitte Schaltpläne nicht in blumiger Prosa sondern als Bild
in Form einer *.png Datei, notfalls auch auf Papier gemalt
und abfotographiert, dann in *.jpg

Du bist neu hier, daher bist du mit der Thematik nicht
vertraut, aber die Fachleute hier wollen klare Bezugspunkte
ohne möglicherweise geschwurbelte Prosa.

Auf deinem Bild ist zwar eine Kurve zu erkennen, was das
aber sein soll ist nicht klar, die Achsen sind nicht
bezeichnet, also könnte man auch Äpfel oder Euro annehmen.

von Christian (christian88)


Angehängte Dateien:

Lesenswert?

Sorry, hier ein skizzierter Schaltplan.

Das Diagramm ist beschriftet: y-Achse mit "V" um 90° gedreht = Volt 
(Spannung)
und die x-Achse ist wohl selbsterklärend eine Uhrzeit..

von Peter D. (peda)


Lesenswert?

USB-Netzteile sind ja Schaltnetzteile und die haben typisch 1nF 
(Rx[50Hz] = 3MΩ) von einer Phase zu -5V. Je nach Steckrichtung liegen 
die -5V daher hochohmig an N (0V) oder L (230V).
Eine Verbindung -5V nach PE sorgt für definierte Pegel.

von Christian (christian88)


Lesenswert?

Müsste also das Umdrehen des Steckers eine Veränderung bringen? Werde 
ich mal testen. Wenn Ground dann hochohmig mit N (in der Verteilung vor 
dem RCD mit PE verbunden...) verbunden ist, sollte das doch vermutlich 
besser werden.

Ist das eine gängige Praxis bzw. darf man überhaupt GND mit PE 
verbinden?

von Klaus H. (nikolaus10)


Lesenswert?

Hallo

Abblocken der Versorgungsleitunge zum ADC (und Sensor) mit LC- Glied 
wuerde helfen.
Sternfoermige Masse auch. Bei den kleinen Spannungungen kann man auch 
ueber Schirmung nachdenken.( Oder saubere Leitungsfuehrung )

(Ist meine persoehnliche Meinung und nicht wirklich wichtig)

Gruesse

von Sebastian W. (wangnick)


Lesenswert?

Wie schwankt denn der Messwert genau? 6 Mal pro Minute, also alle 10 
Sekunden? Und welche Kurvenform hat die Schwankung genau?

LG, Sebastian

von Christian (christian88)


Lesenswert?

Hallo Sebastian,

ja das kommt ungefähr hin - im Eingangspost ist ein Diagramm angehängt, 
da siehst du es. Die Kurve ist etwas abgehackt, da ich den Sensor "nur" 
jede Sekunde abfrage. Ab ca. 18:34:20 Uhr (siehe x-Achse) habe ich die 
Verbindung zu PE gelöst.

Mir ist inzwischen noch etwas aufgefallen: das Metallgehäuse des Sensors 
hat keine Verbindung zu GND (zu VCC natürlich auch nicht). Wenn ich das 
Gehäuse auf GND lege ist es auch deutlich besser. Wäre das die bessere 
Lösung als GND auf PE? Wo liegt hier der Zusammenhang?

: Bearbeitet durch User
von Stefan K. (stk)


Lesenswert?

Christian schrieb:
> Ist das eine gängige Praxis bzw. darf man überhaupt GND mit PE
> verbinden?

Ist in PCs und vielen anderen Geräten mit Schukostecker üblich. Wenn du 
deine Schaltung aus einem USB-Anschluss eines PCs versorgst hast du 
diese Verbindung, ebenso wenn du ein Oszilloskop zum Messen anschließt.

von Christian (christian88)


Lesenswert?

Sebastian W. schrieb:
> Wie schwankt denn der Messwert genau? 6 Mal pro Minute, also alle
> 10
> Sekunden? Und welche Kurvenform hat die Schwankung genau?
>
> LG, Sebastian

Kannst du das noch kurz erklären wie das zustande kommt? Eine 
Überlagerung der Netzfrequenz mit der PWM-Frequenz vom Schaltnetzteil?


Was mich aber schon wundert, ist dass die Störungen bei mir so groß 
sind... Die simplen Bastelanleitungen im ESP-Mikrocontroller-Bereich zum 
Auslesen von 4-20mA Sensoren sehen alle relativ simpel aus, ohne Filter 
und ohne GND-PE Verbindung und keiner klagt über große Störungen. Dass 
der ADC direkt im ESP nichts taugt, ist mir bewusst, deshalb der 
ADS1115.
Was ist bei mir anders? Und warum hat es zeitweise (am Anfang) 
unauffällig funktioniert? Habe auch schon einen anderen ADS1115 
probiert, dass ich den ausschließen kann.

von Steve van de Grens (roehrmond)


Lesenswert?

Ich denke, dass hier die Leitungsführung der Knackpunkt ist.

Jedes Stück Leitung ist eine Antenne, die Radiowellen empfängt. Außerdem 
hat jede Leitung nicht nur einen kleinen Innenwiderstand für DC sondern 
einen viel größeren für hohe Frequenzen. Die Frage ist, wohin die 
empfangene Energie abgeleitet wird. Im Fehlerfall hast du es meistens 
mit ungewollt unterschiedlichen GND Potentialen zu tun.

Fotos vom Aufbau wären hilfreich, dann kann man praktikable Änderungen 
vorschlagen.

von Christian (christian88)


Angehängte Dateien:

Lesenswert?

momentan noch provisorisch ;-)

den Messwiderstand habe ich direkt am Ende des Kabels vom Sensor 
untergebracht und mit Schrumpfschlauch ummantelt, das gelbe Kabel ist 
davor abgegriffen.

von Steve van de Grens (roehrmond)


Lesenswert?

Da fällt mir direkt auf, dass du GND und Stromversorgungs-Leitungen über 
das Steckbrett verteilt hast. Mache das nicht! Löte Kupferkabel direkt 
an die Module an.

Denn die Kontakte der Steckbretter und auch Dupont Kabel haben 
erhebliche Übergangswiderstände. Dazu kommt, dass Dupont Kabel oft aus 
sehr dünnem aus Eisen oder Aluminium sind.

Auch Kroko-Kabel sind häufig problematisch, mit ihren Klemmen aus Eisen, 
zu dünnen Kabeln (auch hier wieder oft aus Eisen oder Aluminium) und oft 
schlecht gecrimpt.

Diese provisorischen Kabel taugen nur für Signale, nicht zur 
Stromversorgung. Jedenfalls nicht, wenn Spannungsabfall unter 1V 
relevant ist.

Achte außerdem darauf, dass die GND und Versorgungs-Leitungen 
Sternförmig an jeweils einem Sammelpunkt zusammen treffen.

: Bearbeitet durch User
von Steve van de Grens (roehrmond)


Lesenswert?

Noch etwas:

Wenn das Hauptproblem behoben ist, könntest du mehrere ADC Messungen 
machen und den Mittelwert verwenden, um empfangene Radiowellen heraus zu 
rechnen. Oder du packst einen Tiefpass (R/C Filter) vor den Eingang des 
ADC.

von Sebastian W. (wangnick)


Lesenswert?

Vielleicht beugst du dich auch beim Verbinden von PE über die Schaltung 
und der Drucksensor misst deine Atmung ...

Ich hatte mal einen Fall im Rechenzentrum der Uni Bremen, wo bei 
geschlossener Serverschranktür das Masseband einen Einschub berührte. 
Bei offener Tür war natürlich immer alles ok :)

LG, Sebastian

von Falk B. (falk)


Lesenswert?

Christian schrieb:
> momentan noch provisorisch ;-)
>
> den Messwiderstand habe ich direkt am Ende des Kabels vom Sensor
> untergebracht und mit Schrumpfschlauch ummantelt, das gelbe Kabel ist
> davor abgegriffen.

Naja. Was mich auf deiner Schaltplanskizze irritiert, sind die Massen. 
Speziell die Masse zum 150 Ohm Shunt. Wo befindet sich der Shunt 
physisch? Auf deinem Steckbrett? Dann wäre das OK. Weit weg? Dann muss 
zumindest die Masseleitung nah, noch besser verdrillt mit dem Signal 
geführt werden. Ein RC-Filter DIREKT am ADC-Eingang mit vielleicht 
10k+100nF kann hier nicht schaden. Wenn dein Steckernetzteil keinen PE 
hat, ist sehr zu empfehlen, die Masse am Netzteil mit PE zu verbinden, 
um die HF-Ströme möglichst kurzzuschließen.

von Christian (christian88)


Angehängte Dateien:

Lesenswert?

Steve van de Grens schrieb:
> Jedes Stück Leitung ist eine Antenne, die Radiowellen empfängt.

Dank einer neuen Erkenntnis vermute ich, dass das ein größeres Problem 
ist als ich dachte. Mehr dazu gleich...

Steve van de Grens schrieb:
> Wenn das Hauptproblem behoben ist, könntest du mehrere ADC Messungen
> machen und den Mittelwert verwenden, um empfangene Radiowellen heraus zu
> rechnen.

Ja, habe ich bei der Umrechnung auf den Druck schon eingebaut, 
funktioniert super mit einem floating average (ESPHome) über die letzten 
10 Werte (=10 Sekunden). Damit würde ich sogar das Rauschen einigermaßen 
herausbekommen, allerdings würde ich lieber die Ursache bekämpfen.

Steve van de Grens schrieb:
> Oder du packst einen Tiefpass (R/C Filter) vor den Eingang des
> ADC.

Das wird mir offen gesagt schon zu umständlich. Wie gesagt: in den 
ganzen einfachen Anleitungen ist auch keine Rede davon. Wenn die Ursache 
sich anders bekämpfen lässt, dann lieber so.

Sebastian W. schrieb:
> Vielleicht beugst du dich auch beim Verbinden von PE über die Schaltung
> und der Drucksensor misst deine Atmung ...

Guter Punkt, habe ich aber ausgeschlossen - ist auch unter Druck bei 
geschlossenem Hahn (um Druckschwankungen auszuschließen). Man könnte 
dabei auch an den Luftdruck denken, der ändert sich aber nicht so 
schnell und regelmäßig.

Den Shunt habe ich direkt ans Ende des Kabels gelötet. An das eine Ende 
(Richtung Sensor) habe ich das gelbe Kabel (Messleitung) gelötet, am 
anderen Ende das schwarze (Ground). Bild (leider schon mit 
Schrumpfschlauch) im Anhang.

von Christian (christian88)


Angehängte Dateien:

Lesenswert?

Steve van de Grens schrieb:
> Jedes Stück Leitung ist eine Antenne, die Radiowellen empfängt.

Dank einer neuen Erkenntnis vermute ich, dass das ein größeres Problem 
ist als ich dachte. Mehr dazu gleich...

Steve van de Grens schrieb:
> Wenn das Hauptproblem behoben ist, könntest du mehrere ADC Messungen
> machen und den Mittelwert verwenden, um empfangene Radiowellen heraus zu
> rechnen.

Ja, habe ich bei der Umrechnung auf den Druck schon eingebaut, 
funktioniert super mit einem floating average (ESPHome) über die letzten 
10 Werte (=10 Sekunden). Damit würde ich sogar das Rauschen einigermaßen 
herausbekommen, allerdings würde ich lieber die Ursache bekämpfen.

Steve van de Grens schrieb:
> Oder du packst einen Tiefpass (R/C Filter) vor den Eingang des
> ADC.

Das wird mir offen gesagt schon zu umständlich. Wie gesagt: in den 
ganzen einfachen Anleitungen ist auch keine Rede davon. Wenn die Ursache 
sich anders bekämpfen lässt, dann lieber so.

Sebastian W. schrieb:
> Vielleicht beugst du dich auch beim Verbinden von PE über die Schaltung
> und der Drucksensor misst deine Atmung ...

Guter Punkt, habe ich aber ausgeschlossen - ist auch unter Druck bei 
geschlossenem Hahn (um Druckschwankungen auszuschließen). Man könnte 
dabei auch an den Luftdruck denken, der ändert sich aber nicht so 
schnell und regelmäßig.

Falk B. schrieb:
> Wo befindet sich der Shunt physisch?

Den Shunt habe ich direkt ans Ende des Kabels gelötet. An das eine Ende 
des Widerstands (Richtung Sensor) habe ich das gelbe Kabel (Messleitung) 
gelötet, am anderen Ende das schwarze (Ground). Bild (leider schon mit 
Schrumpfschlauch) im Anhang.

von Christian (christian88)


Angehängte Dateien:

Lesenswert?

Jetzt aber zu meiner Erkenntnis:
ich habe den Sensor mal direkt mit den Krokoklemmen angeschlossen, 
jedoch über den Shunt, den ich im Kabel eingebaut habe. Siehe da - 
Rauschen so gut wie weg bzw. im normalen Bereich (2mV), davor mehr als 
20mV. Die Positionierung vom Widerstand sollte also anscheinend nicht 
das Problem sein.
Nochmal zur Verdeutlichung: den Shunt habe ich hier nur auf der Seite 
mit den kurzen Kabelenden genutzt - also: schwarz auf gnd, gelb auf 
sensor und ADC Eingang.

Zum Kabel: es ist ein 3-poliges Kabel, 2 Pole sind belegt, Abschirmung 
ist auch drin, ist aber nirgends verbunden. Auch das Sensorgehäuse ist 
weder mit ground noch mit der Abschirmung verbunden.
Was würdet ihr mir jetzt raten? Abschirmung auf Ground oder auf PE? 
Sensorgehäuse auch auf den Schirm legen? Neues Kabel?

von Christian (christian88)


Lesenswert?

So, noch eine Erkenntnis:
das Verbinden der Abschirmung hat keinerlei Änderung gebracht, weder mit 
GND, noch mit PC.
Was aber tatsächlich sehr gut geholfen hat ist das Verbinden vom 
Sensorgehäuse mit GND! Dazu habe ich die 3. vorhandene Leitung im Kabel 
verwendet und diese am Massekontakt vom Sensor angeschlossen und am 
anderen Ende auf GND gelegt.
Warum hat das etwas gebracht? Beim provisorischen Anschluss mit den 
Krokoklemmen habe ich das Gehäuse ja auch nicht "gegroundet". Geht es 
wirklich nur um die parallele Leitungsführung im Kabel?
Man könnte jetzt zwar argumentieren, dass sich damit Ground auch wieder 
PE von der Wasserleitung holt, aber um das auszuschließen, habe ich den 
Sensor mal abmontiert und isoliert hingelegt, auch hier so gut wie keine 
Störungen.

von Steve van de Grens (roehrmond)


Lesenswert?

Christian schrieb:
> Abschirmung auf Ground oder auf PE?

Wenn du eine Erdung hast, dann PE. Außerdem würde ich GND mit PE 
verbinden. Schließe den Schirm nur an einem Ende das Kabels an.

> das Verbinden der Abschirmung hat keinerlei Änderung gebracht, weder mit
> GND, noch mit PC.

Ich würde ihn trotzdem angeschlossen lassen.

> Was aber tatsächlich sehr gut geholfen hat ist das Verbinden
> vom Sensorgehäuse mit GND! Warum hat das etwas gebracht?

Keine Ahnung, ich kenne den Sensor nicht.

Aber es freut mich, dass du eine Lösung gefunden hast.

: Bearbeitet durch User
von Christian (christian88)


Lesenswert?

Falk B. schrieb:
> Ein RC-Filter DIREKT am ADC-Eingang mit vielleicht
> 10k+100nF kann hier nicht schaden.

Prosit Neujahr und nochmals Danke für alle hilfreichen Beiträge! Ich 
habe mich nun endlich dazu aufgerafft, ein Keramik-Kondensator-Sortiment 
zu bestellen und mich noch letztes Jahr (gestern :-D) endlich mit dem 
Thema RC-Filter beschäftigt um die Genauigkeit nochmals zu erhöhen.
Was ich bisher feststellen konnte, lässt sich die Spannung nochmals um 
eine Kommastelle stabilisieren, ich habe dazu 5kOhm und 10uF genommen - 
das gemittelte Signal schwankt jetzt nur mehr um 0,0005V(!!!), das ist 
echt Top! Außerdem gibt es kaum Ausreißer nach oben oder unten. Dadurch 
kann ich jetzt die moving average reduzieren und auch die Abtastrate, 
die ich unnötig hoch hatte, und komme trotzdem auf einen stabileren 
Wert.

Dazu hätte ich noch ein paar kurze Fragen:
1. Macht es theoretisch einen Unterschied, ob ich den Filter vor oder 
nach dem Mess-Shunt einbaue? Beim Einbau vor dem Shunt, würde demnach 
der RC-Widerstand mehr Leistung verbraten (4-20mA Messsignal, also 
maximal 2Watt bei 5kOhn), was unnötig ist, richtig?

2. Die Berechnung der Grenzfrequenz ist mir grundsätzlich klar, aber 
welche Frequenz sollte man bei einem Gleichstromsignal wählen? In meinem 
Fall ergibt das 3Hz. Wovon ist die Wahl der Frequenz in meinem Fall 
abhängig?

3. Bei der Recherche bin ich auch darauf gestoßen, dass die errechnete 
Zeitkonstante des RC-Filters Einfluss auf die Abtastrate des ADCs hat - 
letztere müsse mindestens doppelt so schnell sein.. ist das bei einem 
Gleichstromsignal auch relevant? Kann mir die Geschichte nochmal jemand 
genauer erläutern?

: Bearbeitet durch User
von Rainer W. (rawi)


Lesenswert?

Christian schrieb:
> Macht es theoretisch einen Unterschied, ob ich den Filter vor oder nach
> dem Mess-Shunt einbaue?

Dein Shunt soll den Strom von deinem Sensor mit einem Faktor 150V/A in 
eine Spannung umwandeln. Was passiert wohl mit deinem Filter, wenn du es 
mit 150 Ohm belastet. Oder wie ändert sich der Umsetzungsfaktor, wenn du 
an der Stelle einen Widerstand von insgesamt 5150 Ohm einbaust.
Nimm dir einen Schaltungssimulator (z.B. LTSpice) und dann kannst du dir 
deine Frage selbst beantworten.

> In meinem Fall ergibt das 3Hz. Wovon ist die Wahl der Frequenz in meinem
> Fall abhängig?

Du möchtest Störungen mit einem bestimmten Frequenzgemisch 
herausfiltern. Also muss das Filter diese Frequenzen ausreichend gut 
abschwächen. Was "ausreichend gut" ist, legst du fest. Auch bringt es 
nichts, wenn der ADC den Unterschied nicht auflösen kann.

Christian schrieb:
> letztere müsse mindestens doppelt so schnell sein.

Das gilt nur für Rechteckfilter, die es praktisch nicht gibt. Bei einem 
Tiefpass 1.Ordnung muss der Abstand zwischen Abtastfrequenz und 
Filtergrenzfrequenz wesentlich größer sein, wenn das Signal dort 
spektrale Anteile enthält.

> .... ist das bei einem
> Gleichstromsignal auch relevant?

Bei einem reinen Gleichspannungssignal hast du keine Signalanteile mit 
von 0 verschiedener Frequenz. Das Abtasttheorem bezieht sich auf das 
Verhältnis von Abtast- zu (höchster) Signalfrequenz, wenn du Aliasing 
vermeiden willst.

Christian schrieb:
> beide_Varianten.jpg

Welche Zeitskala besitzt dieses Bild (hh:mm, mm:ss oder was sonst)?
Sind die rechts sichtbaren Störungen die echten Signale oder sind die 
Signale durch Aliasing transformiert? Welche Frequenz haben die 
Störungen?

: Bearbeitet durch User
von Ralf D. (doeblitz)


Angehängte Dateien:

Lesenswert?

Christian schrieb:
> ich habe den Sensor mal direkt mit den Krokoklemmen angeschlossen,
> jedoch über den Shunt, den ich im Kabel eingebaut habe.

Hüstel. Man nimmt Sensoren mit 4..20mA-Schnittstelle eigentlich, damit 
man störungsarm den Strom über lange Strecken übertragen kann. Und in 
der Auswertelektronik bringt man dann den Messwiderstand an, nicht im 
Kabel und schon gar nicht am Sensor.

von Christian (christian88)


Angehängte Dateien:

Lesenswert?

Rainer W. schrieb:
> Welche Zeitskala besitzt dieses Bild (hh:mm, mm:ss oder was sonst)?
> Sind die rechts sichtbaren Störungen die echten Signale oder sind die
> Signale durch Aliasing transformiert? Welche Frequenz haben die
> Störungen?

das Bild ist mit der Zeitskala hh:mm
ich habe hier noch eine Aufzeichnung mit (links) und ohne Filter 
(rechts)
Die deutliche Besserung ist wohl ganz klar zu erkennen..

Bei einem Gleichspannungssignal ist also sowohl die Grenzfrequenz 
unerheblich (solange die störenden Anteile herausgefiltert werden) als 
auch die Zeitkonstante bzw. die Abtastrate vom µC?

Auch wenn es nicht notwendig ist und nur damit ich es richtig verstehe, 
ohne zu tief in die Materie eintauchen zu müssen: Hat es einen Nachteil, 
wenn ich die Grenzfrequenz noch weiter runter setzen würde (zB 1Hz oder 
im milli-Hz Bereich), außer dass ich Bauteile mit entsprechend größeren 
Werten verbauen muss..
Wird ein Gleichspannungsignal irgendwann durch einen zu großen R 
gedämpft?

von Christian (christian88)


Lesenswert?

Ralf D. schrieb:
> Hüstel. Man nimmt Sensoren mit 4..20mA-Schnittstelle eigentlich, damit
> man störungsarm den Strom über lange Strecken übertragen kann. Und in
> der Auswertelektronik bringt man dann den Messwiderstand an, nicht im
> Kabel und schon gar nicht am Sensor.

das habe ich inzwischen alles behoben, war am Anfang nur das 
Provisorium. Jetzt ist alles auf Lochrasterplatine und den Mess-shunt 
eine Lochreihe neben dem ADC-Pin ;-)

von Rainer W. (rawi)


Lesenswert?

Christian schrieb:
> Die deutliche Besserung ist wohl ganz klar zu erkennen..

Damit ist immer noch unklar, welche Frequenz dein Störsignal besitzt und 
ob die im ersten Bild sichtbaren Signale ein Aliasing Artefakt sind.

Christian schrieb:
> Bei einem Gleichspannungssignal ist also sowohl die Grenzfrequenz
> unerheblich (solange die störenden Anteile herausgefiltert werden) als
> auch die Zeitkonstante

Zeitkonstante und Grenzfrequenz sind fest miteinander verbunden. Sie 
beschreiben die gleiche  Eigenschaft - einmal im Zeitbereich und einmal 
im Frequenzbereich.

: Bearbeitet durch User
Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.