Forum: Platinen KiCAD Netzklassenzuweisung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Matthias B. (Firma: BAT) (matbit)


Angehängte Dateien:

Lesenswert?

Hallo

weiss jemand, warum die Verbindungslinien im Schaltplaneditor von KiCAD 
7.02 die Eigenschaften der Leiterbahnen im Platineneditor annehmen? Das 
Ganze wird sehr unübersichtlich und ist auch vollkommen unsinnig. Gibt 
es eine Schalter, mit dem man die Übernahme der Leiterbahnbreite in den 
Schaltplaneditor verhindern kann?

VG

von Andreas B. (bitverdreher)


Lesenswert?

Ich frage mich eher wie man so etwas hinbekommt. Das habe ich noch nie 
gesehen.

von Matthias B. (Firma: BAT) (matbit)


Lesenswert?

Wenn man im Schaltplaneditor mit Rechtsklick auf eine Verbindungslinie 
die Eigenschaften öffnet kann man eine Netzklassenzuweisung erreichen. 
Bei mir war's aber wohl so, daß eine Netzzuweisung im 
Leiterplatteneditor auch auf die Schaltplaneigenschaften durchgegriffen 
hat. Ich verstehe den Zusammenhang nicht recht, auch warum im 
Schaltplaneditor die elektr. Verbindingslinien unterschiedliche Stärken 
haben sollten.

von Andreas B. (bitverdreher)


Lesenswert?

Netzklassen habe ich immer im Platineneditor eingestellt, nie im 
Schaltplaneditor.

von Matthias B. (Firma: BAT) (matbit)


Lesenswert?

Ob man die Netzklassen im Schaltplan-, oder im Leiterplatteneditor 
definiert ist sicher unerheblich. Wenn das so wäre, könnten ja im 
Schaltplan andere Klassen existieren als auf der Leiterplatte. In den 
KiCad Docs
https://docs.kicad.org/7.0/en/eeschema/eeschema.html#schematic-netclasses
wird es explizit so beschrieben.

ES kann also daran wird es nicht liegen.

von Andreas B. (bitverdreher)


Lesenswert?

Matthias B. schrieb:
> Ob man die Netzklassen im Schaltplan-, oder im Leiterplatteneditor
> definiert ist sicher unerheblich.

Im Prinzip ja. Da ich das aber immer im Leiterplatteneditor mache und 
den Effekt des TO nie gesehen habee, kann es also durchaus sein, daß da 
gerade im Schaltplaneditor ein Bug ist.

von M.A. S. (mse2)


Lesenswert?

Ich würde eher sagen, der TO hat die Linienbreiten der Netzklasse im 
Schaltplaneditor eingestellt und nicht (wie vermutlich gedacht) die 
Track-Breiten für den PCB-Editor.
Hab's gerade ausprobiert, geht wie vom TO beschrieben.  ;)

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.