Forum: Analoge Elektronik und Schaltungstechnik Saunaregler Hysterese


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von David D. (der-seemann)


Angehängte Dateien:

Lesenswert?

Moin!
Ich habe eine Sauna mit einer etwas älteren Steuerung.
Die Hysterese der Temperatursteuerung ist gleich null, d.h. wenn die 
eingestellte Temperatur erreicht ist, rattern die Relais los und 
schalten den Ofen laufend ein und aus (viele male / Sekunde).
Kennt jemand die Steuerung oder erkennt zumindest auf die schnelle was 
da los ist?
Rechts an der roten Klemme kommt ein Sicherheitstemperaturbegrenzer (sw) 
und ein Temperaturfühler (rot) an. Die Solltemperatur wird über ein Poti 
eingestellt (die drei dünnen Kabel daneben).
K1 und K2 sind je 3-Phasen Relais die in Serie den Ofen einschalten.

von Mani W. (e-doc)


Lesenswert?

Ja, ein Fall von Elko und Betriebsspannung...

Elko zur Siebung vertrocknet - Ripple - Relaisschnattern

: Bearbeitet durch User
von Irgend W. (Firma: egal) (irgendwer)


Lesenswert?

Mani W. schrieb:
> Elko zur Siebung vertrocknet - Ripple - Relaisschnattern

Das würde aber bereits beim Einschalten auftreten und nicht erst nach 
erreichen der Soll-Temperatur. Wobei der untere Elko so bei "2 Uhr" 
irgendwie etwas merkwürdig "eingedrückt" aussieht, erkennt man so direkt 
von ober aber nur sehr schlecht.

Bei so einer simplen Gleichrichter und OPV-Schaltung sollte man, mit 
etwas Messen mit einem DMM, schon recht weit kommen...

von Mani W. (e-doc)


Lesenswert?

Irgend W. schrieb:
> Das würde aber bereits beim Einschalten auftreten und nicht erst nach
> erreichen der Soll-Temperatur.

Es wirkt sich erst aus, wenn der Betriebsstrom steigt, weil
ein Relais anzieht...

Durch Ripple ist auch die Referenz gestört, der 324 macht dann
halt mal dies, mal das...

von David D. (der-seemann)


Lesenswert?

Vielen Dank für die bisherigen Beiträge!
Das Relais rattert nur genau bei der Solltemperatur. Wenn ich dann die 
Solltemperatur nach oben oder unten ändere ist wieder Ruhe.

Ich werde morgen mal versuchen mit einem Multimeter etwas herum zu 
messen und ggf die beiden Elkos tauschen.


Das Poti oben links ist vermutlich zur Kalibrierung des 
Temperaturfühlers?

: Bearbeitet durch User
von Mani W. (e-doc)


Lesenswert?

David D. schrieb:
> Das Relais rattert nur genau bei der Solltemperatur. Wenn ich dann die
> Solltemperatur nach oben oder unten ändere ist wieder Ruhe.

Möglich auch eine Oxidschicht am Regler, mal einige -zig Mal
hin/her drehen ohne Spannung...

von Bruno V. (bruno_v)


Lesenswert?

David D. schrieb:
> Das Relais rattert nur genau bei der Solltemperatur. Wenn ich dann die
> Solltemperatur nach oben oder unten ändere ist wieder Ruhe.

Darüber oder darunter ist es doch "satt" an oder aus.

Rattern entsteht, wenn beim abschalten die gemessene Temperatur fällt 
und beim einschalten steigt. Z.B. weil der Relaisstrom die 
Versorgungsspannung/Spannungsreferenz beeinflusst.

Oder wenn ein ripple die Referenz 10° rauf und runter schwingen lässt.

Unterscheiden kannst Du beides eventuell dadurch, ob es langsam anfängt 
zu rattern  oder sofort voll loslegt

von David D. (der-seemann)


Lesenswert?

Der große 470 / 40 dürfte ja den Gleichstrom glätten nach dem 
Brückengleichrichter. Könnte ich den ggf auch durch einen größeren 
(natürlich mit min. 24V) ersetzen?

von Εrnst B. (ernst)


Lesenswert?

David D. schrieb:
> Der große 470 / 40 dürfte ja den Gleichstrom glätten nach dem
> Brückengleichrichter. Könnte ich den ggf auch durch einen größeren
> (natürlich mit min. 24V) ersetzen?

Ja, aber nicht übertreiben. Und kontrollier auch mal die Zener-Diode 
"zwischen" den beiden Elkos, die vmtl. zusammen mit R1 die 
Betriebsspannung stabilisieren soll.

von Mani W. (e-doc)


Lesenswert?

Εrnst B. schrieb:
> Ja, aber nicht übertreiben.

Er kann ohne weiteres 1000 - 2200 µF einsetzen...

von H. H. (Gast)


Lesenswert?

Die roten Roedersteiner Plastikelkos sind berühmt berüchtigt. Nach fast 
40 Jahren am besten gleich alle ersetzen.

von Mani W. (e-doc)


Lesenswert?

David D. schrieb:
> Der große 470 / 40 dürfte ja den Gleichstrom glätten nach dem
> Brückengleichrichter. Könnte ich den ggf auch durch einen größeren
> (natürlich mit min. 24V) ersetzen?


Aufpassen!

Wenn die Relais für 24 VDC Spulenspannung ausgelegt sind, dann
muss der für 35/40 V sein

von David D. (der-seemann)


Lesenswert?

Ich habe die beiden Elkos gegen (gebrauchte, vermutlich funktionierende) 
50v getauscht. Hat leider nichts gebracht. Ich werde bei der nächsten 
Gelegenheit mal noch die Diode messen, vermutlich muss die aber dafür 
raus?

von Andrew T. (marsufant)


Lesenswert?

Nachdem das schlichte Tauschen der Elkos nicht zum Ziel führt:

Es wird Zeit, die Platine mal genau anzuschauen und die Schaltung 
rauszuzeichnen.

Alles andere ist blindes stochern im Nebel.

von Mani W. (e-doc)


Lesenswert?

Ein Foto von der Lötseite wäre vielleicht hilfreich...

Ein Oszi natürlich auch...

: Bearbeitet durch User
von Mani W. (e-doc)


Lesenswert?

Auch möglich: das Poti ist an der Stelle abgewetzt (auch in Audio)
              und dadurch gibt es keine klaren Fronten mehr...

von David D. (der-seemann)


Lesenswert?

Ich werde die Schaltung in den nächsten Wochen smartifizieren. Also im 
westlichen durch einem ESP ersetzen, dann sehr ich auch von vom Haus aus 
wenn draußen die Sauna auf Temperatur ist. Der 
Sicherheitstemperaturbegrenzer und der analoge Timer bleiben, die 
Temperaturregelung wird digitalisiert...

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.