Forum: Platinen Fehlströme/Kurzschluss erkennen/ausfindig machen mit Multimeter


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Andreas N. (hpoperator866)



Lesenswert?

Hallo liebe Community,

ich bin (leider) kein Fachmann in Sachen Elektrotechnik.

Kurz zur Beschreibung der Ist-Situation, um mein Anliegen zu 
konkretisieren:

Ich habe Zuhause einen 3D-Drucker an welchem ein Raspberry Pi verbunden 
ist. Es gab an irgendeiner Stelle der Verkabelung wohl eine 
Spannungsspitze (oder er bekam von einem Modul Strom, von wo und an 
welchem Anschluss er keinen Strom bekommen dürfte).
Und seither verweigert er seinen Dienst. auf der Platine ist deutlich 
ein durchgekokelter SMD zu erkennen, am Übergang zum 
USB-/Ethernetcontroller.
An einem USB-Port des Raspberry befindet sich Ausschließlich nur ein 
zwei-adriges Datenkabel (Data + und Data -) welches zu einem kleineren 
Mainboard (EBB36) geht und an welchem 24V + und Ground angeschlossen 
wurde und am anderen USB-Port eine normale USB-Verbindung zum Mainboard 
des 3D-Druckers.   Erwähnenswert ist es wohl auch, dass sich an den 
GPIO-PINS des Raspberry ein TemperaturSensor befindet (DS18B20, welcher 
mit den GPIO-Pins 3V3 / GPIO4 und Grpond verbunden ist.

So, verzeiht die lange "Rede"....
doch ich würde nun gern mit meinem einfachen Multimeter überprüfen 
wollen, ob der RaspberryPi evtl. auf der Datenleitung fälschlicherweise 
Strom bekommt / bekommen hat, oder ob der vermeindliche "Kurzschluss" 
vielleicht durch den TemperaturSensor verursacht wurde.

Wie mache ich dass denn genau?
Wie stelle ich denn den Multimeter ein und welche Leitungen greife ich 
mit den Prüfkabeln ab?

Denn ich möchte vermeiden, dass sich die gleiche Situation mit einem 
neuen RaspberryPi wiederholt.

Ich wäre euch wirklich sehr dankbar wenn ihr mir weiterhelfen könntet. 
(Beigefügt Fotos die noch besser die Ist Situation aufzeigen (die GPIOs 
des TemperaturSensors habe ich leider schon abgeklemmt))

LG

von Cyblord -. (cyblord)


Lesenswert?

Andreas N. schrieb:
> Wie mache ich dass denn genau?

Führe folgende Schritte aus:

1.) Nehme den PI in die Hand.
2.) Deckel der Mülltonne auf
3.) PI in die Tonne
4.) Deckel zu.

Mal im Ernst, das Ding ist schrott und DU kannst das nicht mit einem 
Multimeter ändern.


> Denn ich möchte vermeiden, dass sich die gleiche Situation mit einem
> neuen RaspberryPi wiederholt.

Noobige Grobmotoriker und offene Platinen sind einfach keine gute 
Mischung.
Lerne was das eigentlich ist und wie es funktioniert und lerne 
sorgfältig zu arbeiten.

: Bearbeitet durch User
von Keks F. (keksliebhaber)


Lesenswert?

Andreas N. schrieb:
> An einem USB-Port des Raspberry befindet sich Ausschließlich nur ein
> zwei-adriges Datenkabel (Data + und Data -) welches zu einem kleineren
> Mainboard (EBB36) geht

Das geht doch so nicht.
Da muss mindestens der Potenzialausgleich angeschlossen werden, sonst 
kommt es zu dem wohl eingetretenen Problem.
Wer hat dir das so empfohlen?

Je nach Druckerboard gibt es auch das Problem, dass dessen USB-Anschluss 
nicht mit einer Diode gesichert worden ist, heißt, es fließt gerne mal 
von USB 5V des PIs Strom in das Mainboard rein was auch zu Problemen 
führen kann.

: Bearbeitet durch User
von Andreas N. (hpoperator866)


Lesenswert?

Cyblord -. schrieb:
> Mal im Ernst, das Ding ist schrott und DU kannst das nicht mit einem
> Multimeter ändern.
Verstehe den Kontext nicht, ich möchte den Raspi ganz bestimmt nicht mit 
meinem Multimeter wieder zum Leben erwecken.

> Noobige Grobmotoriker und offene Platinen sind einfach keine gute
> Mischung.

Auch verstehe ich nicht, warum die Formulierung deiner Antwort so 
grobschlächtig sein muss, ist dies der gepflegte Umgangston hier in 
diesem Forum?

Ohne forsch wirken zu wollen, aber ich frage freundlich um Hilfestellung 
und bitte weder darum in irgendeiner Art und Weise denunziert zu werden, 
oder jemanden (--> Dich) darum in meinen Thread den Frust seines wohl 
sehr strapaziösen Arbeitstages abzuladen.

> Lerne was das eigentlich ist und wie es funktioniert und lerne
> sorgfältig zu arbeiten.
und du bitte ordentlich mit Usern zu kommunizieren. Ist doch nicht mehr 
schön was hier abgeladen wird.
Ich bin in mehreren Foren aktiv und passiv unterwegs, doch werden dort 
Etiketten befolgt und es wird versucht zu helfen/Hilfe zu geben.
Ich arbeite nicht mit Starkstrom, bei der man es noch annähernd 
verstehen würde wenn man jemanden mahnend auf Sachverhalte hinweißt.

: Bearbeitet durch User
von Jack V. (jackv)


Lesenswert?

Andreas N. schrieb:
> Auch verstehe ich nicht, warum die Formulierung deiner Antwort so
> grobschlächtig sein muss, ist dies der gepflegte Umgangston hier in
> diesem Forum?

Bei dem betreffenden User ist das leider Standard, ja. Ist eine Art 
Forentourette, oder so.

von Andreas N. (hpoperator866)



Lesenswert?

Keks F. schrieb:
> Das geht doch so nicht.
> Da muss mindestens der Potenzialausgleich angeschlossen werden, sonst
> kommt es zu dem wohl eingetretenen Problem.
> Wer hat dir das so empfohlen?
Danke dir vielmals für deine zeitnahe Antwort:
beigefügt eine Skizze welche diesbezüglich im Discord-Server geteilt 
wurde, auch gehen einige Threads aus anderen Foren auf diese Verkabelung 
ein:
https://forum.drucktipps3d.de/forum/thread/19812-verst%C3%A4ndnisfrage-zum-bigtreetech-btt-ebb36-canbus-v1-2/

https://www.reddit.com/r/klippers/comments/yl491x/ebb36_via_usb/

ich möchte nicht ausschließen das ich etwas falsch verstanden habe.

> Je nach Druckerboard gibt es auch das Problem, dass dessen USB-Anschluss
> nicht mit einer Diode gesichert worden ist, heißt, es fließt gerne mal
> von USB 5V des PIs Strom in das Mainboard rein was auch zu Problemen
> führen kann.
Ok, verstehe. Dieser Sachverhalt war mir auch bisher nicht bekannt. 
Lässt sich solch eine "Diode" recht einfach dazwischen schalten?

LG

von Andreas N. (hpoperator866)


Lesenswert?

Jack V. schrieb:
> Andreas N. schrieb:
>> Auch verstehe ich nicht, warum die Formulierung deiner Antwort so
>> grobschlächtig sein muss, ist dies der gepflegte Umgangston hier in
>> diesem Forum?
>
> Bei dem betreffenden User ist das leider Standard, ja. Ist eine Art
> Forentourette, oder so.
Dann soll er sich doch mal behandeln lassen. Ist ja furchtbar.

: Bearbeitet durch User
von Cyblord -. (cyblord)


Lesenswert?

Jack V. schrieb:
> Andreas N. schrieb:
>> Auch verstehe ich nicht, warum die Formulierung deiner Antwort so
>> grobschlächtig sein muss, ist dies der gepflegte Umgangston hier in
>> diesem Forum?
>
> Bei dem betreffenden User ist das leider Standard, ja. Ist eine Art
> Forentourette, oder so.

Ich warte noch auf deine hilfreiche Antwort wo er die Messspitzen setzen 
soll um die Ursache zu finden.

von Keks F. (keksliebhaber)


Lesenswert?

Andreas N. schrieb:
> ich möchte nicht ausschließen das ich etwas falsch verstanden habe.

Weder die Skizze, noch die beiden Links geben den von dir durchgeführten 
Aufbau her. In jedem Falle wird der Anschluss über USB beschrieben, und 
zwar nicht so, wie du ihn gemacht hast. Das ist elektrisch falsch, somit 
findet ein Potenzialausgleich ("Wo sind 0V?") über andere Leitungen 
statt als ein GND Kurzschluss zwischen den Geräten/USB-ICs direkt.

Die Skizze schließt GND mit -24V kurz. Damit hätte die 24V Leitung zu 
GND 48V, das 5V Netzteil würde 29V liefern. Naja, eigentlich geht dann 
alles Puff.

Andreas N. schrieb:
> Ok, verstehe. Dieser Sachverhalt war mir auch bisher nicht bekannt.
> Lässt sich solch eine "Diode" recht einfach dazwischen schalten?

Da musst du nachgucken ob dein Mainboard betroffen ist. Das Problem wird 
"Backpowering" genannt. Idealerweise lötet man eine (ideale) Diode ein, 
viele trennen die Leiterbahn einfach nur durch bzw. das betreffende 
Kabel.

Auf dem Bild ist keine verkokelte Komponente.

Was heißt denn überhaupt "verweigert er seinen Dienst"?

Ich würde erstmal genau und unabhängig voneinander gucken was und wie 
kaputt ist.

Angefangen davon wie es wohl zum Defekt gekommen ist.

Ich habe da im Makerspace schon einige Kurzschlüsse gesehen. 
Verkabelungen sind oft falsch, mangelhaft ausgeführt, oder nicht richtig 
isoliert.

: Bearbeitet durch User
von Jack V. (jackv)


Lesenswert?

Cyblord -. schrieb:
> Ich warte noch auf deine hilfreiche Antwort wo er die Messspitzen setzen
> soll um die Ursache zu finden.

Wie kommst du auf die seltsame Idee, dass ich dir was schuldig wäre, 
dass du darauf wartest?

von Jörg R. (solar77)


Angehängte Dateien:

Lesenswert?

@TO
Unabhängig von Deinem Problem finde ich dass die Platine nicht gut 
verarbeitet ist. Das Foto lässt sich nicht gut vergrößern, aber für mich 
sieht es doch nach einigen Lötzinnspritzern/Brücken aus. Das solltest Du 
mal genauer untersuchen.

https://www.mikrocontroller.net/attachment/614279/IMG_1714.jpg

: Bearbeitet durch User
von Achim H. (pluto25)


Lesenswert?

Das ist wohl die erste brauchbare Antwort. Dann hätte er sich selbst 
zerschossen.
Das mit dem Potentialausgleich ist falsch, der ist durch den Gnd 
gegeben.
Das mit der Diode auch falsch, da die 5v Seite vom USB nicht 
angeschlossen ist kann dort kein Strom fließen.
Das Multimeter an Gnd und Messen ob nicht irgendwo mehr als 5V am Pi 
anliegen. Ein Fehler im Ebb oder Octopus könnten hohe Spannungen in den 
Usb Anschlüssen bringen die den Pi töten.
Das selbe kann passieren wenn eine Gnd Leitung keine gute Verbindung 
hat.
An keinem der Gnd Anschlüsse darf Spannung angezeigt werden. Auch 
kontrollieren ob vielleicht eine Leiterbahn auf der Lötseite einen Riss 
hat.
Der DS kann keinen Schaden anrichten (solange seine Leitung nicht 
verletzt wird) an seinen Anschlüssen müssten 0V gemessen werden.

PS Auch wenn das nicht empfohlen wird (Brummschleife, Querströme) würde 
ich die Gnd Leitungen der Usb Anschlüsse mit verbinden.

: Bearbeitet durch User
von Keks F. (keksliebhaber)


Lesenswert?

Achim H. schrieb:
> Das mit der Diode auch falsch, da die 5v Seite vom USB nicht
> angeschlossen ist kann dort kein Strom fließen.

Das Mainboard wird hier nicht gezeigt.

: Bearbeitet durch User
von ●DesIntegrator ●. (Firma: FULL PALATINSK) (desinfector) Benutzerseite


Lesenswert?

Andreas N. schrieb:
> auf der Platine ist deutlich ein durchgekokelter SMD zu erkennen

Da es ja sicherlich nicht ausbleibt, einen weiteren Raspi zu besorgen,
könntest du bei einem baugleichen schauen,
ob das verkokelte Bauteil ein brauner oder schwarzer Microziegel ist.
es gibts natürlich auch Bilder im Web,
mit denen man das vergleichen kann. Gleich beim bösen Jeff z.B.

https://m.media-amazon.com/images/I/81ts67SCO2L._AC_SL1500_.jpg

Mit der Bestellung eines Raspi besorgst du dann das entspr. Bauteil.
was kann das sein? 10nF oder 100nF. Baugrösse? selbst ermitteln.
Aber auch grössere kriegt man da rein.

Mit vorausgesetzten Lötfähigkeiten lässst sich sowas tauschen
und wenns halt nicht nur an diesem Teil lag
(hat evtl was anderes mit zerlegt) sammelt man eben Erfahrungen.

Und wenns wider Erwarten danach läuft, Glückwunsch zum 2. Raspi.
Mehr bevor man wegwirft kann man wohl nicht tun.

ich finde so eben zwischendurch auch nur ein "reduced schematic"

https://datasheets.raspberrypi.com/rpi3/raspberry-pi-3-b-plus-reduced-schematics.pdf

: Bearbeitet durch User
von Sebastian W. (wangnick)


Lesenswert?

20231106_190503.jpg sieht ja dubios aus. Was ist das für ein 
USB-Adapter, an den so dicke Kabel angeschlossen werden?

Mit einem Multimeter wirst du Spannungsspitzen, die zum Beispiel das 
EBB36-Bord auf der USB-Verbindung zum Pi eventuell erzeugt, nicht messen 
können.

Wenn der Schaltplan des EBB36 vorläge, dann könnte man zumindest den 
Umgang des Bords gegen die Energie der angeschlossenen 
Induktivitäten/Motoren prüfen.

Von dem EBB36 gibt es ja wohl zwei Versionen?

LG, Sebastian

: Bearbeitet durch User
Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.