Forum: PC Hard- und Software Linux erkennt SATA DVD Laufwerk nicht im AHCI Modus


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Steve van de Grens (roehrmond)



Lesenswert?

Es geht um einen neuen Desktop PC von HP, Modell S01-pf3104ng, frisch 
installiert.

Unter Windows wird das DVD Laufwerk erkannt, unter Linux Debian 12 
nicht. Eine SATA Festplatte funktioniert hingegen tadellos. Anbei 
log-Auszüge mit und ohne Festplatte.

Durch Versuche habe ich herausgefunden, dass Linux das DVD Laufwerk 
erkennt, wenn ich den SATA Modus im BIOS von AHCI auf RAID umstelle. 
Aber dann bootet Windows 11 nicht mehr. Ich habe eine Anleitung 
gefunden, wie man Windows auf diese Umstellung vorbereitet, scheitere 
aber an der Installation des Intel Raid Treibers mit der Fehlermeldung, 
dass meine Hardware dazu inkompatibel sei.

Da Ubuntu oft neuere Treiber enthält, habe ich auch Ubuntu 13.10 
versucht, macht aber keinen Unterschied.

Was ich dazu fragen wollte: Kennt jemand das Problem zufällig und weiß 
eine Lösung?

Wenn nicht: Ich habe nicht vor, da allzu viel Mühe rein zu stecken, denn 
ich brauche den DVD Brenner in absehbarer Zeit nicht. Notfalls kann ich 
mein externes Laufwerk (über USB) benutzen, oder das interne 
austauschen.

: Bearbeitet durch User
von Norbert (der_norbert)


Lesenswert?

Steve van de Grens schrieb:
> habe ich auch Ubuntu 13.10
> versucht,

Du solltest eine Linux Version nicht nur aus dem letzten Jahrzehnt 
sondern vielleicht aus dem letzten Jahrhundert verwenden.

von Frank K. (fchk)


Lesenswert?

Vorschlag:
https://www.amazon.de/dp/B09HXFFBR7/
Reinstecken (Du solltest einen Steckplatz dafür haben) und nur das 
DWD-Laufwerk daran anschließen.

Der Rechner und der Chipsatz sind sehr neu. Entweder kennt Linux die 
Macken des Chipsatzes noch nicht, oder die ACPI-Tabellen im BIOS haben 
Fehler und funktionieren nur unter Windows, aber nicht unter Linux (kann 
vorkommen). Die extra Karte sollte sowohl unter Windows als auch unter 
Linux erkannt werden und dann einfach so funktionieren.

fchk

von Keks F. (keksliebhaber)


Lesenswert?

Norbert schrieb:
> Du solltest eine Linux Version nicht nur aus dem letzten Jahrzehnt
> sondern vielleicht aus dem letzten Jahrhundert verwenden.

Wahrscheinlich ein Tippfehler.

von Steve van de Grens (roehrmond)


Lesenswert?

Norbert schrieb:
> Du solltest eine Linux Version nicht nur aus dem letzten Jahrzehnt
> sondern vielleicht aus dem letzten Jahrhundert verwenden.

Sorry, ich meinte natürlich die Version 23.10

von Tobo M. (chipi)


Lesenswert?

Frag doch mal bei ubuntuusers.de nach

von Steve van de Grens (roehrmond)


Lesenswert?

Frank K. schrieb:
> Vorschlag

Danke, das ist eine praktikable Alternative zum Austausch des Laufwerks.

von Markus W. (dl8mby)


Lesenswert?

Möglicherweise erkennt der Kernel nicht Dein DVD,
weil er selbst keinen Treiber dafür fest einkompiliert
hat und in seiner initrd RAM-Disk, die weitere Treiber
enthält, dieser ebenfalls nicht enthalten ist.

Diesen Treiber musst Du in die initrd reinbekommen und
natürlich vorher finden oder gleich in den Kernel rein-
kompilieren.

Dazu musst Du dir durchlesen, wie der Kernel kompiliert
wird und wie die initrd gebaut wird.

Stichworte make menuconfig, make modules make modules_install,
make ...

Siehe auch:

https://phoenixnap.com/kb/build-linux-kernel

Ist nicht trivial, aber so ist es bei Linux, sofern nicht
alles sofort funktioniert.

Vielleicht hat jemand noch eine besseren Tipp.

Viel Erfolg

Markus

von Norbert (der_norbert)


Lesenswert?

Steve van de Grens schrieb:
> unter Linux Debian 12 nicht

Debian Release ist eher konservativ, stabil und gut abgehangen. Wenn's 
brandneue Hardware ist, eventuell mal sid/experimental mit neuem Kernel 
testen.
lspci könnte evtl. noch Aufschluss geben.
lsmod zeigt die geladenen Module, möglicherweise gibt's passende 
Parameter um ein bestimmtes Verhalten zu erzwingen.

von Eric I. (i716)


Lesenswert?

Versuche mal UAS zu deaktivieren.
Erstelle eine Datei /etc/modprobe.d/usb-storage.conf und fuege dann 
folgendes ein: options usb-storage quirks=vid:pid:u

vid und pid findest Du durch lsusb.

Danach Kernel-Module neu laden oder gleich neues initramfs: 
update-initramfs -u

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.