Forum: PC Hard- und Software Linux-Mint schaltet den PC nicht aus


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Erni (pudding)


Lesenswert?

Hallo, ich brauche Hilfe bei einer Linux-Mint Installation.
Nachdem mein Notebook schon seit langer Zeit mit Linux-Mint läuft, habe 
ich heute auch meinen Desktop-PC mit der neuen Version von Mint 
bespielt. Dazu auch eine neue SSD eingebaut. Installation ohne Probleme 
und schon die meisten meiner Anwendungsprogramme eingerichtet. Nun 
wollte ich Feierabend machen und habe, wie vom Notebook gewohnt, 
"Herunterfahren" gewählt. Der Monitor wird zwar schwarz, jedoch bleibt 
der Einschaltknopf am PC beleuchtet und auch der CPU-Lüfter läuft 
weiter. Nach längerer Wartezeit habe ich dann durch langes drücken des 
Einschalttasters den PC abgeschaltet. Beim zweiten Versuch habe ich 
statt "Herunterfahren" "Bereitschaft" gewählt. Der PC verhält sich 
gleich, Power-LED an, Lüfter an. Langer Tastendruck auf den Einschalter 
schaltet den PC aus, aber beim Wiedereinschalten bleibt der PC im 
Ruhezustand, d.h., der Bildschirm bekommt kein Signal (LED blinkt). Erst 
nachdem der PC kurzzeitig vom Stromnetz getrennt wurde, konnte wieder 
normal eingeschaltet werden.
Es gibt viele Hinweise zu diesem Problem im Netz, die UEFI Einstellungen 
kann ich über das BIOS-Setup nicht ändern, aber ich habe mal den 
Hinweis, den Splash aus Grub zu entfernen durchgeführt:
sudo nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" zu =""
Dies war zwar nicht die Lösung, aber es wird jetzt beim Abschalten diese 
eine Zeile auf dem Monitor ausgegeben:
[FAILURE] Failed to start casper-md5check verify live ISO checksums.
Daraufhin habe ich mit
sudo systemctl disable casper-md5check.service
die Prüfung abgeschaltet, aber nach einem "shutdown -h now" schaltet der 
PC weiterhin nicht ab, auf dem Monitor steht jetzt nur die Zeile
"reboot: Power down"
Es widerstrebt mir zwar, aber ist es ok, den Rechner hart über die 
Steckdosenleiste auszuschalten, wenn Linux es nicht schafft ihn 
herunterzufahren?

Gruß
Erni

von Uli S. (uli12us)


Lesenswert?

Ich kann dir zwar leider nicht helfen, habe jedoch den Eindruck, dass 
mit jeder neueren Version von Mint, lediglich die eingebauten Fehler 
anwachsen.
Vielleicht solltest du versuchen, nicht die allerneueste sondern 
vielleicht 1 oder 2 Stufen zurück nochmal zu installieren.

von Hadmut F. (hadmut)


Lesenswert?

Uli S. schrieb:
> Ich kann dir zwar leider nicht helfen, habe jedoch den Eindruck, dass
> mit jeder neueren Version von Mint, lediglich die eingebauten Fehler
> anwachsen.

Auch mein eindruck. Pip beizubringen pakete für die aktuelle python 
version zu installieren geht nur mit doppelsalto aus dem handstand.

KA woher das kommt, aber man hat versichert es kommt nicht vom "code of 
conduct" und schon gar nicht von den "diversity hires".

Angeleiert hat das der Gates vom konkurrenzprodukt microsoft. Hat dem 
linux dev team faule eier untergeschoben, den linus thorwalds gekickt, 
und damit linux den inkompetenten geschenkt. Die haben unter anderem den 
braile-code mitinstalliert der sämtliche ch340 usb-adapter 
stillschweigend löscht.

Ja, die hälfte der arduino und esp32 boards funktionieren mit mint nicht 
mehr weil man gemäss "code of conduct" auch den minderwertigsten code 
miteinbeziehen muss. Ein "sudo apt-get remove brltty" hilft.

Das nennt sich kompetenzkrise und ist überall im westen zu sehen.

: Bearbeitet durch User
von Erni (pudding)


Lesenswert?

Danke für die Antworten.
Ja, bei meiner Internetsuche habe ich solche Probleme von seit 2009 bis 
jetzt gefunden und auch kaum Hoffnung es selber zu lösen. Wichtig wäre 
für mich, ob das Ausschalten der PC-Stromversorgung schädlich sein kann, 
z.B. für die SSD. Immerhin hat Linux bis dahin schon "Power down" 
gemeldet, so dass doch alles im sicheren Bereich sein sollte?

von Hadmut F. (hadmut)


Lesenswert?

Bei mir geht das übrigens. Auschalten mit knopf.
Das ist eine einstellung an einem unrewarteten ort wo man das 
keinesfalls vermuten würde. Ich schau mal ob ich das noch finde.

Settings manager - power manager - when power button is pressed - 
shutdown.

: Bearbeitet durch User
von Erni (pudding)


Lesenswert?

Ja, eigentlich doch bei den Energieeinstellungen, oder?
Dort hatte es bei mir leider keine Auswirkung.

von Erni (pudding)


Lesenswert?

Hadmut, hast Du einen Desktop-PC oder ein Notebook?

von Erni (pudding)


Lesenswert?

Mein Problem ist ein Desktop-PC mit Linux-Mint v21.3,
auf dem Notebook hier funktioniert v21.2

von Hadmut F. (hadmut)


Lesenswert?

Intel nuc. mini-pc. 120 eur.
Könnte sein das ist nicht die normale energieeinstellung. Ich hab das 
auf englisch, den deutschen namen weiss ich nicht.

: Bearbeitet durch User
von G. K. (zumsel)


Lesenswert?

Bei solchen Problem ist meistens der Computer scheiße weil die Firmware 
von der Kiste rottig ist.

Hier finden sich mögliche Workarounds für deine rottige HW:

https://www.google.com/search?q=linux+shutdown+does+not+power+off

von Erni (pudding)


Lesenswert?

Ja, es ist ein HP Pavilion...
Aber Dein Link zeigt auch auf Probleme die schon seit mehr als 10 Jahren 
bestehen. Da ist Linux wohl zu stolz, um auf meiner rottigen Kiste zu 
laufen.
Windows war da aber großzügiger (weil genauso rottig?)
Ich hatte jetzt Linux Mint Xfce versucht, ob ein anderer Desktop oder 
das LMDE sich wohl eher herablassen würde, mit meinem PC zu 
funktionieren?

von Stephan S. (uxdx)


Lesenswert?

Linux Mint ist wie Windows, es ist zwar ein Linux, aber auf "schön" und 
"einfach" getrimmt, aber nicht auf zuverlässig.

Nimm Debian oder Ubuntu.

von Mario M. (thelonging)


Lesenswert?

Linux Mint ist Ubuntu ist Debian.

von Stephan S. (uxdx)


Lesenswert?

Mario M. schrieb:
> Linux Mint ist Ubuntu ist Debian.

IST ist falsch.

Ubuntu IST nicht Debian, sondern packt eigene Software dazu.

Mint IST weder Ubuntu noch Debian, sondern nutzt beide als Grundlage, 
macht aber eigene Software dazu. Mint ist vielleicht chic, aber buggy, 
die Foren sind voll von Problemen.

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Denke mal, dass ist ein Fehler in der ACPI-Implementation auf dem 
Desktopgerät.

Manchmal hilft hier die Kernel-Boot-Option noacpi mitzugeben.

Der Workaround von Linux war meines Wissens vom UEFI einen Treiber auf 
der EFI-Partition als SW-Bugfix der Firmware auf dem Board reinziehen zu 
lassen, der danach eine generische API für die acpi-Grundfunktionen 
bietet und das zu nutzen.

: Bearbeitet durch User
von Erni (pudding)


Lesenswert?

Naja, ganz so schlecht sehe ich Linux Mint nicht. Auf meinem Notebook 
läuft es ja ohne Probleme. Mit dem harten Ausschalten über die 
Steckdosenleiste könnte ich leben, meine Frage dazu ist aber, ob dies 
ev. schädlich sein könnte für die SSD. Eigentlich ist das Linux dann 
doch schon heruntergefahren (Power down), nur das Board ist noch nicht 
stromlos (Lüfter laufen noch).
Dieter, wo kann ich die Boot-Option "noacpi" einstellen? Geht das ohne 
Neukompilierung des Kernels?

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Erni schrieb:
> Dieter, wo kann ich die Boot-Option "noacpi" einstellen?

Hier für Mint:
https://linuxmint-installation-guide.readthedocs.io/en/latest/boot_options.html

Da dort keine Übersicht über diese Optionen gibt, siehe dort:
https://pendrivelinux.com/ubuntu-cheat-codes/
https://manual.siduction.org/cheatcodes_en.html

> Geht das ohne Neukompilierung des Kernels?

Ja, das ist nicht notwendig. Die Option kann zuletzt einfach in der 
menu.cfg ergänzt werden. Das wird aber erst gemacht, wenn es erfolgreich 
war.

Aber ich kann auch vollkommen daneben liegen, weil Mint vielleicht per 
default alles überschreibt, weil im PowerManagement so eingestellt oder 
wenn kein Treiber gefunden wurde.

Übrigens, wenn das Linux heruntergefahren ist und genau das was Du 
gepostet hast angezeigt wird, kann man den Rechner mit dem Schalter 
ausschalten oder Stecker ziehen.

von Erni (pudding)



Lesenswert?

Hallo Dieter, vielen Dank für Deine Hinweise!
Hier noch als Anhang ein Foto der Meldungen beim Herunterfahren 
(bisheriger Zustand), leider etwas verwackelt, sorry!

: Bearbeitet durch User
von Erni (pudding)


Lesenswert?

Grrr, das war nicht meine Absicht, nun ist das Foto 3mal da.
Moderator, bitte löschen! Auch die Datei mit der verunglückten Endung. 
Danke!

von Erni (pudding)


Lesenswert?

Dieter, ich bin mir nicht sicher ob ich die Vorgehensweise richtig 
verstanden habe. Demnach kann ich durch erneutes Booten mit dem 
Installations-USB-Stick die Änderungen an dem bereits installiertem 
Linux vornehmen? Oder muß ich das komplette Linux neu installieren und 
dabei zuvor die Änderungen einstellen?
Wenn eine Neuinstallation erforderlich ist, dann könnte ich doch auch 
den zuerst vorgeschlagenen "Compatibility mode" auswählen. Dieser stand 
bei meiner jetzigen Installation auch zur Verfügung, aber ich hatte 
"Start Linux Mint" gewählt. Würde der Compatibility Mode etwas bringen 
und kann ich ihn jetzt noch nachträglich aktivieren?

von Steve van de Grens (roehrmond)


Lesenswert?

Stephan S. schrieb:
> Ubuntu IST nicht Debian, sondern packt eigene Software dazu

Und ist nicht so gründlich getestet, weil dort aktuelle Software Vorrang 
vor gut abgehangener hat.

: Bearbeitet durch User
von G. K. (zumsel)


Lesenswert?

Erni schrieb:
> Naja, ganz so schlecht sehe ich Linux Mint nicht. Auf meinem Notebook
> läuft es ja ohne Probleme. Mit dem harten Ausschalten über die
> Steckdosenleiste könnte ich leben, meine Frage dazu ist aber, ob dies
> ev. schädlich sein könnte für die SSD. Eigentlich ist das Linux dann
> doch schon heruntergefahren (Power down), nur das Board ist noch nicht
> stromlos (Lüfter laufen noch).

Niemand wird dir hier irgendwelche Garantien für irgendwelche stinkenden 
SSDs von Grabbeltisch abgeben. Wenn du Angst um die Auswirkungen eines 
Stromausfall auf deine SSD hast solltest du besser eine SSD mit PLP 
kaufen.

von Ob S. (Firma: 1984now) (observer)


Lesenswert?

Dieter D. schrieb:

> Denke mal, dass ist ein Fehler in der ACPI-Implementation auf dem
> Desktopgerät.

Richtig. Das ist oft mehr oder weniger grausig, was dort geliefert wird.

> Manchmal hilft hier die Kernel-Boot-Option noacpi mitzugeben.

Das sollte das letzte Mittel sein, weil das am Problem des nicht 
möglichen PowerOff oft nichts ändert.

Sinnvoller ist es, zunächst das BIOS/UEFI des Geräts upzudaten. Es ist 
garnicht so selten, dass auch an der ACPI-Implementierung nachgebessert 
wird.

Wenn das nicht hilft, kann man noch nach Quirks zum konkreten Gerät 
googeln. Manchmal findet man etwas, was wegen der relativen Seltenheit 
des konkreten Geräts keine Aufnahme in die üblichen Distros gefunden 
hat.
Das passiert inbesondere dann, wenn die Behandlung des Quirks die 
Funktionalität bei anderen, deutlich verbreiteteren Geräten 
beeinträchtigt und es keine Möglichkeit zur zuverlässigen Detektion des 
konkreten Geräts gibt.

von Erni (pudding)


Lesenswert?

> zumsel
Uhh, du fühlst dich durch den Geruch (Gestank?) meiner SSD belästigt?
Nein, ich möchte nur keinen Schaden an der SSD durch unzulässiges 
Ausschalten herbeiführen. Verrecken kann das Teil ohnehin jederzeit, 
ganz still, ohne klicken, ohne Headcrash.
Hilft mir nicht weiter...

von Steve van de Grens (roehrmond)


Lesenswert?

Lieber am Power-Taster aus schalten.

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Erni schrieb:
> ob ich die Vorgehensweise richtig verstanden habe.

Du musst zum Ausprobieren der Optionen nur Dein installiertes Linux 
hochfahren und dabei die Tasten drücken, mit denen Du in das Linux-Boot 
Menü kommst. Dort kannst Du nur für diesen Bootvorgang die Option 
manuell ergänzen und los geht es.

Ob S. schrieb:
> Es ist garnicht so selten, dass auch an der ACPI-Implementierung nachgebessert
> wird.

Die Nachbesserungen befindet sich heutzutage gar nicht so selten nicht 
im BIOS, sondern in einer Datei auf der EFI-Partition.

von Andreas B. (bitverdreher)


Lesenswert?

Erni schrieb:
> Hier noch als Anhang ein Foto der Meldungen beim Herunterfahren

Hier kannst Du ohne Probleme ausschalten, Stecker rausziehen oder was 
auch immer.

von Bauform B. (bauformb)


Lesenswert?

Wenn das Abschalten mit dem Power-Taster nicht so lange dauern würde, 
wäre das der ideale Kompromiss. Schaut euch die Meldungen an, sauberer 
runterfahren geht nicht (mit Mint) und zum Schluss wird der Strom 
abgeschaltet. Ob das vom Kernel oder vom Board per Taster veranlasst 
wird, darf für die SSD wirklich keinen Unterschied machen.

Im Gegenteil ;) Würde Abschalten per Mausklick funktionieren, wäre der 
Ablauf genau der gleiche. Nur wäre der Strom sofort nach der letzten 
Meldung weg. Per Hand abgeschaltet hat die SSD viel mehr Zeit, noch 
ihren Cache ins Flash zu schreiben ;)

von Erni (pudding)


Lesenswert?

Während des Bootens sehe ich die ganzen Textmeldungen durchlaufen. 
Soweit erkennbar auch alle als "OK". Wenn ich in dieser Phase entweder 
ESC oder e drücke läuft der Vorgang weiter, bis zur grafischen 
Oberfläche. Das Bootmenü habe ich so nicht erreicht. Ich werde weiter 
probieren. Danke!

von Erni (pudding)


Lesenswert?

> Steve van de Grens (roehrmond)
> Lieber am Power-Taster aus schalten.

Ja, das sehe ich ein.

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?


von Bauform B. (bauformb)


Lesenswert?

Erni schrieb:
> Während des Bootens sehe ich die ganzen Textmeldungen durchlaufen.
> Soweit erkennbar auch alle als "OK". Wenn ich in dieser Phase entweder
> ESC oder e drücke

ist es viel zu spät. Das 'e' ist für das grub Menü gedacht. Ich benutze 
erstmal die Cursor-Tasten um den Time-Out im grub zu stoppen und die 
richtige Zeile zu suchen (na gut, meistens die erste). Dann kommt das e 
ins Spiel.

Vielleicht ist update-grub doch einfacher, also die Änderung in 
/etc/default/grub zu machen, genau wie du splash und quiet ausgebaut 
hast.

von Erni (pudding)


Lesenswert?

Ein Dankeschön an Dieter für seine PM (nicht zur Thread-Frage), leider 
zu spät entdeckt - aber ein Tipp für die Zukunft.
Ein schönes Wochenende allen Helfenden!
Gruß
Erni

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Erni schrieb:
> aber ein Tipp für die Zukunft.

Wenn sich die zuviel geladenen Dateien nicht löschen lassen, dann sofort 
den ganzen Post löschen, bevor durch den nächsten Post die Änderungen 
blockiert sind.

von Rbx (rcx)


Lesenswert?

Erni schrieb:
> Es widerstrebt mir zwar, aber ist es ok, den Rechner hart über die
> Steckdosenleiste auszuschalten, wenn Linux es nicht schafft ihn
> herunterzufahren?

Musste ich bei Linuxen oder auch bei Unixen noch nie machen. Nur einmal 
bei ReactOS.
Bei einigen Unixen ist das typisch, dass man wissen muss, mit welchen 
Befehlen man den Rechner herunterfahren kann - obwohl das für damalige 
Unix-Systeme nicht so typisch war, waren ja eher keine Desktop-PCs.

shutdown -h now sollte immer gehen. Falls nicht, ist was mit dem System 
nicht in Ordnung.

von Erni (pudding)


Lesenswert?

> shutdown -h now sollte immer gehen
Genau dieses hatte ich so eingegeben. (Siehe Anfangspost)
Der PC fährt herunter, aber schaltet nicht ab.
Es ist kein Fehler für Anfänger, wie mich...

von Rbx (rcx)


Lesenswert?

Erni schrieb:
> Der PC fährt herunter, aber schaltet nicht ab.

Kann sein, aber dann bzw. danach kann man den PC selbst von Hand 
abschalten.

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Rbx schrieb:
> shutdown -h now sollte immer gehen.

Nicht immer, weil eine der alten gebrauchten Kisten hat die Macke in der 
Textkonsole, so wie Dein Rechner zu Enden und Abschalten macht er nur, 
von der grafischen Oberfläche (Gnome, KDE, xfce) aus.

Das hatte aber auch einen Hintergrund. Beim Wechseln von der GUI in die 
Konsole soll damit verhindert werden, dass der Rechner wirklich 
ausschaltet, obwohl nur eine virtuelle Maschine oder chroot-Umgebung 
heruntergefahren werden sollte. Da gab es einen Bug, der den 
Ausschaltbefehl an den Host weiterreichte und der Workaround hatte diese 
Nebenwirkung.

von Erni (pudding)


Lesenswert?

Das manuelle stromlos schalten nach dem Herunterfahren ist kein Problem.
Nur wenn ich versehentlich stattdessen auf "Bereitschaft" klicke, fährt 
der PC in den Ruhemodus, kann aber nicht mit dem Druck auf den 
Einschalttaster wieder aufgeweckt werden. Erst nach dem Unterbrechen der 
Stromversorgung kann ein Kaltstart erfolgen. Dieser Abbruch des 
Ruhezustandes ist sicherlich nicht gut fürs System.

von Rbx (rcx)


Lesenswert?

Dieter D. schrieb:
> Das hatte aber auch einen Hintergrund. Beim Wechseln von der GUI in die
> Konsole soll damit verhindert werden, dass der Rechner wirklich
> ausschaltet,

Das hängt doch aber auch vom Linux ab. Bei einigen startet man die GUI 
von der Konsole aus, und kann diese GUI auch wieder verlassen, um 
anschließend wieder in der (Vollbild) Konsole zu sein.
Der Abgang beim aktuellen Fedora (nicht dem neuen, dem was ich gerade 
draufhabe (37) und wo keine Updates mehr kommen. Obwohl Wine und 
Steam..)
ist auch nicht immer gleich. Optimal ist wohl eine kleine Wartezeit 
(etwas über eine Minute) und dann abschalten. Das mit der Wartezeit 
klappt aber oft gar nicht, dann wird sofort heruntergefahren. Ein 
anderes mal will das System was installieren. Dann wird 
heruntergefahren, Neugestartet, Zeug installiert, wieder 
heruntergefahren. Eigentlich auch nicht optimal.
Aber bei Windows läuft das ja irgendwie auch ganz ähnlich: "beim 
Herunterfahren Aktualisieren"..
Da kann man gar kein Bock drauf haben, weil das Ewigkeiten dauern kann. 
Aber da muss man dann auch den Neustart abwarten, und kann dann 
(irgendwann) endlich die Kiste herunterfahren.
Grundsätzlich wohl kein Trivial-Thema, dieses Herunterfahren, Software 
installieren/aktualisieren, Spaß haben.. ;)

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Rbx schrieb:
> Grundsätzlich wohl kein Trivial-Thema, dieses Herunterfahren, Software
> installieren/aktualisieren, Spaß haben.. ;)

Genau letzteres. Da gab es mal einen Post 🤫 mit der Frage 🤔, wie sage 
ich dem Betriebssystem, dass ich heute !🐐 & 🥳 machen möchte und es möge 
ganz besonders viele lange Updates machen, damit viel ⌛⌛⌛ bleibt für 
🦥🥱😴😴 &  🥳 🥳 🥳. 🤥

von Ein T. (ein_typ)


Lesenswert?

Erni schrieb:
>> shutdown -h now sollte immer gehen
> Genau dieses hatte ich so eingegeben. (Siehe Anfangspost)
> Der PC fährt herunter, aber schaltet nicht ab.
> Es ist kein Fehler für Anfänger, wie mich...

Versuch doch mal "sudo shutdown -P now" oder "sudo /sbin/poweroff". Ich 
hatte vor Ewigkeiten mal eine Maschine, die mit "shutdown -h" nur 
angehalten, aber kein Poweroff ausgeführt hat. Vielleicht ist das bei 
Dir ja ähnlich?

von Bauform B. (bauformb)


Lesenswert?

Erni schrieb:
> wenn ich versehentlich stattdessen auf "Bereitschaft" klicke, fährt
> der PC in den Ruhemodus, kann aber nicht mit dem Druck auf den
> Einschalttaster wieder aufgeweckt werden. Erst nach dem Unterbrechen der
> Stromversorgung kann ein Kaltstart erfolgen. Dieser Abbruch des
> Ruhezustandes ist sicherlich nicht gut fürs System.

Eigentlich sollte das auch harmlos sein. Mit suspend to disk könnte 
man beim nächsten Start das Image benutzen - oder man benutzt es eben 
nicht. Ja, ok, wenn man 23 Edits offen hat, wird es lästig. Aber wenn 
dabei etwas kaputt geht, ist das ein Bug im Editor.

Mit suspend to RAM ist es unübersichtlicher, aber die Festplatten werden 
auch komplett ausgeschaltet, also gibt es an der wichtigsten Stelle 
keinen Unterschied.

Man darf nur nicht sofort hart ausschalten, während das Image kopiert 
wird.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.