Forum: Analoge Elektronik und Schaltungstechnik Spannungswandler Recom RPX-1.0


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Gerd T. (blaubart)


Angehängte Dateien:

Lesenswert?

Hallo,

zunächst, ich weiß, Fehlerdiagnose aus der Ferne ist schwer. Ich 
versuche direkt alle notwendigen Infos zur Verfügung zu stellen, aber 
wenn etwas fehlt, oder wenn weitere Infos notwendig sind, fragt bitte 
nach. Ich werde es nach bestem Wissen nachliefern. Und ja, ich bin kein 
Elektroingenieur, sondern Hobbybastler und bin mir darüber im Klaren, 
dass mir bei Weitem nicht alle Grundlagen bekannt sind!

Ich verwende einen RPX-1.0 von Recom um 12V auf 3,3V zu reduzieren. 
Damit werden ein kleines Display, ein MAX3232CWE und ein ESP32 
betrieben. Den Schaltplan des Recom hänge ich am Ende an. Der ESP32 
stürzt kurz nach dem Einschalten ab und startet neu. Nutze ich testweise 
einen Spannungswandler mit einem NCP 1117 ST33T3G läuft die Schaltung 
fehlerfrei. Ich kann somit grundlegende Fehler in der Schaltung 
ausschließen. Um sicher zu gehen, dass der RPX-1.0 nicht zu schwach ist, 
habe ich einen RPX-1.5 verwendet, gleiches Verhalten.

Nun zu dem, was ich bisher versucht habe herauszufinden.

1. Ich bin mit dem Support von Recom im Kontakt. Dort hat man empfohlen 
den C7 herauszunehmen, und den C12 auf 22müF zu vergrößern. Seither 
läuft es etwas stabiler, stürzt aber nach einer Zeit erneut ab.

2. Ich habe mit dem Oszi die Ausgangsspannung des RPX-1.0 gemessen. Mit 
den alten Kondensatoren waren da deutliche Spannungsspitzen nach unten 
zu sehen, deren Intervalle immer enger wurden. Mit der neuen Anordnung 
sehe ich etwa einmal pro Sekunde einen Abfall der Spannung auf etwa 2V.

3. Der ESP32 schaltet kein WiFi ein, es ist also ausgeschlossen, dass er 
ein plötzliches Leistungsmaximum wegen des WiFis hat.

Ich wäre euch sehr dankbar für Lösungsansätze.

: Verschoben durch Moderator
von Wf88 (wf88)


Lesenswert?

Hast du denn die Grundlast eingehalten?

von Gerd T. (blaubart)


Lesenswert?

Das Display 
(https://newhavendisplay.com/2-4-inch-sunlight-readable-tft-without-touchscreen/) 
wird mit weniger als 150mA angegeben, der ESP32 laut Datenblatt mit max. 
500mA. Also das sollte passen. Zudem der RPX-1.5 ja das gleiche 
Verhalten zeigt.

von Wf88 (wf88)


Lesenswert?

Grundlast, nicht maximal last. Und sollte passen? Messen!

von Gerd T. (blaubart)


Lesenswert?

OK, messe ich nachher.

von Thorsten S. (thosch)


Lesenswert?

Grundlast bedeutet aber Mindestlast, nicht Maximallast!

von Gerd T. (blaubart)


Lesenswert?

Also ihr denkt, dass er "unterfordert" ist?

: Bearbeitet durch User
von Gerd T. (blaubart)


Lesenswert?

Grundlast sind etwa 250mA

von Wolf17 (wolf17)


Lesenswert?

Gerd T. schrieb:
> Ich habe mit dem Oszi die Ausgangsspannung des RPX-1.0 gemessen
Speicheroszi verfügbar?
Mal 1R in die +12V Speisung einschleifen und davor und dahinter 
aufzeichnen. Auf negative Flanke dahinter triggern. Mit 1ms/div 
anfangen.

von Luca E. (derlucae98)


Lesenswert?

Hast du dich an die Layoutempfehlung aus dem Datenblatt gehalten?

von Lu (oszi45)


Lesenswert?

Datenblatt 
https://g.recomcdn.com/media/Datasheet/pdf/.fIsfm97X/.t949edc23fade0802fd02/Datasheet-334/RPX-1_0.pdf

Wenn ich Deinen C7 vergleiche, hast Du nur 18pF statt 22pF lt.DB.
Evtl. schwingt etwas?

: Bearbeitet durch User
von Gerd T. (blaubart)


Lesenswert?

@ Wolf17:
Du meinst einen Widerstand mit 1 Ohm in die 12V-Leitung? Leider habe ich 
nur ein uraltes Oszi.

@Luca E.:
Nein, weil mir die Schaltung so von einem Industriebetrieb gegeben 
wurde. Die betreiben so hunderte ESPs

@Lu O.:
Ja, da schwingt definitiv was. Aber nachdem der Support dazu riet den C7 
zu entfernen und den C12 zu erhöhen schwingt es scheinbar nicht mehr. Im 
Oszi sieht man nur noch den gelegentlichen Spannungseinbruch.

: Bearbeitet durch User
von Wolf17 (wolf17)


Lesenswert?

Gerd T. schrieb:
> Du meinst einen Widerstand mit 1 Ohm in die 12V-Leitung? Leider habe ich
> nur ein uraltes Oszi.
So war das gedacht. Um zu kontrollieren, ob vielleicht schon die 12V 
einbrechen und ob der Strom kurz zu hoch wird. Dann wäre nicht das Modul 
schuld.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.